13:02:17 <joehuang> #startmeeting tricircle
13:02:17 <openstack> Meeting started Wed Aug  3 13:02:17 2016 UTC and is due to finish in 60 minutes.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:21 <openstack> The meeting name has been set to 'tricircle'
13:02:22 <zhiyuan> hello
13:03:11 <joehuang> #topictopicto
13:03:28 <joehuang> #topic rollcall
13:03:37 <joehuang> #info joehuang
13:03:42 <zhiyuan> #info zhiyuan
13:03:42 <Yipei> #info Yipei
13:03:49 <yinxiulin> #info yinxiulin
13:04:34 <joehuang> #topic feature progress review
13:05:09 <joehuang> hello, let's talk about our feature implemtation progressss
13:05:25 <yinxiulin> I finished microversion debugging and unit testing code
13:05:38 <joehuang> o, xiulin, good progress
13:05:48 <yinxiulin> thanks :)
13:06:13 <joehuang> is there any challenge?
13:06:36 <yinxiulin> yes, a bit
13:06:49 <joehuang> please
13:06:51 <Yipei> i finish my paper, i begin coding now, and i think i can finish it on time
13:07:11 <joehuang> you can submit small patch by patch
13:07:42 <zhiyuan> for l3 networking in shared vlan network, the code is almost done, but need more tests. i think i can submit the patch in late early next week
13:07:52 <yinxiulin> The main quesion is not  familiar tricirecle
13:07:59 <joehuang> no need to wait until the whole feature implemented
13:09:12 <joehuang> to xiulin, understand, you will be familar with it after you submit a patch, and know how it works
13:09:14 <Yipei> yes
13:09:28 <Yipei> i will submit a patch soon
13:09:32 <joehuang> to zhiyuan, good job!
13:09:49 <joehuang> to yipei, look forward to your patch
13:09:55 <Yipei> ok
13:09:58 <Yipei> some problem
13:10:00 <yinxiulin> ok , no problem
13:10:41 <Yipei> about the filter_handler in nova
13:12:08 <Yipei> i plan to design a filter which filters all the available pods
13:12:42 <Yipei> i try to learn the logic of filter_handler
13:13:11 <zhiyuan> do you mean a filter that return all the pods?
13:13:16 <Yipei> yes
13:14:10 <joehuang> I think it should be a filter by AZ, and if AZ is not specifed, then all will be returned
13:15:40 <joehuang> is it necessary to have a filter return all pods?
13:15:57 <Yipei> no, i just want to finish the framework
13:16:06 <joehuang> ok
13:16:25 <zhiyuan> so that's a dummy filter
13:16:59 <Yipei> other logics of filters can be implemented in the future
13:17:38 <Yipei> i think the logic should be designed in a function, which filters the pods
13:17:53 <joehuang> hmm, I need to read your source code to understand your code design
13:18:17 <Yipei> can i submit a patch which is not fully implemented?
13:18:38 <joehuang> of course, with [WIP] in the patch title
13:18:50 <joehuang> means it's still work in progress
13:19:25 <yinxiulin> do i need with [WIP] in the patch title
13:20:04 <Yipei> ok, got it
13:20:10 <joehuang> ok, xiulin
13:20:43 <Yipei> i think i can submit a WIP patch
13:21:26 <joehuang> pods and podbindings have already ben implemented, but the documentation is not there, could dongfeng to submit a documentaion on these two features?
13:22:16 <joehuang> #link https://github.com/openstack/tricircle/blob/master/doc/source/api_v1.rst
13:22:31 <Yipei> ok, i will tell him about it
13:22:52 <joehuang> the documentation needs to be updated for new added features, especially pods/podbindings/routings
13:23:34 <joehuang> great
13:24:08 <joehuang> #action update the tiricircle API documentation about pods/podbindings/routings
13:24:11 <Yipei> ok, got it, i will tell him to follow the template
13:24:26 <joehuang> #topic open discussion
13:24:31 <joehuang> other topics?
13:24:53 <zhiyuan> no
13:25:05 <Yipei> no for me
13:25:08 <yinxiulin> no
13:25:53 <joehuang> ok, thank you for attending the meeting, let's end the meeting earlier today
13:26:06 <joehuang> #endmeeting