13:02:12 <joehuang> #startmeeting tricircle
13:02:13 <openstack> Meeting started Wed Aug 24 13:02:12 2016 UTC and is due to finish in 60 minutes.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:16 <openstack> The meeting name has been set to 'tricircle'
13:02:33 <joehuang> #topic rollcall
13:02:37 <joehuang> #info joehuang
13:02:51 <Yipei> #info Yipei
13:02:52 <dongfeng> #info dongfeng
13:02:57 <yinxiulin> #info xiulin
13:03:02 <zhiyuan> #info zhiyuan
13:03:53 <joehuang> #topic feature implementation progress
13:04:29 <joehuang> hi, please share your recent progress in feature implementation, thanks
13:05:56 <zhiyuan> patches for subnet and floating ip clearing have been submitted, i am going to submit the patch for router clearing tomorrow
13:05:59 <joehuang> Zhiyuan fixed one py27 test error today, so please rebase your patch to pass the py27 check and gate test
13:06:30 <yinxiulin> I resubmitted a patch based APP implementations for  microversion
13:06:48 <joehuang> thanks to zhiyuan, this is necessary for nova action to pass the tempest test
13:06:48 <Yipei> about dynamic pod binding, the unit tests fail locally. so spends a lot time on tests.  but i just submitted a patch, all the tests pass.
13:07:06 <Yipei> this week i will revise commit message and submit a patch. i will add you guys in the reviewer list
13:07:22 <dongfeng> I have finished the documentation on pod and pod binding. but they are not merged yet.
13:07:30 <joehuang> that means all unit test passed for dynamic pod binding?
13:08:03 <joehuang> to Dongfeng, have you tried the command for pod and pod binding?
13:08:20 <joehuang> to Xiulin, great!
13:08:47 <hejiawei> this week,I commit a patch that force a volume to detach,but not passed .this is my first time to commit,I will retest it and thanks all the reviewers
13:09:01 <dongfeng> yes, after the releveant functions by curl, i look up the response code in screen -x
13:09:05 <joehuang> FOr me, the policy patch has been updated according to the review comment
13:09:40 <joehuang> to Jiawei, thank you very much for the first commit!
13:11:01 <dongfeng> after i run the command by curl, i look up the response code in screen -x. it could be verified that the response code is 200 if correct.
13:11:22 <joehuang> if you found your patch can't pass the py27 test, please rebase your patch
13:11:44 <joehuang> to Dongfeng, yes, it should be like that
13:12:55 <joehuang> any more information on feature implementation?
13:13:08 <Yipei> ok, i will try. i did not add more tests, just try to checks whether need to dynamically bind a pod when creating a vm.
13:13:18 <joehuang> everybody is encouraged to review other's patch
13:13:52 <Yipei> i will submit a patch without [WIP] tag this week, and add you guys in the reviewer list.
13:14:15 <joehuang> Thank you very much, Yipei, go ahead
13:15:01 <joehuang> ok, let's talk about the TC concerns on tricircle big tent application
13:15:12 <Yipei> you are welcome, it is my duty
13:15:30 <joehuang> #topic TC concerns on tricircle big tent application
13:16:00 <joehuang> Tricircle has started to apply big tent project last month
13:16:29 <joehuang> and two rounds dicussion in the TC weekly meeting
13:17:11 <joehuang> a lot of review comment in the patch
13:17:47 <joehuang> #link https://review.openstack.org/#/c/338796/
13:19:22 <joehuang> #info the main concerns are API consistency in Nova API-GW / Nova, Cinder API-GW/Cinder
13:20:32 <joehuang> #info but the value of networking automation across Neutron is recogized
13:21:42 <joehuang> what's your idea to move tricircle forward?
13:22:00 <joehuang> or proposal
13:23:05 <zhiyuan> so it's better if our networking automation features can work with classical Nova and Cinder server
13:23:44 <joehuang> you mean decouple the networking from Nova-API-GW and Cinder API-GW?
13:24:32 <joehuang> Currenly Nova API GW is involved in networking automation
13:24:42 <zhiyuan> yes, so the main concern is away :)
13:25:31 <joehuang> that means let Nova/Cinder still work in multi-region mode
13:26:40 <joehuang> #info idea1, to make networking automaton work with multi-region Nova/Cinder, decouple from Nova API-GW
13:26:58 <joehuang> any other idea or proposal?
13:27:50 <dstanek> samueldmq: it uses an extra random number as part of the key so that when we change it (invalidate) the keys are effectively invalidated
13:28:48 <joehuang> this is a good idea, no need to worry about Nova API-GW/Cinder API-GW will have overlapping/different API implementation
13:29:14 <lzy2> sorry i am late.I have watched sound code this week and prepared to code in the next few days.
13:29:53 <joehuang> I also have another proposal to introduce plugin mechanism in Nova Cinder API layer
13:30:33 <joehuang> but it'll take long time to disuss in Nova/Cinder to support such a feature
13:31:01 <zhiyuan> for decoupling, it's not that straightforward since Nova server doesn't provide driver framework, you can only write driver for nova compute
13:31:14 <joehuang> #info idea2 propose to introduce plugin mechanism in Nova Cinder API layer
13:31:37 <joehuang> agree
13:31:53 <zhiyuan> but we need VM booting event to trigger networking automation
13:32:47 <joehuang> yes
13:33:31 <joehuang> so, zhiyuan, could you draft the idea1, and let's have more and broad discussion on this topic to see if it's possible
13:34:38 <zhiyuan> ok, i will prepare for the discussion
13:35:05 <joehuang> but for our current development, just like what TC expect, continue our current implementation
13:35:19 <joehuang> don't stop it
13:35:55 <joehuang> #action discussion on the possiblity to decouple the networking automation
13:35:56 <yinxiulin> ok, got it
13:36:51 <zhiyuan> ok
13:36:59 <joehuang> good, please continue our development and think about how to address TCs' concerns and worries
13:37:18 <joehuang> #topic open discussion
13:37:37 <joehuang> any other topic?
13:38:47 <zhiyuan> no from me
13:38:57 <Yipei> no for me
13:39:02 <yinxiulin> no for me
13:39:07 <dongfeng> no for me
13:39:34 <joehuang> ok, thank you very much, let's conclude the meeting
13:39:43 <joehuang> #endmeeting