13:01:33 <joehuang> #startmeeting tricircle
13:01:33 <openstack> Meeting started Wed Sep  7 13:01:33 2016 UTC and is due to finish in 60 minutes.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:37 <openstack> The meeting name has been set to 'tricircle'
13:01:48 <Yipei_> hi
13:01:51 <joehuang> #topic rollcall
13:01:57 <joehuang> #info joehuang
13:01:58 <WuCheng> hi
13:02:05 <yinxiulin> #info xiulin
13:02:07 <zhiyuan> #info zhiyuan
13:02:21 <joehuang> hi WuCheng, first time to meet you here
13:02:28 <WuCheng> yeah
13:02:38 <joehuang> could you introduce yourself shortly?
13:03:21 <WuCheng> hello everyone,I'm ZhuangzhuangXu,or Wucheng
13:03:23 <hejiawei> #info jiawei
13:03:32 <Yipei_> #info Yipei
13:04:05 <joehuang> great! welcome to join, Wucheng
13:04:10 <Yipei_> Zhuangzhuang is his real name
13:04:47 <WuCheng> thanks
13:04:52 <joehuang> so Wucheng is your nick name
13:05:00 <WuCheng> the name in ali
13:05:01 <Yipei_> he is a undergraduate student and going to be a master student of Prof. Fanmging Liu next year
13:05:11 <WuCheng> yeah
13:05:27 <dongfeng> #info dongfeng.network connection failed.
13:05:32 <joehuang> ok, next topic
13:05:46 <joehuang> #topic feature parity review
13:06:07 <joehuang> please share your feature implementation progress shortly
13:06:08 <Rong-hui> hello
13:06:15 <joehuang> hi, Ronghui
13:06:28 <Rong-hui> #Ronghui
13:06:34 <Rong-hui> #info Ronghui
13:07:40 <yueyuquan> #info yueyuquan
13:07:52 <lzy2> #info lzy2
13:09:11 <Yipei_> @joe, about the error we discussed in the afternoon, i checked the source code, but fail to find where pod bindings are created
13:09:12 <joehuang> hello, for policy control patch, needs your review, thanks
13:09:17 <zhiyuan> (1) patch for l3 networking with shared vlan network has been merged (2) patches for resource clean-up have been submitted, waiting to be approved, there are 3 patches (3) local plugin and central plugin for project separation are under development, I have figured out how to implement basic VM booting and l3 E-W communication
13:10:10 <zhiyuan> I think I will submit a specification document before submitting the codes
13:10:28 <joehuang> to Zhiyuan, great, spec review is needed
13:10:56 <joehuang> #action spec for Tricircle Local Neutron Plugin
13:11:19 <yinxiulin> I submitted a patch for part of server action, but Jeanks didn't pass.
13:11:56 <joehuang> to Yipei, you have not provided the value for the is_current_binding field in the test cases
13:12:44 <Yipei_> you mean in test_az_ag.py?
13:13:01 <joehuang> to Xiulin, tempest not pass
13:13:08 <zhiyuan> for the jenkins problem xiulin mentioned, I checked the logs of nova api gateway and found "EndpointNotUnique" exception was raised, a bit strange
13:13:43 <zhiyuan> the exception means that for one service in one pod, we find more than one url
13:13:51 <Rong-hui> i finish the wiki and add some new way to install tricircle with virtualbox
13:14:34 <zhiyuan> will check with xiulin tomorrow
13:14:44 <yinxiulin> thanks zhiyuan
13:14:52 <joehuang> to Ronghui, thank you very much to provide the guide
13:15:20 <liukun> #info hi
13:16:30 <joehuang> so xiulin, keep going
13:16:59 <yinxiulin> ok, thanks for zhiyuan's and your help
13:17:08 <hejiawei> for me,I l am learning use tox to test my patch, when I use this command "tox -v -epep8" test my patch,it show the all resuilt of tricircle.I don't know how to test my patch singly
13:17:09 <joehuang> if you finisihed a feature, please update the google doc
13:17:52 <joehuang> you can run flake8 locally
13:18:44 <joehuang> if flake8 succeed, then pep8 could be pass in most cases
13:19:10 <zhiyuan> before you run flake8, you need to install test requirement, run "pip install -r test-requirements.txt" under tricircle folder
13:19:29 <dongfeng> for me,  I will use curl to get and set the relevant values and use those values to verify the correctness of the features of pod and pod bindings. is it correct ?  I will use the same logic as test_pod.py which is located "tricircle/tricircle/tests/unit/api/controllers". for short, the content of test_pod.py is at http://paste.openstack.org/show/567459/
13:19:49 <joehuang> yes, dongfeng
13:19:55 <hejiawei> ok, I will try it.
13:20:20 <zhiyuan> there is a "hacking" lib in the requirement, which adds some OpenStack-specific style check
13:20:36 <dongfeng> ok, i will try and submit a patch to test pod and pod bindings.
13:21:46 <Yipei_> @joe, so i need to provide the values of newly added field in unit tests? but i did not find it in former code, is there any example that i can follow
13:21:57 <joehuang> to dongfeng, good, once you know how to test a feature, then you can develop feature, and verify it works or not
13:22:09 <joehuang> to Yipei, yes
13:22:26 <zhiyuan> I remember that we already have tests for pod and binding api?
13:22:54 <dongfeng> it is unit test and it is located at tricircle/tricircle/tests/unit/api/controllers
13:23:27 <joehuang> to zhiyuan, yes, it's functional test
13:23:38 <joehuang> https://github.com/openstack/tricircle/blob/master/tricircle/tests/functional/api/controllers/test_pod.py
13:24:04 <zhiyuan> oh, so unit tests will be added?
13:24:11 <joehuang> maybe we don't need to provide tempest test cases? for functional test will load web app too
13:24:18 <joehuang> no
13:24:49 <joehuang> I think functioanl test is good enough if it covers all condition
13:25:50 <joehuang> to Dongfeng, one second
13:25:55 <dongfeng> ok
13:26:13 <joehuang> do you plan to add tempest test for pod and podbinding or only unit test?
13:27:43 <dongfeng> is tempest test a must ?
13:28:32 <joehuang> this is a question
13:28:52 <joehuang> zhiyuan, what's your proposal?
13:31:08 <zhiyuan> i think currently functional test is enough since our API is not that complex, just database operation
13:32:27 <joehuang> to yipei, when you call get_pod_by_az_tenant. the binding will be created in this function, but the value for is_current_binding is not provided, and it's not-null field, so the issue happened, you must provide value in create binding
13:32:40 <Rong-hui> so for the existing patch, it is not necessary to use tempest test?
13:32:47 <joehuang> to Zhiyuan, I think so
13:33:16 <joehuang> so for Dongfeng, maybe provide API for the routing table will be a good try
13:33:18 <zhiyuan> we need tempest test for nova api gateway and cinder api gateway, but no need to write new tests
13:33:45 <zhiyuan> just reuse tempest tests for nova api and cinder api, like what we are doing noew
13:34:56 <joehuang> +1
13:35:45 <Rong-hui> ok
13:35:57 <joehuang> dongfeng, how about to develop the API for the routing table? you can refer to Pod/PodBinding
13:36:05 <dongfeng> ok.
13:36:31 <zhiyuan> you can see from xiulin's patch that relavant tempest tests are enabled along with feature implementation
13:36:36 <joehuang> you have writen the documentation for Pod/PodBinding, so you know how to test that using curl
13:37:11 <Yipei_> @joe, i see, but in the function, there is not any line creating pod bindings
13:38:51 <joehuang> line 145~151 https://github.com/openstack/tricircle/blob/1f4d505b84e3c110a6be3b387e0aa236feb55d50/tricircle/common/az_ag.py
13:39:23 <joehuang> for db accessing, it'll be better to move the table operation to db_api.py
13:40:27 <Yipei_> i see, i just search the unit test cases
13:40:47 <joehuang> #action move db access code to db_api.py
13:41:00 <Yipei_> i will fix the error, and begin designing the unit tests
13:41:55 <joehuang> for core.query_resource and core.create_resource etc calling, it will be better to move these to db_api.py
13:42:47 <joehuang> to Ronghui, for cinder API-GW api, tempest test is necessary
13:42:58 <Rong-hui> ok
13:43:46 <joehuang> ok, next topic
13:44:07 <joehuang> #topic Tricircle Splitting
13:44:23 <joehuang> #link  https://etherpad.openstack.org/p/TricircleSplitting
13:46:50 <joehuang> your comments are very important
13:53:41 <joehuang> #info discussion in the etherpad https://etherpad.openstack.org/p/TricircleSplitting
13:57:32 <zhiyuan> @joe, almost 10pm, shall we update the etherpad offline?
13:59:58 * krotscheck patiently waits for the room to clear
14:00:58 <joehuang> ok, let's update and disucss offline
14:01:39 <joehuang> #endmeeting