13:01:47 <joehuang> #startmeeting tricircle
13:01:48 <openstack> Meeting started Wed Oct 19 13:01:47 2016 UTC and is due to finish in 60 minutes.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:52 <openstack> The meeting name has been set to 'tricircle'
13:02:15 <joehuang> #topic rollcall
13:02:20 <zhiyuan> #info zhiyuan
13:02:24 <joehuang> #info joehuang
13:02:31 <Yipei> #info Yipei
13:02:41 <yinxiulin_> #info xiulin
13:03:25 <joehuang> #topic tricircle cleaning
13:03:41 <ronghui_> hello
13:03:55 <joehuang> hello, just noticed that all MUST TO HAVE patches were merged
13:04:10 <yinxiulin_> ?
13:04:47 <joehuang> that means the tricircle cleaning is completed https://github.com/openstack/tricircle/
13:05:17 <joehuang> so the Tricircle now only includes networking automation functionality
13:06:14 <joehuang> thank you everybody for the moment
13:06:31 <zhiyuan> cool, the two patches were merged right before the meeting :)
13:06:40 <joehuang> ya
13:07:32 <joehuang> so a tag will be given tomorrow to have a milestone for the cleaning
13:08:01 <joehuang> so that pip installation can install the clean tricircle
13:08:41 <joehuang> and big-tent application will resume after the tagging
13:08:59 <joehuang> to Ronghui
13:09:51 <joehuang> for the release notes in the master branch, could you update README with a link to the release notes?
13:10:05 <ronghui_> ok
13:10:26 <ronghui_> for the tricircle or the tiro2o?
13:10:50 <joehuang> for tricircle
13:10:54 <ronghui_> ok
13:11:28 <joehuang> just like the installation link in the README of https://github.com/openstack/tricircle
13:12:03 <joehuang> good, a link for the release notes help contributor to find out what's feature provided
13:12:32 <ronghui_> ok  and it also need to delete the describe about the Nova-GW and Cinder-GW?
13:12:42 <joehuang> already deleted
13:12:54 <ronghui_> ok
13:13:28 <joehuang> ok next topic
13:13:33 <joehuang> #topic bugs and blueprint cleaning
13:13:48 <joehuang> as Newton has been released
13:14:11 <joehuang> bugs and blueprint which have been fixed should be updated
13:15:11 <joehuang> #link https://blueprints.launchpad.net/tricircle
13:15:38 <joehuang> the dynamic pod binding blueprint should be closed for we'll move this function to Trio2o
13:16:16 <joehuang> to Yipei, could u update this BP?
13:16:23 <Yipei> OK
13:17:58 <joehuang> And zhiyuan, could u update the bp "cross site connectivity"
13:18:04 <joehuang> #link https://blueprints.launchpad.net/tricircle/+spec/cross-site-connectivity
13:18:19 <zhiyuan> no problem
13:18:59 <joehuang> we may close this one, and register new BP for later L2/L3 features if needed
13:19:18 <joehuang> #action update "dynamic pod binding" blueprint
13:19:26 <Yipei> how to update the BP? move it to the BP of trio2o?
13:19:48 <joehuang> #action update "cross site connectivity" blueprint
13:20:21 <joehuang> to Yipei, update regarding items, and close the BP, register a new one in Trio2o
13:20:32 <Yipei> ok, got it
13:20:40 <joehuang> ok
13:20:57 <zhiyuan> Do I need to include the implementation patches both before and after the projet split? Since there are two kinds of implementation
13:21:58 <joehuang> both, history is good
13:22:04 <zhiyuan> ok
13:23:10 <joehuang> and we also need to close the bugs listed in launchpad for those have already been fixed but not updated in lauchpad
13:23:21 <joehuang> #link https://bugs.launchpad.net/tricircle
13:23:44 <joehuang> there are some bugs alread been fixed, but not close, we need to close these bugs
13:24:22 <joehuang> in the future, you can add a tag in the patch to make the patch is linked to some specific bug report
13:24:42 <joehuang> so that if the patch merged, the bug in launchpad can be closed automaticly
13:25:48 <zhiyuan> how to add this mechanism? config via the openstack/project-config ?
13:27:26 <joehuang> no, seems just one line in the commit message
13:28:50 <joehuang> will provide the guide in mail-list tomorrow
13:29:36 <joehuang> any questions on the bugs/blueprint cleaning?
13:31:22 <joehuang> ok, next topic
13:31:34 <joehuang> #topic Ocata planning, mile stones.  OpenStack Ocata planning
13:31:55 <joehuang> #link https://releases.openstack.org/ocata/schedule.html
13:32:17 <joehuang> there are several milestone in OpenStack release schedule
13:34:02 <zhiyuan> wow, only four months for this circle
13:34:04 <joehuang> how do you think about the milestone based plan, what's your proposal for tricircle?
13:34:19 <joehuang> yes, this is a quite short release
13:34:54 <joehuang> because the reform of design summit, which will not be held together with summit
13:35:26 <zhiyuan> routing admin API can be included in ocata-1
13:36:34 <joehuang> yes, so register one blueprint for routing API
13:37:02 <joehuang> for the first release, no need to have so much milestone
13:37:07 <zhiyuan> It's under review and has been improved with several patch sets, i think it can catch up with ocata-1
13:37:52 <zhiyuan> oh i see, so we don't need to match the three milestone?
13:38:59 <zhiyuan> Dongfeng is the owner of the routing API patch so Dongfeng register the BP?
13:39:04 <joehuang> we may define less milestone, so that there is some window to adapt the milestone based plan, and next cycle keep align with the same milestone
13:39:14 <joehuang> Is Dongfeng online?
13:39:47 <Yipei> OK, i will tell him. He is attending class
13:40:10 <joehuang> ok
13:41:39 <joehuang> please give your milestone proposal in the design summit session etherpad
13:42:18 <joehuang> #link https://etherpad.openstack.org/p/ocata-tricircle-work-session
13:43:35 <zhiyuan> so how many milestone should we set, Joe?
13:43:36 <joehuang> please input your thoughts in the etherpad, no need to wait for design summit
13:43:57 <joehuang> two? then release date?
13:44:26 <joehuang> we need time to adapt that
13:46:20 <zhiyuan> if we set two milestones, we have about one and half a month for each milestone
13:46:26 <joehuang> ok, so next week weekly meeting will be cancelled due to summit
13:46:46 <joehuang> good idea, you can input your proposal in the etherpad
13:47:17 <zhiyuan> ok, I will write down a proposal date
13:47:48 <joehuang> and two design summit session will be held next week: https://wiki.openstack.org/wiki/Design_Summit/Ocata/Etherpads#Tricircle
13:48:30 <joehuang> other topics?
13:48:57 <zhiyuan> no
13:49:00 <Yipei> no for me
13:49:05 <yinxiulin> no
13:49:06 <ronghui_> no for me
13:49:30 <hejiawei> no
13:49:41 <joehuang> thank you for attending the meeting
13:49:46 <joehuang> #endmeeting