13:03:42 <joehuang> #startmeeting tricircle
13:03:43 <openstack> Meeting started Wed Nov 16 13:03:42 2016 UTC and is due to finish in 60 minutes.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:03:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:03:46 <openstack> The meeting name has been set to 'tricircle'
13:03:53 <joehuang> #topic rollcall
13:03:58 <joehuang> #info joehuang
13:04:10 <dongfeng> #info dongfeng
13:04:11 <Yipei> #info Yipei
13:04:12 <joehuang> sorry the net is not stable
13:04:26 <zhipeng> #info zhipeng
13:04:27 <zhiyuan> #info zhiyuan
13:04:50 <yinxiulin> #info xiulin
13:05:01 <zhipeng> dongfeng Yipei yinxiulin
13:05:11 <zhipeng> we have established a wechat group today
13:05:21 <zhipeng> you are more than welcomed to join
13:06:12 <joehuang> #topic Ocata feature development discussion
13:06:19 <dongfeng> fine, glad to join.
13:06:52 <joehuang> have a short description about feature development progress
13:06:58 <joehuang> please
13:07:09 <joehuang> before that
13:07:46 <joehuang> glad to announce that Tricircle has been openstack big-tent project, thanks to all your contribution
13:08:17 <zhiyuan> hooray!!!
13:08:32 <yinxiulin> Congratulations
13:08:41 <dongfeng> great~
13:08:42 <joehuang> #info Tricircle is one of  openstack big-tent projects
13:09:04 <joehuang> that means our project is also one of openstack official project
13:09:50 <joehuang> so let's have a short review for current features now
13:10:06 <joehuang> current feature development
13:10:26 <zhiyuan> progress: (1) patch for manual installation guide has been submitted (2) spec for changes on bridge network has been summitted (3) patch for changes on bridge network is under development
13:11:22 <dongfeng> the patch of the documentation on resource routing api has been committed.
13:11:35 <zhiyuan> the spec will discuss what changes on bridge network is needed and why
13:11:35 <joehuang> some new reviewers from ChinaMobile, ChinaUnionPay, Huasheng, etc will join the patch review and contribution
13:11:58 <joehuang> thank you dongfeng
13:12:14 <dongfeng> happy to contribute~
13:12:31 <yinxiulin> I am learning vpnaas related knowledge,and begin to write Specifications document
13:12:52 <Yipei> about LBaaS, i have already installed devstack with neutron network, i will try to install and configure LBaaS tomorrow.
13:12:55 <joehuang> later we'll discuss documentation as we are big-tent project, some new requirements may be applied
13:13:22 <joehuang> to Xiulin, for VPNaas, there is some risk of implementation
13:13:52 <yinxiulin> what, for example ?
13:14:04 <joehuang> today, the VPNaaS may be stopped to reside under Neutron
13:14:15 <joehuang> for no active contribution in this feature
13:14:59 <yinxiulin> oh
13:15:20 <yinxiulin> so what can i do now ?
13:15:58 <joehuang> #link http://lists.openstack.org/pipermail/openstack-dev/2016-November/107384.html
13:16:04 <zhiyuan> that means networking-vpnass will be removed from neutron stadium?
13:16:29 <joehuang> #info [openstack-dev]vpnaas no longer part of The neutron governance
13:16:48 <joehuang> at least to some extent
13:17:29 <joehuang> need to invetigate is there any urgent need for VPNaaS, please consult with ChinaMobile/ChinaUnionpay etc
13:17:41 <joehuang> whether they have need for VPNaaS
13:18:47 <joehuang> what's your suggestion?
13:20:10 <yinxiulin> I can do other functions of tricircle
13:20:38 <joehuang> how about help to make resource update work in Tricircle, now several resources lack of update support
13:21:59 <yinxiulin> can we discuss it tomorrow offline
13:22:38 <joehuang> you mean #openstack-tricircle?
13:22:52 <yinxiulin> no , my job
13:22:58 <yinxiulin> next to do
13:23:35 <zhipeng> we could chat offline on Wechat group
13:24:10 <joehuang> ok
13:24:26 <joehuang> we need to investigate how far VPNaaS is required
13:25:13 <yinxiulin> no problem, thanks zhipeng
13:25:51 <joehuang> Do anyone know the port VTEP progress in Neutron
13:26:54 <joehuang> I did not find spec on this topic yet
13:27:41 <zhiyuan> I relied on the mail list about neutron-agent retrospective, but no further feedback
13:28:07 <zhiyuan> It was said that VTEP information may be moved to port model
13:28:46 <joehuang> good let's keep eye on that, and actively contribute in this feature, it's quite useful for Tricircle
13:29:09 <joehuang> #topic Documentation requirement
13:29:51 <joehuang> hello, for current documentation is in review, we can keep its format, and finish the review process
13:30:13 <joehuang> For tricircle is one of big-tent project
13:30:50 <joehuang> we need to align the documentation requirements with other OpenStack big-tent project
13:31:26 <joehuang> #link http://docs.openstack.org/contributor-guide/quickstart/new-projects.html
13:31:49 <joehuang> seems not easy for a new project :(
13:32:33 <joehuang> what's your proposal
13:34:05 <zhiyuan> need some time to read the guide
13:34:54 <zhiyuan> "Any configuration options or command line tools should be documented using the automated openstack-doc-tools" so RongHui can try to use this tool!
13:35:13 <joehuang> is Ronghui online?
13:35:25 <joehuang> and Junsik?
13:36:56 <joehuang> they are not online today
13:38:11 <joehuang> I'll try to seek for help from OpenStack documentation team, to see if we can make the documentation work ease
13:39:06 <joehuang> #action communication with documentation team on new project documentation
13:39:39 <joehuang> #topic Open Discussion
13:39:51 <zhipeng> got one item here :)
13:39:55 <joehuang> it's time for open discussion
13:40:04 <zhipeng> #info Tricircle and Karbor collaboration
13:40:05 <joehuang> please
13:40:24 <zhipeng> currently leon_wang_ is working on Multisite support for Karbor
13:40:31 <joehuang> intersting
13:40:36 <zhipeng> for those of you who are not familiar with Karbor
13:40:43 <zhipeng> it is a data protection service
13:40:52 <leon_wang_> hi everyone
13:40:55 <zhipeng> #link https://wiki.openstack.org/wiki/Karbor
13:41:02 <joehuang> hi, leon_wang
13:41:17 <zhipeng> So we divided the multisite scenario into two sub-scenarios
13:41:22 <zhipeng> One is with Tricircle
13:41:41 <zhipeng> that means Tenant first create resources across multiple clouds using Tricircle
13:41:56 <zhipeng> and then use karbor for cross site data protection
13:42:14 <zhipeng> meaning one site could be a backup for another site
13:42:16 <joehuang> tricircle is for cross Neutron networking automation now
13:42:37 <zhipeng> yes and Karbor also backup network-related metadata :)
13:42:51 <joehuang> it's data protection for port/subnet/network etc info?
13:43:03 <zhipeng> yep you could use Karbor to do that
13:43:22 <leon_wang_> joehuang: so what should Karbor do to work with Tricircle?
13:43:29 <joehuang> where the data will be backup to
13:43:44 <zhipeng> now we think that with tricircle, (1)Karbor could querry Tricircle DB for tenant infomation
13:43:52 <joehuang> it's up to what data want to protect
13:43:53 <zhipeng> backup to swift
13:44:18 <zhipeng> since when a prod site goes down and then go up again
13:44:23 <zhipeng> the tenant info will change
13:44:43 <zhipeng> however tricircle could help maintain a global view of tenant info cross multiple sites
13:45:13 <joehuang> yes, the central neutron server's data and tricircle DB data need to protect
13:45:23 <zhipeng> and (2)Tricircle could use Karbor for data protection
13:45:45 <zhipeng> so we want to determine what we need to do to achieve multisite ddata protection
13:45:51 <leon_wang_> +1
13:45:53 <joehuang> for data in each region, it's could be up to the operator's choice
13:46:05 <zhipeng> joehuang correct
13:46:38 <joehuang> great
13:46:44 <zhipeng> our proposal would be (1) develop a Karbor GW within Tricircle
13:47:05 <joehuang> which component?
13:47:14 <leon_wang_> joehuang: can operator change the size of region?
13:47:35 <leon_wang_> the number of sites
13:47:36 <joehuang> what dimention of size?
13:47:42 <joehuang> of course
13:48:00 <joehuang> regions can join or leave
13:48:51 <zhipeng> ok let me continue my previous thought
13:49:19 <joehuang> I hope that Tricircle and Karbor is loose coupling, work independent
13:49:36 <zhipeng> we need  a way for Karbor to querry Tricircle DB for cross site info
13:49:37 <leon_wang_> of course
13:49:52 <zhipeng> and need a way for Tricircle to use Karbor to protect its data
13:50:23 <zhipeng> how should we accomplish these two goals ?
13:50:35 <joehuang> I don't think a dependency from Tircircle to Karbor should be there
13:50:45 <zhiyuan> Tricircle provides admin API to query site info, for network resource info, directly query Neutron server
13:50:57 <joehuang> Karbor can query data from Tricircle Admin api and Neutron API
13:51:09 <joehuang> to Zhiyuan +1
13:51:32 <zhiyuan> for resource mapping, ther routing API is under development which is part of the admin API
13:51:37 <leon_wang_> karbor can protect data in neutron now.
13:51:38 <joehuang> only single way dependency, from Karbor to Tricircle,
13:51:40 <zhipeng> okey then I guess for this part, it would be for Karbor to have a Tricircle plugin
13:51:53 <joehuang> no plugin is needed
13:52:06 <zhipeng> it is a Karbor mechanism :P
13:52:08 <joehuang> Tricircle Admin API should be enough
13:52:21 <joehuang> o, I got it
13:52:27 <zhipeng> so how should Tricircle utilize Karbor ?
13:52:33 <joehuang> you mean to have one Tricircle plugin in Karbor
13:52:37 <zhipeng> could we achieve that the same way
13:52:57 <joehuang> Tricircle should be unaware of whether it's in protection or not
13:53:17 <leon_wang_> tricircle plugin in Karbor or the contrast?
13:53:33 <joehuang> single way dependency
13:53:36 <zhiyuan> I think if Karbor can directly interact with Neutron, no access to Tricircle admin API is needed, Karbor can directly interact "central Neutron server"
13:53:45 <joehuang> Trcircle will only rely on Neutron
13:53:57 <zhipeng> zhiyuan we need the tenant mapping info
13:54:09 <zhipeng> so that when site changes, it anchors with the tenant
13:54:18 <joehuang> to Zhiyuan, they would like to protect the az mapping, routing etc
13:54:24 <joehuang> too
13:54:29 <zhiyuan> oh i see
13:54:38 <zhipeng> hoehuang yes
13:54:43 <zhipeng> joehuang yes
13:55:36 <joehuang> I think, more thoughts are needed for the data protection, we can discuss in next meeting. less dependency, the better
13:56:00 <zhipeng> okey definitely :)
13:56:02 <leon_wang_> if you think it would work, i will propose a BP in Karbor.
13:56:22 <joehuang> good, we can review that in karbor
13:56:25 <Yipei> @joehuang, about LBaaS, shall i prepare to submit a spec for LBaaS first?
13:56:44 <joehuang> If you have an idea on how to that, don't hesitate
13:56:59 <joehuang> we can work together to make it better
13:57:00 <Yipei> ok, got it
13:57:33 <joehuang> other topic?
13:58:01 <Yipei> no for me
13:58:04 <zhiyuan> no
13:58:13 <dongfeng> no
13:58:17 <zhipeng> none
13:58:25 <joehuang> ok, thank you.
13:58:32 <joehuang> #endmeeting