13:02:02 <joehuang_> #startmeeting tricircle
13:02:03 <openstack> Meeting started Wed Dec 28 13:02:02 2016 UTC and is due to finish in 60 minutes.  The chair is joehuang_. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:06 <openstack> The meeting name has been set to 'tricircle'
13:02:19 <joehuang_> #topic rollcall
13:02:27 <zhiyuan> #info zhiyuan
13:02:28 <joehuang_> #info joehuang
13:02:33 <dongfeng> #info dongfeng
13:02:34 <Yipei> #info Yipei
13:02:37 <yinxiulin> #info xiulin
13:02:53 <hejiawei> #info jiawei
13:03:59 <joehuang_> #topic shadow_agent for VxLAN L2 networking/L3 DVR issue
13:04:16 <joehuang_> hello, zhiyuan, how about the poc of shadow_agent
13:06:41 <zhiyuan> here is how i try: when local plugin receives update request from local nova, it sends agent info to central plugin; central plugin then store agent info in the tricircle database(i create a new table)
13:07:44 <joehuang_> ok
13:07:50 <RonghUI> #info ronghui
13:08:04 <RonghUI> hello
13:08:10 <zhiyuan> then when local plugin receives create request with binding:host_id and agent info(i set it in the binding:profile), it creates the shadow agent in the local neutron database and bind the port
13:08:51 <joehuang_> "create request" or "update request"?
13:09:27 <zhiyuan> i manually sent the create request and the shadow agent and port can be successfully created, later this should be done by XJob
13:10:02 <zhiyuan> "create request", XJob uses create request to create the shadow port first
13:10:16 <joehuang_> ok
13:10:23 <zhiyuan> then XJob needs to send update request to trigger l2 population
13:10:46 <joehuang_> I think it's ok
13:11:20 <zhiyuan> however, port status can not be updated via API request, so we need to add some label in binding:profile in the update body to tell local plugin the update the port status
13:11:47 <zhiyuan> sorry, "tell local plugin to update the port status"
13:12:19 <joehuang_> if we can judge the port is shadow port with shadow agent, then it's ok to assume the port is up
13:12:45 <joehuang_> no need to update the port status through local Neuton API
13:13:35 <zhiyuan> after shadow port is created, though it's bound to the shadow agent, l2 population will not be triggered since the port status is down, we need to update the status to up to trigger l2 population
13:13:50 <joehuang_> may the shadow DVR mac can be set at the same time?
13:14:05 <zhiyuan> l2 population is processed during port update
13:14:15 <zhiyuan> not port create
13:14:24 <joehuang_> yes
13:14:54 <zhiyuan> so the extra port update is needed
13:15:06 <joehuang_> understand
13:16:24 <joehuang_> this is a great message that the shadow_agent idea seems work
13:16:26 <zhiyuan> this solution may work for DVR MAC, need investigation
13:17:06 <zhiyuan> will test tomorrow to see if i can manually trigger l2 population
13:17:51 <joehuang_> great, look forward to the new progress
13:17:57 <zhiyuan> if it works, we can start to move the manual work to XJob
13:18:08 <zhiyuan> hope so :)
13:18:21 <joehuang_> other question?
13:18:55 <joehuang_> #topic async. job reliability
13:19:10 <joehuang_> zhiyuan, you mentioned the topic async. job reliability
13:19:16 <joehuang_> in the irc channel
13:20:21 <zhiyuan> right, i have updated the spec and listed the pros and cons of the three solutions, would like to hear the feedback
13:21:10 <joehuang_> #link https://review.openstack.org/#/c/412762/
13:22:05 <joehuang_> please review the spec
13:23:05 <joehuang_> async job's reliability is very important for the system to work healthy and auto healing
13:23:57 <joehuang_> #topic db migration version
13:24:03 <joehuang_> hello, guys
13:24:29 <joehuang_> there is one bug was found during the review on Victor's patch
13:28:06 <joehuang_> sorry the network was broken
13:28:11 <joehuang_> #link https://bugs.launchpad.net/tricircle/+bug/1652708
13:28:12 <openstack> Launchpad bug 1652708 in Tricircle "db migration version should be able to be specified in the cli" [Undecided,New]
13:28:52 <joehuang_> I am also working in the kinbird project
13:29:25 <joehuang_> and in Kingbird, migration is more  using flexible with cli
13:29:50 <joehuang_> if no target version is not specified, then migrate to latest version
13:30:17 <joehuang_> if version is specified, migrate to this version
13:30:32 <zhiyuan> yeah, version is hard-coded in tricircle currently
13:30:48 <joehuang_> also provide command to lict current version the software is running
13:31:33 <joehuang_> it's not difficult to fix, just make it work like what did in kingbird
13:32:14 <joehuang_> would someone can help on this bug?
13:34:02 <dongfeng> is it urgent ? if not so urgent, i can try to work with it.
13:34:30 <joehuang_> merge before Jan. 24OC
13:34:58 <dongfeng> oh, I won't be able to finish timely
13:34:59 <joehuang_> that means it must be in the Ocata release
13:35:12 <Yipei> i will do it
13:35:29 <joehuang_> ok, thanks, Yipei
13:35:37 <Yipei> following this design #link https://github.com/openstack/kingbird/blob/master/kingbird/cmd/manage.py
13:35:51 <joehuang_> #action Yipei to fix db mirgation
13:35:56 <joehuang_> yes
13:36:00 <Yipei> ok, got it
13:36:15 <joehuang_> almost same
13:36:19 <Yipei> how to test the code?
13:36:34 <joehuang_> you can use devstak to intall tricircle
13:38:00 <joehuang_> after then just type the command "tricircle-manage db_sync"
13:38:17 <joehuang_> or "tricircle-manage db_version"
13:38:28 <Yipei> ok, got it
13:39:14 <joehuang_> if it's kingbird,  it's similar, jus replace the command to kingbird-xxx
13:39:49 <joehuang_> because Victor's patch has been merged, so the command entry point is avaialble now
13:40:15 <joehuang_> #topic Ocata stable branch plan
13:40:40 <joehuang_> hello, the ocata release data is approaching
13:41:47 <joehuang_> the stable branch date will be around Jan.24
13:42:10 <joehuang_> so all patches should be merged before Jan.24
13:43:40 <joehuang_> after that patches in the master branch will be cherry picked to Ocata branch as needed, maybe not all
13:45:03 <joehuang_> how do you think about the stable branch date
13:46:03 <zhiyuan> we pick up a date before Jan 24th?
13:46:28 <joehuang_> just Jan 24 is also ok, but no later than that
13:46:56 <RongHui11> Jan 24 is ok
13:47:31 <zhiyuan> i think so
13:47:45 <joehuang_> and others?
13:48:05 <Yipei> Jan 24 is fine
13:49:43 <dongfeng> it is fine
13:49:57 <yinxiulin> it is fine
13:50:37 <joehuang_> ok, let's have a stable branch date on Jan 24. After that, some of us may begin Chinese New Year
13:50:46 <joehuang_> holiday
13:51:23 <joehuang_> #info Ocata stable branch date Jan.24
13:51:58 <joehuang_> #topic Tricircle python client
13:52:22 <joehuang_> hello, Victor has started a small project for Tricricle Client
13:54:09 <joehuang_> #link https://github.com/electrocucaracha/python-tricircleclient/
13:54:28 <joehuang_> this is a very good, no need to type curl ....
13:54:46 <zhiyuan> cool, i am tired of curl
13:55:01 <joehuang_> yes, it's very cool
13:56:35 <joehuang_> I don't know how to include the repository into tricircle project
13:57:30 <joehuang_> but found that one project may include several sub-project in one official project
13:57:52 <zhiyuan> it seems that client codes are all put in a separate project
13:58:11 <joehuang_> a separate project? it's also ok
13:58:34 <zhiyuan> like novaclient, neutronclient project
13:59:25 <joehuang_> hmm, time is flying, lots of topics today
13:59:36 <joehuang_> #open discussion
13:59:46 <joehuang_> any topic?
13:59:57 <zhiyuan> no
14:00:00 <dongfeng> no for me.
14:00:06 <RongHui11> no for me
14:00:08 <Yipei> no for me
14:00:27 <yinxiulin> no for me
14:00:55 <joehuang_> ok, thank you for attending the meeting
14:01:00 <joehuang_> #endmeeting