13:01:32 <joehuang> #startmeeting tricircle
13:01:33 <openstack> Meeting started Wed Jan  4 13:01:32 2017 UTC and is due to finish in 60 minutes.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:36 <openstack> The meeting name has been set to 'tricircle'
13:01:52 <yinxiulin> hello
13:01:56 <joehuang> #topic rollcall
13:02:01 <joehuang> #info joehuang
13:02:07 <zhiyuan> #info zhiyuan
13:02:12 <Yipei> #info Yipei
13:02:15 <dongfeng> #info dongfeng
13:02:25 <yinxiulin> #info xiulin
13:02:29 <WuCheng> #WuCheng
13:02:39 <WuCheng> #info WuCheng
13:03:02 <JunSik> #info JunSik
13:03:39 <joehuang> #topic shadow_agent for VxLAN L2 networking/L3 DVR issue
13:04:05 <joehuang> hello, zhiyuan, how about the PoC progress of shadow agent
13:04:24 <joehuang> any challenges found?
13:05:51 <zhiyuan> i have finished the PoC test and yes, the shadow agent/port solution works. some works left before the submission, i need to add a new type driver for shared_vxlan, and also handle resource clearing
13:06:20 <joehuang> so you can prepare a spec for review
13:06:28 <RongHui11> hello
13:06:35 <joehuang> hello, ronghui
13:06:42 <RongHui11> sorry for late
13:06:53 <joehuang> it's fine :)
13:06:55 <zhiyuan> after creating VMs in two pods in the same network, the vxlan tunnels are creating in both pods and thus the two VMs are connected
13:07:10 <zhiyuan> yes, will start to write the spec
13:07:15 <joehuang> awsome!
13:07:36 <joehuang> looking forward for the spec
13:08:27 <zhiyuan> :)
13:08:29 <joehuang> how about L3 bridge network using VxLAN
13:09:12 <zhiyuan> oh, this part not tested yet
13:10:04 <zhiyuan> then i test the vxlan network for l3 first?
13:10:25 <joehuang> it's the key whether we can get the vtep for external gateway port
13:11:25 <zhiyuan> we can collect this in central plugin, but need to figure out how to trigger l2 pop
13:12:01 <zhiyuan> external gateway port is not VM port
13:12:09 <joehuang> for L3 networking, although we can use vlan, but the number is limited, so it's better to use vxlan as the bridge network, no matter for which kind of local network
13:13:20 <joehuang> correct, it's not VM port, the device owner is different
13:13:57 <zhiyuan> maybe we can also create shadow port and shadow agent for gateway port, need further investigation
13:15:57 <joehuang> since currently no vxlan external network has been used yet, so maybe some chanllenge
13:18:29 <joehuang> #action investigate whether shadow agent/port can help L3 networking on VxLAN bridge network
13:18:40 <joehuang> good, next topic
13:18:52 <joehuang> one second
13:19:10 <joehuang> other question on shadow agent/port?
13:20:23 <joehuang> #topic db migration version
13:20:40 <joehuang> hello yipei, how about the db migrate_version
13:20:58 <Yipei> already finish it and tested in my environment
13:21:48 <joehuang> cool
13:21:57 <Yipei> it works, but still have some small problems in code, i will improve it
13:22:24 <Yipei> i just imitate the code in kingbird
13:22:30 <joehuang> #link https://review.openstack.org/416534
13:22:41 <Yipei> still need to do some research on code
13:23:34 <joehuang> tricircle has no tricircle-engine
13:23:36 <Yipei> i still do not understand some details in code
13:23:38 <Yipei> yes
13:23:53 <Yipei> i also discover the problem
13:24:17 <Yipei> need to go on improving the code
13:24:44 <joehuang> you can use configuration file api.conf
13:25:08 <joehuang> but I don't know why configuration file is needed for db-sync
13:27:48 <Yipei> configuration file?
13:28:12 <joehuang> line 65 default_config_files
13:28:48 <Yipei> i also do not know why, i will figure out
13:30:25 <joehuang> ok, please jump to the source code oslo_config to find out the cfg.CONF initiailization
13:30:48 <joehuang> any question?
13:31:03 <Yipei> no
13:31:50 <joehuang> #open discussion
13:31:53 <RongHui11> no
13:32:03 <joehuang> #topic open discussion
13:33:15 <joehuang> how about the qos feature?
13:34:32 <joehuang> is xiongqiu online?
13:34:59 <Yipei> for lbaas, i tested lbaas with Octavia in tricircle
13:35:09 <Yipei> i find some problems
13:35:12 <joehuang> what's found
13:36:00 <joehuang> what did you find?
13:36:02 <Yipei> firstly, for the functions of tricircle, the command "neutron --os-region-name=CentralRegion net-create net1" fails
13:36:38 <Yipei> the error is as follows. Region CentralRegion is not a valid region name for cloud envvars. Valid choices are RegionOne. Please note that region names are case sensitive.
13:36:49 <zhiyuan> oh, that's an old issue
13:37:06 <joehuang> you need to unset the environment variables
13:37:09 <zhiyuan> just run "unset OS_REGION_NAME"
13:37:10 <Yipei> neutron --os-region-name=RegionOne net-create net1, it works
13:37:35 <joehuang> yes
13:37:53 <Yipei> it tried
13:38:03 <Yipei> InternalServerError: Request Failed: internal server error while processing your request.
13:38:40 <Yipei> File "/usr/local/lib/python2.7/dist-packages/neutronclient/v2_0/client.py", line 365, in post
13:38:59 <joehuang> have you added the pod? and all pods exists
13:39:09 <Yipei> yes, all the pods are added
13:39:34 <joehuang> one region or two region
13:39:49 <Yipei> two region
13:40:32 <zhiyuan> then need to dig into the log file to see why
13:40:39 <joehuang> did the second region register to the keystone
13:41:10 <longxiongqiu> Hello, joe. Sorry for lating, i am recently writing a paper for a conference in order to graduate, the conference dead time is near. i will give the completed code to jiawei for testing and upload it.
13:41:34 <joehuang> to xiongqiu, how about the spec?
13:41:55 <RongHui11> i will finish the spec
13:42:07 <Yipei> to joehuang, yes
13:42:35 <Yipei> i will check logs to find the error
13:42:46 <joehuang> so openstack --os-region-name=RegionOne endpoint list works?
13:42:52 <joehuang> yes, please.
13:43:01 <joehuang> Other topics?
13:43:18 <Yipei> to joehuang, it works
13:43:26 <Yipei> also
13:44:08 <Yipei> if i create a net successfully, will neutron create corresponding ports?
13:44:17 <joehuang> no
13:44:26 <Yipei> ok, i see
13:44:47 <joehuang> only if you boot a VM in Nova, or explicitly create a port
13:45:25 <Yipei> how about dhcp_port?
13:45:42 <Yipei> will it also created when booting a VM?
13:45:47 <zhiyuan> dhcp port is created when you create the subnet
13:45:57 <joehuang> not network
13:46:11 <Yipei> no, i create a subnet, but there is no dhcp_port
13:46:17 <joehuang> and if enable_dhcp is true when creating subnet
13:46:42 <zhiyuan> you mean no dhcp port in local neutron?
13:47:18 <Yipei> yes, at first, i tried to install tricircle and octavia together with devstack
13:47:59 <Yipei> octavia will create a subnet, but it fails since there is no dhcp_port
13:48:19 <Yipei> i tried to install octavia manually
13:48:34 <Yipei> after create a subnet, still no dhcp_port
13:48:40 <joehuang> octavia will send command to regionone, I think. Unless you install ocatavia in central region
13:49:41 <joehuang> need to figure out which region ocatavia belongs to, and where the request it issued to
13:49:57 <Yipei> i see
13:50:42 <joehuang> by default, only tricircle api/xjob and central neutron server in central region in devstack installation
13:50:56 <joehuang> so ocatavia by default will be installed in regionone
13:51:31 <zhiyuan> yes, if lb talks to local neutron, it can create the subnet, but dhcp agent will fail to create the dhcp port because the ip is not allocated in central neutron
13:51:52 <Yipei> oh, i see
13:53:01 <joehuang> yes, the local neutron has been configured with tricircle local plugin, the dhcp port behavior is different the default
13:53:43 <Yipei> so i will check logs and try to create nets and subnets first, then install octavia manually. And go on testing
13:53:55 <joehuang> ok, to ronghui, look forward to the spec of qos
13:54:11 <zhiyuan> i think you can just configure LB to talk to central neutron
13:54:32 <zhiyuan> OR we need LB to talk to local neutron?
13:54:33 <joehuang> you can register ocatavia in central region, manually register
13:54:49 <joehuang> remove the old endpoint which resides in the regionone
13:55:38 <joehuang> yes, zhiyuan's proposal may also work
13:55:55 <joehuang> need to find the neutron url configuration in ocatavia
13:56:12 <joehuang> and change it, reboot ocatvia service
13:56:40 <joehuang> but one second
13:56:52 <joehuang> I am afraid it'll fail
13:57:09 <joehuang> because ocatavia now will boot LB service via Nova
13:58:11 <joehuang> I am not sure whether ocatavia can work with different region services, nova/glance in regionone, neutron in centralregion
13:58:22 <zhiyuan> if LB does need to talk to local neutron, then we need to create the network and subnet in central neutron first
13:59:08 <joehuang> I suggest Yipei to study that in detail
13:59:19 <joehuang> time is up
13:59:25 <Yipei> ok
13:59:28 <zhiyuan> and pass the subnet ID in central neutron to LB, when LB tries to query the subnet, the subnet will be created in local plugin
13:59:37 <joehuang> thank you for attending the meeting
13:59:57 <joehuang> #endmeeting