13:01:32 <joehuang> #startmeeting tricircle
13:01:34 <openstack> Meeting started Wed Mar  1 13:01:32 2017 UTC and is due to finish in 60 minutes.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:37 <openstack> The meeting name has been set to 'tricircle'
13:01:54 <joehuang> #topic rollcall
13:01:56 <joehuang> #info joehuang
13:02:04 <RongHui11> #info ronghui
13:02:05 <Yipei> #info Yipei
13:02:06 <dongfeng> #info dongfeng
13:02:14 <zhiyuan> #info zhiyuan
13:02:24 <xiulin> info xiulin
13:02:57 <joehuang> #topic pike release schedule
13:03:13 <joehuang> hello, pike release schedule has been published
13:03:37 <joehuang> #info pike release schedule: https://releases.openstack.org/pike/schedule.html
13:03:52 <joehuang> for milestone pike-1
13:04:16 <joehuang> we have defined our own milestone on Mar.23
13:04:30 <joehuang> #info tricircle milestone pike-1 on Mar.23
13:04:55 <joehuang> for pike-2 and pike-3, we will follow community's plan
13:05:00 <joehuang> that is
13:05:21 <joehuang> #pike-2 jun.9
13:06:15 <joehuang> #info pike-2 Jun.9, pike-3 Jul. 28
13:06:45 <joehuang> any question?
13:07:00 <RongHui11> no
13:07:04 <dongfeng> no
13:07:07 <zhiyuan> no
13:07:07 <Yipei> no
13:07:16 <xiulin> no
13:07:18 <joehuang> good
13:11:54 <tricircle> hello
13:12:10 <RongHui11> you are offline
13:12:12 <joehuang> #topic Launch pad blueprint registration and spec
13:12:17 <joehuang> yes
13:12:36 <joehuang> there are several specs in review
13:12:54 <joehuang> need to register blueprint too
13:13:06 <joehuang> and link the spec to the blueprint
13:14:21 <joehuang> #link https://blueprints.launchpad.net/tricircle
13:15:39 <joehuang> any question on blueprint
13:15:46 <zhiyuan> oh, I will register a BP for cross neutron VxLAN network tomorrow
13:16:05 <dongfeng> will the async job management API need a BP?
13:16:18 <joehuang> #action register a BP for cross neutron VxLAN network
13:16:24 <joehuang> to dongfeng, yes
13:16:33 <dongfeng> ok, will do that.
13:16:52 <joehuang> #action blueprint for async job management API
13:18:10 <joehuang> to ronghui, QoS need a bp too
13:18:26 <RongHui11> ok
13:18:47 <joehuang> to Yipei, and same for LBaaS
13:19:01 <Yipei> ok, i will register a BP for LBaaS, too.
13:19:06 <joehuang> #actopn blueprint for QoS
13:19:20 <joehuang> #action blueprint for LBaaS
13:19:37 <joehuang> ok
13:19:41 <joehuang> next topic
13:19:55 <joehuang> #topic Pike features development
13:20:51 <joehuang> do you have any topic or challenge to be disucssed for feature development
13:21:35 <Yipei> for LBaaS, already enable allowed pair address in central neutron, and success in creating lb, listener, pool, as well as members
13:21:51 <Yipei> via central neutron
13:21:59 <joehuang> o, this is a great progress
13:22:02 <Yipei> however
13:22:41 <Yipei> i find that the vms reside in one subnet cannot communicate with each other
13:23:04 <joehuang> this is caused by security group
13:23:17 <zhiyuan> are they in the same host or different hosts?
13:23:24 <Yipei> in the same host
13:24:21 <Yipei> i try to login the vm through ssh under its network namespace, it fails
13:24:41 <joehuang> when I run LBaaS in lab, you need to create security group rule to allow ssh and icmp for ping
13:24:42 <Yipei> but vnc works
13:24:54 <Yipei> oh, i see
13:25:44 <joehuang> openstack security group rule create default --protocol icmp
13:25:44 <joehuang> openstack security group rule create default --protocol tcp --dst-port 22:22
13:25:47 <joehuang> openstack security group rule create default --protocol tcp --dst-port 80:80
13:25:54 <joehuang> #link https://docs.openstack.org/developer/devstack/guides/devstack-with-lbaas-v2.html
13:26:08 <joehuang> you can refer to the guide I just pasted
13:26:13 <Yipei> ok, got it. i will try
13:26:20 <Yipei> so if it works
13:26:46 <Yipei> i think the LBaaS among vms in the same region can work
13:26:48 <joehuang> there are several default seg, you may have to remmove some unused "default"
13:26:52 <zhiyuan> oh, I think we don't support updating defaulg sg currently
13:27:43 <joehuang> there is one action item for default rule update, may be it's time to do it
13:28:31 <Yipei> i want to have a try, since it is related to LBaaS
13:28:49 <zhiyuan> we need to figure out what rule can be added to default sg
13:29:00 <joehuang> to Yipei, is the address pair sync-ed to the local Neutron?
13:30:47 <Yipei> how to check? in DB?
13:31:11 <joehuang> to zhiyuan, but if there is not under LBaaS, VMs is ping-able?
13:31:29 <Yipei> oh, when installing octavia
13:31:39 <Yipei> it will create many security rules
13:31:59 <Yipei> maybe they are created by octavia
13:32:17 <joehuang> query in local neutron
13:32:32 <zhiyuan> not from external network
13:32:54 <joehuang> for the port which should have addressed pair
13:32:56 <zhiyuan> user needs to create a new sg that allow external access then update the VM port
13:33:25 <zhiyuan> default sg only allows communication between VMs
13:34:21 <joehuang> remote ip prefix is the cidr
13:34:46 <joehuang> otherwise not allowed
13:36:43 <zhiyuan> and we need to tell users that once the original remote-seg-group rule is deleted, they cannot add them back
13:37:13 <zhiyuan> then there's no differences between default sg update and normal sg update
13:40:10 <joehuang> ok. we can discuss this in more detail in #openstack-tricircle
13:40:23 <joehuang> other topics to be discussed?
13:40:48 <joehuang> #info default seg rule update
13:40:55 <Yipei> i checked. the info of allowed address pair is synced in local neutorn
13:41:01 <zhiyuan> do we have a plan of what features should be landed in pike-1 ?
13:41:32 <zhiyuan> follow the schedule we discussed in the meetup?
13:41:59 <joehuang> yes, we have marked features in meetup
13:42:08 <zhiyuan> ok, fine
13:42:21 <joehuang> #info features to be landed in pike-1 is in https://etherpad.openstack.org/p/tricircle-pike-design-topics
13:42:25 <RongHui11> for the new meeting time?
13:42:42 <joehuang> yes, a poll was sent today
13:42:52 <RongHui11> in the maillist there is no info about it
13:43:11 <joehuang> you can click the doodle poll link
13:43:39 <dongfeng> http://doodle.com/poll/hz436r6wm99h4eka#table
13:43:45 <dongfeng> here is the link
13:44:06 <RongHui11> ok
13:44:15 <RongHui11> thank~
13:44:16 <joehuang> #info new weekly meeing poll http://doodle.com/poll/hz436r6wm99h4ekazx455iy5
13:44:21 <joehuang> welcome
13:44:59 <joehuang> other topic?
13:45:05 <dongfeng> oh, joe, your link is not effective
13:45:12 <joehuang> sorry
13:45:24 <joehuang> how to undo
13:45:54 <joehuang> #info new weekly meeing poll (this one is correct) http://doodle.com/poll/hz436r6wm99h4eka#table
13:46:42 <zhiyuan> i find a "#undo topic" command
13:47:04 <joehuang> not topic, undo #info :(
13:48:44 <joehuang> ok, if no other topic, let's end the meeting
13:49:05 <RongHui11> ok
13:49:07 <dongfeng> ok
13:49:12 <zhiyuan> ok
13:49:13 <joehuang> thank you attending the meeting
13:49:20 <joehuang> #endmeeting