01:07:01 <joehuang> #startmeeting tricircle
01:07:02 <openstack> Meeting started Wed Jul 19 01:07:01 2017 UTC and is due to finish in 60 minutes.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
01:07:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
01:07:05 <openstack> The meeting name has been set to 'tricircle'
01:07:18 <joehuang> #topic pike release schedule
01:07:37 <joehuang> hello, the pike release schedule is https://releases.openstack.org/pike/schedule.html
01:08:01 <joehuang> #info pike release schedule
01:08:08 <joehuang> #info pike release schedule https://releases.openstack.org/pike/schedule.html
01:08:47 <joehuang> we'll have pike-3 on Jul 28
01:09:16 <joehuang> let's discuss whether there is challenge for features to land
01:09:24 <joehuang> one by one?
01:09:49 <dongfeng> documentation for routing pagination is under review. may be land in time
01:11:01 <xuzhuang> for job pagination, under modifying after reviews
01:12:00 <joehuang> ok
01:12:40 <RongHui11> for the QoS, merge the two parts and try to pass the jenkins test
01:12:54 <zhiyuan> the smoke test engine has been implemented, may be landed on time. also I have written test for trunk/service function chaining using that engine
01:13:24 <joehuang> yes, I saw that many tests not passed for QoS patch
01:13:42 <Yipei> for lbaas, already finish lbaas in multiple region, it works across instances residing in one subnet, but fail among instances of different subnets
01:13:48 <zhiyuan> though only creation is tested for trunk/service function chaining, it can be improved later
01:13:57 <zhiyuan> so I mark them as WIP
01:14:27 <joehuang> ok, fine. Smoke test should be in high priority to ensure code is merged with quality
01:14:44 <joehuang> To yipei, this is great progress
01:14:56 <Yipei> neutron_lbaas checks whether the subnet of another region exists, and fail to find it
01:15:19 <zhiyuan> because the subnet is not created in that region?
01:16:41 <Yipei> to zhiyuan, yes, i try to add an instance of anther region as a member
01:18:13 <joehuang> I remember that we discussed in the past for subnet in the local Neutron
01:18:39 <joehuang> how to deal with the subnet issue if it's not there for LBaaS
01:19:15 <zhiyuan> yes, I remember that we need to recognize that the get-subnet request is from LB so we redirect the request to central Neutron
01:19:35 <joehuang> #info for lbaas, already finish lbaas in multiple region, it works across instances residing in one subnet, but fail among instances of different subnets
01:20:30 <joehuang> Ronghui, please make sure the patch pass all test, so that further review can be done
01:20:58 <RongHui11> got
01:21:00 <RongHui11> it
01:21:54 <zhiyuan> to yipei, need to check the LB code to see how it validates the existence of the subnet so we can figure out how to play the trick
01:21:57 <joehuang> ok, it's better to include the cli for tricircle API in pike
01:22:27 <joehuang> curl is not friendly
01:22:44 <Yipei> to zhiyuan, got it
01:23:04 <dongfeng> add a link to python tricircleclient at tricircle github directly?
01:23:10 <joehuang> #info discuss how to validates the existence of the subnet in LBaaS
01:23:58 <joehuang> to dongfeng, just need to finish the feature tricircle client, it's can be discovered by openstackclient
01:24:05 <dongfeng> yes
01:24:30 <dongfeng> I use openstack --help can find the command for it
01:25:11 <dongfeng> I find some issues in current implementation of job cli. I'm modifying it
01:26:01 <joehuang> ok, dongfeng, do you think the cli for job and routing could be ready in two weeks?
01:26:22 <dongfeng> cli for routing already implemented
01:26:33 <dongfeng> it's done by victor
01:26:58 <dongfeng> now I only need to implement job cli. I think it can be complete
01:27:23 <joehuang> great, so only job, but how to support pagination in cli?
01:27:52 <dongfeng> job pagination in not implemented in tricircle
01:28:22 <dongfeng> routing pagination can be added to cli in the future
01:28:53 <joehuang> ok
01:31:34 <joehuang> dongfeng, could you initiate one discussion in openstack mail-list, how to implement pagination in cli
01:32:13 <joehuang> if cli will query all pages and display together, the client will be too busy to display information
01:32:57 <joehuang> how openstack deal  with cli in pagination with consistent experienec?
01:33:18 <dongfeng> ok, no problem
01:34:07 <joehuang> #action discuss how to implement pagination query in cli, not lead to cli not working
01:37:23 <joehuang> so I am wondering the usability of CLI if we can not make CLI work well with huge mount of data
01:37:52 <joehuang> pagination is to divide the burden from the server side
01:38:37 <joehuang> but if cli can now work well for pagination(have to show all data in one command), then it's terrible in production
01:39:09 <joehuang> but if cli can not work well for pagination(have to show all data in one command), then it's terrible in production
01:40:00 <joehuang> fortunately we support API first, the client side can use curl to query page by page
01:41:51 <joehuang> Hi, Ronghui, do you think QoS can be landed in time for pike-3
01:42:01 <joehuang> the milestone is Jul 28
01:42:38 <RongHui11> i think there is no problem
01:45:07 <joehuang> ok, let's try best to review the code. And if you want QoS to land in Pike-3, please update the patch as fast as possible after new review comment arrived, and make sure all test passed before next review
01:45:33 <RongHui11> ok
01:46:00 <joehuang> #topic open discussion
01:46:16 <joehuang> any topic to discuss?
01:46:26 <zhiyuan> no from me
01:46:56 <Yipei> no from me
01:46:56 <RongHui11> no
01:47:40 <xuzhuang> no from me
01:48:34 <joehuang> ok, one more topic
01:48:39 <joehuang> #topic PTL election
01:48:55 <joehuang> hello, the PTL election season starts
01:49:30 <joehuang> please nominate yourself if you want to serve as PTL in Queen cycle
01:50:47 <joehuang> the election process is here : https://governance.openstack.org/election/
01:51:10 <joehuang> #info PTL nomination	Jul 31, 2017 23:59 UTC	Aug 09, 2017 23:45 UTC
01:51:32 <joehuang> #info PTL elections	Aug 09, 2017 23:59 UTC	Aug 16, 2017 23:45 UTC
01:52:30 <joehuang> I will be happy to stepping down from PTL after Pike for I have been PTL many cycles, so I  hope you guys can step up for PTL role in Queen
01:53:18 <joehuang> Any question on PTL election, you can send mail in openstack-dev mail-list
01:54:10 <joehuang> other topic
01:54:13 <joehuang> >
01:54:20 <joehuang> other topic?
01:54:26 <dongfeng> no
01:54:34 <Yipei> no
01:54:40 <xuzhuang> no
01:54:45 <zhiyuan> no
01:55:04 <joehuang> ok, let's end the meeting
01:55:09 <joehuang> #endmeeting