01:01:26 <joehuang> #startmeeting tricircle
01:01:27 <openstack> Meeting started Wed Aug  2 01:01:26 2017 UTC and is due to finish in 60 minutes.  The chair is joehuang. Information about MeetBot at http://wiki.debian.org/MeetBot.
01:01:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
01:01:30 <openstack> The meeting name has been set to 'tricircle'
01:01:35 <RongHui11> hello
01:01:35 <joehuang> hello
01:01:44 <joehuang> #topic rollcall
01:01:56 <joehuang> #info joehuang
01:02:00 <zhiyuan> #info zhiyuan
01:02:00 <RongHui11> #info ronghui
01:02:02 <dongfeng> #info dongfeng
01:02:03 <Yipei> #info Yipei
01:03:37 <joehuang> #topic PTL nomination
01:03:47 <joehuang> hello, the PTL nomination is open
01:03:51 <joehuang> #link http://lists.openstack.org/pipermail/openstack-dev/2017-August/120383.html
01:04:28 <joehuang> as I had announced in the weekly meeting and mail-list, I won't plan to run PTL for next cycle
01:04:46 <joehuang> we need more diversity of the community
01:05:08 <joehuang> so I hope that someone else can step up and lead the community
01:05:57 <zhiyuan> I would like to have a try :)
01:06:28 <joehuang> thank you zhiyuan, and please follow the guide in the above link
01:06:37 <joehuang> all of you can have a try :)
01:07:03 <joehuang> please be aware of the nomination deadline
01:07:28 <zhiyuan> ok
01:07:46 <joehuang> except the file submitted to the repository, it's a tradition to send the self-nomination announcement to the mail-list
01:08:09 <joehuang> and prepare for the challenge
01:09:15 <joehuang> next topic, pike-rc
01:09:19 <dims> go zhiyuan !
01:09:27 <joehuang> #topic pike-rc
01:10:11 <joehuang> to dims, we have submitted the patch for tricircle 3.4.0 release
01:10:39 <joehuang> could you help review the release patch, https://review.openstack.org/#/c/488904/
01:10:49 <joehuang> thank you very much
01:11:05 <dims> joehuang : ack
01:11:13 <joehuang> thank you! dims
01:11:49 <zhiyuan> what about the stable/pike branch? is it created automatically?
01:11:58 <joehuang> after 3.4.0 release is tagged successfully, we can start to do regression test for all features landed in pike
01:12:03 <zhiyuan> or we need another patch later?
01:12:27 <joehuang> don't understand your question, zhiyuan
01:12:59 <joehuang> stable/pike for tricircle will not be created now
01:13:26 <zhiyuan> i am asking when the stable/pike branch will be created
01:13:39 <joehuang> after regression test passed, we'll have 3.5.0 release on Aug.22 and with stable/pike branching
01:14:04 <zhiyuan> i see
01:14:50 <joehuang> so for now, we have arrive at the point of feature freeze
01:15:36 <joehuang> and any feature wish to land in pike from now need to ask for RFE(request for exception)
01:16:09 <joehuang> usually no feature will be allowed to be merged, only bug fix is allowed, for stability purpose
01:17:03 <joehuang> but feature development can keep going, and once stable/pike is created, the window for new feature will be openned
01:17:23 <joehuang> any comment
01:17:31 <dongfeng> how about adding pagination for job in tricircleclient ? I planned to add it to tricircleclient before aug 22
01:18:17 <joehuang> you can send one RFE in mail-list
01:18:26 <dongfeng> ok, got it
01:18:38 <joehuang> but tricircleclient has been released
01:19:06 <joehuang> so pagination support for job will be available in next release
01:19:27 <joehuang> tricircleclient has been created with stable/pike.
01:19:56 <joehuang> the community schedule is to freeze client feature on milestone-3
01:20:21 <joehuang> one second
01:21:03 <joehuang> it's no RFE needed for tricircleclient, because the stable/pike has just been created on Monday by ttx
01:21:31 <dongfeng> I saw the your talk about tricircleclient, so finally tricircleclient got released?
01:21:52 <joehuang> https://releases.openstack.org/pike/schedule.html#p-final-clientlib
01:21:53 <joehuang> yes
01:22:13 <joehuang> #link https://review.openstack.org/#/c/488903/
01:22:47 <dongfeng> that's fine.
01:23:08 <joehuang> Jul 24 - Jul 28	R-5	Pike-3 milestone Feature freeze Final release for client libraries
01:24:13 <joehuang> question on the plan?
01:26:01 <dongfeng> Aug. 1 to Aug .22 is time for regressing test ?
01:26:07 <dongfeng> regression test.
01:26:41 <joehuang> yes
01:27:26 <dongfeng> got it.
01:27:36 <joehuang> though most of features are covered by smoke test, it's encouraged to add more test cases to the smoke test
01:28:00 <joehuang> and do manually test as far as possible
01:28:14 <zhiyuan> yes, like test for trunk, I only define the tests for trunk create/delete
01:28:23 <joehuang> once you find some bug, fix it and add new test cases to cover the case
01:28:37 <zhiyuan> need to test add/delete subport
01:29:25 <joehuang> and test cases enhancement will be reviewed and approved quickly
01:30:47 <joehuang> #topic feature development
01:31:05 <joehuang> hello, is there something to share for feature development?
01:32:49 <RongHui11> For the QoS, has not passed the gate-tricircle-dsvm-multiregion-ubuntu-xenial-nv. Could you give us some help
01:32:55 <Yipei> adding instances from different subnet via neutron-lbaas api is ongoing, hopefully it can be delivered in next release
01:36:38 <zhiyuan> to ronghui, you are still struggling on the configuration loading problem?
01:37:00 <RongHui11> yes
01:37:47 <RongHui11> and try some method but still failure
01:41:09 <zhiyuan> ok, will take some time to look at it
01:41:28 <RongHui11> thank you so much
01:41:33 <joehuang> I think we need to submit a patch to make the gate-tricircle-dsvm-multiregion-ubuntu-xenial-nv as voting job
01:42:19 <joehuang> currently this job is non-voting job, so verified ok doesn't mean it pass all test
01:42:44 <joehuang> gate-tricircle-dsvm-multiregion-ubuntu-xenial-nv is much more stable, so we can turn it into voting job
01:43:21 <RongHui11> agree with it
01:44:30 <joehuang> #action make gate-tricircle-dsvm-multiregion-ubuntu-xenial-nv being voting job
01:44:42 <joehuang> #open discussion
01:44:46 <joehuang> other topic?
01:44:50 <dongfeng> no
01:44:52 <RongHui11> no
01:44:57 <Yipei> no
01:45:22 <zhiyuan> what about adding coverage test at the same time?
01:45:33 <zhiyuan> it's also non-voting job
01:45:39 <joehuang> good proposal
01:45:55 <joehuang> #action convert coverage test as voting job too
01:46:13 <RongHui11> good
01:46:54 <dongfeng> then It's more difficult to commit codes. I remember I change the coverage rate when coverage test fails in tricircleclient.
01:46:58 <joehuang> I found that meher from orange has succeeded in installation of two node tricircle
01:47:46 <zhiyuan> to dongfeng, yes, so you need to add test for your newly-added code
01:47:48 <joehuang> coverage is to guarantee the code being tested as far as possible
01:48:37 <dongfeng> :), yes, I willl
01:49:30 <joehuang> next weekly meeting, we may begin to prepare the next cycle, so how about talk about the PTG for next cycle
01:50:28 <dongfeng> that's fine.
01:50:42 <RongHui11> ok
01:50:47 <joehuang> and our weekly meeting time slot is not friendly for European contributor, it's also a good topic
01:51:12 <joehuang> I am sure Meher is based in France.
01:51:53 <joehuang> other topic
01:51:59 <joehuang> ?
01:52:01 <RongHui11> no for me
01:52:06 <zhiyuan> no for me
01:52:14 <Yipei> no for me
01:52:22 <dongfeng> no for me
01:52:37 <joehuang> ok, let's end the meeting
01:52:42 <joehuang> #endmeeting