01:01:40 <zhiyuan> #startmeeting tricircle
01:01:41 <openstack> Meeting started Wed Aug 30 01:01:40 2017 UTC and is due to finish in 60 minutes.  The chair is zhiyuan. Information about MeetBot at http://wiki.debian.org/MeetBot.
01:01:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
01:01:44 <openstack> The meeting name has been set to 'tricircle'
01:02:55 <zhiyuan> at the beginning, just to remind that our PTG will be held on Sep 15th. I set the time from 9:00am to 17:00 pm, is that fine for you?
01:03:09 <joehuang> fine
01:03:18 <Yipei> fine
01:03:21 <dongfeng> fine
01:03:24 <xuzhuang_> fine
01:04:10 <zhiyuan> ok, then I would to have a discussion of one of our configuration options
01:04:34 <zhiyuan> #topic auth_url-and-identity_url
01:04:48 <zhiyuan> currently we have two options about keystone url
01:05:04 <zhiyuan> I scan our code and find that only auth_url is used
01:06:29 <zhiyuan> I am just thinking that these two options may make users confused, especially only one of them takes effect
01:06:30 <joehuang> yes, too many terms in keystone configuration, quite confused
01:07:55 <zhiyuan> this comes to my mind because about two days ago sapd pinged me in the #openstack-tricircle channel
01:08:43 <joehuang> good idea to refine the configuration items
01:09:07 <zhiyuan> sapd failed to access the local neutron server because of keystone auth error.
01:09:42 <RongHui11> hello
01:09:56 <zhiyuan> after modifying the code a bit and use identity_url, sapd succeeded to access the server, so I guess the options are mis-configured
01:10:11 <zhiyuan> hi ronghui
01:11:24 <joehuang> it would be great if sapd can submit a patch to enhance the configuration
01:12:56 <zhiyuan> sapd fork our repos and modify in his own repos, but I have told him the git-review way
01:13:55 <zhiyuan> he tries to use session instead of directly using token in his modification
01:14:45 <joehuang> is the configuration guide not clear enough, then there is space to improve it.
01:14:55 <zhiyuan> but I think improve our configuration options are also fine, since the CI shows that our code works in the default configuration
01:16:02 <zhiyuan> what about improving our doc to tell that auth_url is the used one
01:16:31 <zhiyuan> and also tell users how to correctly configure it
01:16:37 <joehuang> +1
01:17:01 <zhiyuan> later we can remove the identity_url option
01:18:27 <zhiyuan> #action improve configuration guide about auth_url and identity_url
01:18:50 <joehuang> maybe we can have a chat in #openstack-tricircle with sapd, he is not in the meeting now
01:19:28 <zhiyuan> sapd seems to be online at about 11:00
01:19:53 <zhiyuan> we can ping him after the meeting
01:20:12 <zhiyuan> he is trying to intergrate trio2o and tricircle :)
01:20:35 <joehuang> ok
01:22:19 <zhiyuan> ok, next let's sync our progress
01:22:48 <zhiyuan> #topic development-progress
01:24:33 <dongfeng> for me, the patch for job pagination in tricircleclient is committed.
01:24:43 <Yipei> for lbaas, working on improving get_subnet and fixing the wrong route configuration. already tested the code in the environment, it works
01:25:01 <zhiyuan> I have a patch about supporting network direct deleting, but need to evaluate whether it also works in concurrency scenario
01:25:41 <zhiyuan> to dongfeng, yes, I see virtor already posts +2
01:25:55 <joehuang> will review soon
01:26:30 <dongfeng> en, I test it, it works.
01:26:38 <zhiyuan> to yipei, what's the wrong route configuration?
01:27:16 <Yipei> after adding member, the route table is updated
01:27:57 <Yipei> two entries for east-west traffic are replaced
01:28:37 <zhiyuan> oh, I recall the issue. we have discussed that
01:28:42 <Yipei> yes
01:29:45 <zhiyuan> so you can submit both the patch for improving get_subnet and fixing route
01:29:45 <RongHui11> a question for QoS configuration, the configuration of central neutron is according to the driver method, and not very understand for this method
01:30:31 <Yipei> to zhiyuan, ok, got it
01:31:18 <zhiyuan> to ronghui, add QoS pluin to the service plugin, then set the QoS driver as your implementation, have you tried that?
01:32:01 <RongHui11> just trying
01:32:13 <zhiyuan> I think it should be similar to SFC: https://docs.openstack.org/tricircle/latest/networking/networking-guide.html#service-function-chaining-guide
01:32:24 <RongHui11> ok
01:32:49 <zhiyuan> so the problem is that your driver is not called?
01:33:21 <RongHui11> yes
01:35:08 <zhiyuan> the central neutron server log may also show what drivers are loaded
01:35:52 <RongHui11> ok we will check the log and try to fix it
01:36:20 <zhiyuan> one second, let me check the neutron code
01:37:15 <RongHui11> ok
01:41:06 <zhiyuan> the registration of qos driver is not based on configuration
01:41:37 <zhiyuan> it's becaused on notification
01:42:26 <zhiyuan> after receiving the AFTER_INIT event of QOS_PLUGIN, the driver registers itself
01:43:56 <RongHui11> you mean we dont need to add QoS to the service plugin?
01:44:06 <RongHui11> sorry QoS plugin
01:44:25 <zhiyuan> QoS plugin should be added to service-plugin, but no extra driver options
01:44:38 <RongHui11> got it
01:47:13 <zhiyuan> could you check what drivers are loaded by add some print commands in the code?
01:47:47 <zhiyuan> you may need to modify qos plugin in neutron
01:48:35 <RongHui11> not check yet
01:50:07 <zhiyuan> you already call qos_driver.register() in the __init__ of central plugin, so I am confused why the driver is not called
01:51:21 <zhiyuan> we can have further discussion on #openstack-tricircle channel
01:51:31 <RongHui11> ok
01:51:54 <zhiyuan> #topic open-discussion
01:52:07 <zhiyuan> any other topics?
01:52:13 <joehuang> no
01:52:30 <Yipei> no
01:52:32 <RongHui11> no
01:52:56 <zhiyuan> then let's end our meeting, thanks for attending, bye
01:52:57 <dongfeng> no
01:53:06 <dongfeng> bye.
01:53:10 <zhiyuan> #endmeeting