#openstack-meeting: Tricircle Weekly Meeting 2015.06.24

Meeting started by zhipeng at 13:04:14 UTC (full logs).

Meeting summary

  1. Roll Call (zhipeng, 13:04:33)
    1. zhipeng (zhipeng, 13:04:39)
    2. joehuang (joehuang, 13:04:48)
    3. gampel (gampel, 13:05:20)
    4. smizrahi (saggi, 13:05:31)
    5. gsagie (gsagie, 13:05:56)
    6. zhiyuan_cai (joehuang, 13:06:07)

  2. agenda bashing (zhipeng, 13:06:52)
    1. https://wiki.openstack.org/wiki/Meetings/Tricircle (zhipeng, 13:07:16)
    2. today's agenda is on the meeting wiki page (zhipeng, 13:07:32)
    3. any suggestion on more items ? (zhipeng, 13:07:47)
    4. AGREED: agenda agreed (zhipeng, 13:09:05)

  3. introduction of tricircle project (zhipeng, 13:09:21)
    1. The Tricircle idea is originated from two practical projects. (joehuang, 13:10:30)
    2. We have a multi-region solution delivered to our customer, the customer complained on some manual operation like has to configure the VPN connection for the router allocated in different OpenStack instances, and has to repeat that for a new tenant. (joehuang, 13:10:51)
    3. and also like security group, it is difficult to configure per region base for a tenant (joehuang, 13:11:19)
    4. and has to upload image to each region separatly, do the replication manually, but not on demand (joehuang, 13:12:35)
    5. and has to configure the tenant quota per region base. This is painful. (joehuang, 13:12:55)
    6. The second project asked us to provide a layer above multi-region OpenStack instances, but this layer must provide well adopted open api. (joehuang, 13:13:17)
    7. Some other customer also showed similar concerns, at last we think we need to find a way to solve these issues, that's the idea to start tricircle like project. (joehuang, 13:13:53)
    8. zhiyuan explains the clean code base (zhipeng, 13:15:47)
    9. I have added a tag "poc" to the previous code and submitted the new code base. (zhiyuan, 13:15:57)
    10. The code base is simple enough that it only handles creating server and synchronizing status of server and ports, working with openstack 2015.1.0 version (zhiyuan, 13:16:38)
    11. We have built a third party CI to test the new code base. Thought currently this CI doesn't have voting right, we will manually guarantee test passes before patches can be merged. (zhiyuan, 13:17:07)

  4. initial work goal setting (zhipeng, 13:23:56)
    1. ML2 MD + L3 service plugin -> networking-tricircle, would be the L release goal (zhipeng, 13:25:42)
    2. ACTION: gampel saggi specific design doc on API layer idea (zhipeng, 13:36:15)

  5. Project Logistics Discussion (zhipeng, 13:40:31)
    1. AGREED: BP, no spec required for contribution (zhipeng, 13:46:05)
    2. AGREED: joehuang and gampel serve as core reviewers (zhipeng, 13:47:33)

  6. AoB (zhipeng, 13:48:02)
    1. AGREED: concept of code in a branch (zhipeng, 13:53:36)
    2. for daily discussion other than weekly meeting, we could use #openstack-tricircle (zhipeng, 13:55:47)
    3. ACTION: joehuang to clean core member team (zhipeng, 13:59:33)


Meeting ended at 14:00:14 UTC (full logs).

Action items

  1. gampel saggi specific design doc on API layer idea
  2. joehuang to clean core member team


Action items, by person

  1. gampel
    1. gampel saggi specific design doc on API layer idea
  2. joehuang
    1. joehuang to clean core member team
  3. saggi
    1. gampel saggi specific design doc on API layer idea


People present (lines said)

  1. zhipeng (60)
  2. joehuang (58)
  3. gampel (37)
  4. saggi (30)
  5. zhiyuan (14)
  6. openstack (3)
  7. gsagie (1)


Generated by MeetBot 0.1.4.