20:01:31 <lifeless> #startmeeting tripleo
20:01:32 <openstack> Meeting started Mon Jun 10 20:01:31 2013 UTC.  The chair is lifeless. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:35 <openstack> The meeting name has been set to 'tripleo'
20:01:35 <lifeless> welcome welcome welcome
20:01:39 <devananda> \o
20:01:49 <lifeless> #topic agenda
20:01:55 <lifeless> bugs
20:01:56 <lifeless> Grizzly test rack status
20:01:56 <lifeless> CI virtualized testing progress
20:01:56 <lifeless> open discussion
20:02:01 <lifeless> #topic bugs
20:02:32 <lifeless> https://bugs.launchpad.net/tripleo
20:02:58 <lifeless> 12 criticals now, which is better
20:03:00 <lifeless> most in progress
20:03:21 <lifeless> SpamapS: I had the impression you were on  bug 1188301 ?
20:03:23 <uvirtbot> Launchpad bug 1188301 in tripleo "keystone kvs driver causes process to grow indefinitely and spin on CPU with thousands of keys in a single python dict" [Critical,Triaged] https://launchpad.net/bugs/1188301
20:04:12 <lifeless> bug 1188487 is a dup with Ng's work, will mark it so
20:04:13 <uvirtbot> Launchpad bug 1188487 in tripleo "QuantumError updating quantum quotas" [Critical,Triaged] https://launchpad.net/bugs/1188487
20:05:46 <lifeless> bug 1189385 is a fun one - dkehn you might want to eyeball this once you've gotten your current tranch of quantum stuff done
20:05:47 <uvirtbot> Launchpad bug 1189385 in tripleo "quantum-server hung up it's listening port" [Critical,Triaged] https://launchpad.net/bugs/1189385
20:06:00 <dkehn> k
20:06:55 <dkehn> fairly reproducible?
20:06:57 <lifeless> https://bugs.launchpad.net/diskimage-builder/ has no criticals
20:07:16 <lifeless> dkehn: not reproducable at all :(. Get a rack of machines and have users use it.. wait.
20:07:34 <lifeless> dkehn: there may be data in the quantum-server logs if we dig deep enough
20:08:11 <dkehn> lifeless, of course, ok will dig into it, we still need to have a VLAN conversation
20:08:14 <lifeless> any other discussion around bugs? I think we're in ok shape atm, given that we have these zomg's.
20:08:18 <lifeless> dkehn: ok!
20:09:50 <lifeless> #topic Grizzly test rack status
20:11:11 <lifeless> The test rack is still up \o/. We got feedback that quotas were too low, and when trying to raise them the default implementation in Quantum... is static.
20:11:22 <lifeless> #action lifeless to raise that as a quantum bug
20:12:37 <lifeless> other than that though, we seem to be quite operational. No monitoring yet, and I sucked last week - didn't do my actions on writing up requirements.
20:12:46 <lifeless> #action lifeless to do last weeks todos.
20:12:54 <lifeless> any other business around the test rack ?
20:13:25 * mordred likes the test rack
20:13:52 <lifeless> oh-la-la :)
20:13:59 <lifeless> ok,
20:14:02 <lifeless> #topic CI virtualized testing progress
20:14:04 <lifeless> pleia2: tag
20:14:41 <pleia2> so I've been working some on trying to get lxc running tripleo
20:15:03 <pleia2> I got some networking stuff sorted out, but still struggling a bit with getting lxc to boot an image that dib makes
20:15:13 <pleia2> can't even get it to boot the .raw
20:15:41 <lifeless> pleia2: I don't think you want to 'boot it' so much as just mount the filesystem and run it like a regular lxc container, no ?
20:15:55 <lifeless> pleia2: think of it as a fancy chroot problem, not a vm problem.
20:16:08 <pleia2> lifeless: well right, so I've tried some methods of using kpartx on the img
20:16:11 <lifeless> pleia2: would you like a hand? Can one of us familiar with the nasty plumbing help out ?
20:16:29 <pleia2> I might just need to mount it some more manual way and copy stuff over, or something
20:16:32 <lifeless> pleia2: the very fact you say kpartx tells me you're off in the weeds :)
20:16:39 <pleia2> hah, oh no
20:16:54 <lifeless> pleia2: lets take this to -infra, later today.
20:17:00 <pleia2> ok, thanks
20:17:10 <lifeless> #topic open discussion
20:17:31 * lifeless cedes the floor to $someone
20:18:09 <jog0> will the CI virtualized testing replace bm_posuer?
20:18:42 <lifeless> Quite different things I think.
20:19:35 <jog0> aren't both simulating a bare metal multi node enviornment?
20:19:36 <pleia2> right now virtualized testing plans still use bm_posuer
20:20:07 <pleia2> (since it's essentially just an automated version of notes.md)
20:20:09 <lifeless> jog0: bm-poseur is just a setup helper.
20:20:17 <jog0> pleia2: ahh thanks
20:20:39 <pleia2> jog0: have you seen dprince's toci?
20:20:50 <lifeless> jog0: it's like saying 'will ironic replace nova'? -> Huh? What? - no, different beasts.
20:21:33 <pleia2> this is how it's tested on actual hardware: https://github.com/toci-dev/toci and virtualized testing should be somewhat similar
20:21:42 <pleia2> (will probably even use or fork this)
20:22:01 * jog0 is looking now
20:22:58 <jog0> that looks much easier then follwing the notes.md file
20:23:06 <lifeless> heh
20:23:26 <pleia2> when it succeeds, it certainly is
20:23:30 <pleia2> (when it fails, where did it fail?)
20:24:02 <derekh> pleia2 all the logs are loaded into a log dir,
20:24:12 <lifeless> incubation of diskimage-builder is pending proposing tripleo as a program
20:24:22 <lifeless> [opendiscussion segue]
20:24:23 <pleia2> derekh: *nods* that has been very helpful
20:24:47 <derekh> pleia2: also you can make it not do cleanup, helps me a lot when I want to jump in and look around
20:25:16 <pleia2> derekh: I actually had to disable cleanup anyway because I have other kvm instances in libvirt and cleanup is a bit... aggressive :)
20:25:27 * pleia2 learned the hard way
20:25:48 <pleia2> backups are good
20:25:55 <derekh> pleia2: yup, sorry, we should probably change that, noted
20:29:26 <lifeless> ok
20:29:35 <lifeless> seems like we're done here. Last call for threads.
20:35:04 <lifeless> #endmeeting