19:01:34 <lifeless> #startmeeting tripleo
19:01:35 <openstack> Meeting started Tue Oct 29 19:01:34 2013 UTC and is due to finish in 60 minutes.  The chair is lifeless. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:36 <pleia2> o/
19:01:36 <marios> hi
19:01:36 <jog0> o/
19:01:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:39 <openstack> The meeting name has been set to 'tripleo'
19:01:43 <lsmola> hello
19:01:43 <ifarkas> hi
19:01:43 <slagle> hello
19:01:45 <rpodolyaka1> o/
19:01:49 <bnemec> \o
19:02:16 <tzumainn> hiya
19:02:17 <lifeless> #topic agenda
19:02:20 <lifeless> bugs
19:02:20 <lifeless> reviews
19:02:20 <lifeless> Projects needing releases
19:02:20 <lifeless> CD Cloud status
19:02:20 <lifeless> CI virtualized testing progress
19:02:22 <lifeless> Insert one-off agenda items here
19:02:25 <lifeless> open discussion
19:02:37 <lifeless> I want to try and have more time for discussion today, so the regular stuff is going to be rapidfire
19:02:42 <lifeless> #topic bugs
19:02:43 <jcoufal> o/
19:02:48 <lifeless> #link https://bugs.launchpad.net/tripleo/
19:02:48 <lifeless> #link https://bugs.launchpad.net/diskimage-builder/
19:02:48 <lifeless> #link https://bugs.launchpad.net/os-refresh-config
19:02:48 <lifeless> #link https://bugs.launchpad.net/os-apply-config
19:02:48 <lifeless> #link https://bugs.launchpad.net/os-collect-config
19:02:50 <lifeless> #link https://bugs.launchpad.net/tuskar
19:02:53 <lifeless> #link https://bugs.launchpad.net/tuskar-ui
19:02:55 <lifeless> #link https://bugs.launchpad.net/python-tuskarclient
19:03:10 <lifeless> https://bugs.launchpad.net/tripleo/+bug/1245852
19:03:33 <lifeless> https://bugs.launchpad.net/tripleo/+bug/1245863
19:03:36 <shadower> hey, sorry I'm late
19:03:49 <lifeless> rpodolyaka1: whats needed to close 1245863 in tripleo ?
19:04:29 <rpodolyaka1> lifeless: it's been merged to Heat so we effectively use it now
19:04:32 <lifeless> shadower: no worries
19:04:36 <lifeless> rpodolyaka1: ok, so fix released?
19:04:41 <rpodolyaka1> lifeless: yep
19:05:03 <bnemec> For tripleo it's probably invalid, since it was a legitimate bug in heat.
19:05:09 <lifeless> shadower: btw in https://bugs.launchpad.net/tuskar/+bug/1244202 you mark it triaged with unknown importance - could you also please set an importance when triaging ?
19:05:18 <lifeless> bnemec: 6/1 1/2 of the other
19:05:22 <bnemec> Yeah
19:05:25 <shadower> lifeless: oh sorry, will do
19:06:31 <lifeless> ok so *thank you everyone!*
19:06:39 <lifeless> we have no untriaged bugs
19:06:50 <lifeless> that means every user issue reported has had at least minimal eyeballs
19:07:05 <rushiagr2> Hi all!
19:07:06 <lifeless> and ones that seem big marked high/critical. Good stuff
19:07:29 <lifeless> we have one current critical - https://bugs.launchpad.net/tripleo/+bug/1245852
19:08:07 <lifeless> this is a firedrill effectively - whatever it is is breaking overcloud deploys
19:08:33 <lifeless> so if you are in the sysadmin team, please gather data on it, if you aren't please see if you can offer any insight/any requests for data to gather
19:08:56 <rpodolyaka1> has anyone seen it in devtest runs?  (I mean, besides of tripleo-cd cloud)
19:09:29 <lifeless> sounds like no
19:09:39 <lifeless> ok, followup-in-#tripleo-or-the-bug
19:09:56 <lifeless> any additional bug topics?
19:10:23 <lifeless> #topic reviews
19:10:31 <lifeless> http://russellbryant.net/openstack-stats/tripleo-openreviews.html
19:10:34 <lifeless> http://russellbryant.net/openstack-stats/tripleo-reviewers-30.txt
19:10:37 <lifeless> http://russellbryant.net/openstack-stats/tripleo-reviewers-90.txt
19:10:54 <lifeless> we've slipped a little
19:10:56 <lifeless> 
19:10:56 <lifeless> Stats since the last revision without -1 or -2 (ignoring jenkins):
19:11:00 <lifeless> Average wait time: 1 days, 14 hours, 20 minutes
19:11:02 <lifeless> 1rd quartile wait time: 0 days, 2 hours, 21 minutes
19:11:05 <lifeless> Median wait time: 0 days, 4 hours, 7 minutes
19:11:05 <lifeless> 1st quartile is fantastic
19:11:08 <lifeless> 3rd quartile wait time: 4 days, 3 hours, 13 minutes
19:11:25 <lifeless> median is ok
19:11:29 <lifeless> 3rd quartile is sad
19:11:30 <lifeless> 
19:11:31 <lifeless> Longest waiting reviews (based on latest revision):
19:11:31 <lifeless> 5 days, 6 hours, 52 minutes https://review.openstack.org/53587 (Add James Slagle to tripleo-cd-admins.)
19:11:34 <lifeless> 1 days, 5 hours, 27 minutes https://review.openstack.org/54121 (Allow Neutron to schedule networks lazily)
19:11:37 <lifeless> 0 days, 4 hours, 7 minutes https://review.openstack.org/54347 (Rename heat_watch_server_url to watch_server_url)
19:12:02 <lifeless> the admins team one now has enough votes, I'll ack that
19:12:11 <lifeless> whats up with the lazy neutron review?
19:12:49 <rpodolyaka1> it's been actively +1'ed :)
19:12:58 <lifeless> yeah
19:13:07 <lifeless> I'm sure of those +1's have +2 access, no ?
19:13:22 <lifeless> lsmola: marios: ?
19:13:55 <lsmola> lifeless, I haven't try whether it actually works, just code review
19:13:55 <lifeless> yeah, lots do
19:14:07 <marios> lifeless: yeah i was following the "if you're not entirely familiar then just +1 it"
19:14:13 <lifeless> ok, fair enoug
19:14:17 <lifeless> *fair enough*
19:14:32 <lifeless> SpamapS: since i know you're around, care to wrap that one up :)
19:15:01 <lifeless> still, I'm broadly happy, two outliers does not a systemic problem make.
19:15:10 <lifeless> Again, thank you all for stepping up
19:15:23 <lifeless> #topic
19:15:27 <lifeless> #topic  Projects needing releases
19:15:32 <lifeless> ng, where is ng
19:16:08 <lifeless> we may need to come back to this topic
19:16:15 <lifeless> #topic CD Cloud status
19:16:30 <lifeless> firstly healthwise
19:16:47 <lifeless> pretty good except a) the undercloud firmware on it's eth2 keeps crapping out every few days :(.
19:17:14 <lifeless> And b) just last night ovs-vsctl calls started wedging themselves, and thats make neutron-api unhappy, and thats make nova unhappy
19:17:17 <lifeless> and -> fail.
19:17:36 <lifeless> there is a bug about the specific thing but we may want to file a bug about the cascading failure nature of it too
19:18:04 <lifeless> I suggest that whoever gets to the bottom of the failure bug make a decision as to whether to file another bug
19:18:10 <lifeless> Progress wise
19:18:29 <lifeless> we've got a patch set up adding ephemeral support for nova
19:18:47 <lifeless> review 52704 is the top of that
19:19:11 <lifeless> we've got basic code for using the ephemeral partition in t-i-e but nothing actively exercising it yet
19:19:24 <lifeless> we haven't started doing db sync more regularly
19:19:39 <jog0> t-i-e?
19:19:46 <lifeless> and we haven't taught rebuild how to preserve the ephemeral partition - but we do seem to have broad acceptance of the idea on openstack-dev
19:19:50 <lifeless> jog0: tripleo-image-elements
19:20:18 <lifeless> there will be some minor glue after this teaching our heat templates to use rebuild
19:20:27 <lifeless> but we're nearly there I think
19:20:52 <lifeless> modulo getting stuff landed ;)
19:21:07 <jog0> landing stuff will cease up next week
19:21:10 <lifeless> #topic CI virtualized testing progress
19:21:15 <lifeless> pleia2: ^
19:21:34 <pleia2> so last week I started sorting out some of the networking stuff for setting up the framework for testing
19:21:53 <pleia2> fortunately we don't statically mention brbm many places, so this isn't much of a headache (configure-vm will need to be updated)
19:22:20 <pleia2> continuing to work through iteration 2, trying to use as much existing tripleo code as possible for it
19:22:23 <pleia2> #link https://etherpad.openstack.org/p/tripleo-test-cluster
19:22:55 <pleia2> and I nudged infra folks about getting some assistance with gearman, so that should be lined up when I'm ready
19:23:15 <lifeless> cool
19:23:34 <lifeless> remember it is a new gearman instance, so if it's deploy stuff you need, ping #tripleo :)
19:23:50 <lifeless> if it's knowledge, -infra is totally the people to ask
19:24:06 <pleia2> right, this is knowledge stuff, I'm pretty weak on gearman still (it's a newish thing for us)
19:24:24 <lifeless> kk (me too FWIW)
19:24:42 <lifeless> any more CI virt testing stuff ?
19:24:45 <pleia2> that's it
19:25:12 <lifeless> ok
19:25:14 <lifeless> so no sign of ng
19:25:21 <lifeless> #topic Projects needing releases
19:25:43 <lifeless> Anyone want to volunteer to pick up the torch of making sure every project with unreleased commits has had a release this week ?
19:25:56 <lifeless> it would be grand to walk into the summit with no backlog
19:26:24 <rpodolyaka1> lifeless: I'd like to help, but know nothing about release process :(
19:26:33 <rpodolyaka1> lifeless: if there is a guide, I could make it
19:26:40 <lifeless> rpodolyaka1: if you're willing to learn, your help will be totally appreciated!
19:26:59 <rpodolyaka1> lifeless: sure, I'll take it
19:27:03 <lifeless> cool
19:27:20 <lifeless> I will look for existing docs and send you + -dev an email later today.
19:27:25 <rpodolyaka1> lifeless: thanks!
19:27:39 <lifeless> #action lifeless look for existing docs and send rpodolyaka1 + -dev an email later today on doing releases.
19:28:50 <lifeless> #topic open discussion
19:30:22 <rushiagr2> I am new here, but going to stay for long
19:30:39 <rushiagr2> Would keep bothering u guys as i come up to speed with tripleo
19:30:43 <lifeless> rushiagr2: welcome!
19:30:44 <jcoufal> rushiagr2: welcome on board :)
19:30:50 <lsmola> rushiagr2, welcome
19:31:01 <lifeless> rushiagr2: what has you interested in tripleo ?
19:31:31 <rushiagr2> We are coming up with a huge public cloud, from india
19:32:04 <lifeless> rushiagr2: cool! with soren etc?
19:32:09 <rushiagr2> And we are just starting.. So i took up the job to help with ci/cd
19:32:10 <lifeless> rushiagr2: or another one?
19:32:17 <rushiagr2> Yes, with soren
19:32:58 <lifeless> sweet
19:33:43 <lifeless> How is this meeting time for the european contingent?
19:33:50 <lifeless> IIRC you just entered daylight savins?
19:33:53 <lifeless> *savings*
19:34:00 <jcoufal> yeah, currently it starts at 8pm
19:34:57 <jcoufal> not big change though, at least for me
19:35:27 <rushiagr2> In India it is 00:30 in the morning (night?)
19:35:36 <lifeless> rushiagr2: eep!
19:35:44 <lifeless> rushiagr2: dedication!
19:36:06 <rushiagr2> Forced dedication :-P
19:36:08 <shadower> lifeless: you wanna keep the meeting bound to UTC or observe some summer/winter time change?
19:36:12 <lsmola> :-D
19:36:50 * shadower is perfectly happy with UTC, fwiw
19:37:07 * jcoufal is voting for UTC
19:37:14 <jomara> shadower: does czech republic do utc or change times?
19:37:18 <lsmola> UTC is cool
19:37:32 <shadower> jomara: we've just switched away from DST
19:37:34 <lifeless> shadower: keeping it to the one time is better if possible.
19:37:40 <shadower> jomara: just like the US only two weeks earlier
19:37:41 <jomara> shadower: ah ok, we do sunday
19:37:52 <lifeless> shadower: since there are like 4 different DST dates for different countries - at each edge
19:37:59 <shadower> lifeless: yeah
19:38:02 <shadower> fine by me
19:38:08 <lifeless> Ng: welcome!
19:38:18 <lifeless> Ng: rpodolyaka1 is going to take on getting releases done this week
19:38:29 <lifeless> Ng: could you give him a quick handover email?
19:38:52 <Ng> sure
19:38:56 <rpodolyaka1> Ng: thanks!
19:39:11 <Ng> rpodolyaka1: what's your preferred mail address for that?
19:39:34 <rpodolyaka1> Ng: rpodolyaka@mirantis.com
19:39:43 <lifeless> ok
19:39:56 <lifeless> so I think we're basically done then. Lets let rushiagr2 get some sleep :)
19:39:59 <Ng> rpodolyaka1: thanks
19:40:01 <lifeless> #endmeeting