19:00:41 <lifeless> #startmeeting tripleo
19:00:41 <openstack> Meeting started Tue Dec 10 19:00:41 2013 UTC and is due to finish in 60 minutes.  The chair is lifeless. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:44 <openstack> The meeting name has been set to 'tripleo'
19:00:47 <dkehn> hi
19:00:47 <slagle> hi
19:00:48 <jtomasek> hi
19:01:01 <lsmola_> o/
19:01:03 <marios> o/
19:01:09 <lifeless> ulp, someone deleted standing agenda items, please hold while I recover from history
19:01:12 <tzumainn> hiya
19:01:15 <jprovazn> hi
19:01:16 <jistr> o/
19:01:16 <dprince> sup
19:01:35 <devananda> \o
19:01:36 <bnemec> \o
19:02:17 <lifeless> #topic agenda
19:02:19 <lifeless> bugs
19:02:19 <lifeless> reviews
19:02:19 <lifeless> Projects needing releases
19:02:19 <lifeless> CD Cloud status
19:02:21 <lifeless> CI virtualized testing progress
19:02:24 <lifeless> Insert one-off agenda items here
19:02:26 <lifeless> moving TripleO UI under Horizon codebase
19:02:29 <lifeless> open discussion
19:02:33 <lifeless> #topic bugs
19:02:39 <lifeless> #link https://bugs.launchpad.net/tripleo/
19:02:39 <lifeless> #link https://bugs.launchpad.net/diskimage-builder/
19:02:39 <lifeless> #link https://bugs.launchpad.net/os-refresh-config
19:02:39 <lifeless> #link https://bugs.launchpad.net/os-apply-config
19:02:39 <lifeless> #link https://bugs.launchpad.net/os-collect-config
19:02:41 <lifeless> #link https://bugs.launchpad.net/tuskar
19:02:44 <lifeless> #link https://bugs.launchpad.net/tuskar-ui
19:02:46 <lifeless> #link https://bugs.launchpad.net/python-tuskarclient
19:03:23 <lifeless> criticals:
19:03:28 <lifeless> https://bugs.launchpad.net/tripleo/+bug/1254246
19:03:34 <lifeless> https://bugs.launchpad.net/tripleo/+bug/1254555
19:03:50 <rpodolyaka1> fix for the first one is on review
19:03:55 <rpodolyaka1> one +2 so far
19:04:15 <rpodolyaka1> but reviews in neutron are really slow
19:04:26 <lifeless> untriaged:
19:04:32 <lifeless> https://bugs.launchpad.net/os-apply-config/+bug/1258351
19:04:38 <lifeless> https://bugs.launchpad.net/diskimage-builder/+bug/1252977
19:04:47 <lifeless> https://bugs.launchpad.net/tripleo/+bug/1259417
19:04:54 <lifeless> https://bugs.launchpad.net/tripleo/+bug/1242266
19:05:23 <lifeless> rpodolyaka1: would it help if we agitate for these in the Neutron meeting; given they are regressions...
19:06:47 <rpodolyaka1> lifeless: ok. will try to ping folks in irc tomorrow, the meeting was yesterday
19:06:53 <lifeless> rpodolyaka1: ok, cool
19:07:11 <lifeless> So we're a little behind on triage; I know I let myself get a little slack, cause we were so well triaged for a while.
19:07:27 <lifeless> Reminder to everyone! triage all the projects once a week - many hands, light work.
19:07:54 <slagle> ack
19:08:18 <jprovazn> one bug which I think should be set to high or critical - https://bugs.launchpad.net/tripleo/+bug/1226310 (the neverending LIBVIRT_URI), if you agree, I'll be happy to create/send a patch which adds nova config option for this?
19:08:26 <lifeless> A cursory look suggests at least one high in there
19:08:44 <lifeless> jprovazn: hey; so I *thought* we fixed it back at the sprint
19:09:08 <slagle> we had a fix, it no longer works
19:09:10 <lifeless> jprovazn: export it locally, or is this for the overcloud itself ?
19:09:23 <slagle> the environment variable in the systemd service file for nova compute no longer seems to be taking effect
19:09:27 <jprovazn> lifeless, I remember you mentioned it's sovled, but I never got abck to it since that, I think it's exported on wrong machine
19:09:27 <lifeless> ok, nuts.
19:09:55 <slagle> i wonder if something changed in the virtual power driver somewhere to how the evnironment is exported to ssh
19:10:00 <jprovazn> lifeless, so quick fix: document it, longer/better fix: nova patch
19:10:15 <lifeless> jprovazn: +1 IMO; review if nova have concerns
19:10:21 <lifeless> s/review/revisit/
19:10:34 <slagle> there's no fix to document yet, unless we add to bashrc on the host or something
19:10:39 <slagle> but we can discuss post-meeting
19:10:48 <lifeless> ack
19:10:49 <jprovazn> ok
19:10:54 <lifeless> any other bug business?
19:11:52 <lifeless> moving on
19:11:59 <lifeless> #topic reviews
19:12:13 <lifeless> #link http://russellbryant.net/openstack-stats/tripleo-openreviews.html
19:12:21 <lifeless> 
19:12:21 <lifeless> Stats since the last revision without -1 or -2 :
19:12:21 <lifeless> Average wait time: 3 days, 12 hours, 43 minutes
19:12:21 <lifeless> 1rd quartile wait time: 0 days, 3 hours, 22 minutes
19:12:21 <lifeless> Median wait time: 0 days, 9 hours, 2 minutes
19:12:23 <lifeless> 3rd quartile wait time: 8 days, 3 hours, 26 minutes
19:12:31 <lifeless> so our latency is good - folk are getting prompt feedback
19:12:39 <lifeless> are there any specific reviews folk want to talk about ?
19:12:50 <jomara> lifeless: do you ever compare us to other projects?
19:12:54 <lifeless> jomara: yes
19:12:54 <jomara> lifeless: we have to be #1 in the business
19:12:55 <marios> lifeless: srsly - this is beyond good. you should see what happens in neutron
19:13:21 <lifeless> I'm really thrilled with how we're handling reviews
19:13:36 <lsmola_> agreed, also Horizon is muuuch slower
19:13:43 <jomara> yeah patches in horizon take weeks
19:13:46 <rpodolyaka1> good job!
19:14:02 <jomara> upside: you never have a hard time finding something to review there :)
19:14:13 <jcoufal> o/
19:14:25 <lifeless> jomara: zing :(
19:14:28 <tzumainn> lol
19:14:32 <lifeless> ok, moving on
19:14:40 <lifeless> #topic Projects needing releases
19:15:02 <lifeless> rpodolyaka1: Should we rotate the post, or are you up for another week ?
19:15:16 <rpodolyaka1> lifeless: I am up
19:15:33 <lifeless> #note rpodolyaka1 to release projects again - thanks!
19:15:55 <lifeless> #topic CD Cloud status
19:16:16 <lifeless> SpamapS put in a tone of effort to turn around the quagmire we had gotten stuck in
19:16:26 <lifeless> over the weekend we ran out of undercloud disk space
19:16:47 <lifeless> We're currently blocked on further improvements on the nova rebuild feature
19:17:22 <lifeless> SpamapS: is there more we should capture?
19:17:36 <lifeless> rpodolyaka1: any update on that? I've been struggling to get a deep enough timeslice to move it forward
19:17:50 <rpodolyaka1> lifeless: unfortunately, no :(
19:18:08 <rpodolyaka1> planning to hack on this tomorrow though
19:18:30 <lifeless> ok; I'm wondering if we should cast a somewhat wider net - e.g. the main list - and ask for a volunteer
19:18:49 <rpodolyaka1> +1
19:18:49 <lifeless> I suggested to SpamapS he might want to tool up on Nova and get into it
19:18:57 <rpodolyaka1> at least to get attention of reviewers
19:19:03 <rpodolyaka1> to get early feedback
19:19:22 <lifeless> so that is fairly discouraged on the list
19:19:42 <lifeless> I would happily say 'hey, we're having folk pulled this way and that, and it's super important to us, so if you have spare time we'd love the help
19:19:55 <lifeless> but if we want some eyeballs, #openstack-nova and a gentle ask there is the way to go
19:20:02 <rpodolyaka1> got it
19:20:26 <lifeless> I will ask in IRC today for some quick one-off reviews
19:20:35 <rpodolyaka1> cool!
19:20:35 <lifeless> coarse grained, no deep thought
19:20:46 <lifeless> #todo lifeless to ask for first-pass reviews of the rebuild patch set
19:20:58 <lifeless> rpodolyaka1: is it functional, do you think?
19:20:59 <lifeless> like
19:21:18 <rpodolyaka1> lifeless: so rebuild works for me for libvirt
19:21:24 <lifeless> if it worked, we could deploy that on our undercloud while it gets polish, and move forward
19:21:35 <lifeless> with preservation?
19:21:42 <rpodolyaka1> oh, not yet
19:21:45 <lifeless> oh, we'll need the client to expose the option too, right ?
19:21:55 <rpodolyaka1> yep, and we've got a patch already
19:22:10 <lifeless> sweet!
19:22:23 <rpodolyaka1> so no preservation yet, just the glue for it
19:22:31 <rpodolyaka1> from API layer
19:22:57 <lifeless> ok -> #openstack-meeting for a minute, they are talking tripleo testing - and it was the next item on the agenda here too
19:23:07 <lifeless> #topic testing
19:38:28 * SpamapS arrives late
19:39:30 * bnemec points SpamapS to openstack-meeting
19:39:32 <jdob> SpamapS: we're over in #openstack-meeting
19:39:36 <bnemec> It's where all the cool kids are. :-)
19:39:53 <SpamapS> I see that
19:39:55 <lifeless> sorry folk, we're still going on testing over <- there
19:40:02 <jdob> talking testing and we just narrowly avoided trying to get the bots to talk between channels and gain sentience and all of the armageddon that entails
19:48:02 <lifeless> ok
19:48:17 <lifeless> #topic moving TripleO UI under Horizon codebase
19:49:39 <lifeless> so - thoughts on this?
19:49:43 <SpamapS> I'm +1 for that. I don't feel qualified at all to do reviews of the code itself.
19:49:52 <SpamapS> The design process should still happen in TripleO
19:50:04 <jistr> SpamapS: +1
19:50:13 <lsmola_> lifeless, when should this happen?
19:50:17 <jtomasek> +1
19:50:42 <lifeless> lsmola_: if there is consensus on it happening, both here and w/Horizon, we can talk timing :)
19:50:50 <lsmola_> lifeless, and yeah +1, seems all UI belongs to Horizon
19:50:58 <slagle> has the horizon team said anything? besides dlyle's initial response on the list to the core reviewer thread?
19:50:59 <lifeless> lsmola_: I think it's largely up to the folk doing the work
19:51:14 <jtomasek> lifeless: we will discuss this on horizon meeting in few hours
19:51:18 <lifeless> slagle: ^ :)
19:51:23 <slagle> :)
19:51:29 <lifeless> So the one thing I'm concerned about is review latency there
19:51:41 <slagle> yes, me too (given earlier comments)
19:51:53 <jtomasek> I think we are in process to improve that too
19:52:04 <slagle> so, hopefully folks who are tripleo core and working on tuskar_ui can become horizon core?
19:52:07 <jistr> are any of the tripleo folks also horizon core?
19:52:08 <lsmola_> lifeless, well it should be better when we will be there fulltime, itÅ› like extra 6 people
19:52:27 <lsmola_> jistr, not yet
19:52:30 <jtomasek> jistr: not yet afaik
19:52:48 <lsmola_> jistr, though we will need to become core, to keep things rolling
19:53:03 <lifeless> lsmola_: perhaps - I mean, it depends on why there is the latency there is.
19:53:17 <lifeless> If it's not enough core bandwidth, then yeah, adding to core will help.
19:53:32 <lifeless> If it's something else, might need to focus on figuring that out and debugging it.
19:53:49 <lifeless> review is just a process like any other :)
19:53:58 <lsmola_> lifeless, well right now, there are only a few people doing reviews
19:54:10 <lifeless> ok, so yeah then I concur :)
19:54:39 <jistr> lsmola_: ok so seems there might be a bump initially, but when some of you guys get into core, it should be ok again
19:55:09 <lsmola_> jistr, yeah, I guess
19:55:13 <lifeless> I think it would be reasonable to do what we did with the initial tuskar -> tripleo merge
19:55:36 <jistr> lifeless: +1 that's a great idea, hopefully horizon folks will be ok with that
19:55:37 <lifeless> which is to say (as tuskarUI would still be a distinct codebase until tuskar API has been integrated) -
19:55:43 <lsmola_> lifeless, not sure if that will be possible, but yeah, it would be nice
19:56:25 <lifeless> have all of horizon-core + the folks from tripleo-core that want to work on tuskar-ui be -core for tuskar-ui specifically, then take 3/4/5 months to let them learn the horizon review norms
19:56:41 <lifeless> make it graceful
19:57:00 <lifeless> I don't think thats a sustainable long term structure - silos and all - but to make the move smooth it makes a lot of sense to me
19:57:10 <lsmola_> lifeless, well most of us are on Horizon code around 5 months
19:57:31 <lifeless> lsmola_: sure, so well integrated already one hopes :)
19:57:53 <lifeless> so there seems definite consensus here on moving the UI under the horizon programme
19:58:09 <lifeless> will someone take point on coordinating that?
19:58:31 <lsmola_> lifeless, we will see after the Horizon meeting
19:58:44 <lifeless> lsmola_: Ok, but I'd like to have a contact person
19:58:51 <lsmola_> lifeless, seems like david-lyle has to decide :-)
19:58:51 <lifeless> lsmola_: contingent on the Horizon folk also wanting this.
19:59:12 <lsmola_> lifeless, ok I volunteer if nobody else wants it
19:59:17 <lifeless> I'd like to be able to say - talk to <foo> about the mechanics for making this happen, they are going to do the work
19:59:52 <lifeless> 20s for someone else to volunteer1
20:00:00 <jomara> lsmola_: you've got it@!
20:00:13 <lsmola_> excellent
20:00:28 <jtomasek> I can split the work with lsmola if it's too much for him:)
20:00:30 <lifeless> #action lsmola_ to be executor for tuskar-UI->horizon move (if Horizon agrees)
20:00:34 <lsmola_> lifeless, I am good at delegating :-)
20:00:38 <lifeless> #topic open discussion
20:00:42 <lifeless> #endmeeting