19:01:32 <lifeless> #startmeeting tripleo
19:01:33 <openstack> Meeting started Tue May 20 19:01:32 2014 UTC and is due to finish in 60 minutes.  The chair is lifeless. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:35 <lifeless> #topic agenda
19:01:36 <openstack> The meeting name has been set to 'tripleo'
19:01:39 <lifeless> bugs
19:01:39 <lifeless> reviews
19:01:39 <lifeless> Projects needing releases
19:01:39 <lifeless> CD Cloud status
19:01:39 <lifeless> CI
19:01:41 <lifeless> Insert one-off agenda items here
19:01:44 <lifeless> open discussion
19:01:52 <lifeless> any one-off things to add ?
19:02:09 <tchaypo> I'd like to talk about switching to an alternate time every second week
19:02:14 <tchaypo> Starting next week maybe
19:02:32 <bnemec> o/
19:02:35 <lifeless> ok, #topic bugs
19:02:42 <lifeless> #link https://bugs.launchpad.net/tripleo/
19:02:43 <lifeless> #link https://bugs.launchpad.net/diskimage-builder/
19:02:43 <lifeless> #link https://bugs.launchpad.net/os-refresh-config
19:02:43 <lifeless> #link https://bugs.launchpad.net/os-apply-config
19:02:43 <lifeless> #link https://bugs.launchpad.net/os-collect-config
19:02:45 <lifeless> #link https://bugs.launchpad.net/os-cloud-config
19:02:47 <lifeless> #link https://bugs.launchpad.net/tuskar
19:02:50 <lifeless> #link https://bugs.launchpad.net/python-tuskarclient
19:03:41 <lifeless> its all red :(
19:04:43 <pblaho> o/
19:04:55 <SpamapS> lifeless: progress! (before it was all untriaged) ;)
19:05:17 <lifeless> hah
19:05:38 <bnemec> That many critical bugs suggests that _nothing_ should be working right now.  This makes me think our severity assignments may need tweaking...
19:06:05 <lifeless> bnemec: some hp folk spent a huge chunk of last week dealing with nothing working right now :)
19:06:16 <lifeless> https://bugs.launchpad.net/tuskar/+bug/1308172
19:06:19 <lifeless> has no assignee
19:06:22 <SpamapS> and arguably.. nothing is working.. :-P
19:06:27 <SpamapS> CI down.. nothing working :)
19:06:46 <lifeless> https://bugs.launchpad.net/diskimage-builder/+bug/1314021 has a patch needing +A
19:06:57 <bnemec> I thought CI was up, but R1 was having issues.
19:07:06 * bnemec is still catching up after Summit though
19:07:24 <lifeless> R1 has twice-ish the capacity, it being down == huge queues
19:07:27 * giulivo got a successful run today at some point though
19:07:50 <tchaypo> It sounds like we have a clear focus for everyone for the next couple of days then
19:08:08 <bnemec> Right, which is _one_ critical bug. :-)
19:08:20 <greghaynes> A lot of them are bm specific
19:08:32 <lifeless> do you mean
19:08:33 <bnemec> (not saying we don't have others - we don't test everything in CI - but I'm skeptical that there are really that many crits still)
19:08:34 <lifeless> 'on baremetal'
19:08:37 <greghaynes> yes
19:08:39 <lifeless> or 'nova-baremetal'
19:08:49 <greghaynes> on baremetal
19:08:50 <lsmola> lifeless: I have created same tuskar bug months ago
19:09:02 <greghaynes> because theres also the fun ironic ones :)
19:09:03 <lsmola> lifeless: the solution is to use barbican most probably
19:09:07 <lifeless> lsmola: that is a tuskar bug :/
19:09:11 <SpamapS> https://bugs.launchpad.net/os-apply-config/+bug/1299109 can be closed I think
19:09:14 <lifeless> lsmola: well its marked critical
19:09:19 <SpamapS> or dropped to Medium
19:09:46 <jdob> lifeless: the answer to it is gonna change in juno than what it would be in icehouse, can we punt it until then?
19:10:02 <lifeless> jdob: as a team we're meant to be jumping on criticals
19:10:04 <jistr> i don't think the tuskar bug is critical tbh
19:10:14 <lifeless> jdob: if the priority is wrong - fix it
19:10:22 <slagle> it's a security issue, that's why i filed it as critical
19:10:30 <slagle> you dont display plain text passwords to users
19:10:36 <lifeless> jdob: if the priority is right, lets fix it in whatever fashion as soon as possible
19:10:46 <slagle> if folks disagree, change the priority, but i feel it's a crit
19:10:51 <lifeless> jdob: in this case, it looks like a hack might work around it in short order
19:10:59 <lifeless> slagle: I agree with you :)
19:11:25 <jdob> slagle: I agree with the sentiment, but i suppose I'm questioning calling anything in tuskar icehouse a critical
19:11:29 <jdob> is anyone actually using it?
19:11:37 <lifeless> jdob: thats tuskar trunk, no ?
19:11:47 <jdob> ya
19:11:52 <lsmola> slagle: I have put it to high, the migration to barbican is planned
19:12:13 <jdob> slow down there, I wouldn't say a "migration to barbican is planned"
19:12:16 <lsmola> slagle: there is no quick fix, I tried before
19:12:24 <jdob> it's being discussed, but to say that's a plan is a bit presumptious
19:12:26 <lsmola> jdob: well something like that
19:12:39 <lsmola> jdob: it's the best option so far
19:12:51 <lifeless> we're going to be passing in passwords forever
19:12:57 <jdob> ya, but that doesn't equal "planned", but we're off topic for the meting
19:12:59 <lifeless> for the case where a stack integrates with an existing facility
19:13:13 <slagle> lsmola: there is always a quick fix :). if 'Password' in ParameterName, display ****
19:13:20 <lifeless> its not clear to me that barbican helps there, but ^^^ seems doable
19:13:30 <jistr> slagle: yeah that sounds like the best we can do for now
19:13:35 <lsmola> slagle: you mean just for CLI?
19:14:00 <lifeless> FWIW I'd be happier for such a fix to be done and the bug to still be critical :)
19:14:04 <SpamapS> I missed the link to the bug being discussed
19:14:10 <jistr> ok i'll take the bug
19:14:12 <lsmola> slagle: cause we are using Admin Password to connect to Overcloud now
19:14:15 <jdob> SpamapS: https://bugs.launchpad.net/tuskar/+bug/1308172
19:14:17 <slagle> i would say api as well, i dunno, what does Heat do?
19:14:33 <jistr> ah i see rpodolyaka1 took it
19:14:33 <SpamapS> Ah. Yeah, don't do that. ;)
19:14:33 <jistr> ok
19:14:37 <jdob> heat looks at the no echo attribute
19:14:40 <jdob> which we don't have in icehouse
19:14:44 <jdob> but will for juno
19:15:51 <bnemec> Does this help at all? https://github.com/openstack/oslo-incubator/blob/master/openstack/common/log.py#L245
19:16:23 <jdob> bnemec: the thing is, there's no inspection done on the config values when they are displayed
19:16:34 <jdob> not that it couldn't be added
19:16:48 <jdob> with a quick hack similar to what slagle suggested
19:17:18 <lsmola> slagle: https://bugs.launchpad.net/tuskar/+bug/1282066
19:17:40 <lsmola> slagle: it was discussed before and agreed as a weakness
19:18:00 <lsmola> slagle: we are planning to do it properly in Juno
19:18:10 <lifeless> ok so
19:18:13 <lifeless> I think the lesson here is
19:18:19 <lifeless> we should all spend more time looking at criticals
19:18:22 <lifeless> and asking questions
19:18:30 <lifeless> because this design discussion could have happened weeks ago :)
19:19:07 <jdob> ya, that makes sense
19:19:18 <lifeless> now looking at the other criticals
19:19:26 <lifeless> they seem to be things that CI doesn't cover
19:19:31 <lifeless> e.g. newer versions of rabbit
19:19:37 <lifeless> or physical hardware issues
19:19:45 <lifeless> so they may well be critical but untested :(.
19:20:00 <lifeless> lets circle back to that aspect in the CI segment ?
19:20:07 <SpamapS> agreed
19:20:35 <tchaypo> +1
19:20:37 <lifeless> #topic reviews
19:20:51 <lifeless> http://russellbryant.net/openstack-stats/tripleo-openreviews.html is still sadface
19:21:16 <lifeless> I know I know there is another thing
19:21:19 <SpamapS> can we at least acknowledge that http://www.stackalytics.com/report/reviews/tripleo-group/open is more useful than no data at all?
19:21:29 <SpamapS> http://www.stackalytics.com/report/contribution/tripleo-group/30 too
19:21:31 <jdob> stats are gonna be a bit goofy this month with summit
19:21:55 <SpamapS> Yeah I did like, 5 reviews over the last 10 days
19:21:57 <lifeless> SpamapS: it is more useful than no data, but is not the data we consult in this part of the meeting
19:22:05 <SpamapS> lifeless: it is today. :)
19:22:05 <lifeless> SpamapS: so its a wash, at best IMO.
19:22:16 <lifeless> anyhow, we
19:22:20 <lifeless> we're still under water
19:22:32 <lifeless> I will look to see if there is a pattern or something today and send mail
19:22:35 <SpamapS> and it has been far more available than russleb's stats
19:23:00 <lifeless> SpamapS: thats all true but doesn't get the since-negative slice that we've been consulting
19:23:14 <lifeless> SpamapS: so its getting kindof old that you point at it everytime when it doesn't answer the question I'm asking
19:23:21 <bnemec> http://www.nemebean.com/reviewstats/tripleo-open.html
19:24:11 <bnemec> I'm only generating the stuff I care about, but I started copying my local stats to a public place.
19:24:30 <SpamapS> lifeless: "more useful than no data at all?" is the question I ask.
19:24:33 <lifeless> bnemec: thank you!
19:24:57 <lifeless> SpamapS: useful enough to look at is the question I'm asking.
19:25:15 <lifeless> bnemec: maybe we should add that to the wiki page for the meeting
19:25:29 <lifeless> anyhow
19:25:30 <lifeless> 1rd quartile wait time: 1 days, 1 hours, 11 minutes
19:25:30 <lifeless> Median wait time: 6 days, 9 hours, 49 minutes
19:25:30 <lifeless> 3rd quartile wait time: 13 days, 5 hours, 46 minutes
19:25:36 <bnemec> We should really get reviewstats running in infra...
19:25:46 <tchaypo> is that wait for comment?
19:25:58 <lifeless> tchaypo: thats the
19:25:58 <lifeless> Stats since the last revision without -1 or -2 :
19:26:20 <bnemec> Lower than I expected right after summit.
19:26:37 <lsmola> jdob: http://lists.openstack.org/pipermail/openstack-dev/2014-February/027582.html , I think barbican was mentioned here
19:27:07 <lifeless> ok so
19:27:19 <tchaypo> now that the gate is fixed, i have some reviews which have >=2 +2s and have passed the gate, so I'll bug people about +As for those later
19:27:23 <lifeless> can we set a group goal? next week, get that 13 days down to 12 ?
19:27:44 <GheRivero> +2
19:28:01 <GheRivero> It should be doable
19:28:27 <lifeless> #vote group goal - 12 days 3rd quartile wait time for since-negative-review ?
19:28:37 <lifeless> hmm
19:28:37 <bnemec> Hmm, some of those look to be WIP.
19:28:45 <marios> tchaypo: i've come across a bunch of those last few days too
19:29:02 <bnemec> I wonder if reviewstats is still missing some Gerrit-2.8-isms.
19:29:13 <bnemec> Seems like WIP shouldn't count against these stats.
19:29:17 <lifeless> bnemec: it may be, I agree
19:29:20 <marios> lots with +2 but not approved waitimg]]ng on tests
19:29:26 <lifeless> #startvote group goal - 12 days 3rd quartile wait time for since-negative-review ?
19:29:27 <openstack> Begin voting on: group goal - 12 days 3rd quartile wait time for since-negative-review ? Valid vote options are Yes, No.
19:29:28 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:29:33 <lifeless> #vote yes
19:29:43 <Ng> #vote yes
19:29:44 <jdob> #vote yes
19:29:46 <tchaypo> marios: the gate has been broken, but i believe it got fixed last night
19:29:48 <jistr> #vote yes
19:29:49 <GheRivero> #vote yes
19:29:50 <jprovazn> #vote yes
19:29:51 <rpodolyaka1> #vote yes
19:29:54 <bnemec> #vote yes
19:29:58 <marios> yes
19:30:01 <tchaypo> #vote yes
19:30:04 <slagle> #vote yes
19:30:08 <marios> #vote yes
19:30:16 <greghaynes> #vote yes
19:30:25 <greghaynes> welp, this vote looks like a close one
19:30:29 <lifeless> #endvote
19:30:31 <openstack> Voted on "group goal - 12 days 3rd quartile wait time for since-negative-review ?" Results are
19:30:39 <lifeless> contentious
19:30:43 <tchaypo> dammit, I was about to change my vote
19:30:44 <Ng> results indeed are
19:30:59 <lifeless> I wonder
19:30:59 <bnemec> Heh, is the voting case-sensitive?
19:31:02 <lifeless> #startvote group goal - 12 days 3rd quartile wait time for since-negative-review ?
19:31:03 <openstack> Begin voting on: group goal - 12 days 3rd quartile wait time for since-negative-review ? Valid vote options are Yes, No.
19:31:04 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:31:05 <lifeless> #vote Yes
19:31:09 <bnemec> #vote Yes
19:31:09 <jdob> #vote Yes
19:31:10 <lsmola> #vote yes
19:31:11 <Ng> #vote Yes
19:31:12 <jistr> #vote Yes
19:31:13 <rpodolyaka1> #vote Yes
19:31:13 <jistr> :)
19:31:21 <lifeless> #endvote
19:31:22 <openstack> Voted on "group goal - 12 days 3rd quartile wait time for since-negative-review ?" Results are
19:31:28 <lifeless> nope, just broken :)
19:31:32 * jdob anxiously waits for the votes to be reported
19:31:38 <lifeless> can someone take an action to file a bug on infra  ?
19:31:57 <lifeless> #topic projects needing releases
19:32:20 <rpodolyaka1> I'm ready to help here :)
19:32:21 <lifeless> Any volunteers?
19:32:25 <lifeless> sweet
19:32:29 <lifeless> #action rpodolyaka1 to release the world.
19:32:38 <lifeless> #topic CD Cloud status
19:32:52 <lifeless> HP region is in bad shape; SpamapS has details
19:33:04 <tchaypo> marios: since you have +2, maybe you could hunt down some of them and push them through now? ;)
19:33:24 <Ng> https://bugs.launchpad.net/openstack-ci/+bug/1321434
19:33:50 <marios> tchaypo: sure did a round of recheck no bugs today will chase up tomorrow
19:33:53 <tchaypo> I'm still unable to get my hpcloud vpn working; I'll follow up about that later today
19:34:02 <tchaypo> marios: thanks
19:34:47 <lifeless> neither derekh nor dprince are here
19:34:55 <lifeless> but AFAIK the RH region is fine
19:35:07 <lifeless> #topic CI
19:36:19 <lifeless> ok so
19:36:55 <lifeless> we were talking about coverage before
19:37:23 <lifeless> is there anything we can do to get a wider set of coverage
19:38:27 <jistr> get tuskar on par with tripleo-incubator scripts and use tuskar in the CI jobs instead
19:38:31 <greghaynes> There was a thing brought up at the summit about maybe having a contrib for elements
19:39:00 <greghaynes> basically do something about the elements which arent actually tested anywhere and live in t-i-e
19:39:45 <lifeless> jistr: that will get tuskar coverage indeed
19:41:29 <bnemec> It's a tricky thing to automate coverage of all the elements - we probably can't just build an image with $EVERYTHING.
19:41:49 <greghaynes> also having fedora test one set of elements thats not necessarially the same as ubuntu was mentioned (e.g. fedora use mariadb and ubuntu use percona)
19:41:55 <lifeless> so we need functional tests
19:42:01 <lifeless> e.g. the rabbit latest thing
19:42:08 <lifeless> thats not failing at build
19:42:11 <lifeless> its failing at runtime
19:42:35 <lifeless> dan is very worried about adding width until we've got high reliability of what we have
19:42:39 <bnemec> Which is a whole other level of complexity.
19:42:41 <lifeless> derek ran a session on that at the summit
19:43:28 <lifeless> so perhaps the thing is to help him get that into a spec
19:43:34 <lifeless> and then pick an item and hack on it ?
19:43:52 <bnemec> +1
19:44:00 <bnemec> We aren't going to be able to do everything all at once anyway.
19:44:05 <lifeless> naturally
19:44:19 <lifeless> anyone care to volunteer to touch base with derek about the specificiation of this ?
19:44:29 <lifeless> (and help :))
19:45:06 <bnemec> I can get together with him.  It's kind of related to my testing stuff anyway.
19:45:13 <lifeless> cool
19:45:27 <lifeless> #action bnemec to follow up with derekh on CI improvements + spec
19:45:55 <lifeless> #topic meeting times
19:46:06 <lifeless> tchaypo: you have de floor
19:46:35 <tchaypo> So, we've had lots of email discussion, we seem to have agreed on a time, I think
19:46:48 <lifeless> we did? cool. (what was it :))
19:46:59 <greghaynes> I think it was midnight PST?
19:47:07 <greghaynes> which actually is totally fine with me ;)
19:47:14 <lifeless> great
19:47:15 <tchaypo> I don't remember, that's why I was being vague - it's about 2 weeks since I looked at the email.. let me dig it up
19:47:22 <tchaypo> What I was going to ask is if anyone objects
19:47:34 <lifeless> tchaypo: so action it - this meeting has less coverage than the list :)
19:47:36 <tchaypo> and also if anyone knows how to edit the calendar, since it seems to be wrong for other people's meetings as well
19:48:34 <tchaypo> yep, 0700UTC is what I suggested, which is midnight PST at the moment
19:48:59 <tchaypo> Great. I'll go ahead and edit the wiki today and see if I can find someone who knows how to update the calendar
19:49:09 <lifeless> its a script
19:49:11 <lifeless> talk to ttx
19:49:19 <lifeless> #topic open discussion
19:49:38 <slagle> lifeless: are you going to run the meeting at both times?
19:49:47 * bnemec not attending a 2AM meeting
19:50:08 <bnemec> But that's a tradeoff of better international coverage, so no choice really.
19:50:24 <jprovazn> more feedback on haproxy ports mail (http://lists.openstack.org/pipermail/openstack-dev/2014-May/034915.html) would be appreciated to get some consensus
19:50:28 <lifeless> slagle: I hope so, need to check local time and see if its baby bedtime or later
19:50:44 <lifeless> slagle: if I can't, then e.g. tchaypo or stevenk certainly can
19:50:50 <slagle> ok, if not, we should have a designated leader i think for the alternate time
19:50:59 <lifeless> slagle: great point, I agre
19:51:12 <marios> lifeless: its time of this meeting +12hrs noif not mistaken
19:51:34 <giulivo> FWIW we tried alternate meetings in tempest , for me they didn't work very well , people tend to forget about or join only half of the times
19:52:18 <tchaypo> yeah, #meetbot looks fairly simple to drive
19:52:24 <tchaypo> but no, it's only 10 hours offset
19:52:32 <marios> how about alternating the weekly meeting between the 2 slots and have reviews meeting for the other
19:52:42 <tchaypo> this meeting is UTC1900, the alternate I've suggested is UTC0700
19:52:46 <tchaypo> wait, that's 12 hours
19:52:49 <lifeless> tchaypo: you sure about that ? thats 12 ..
19:52:57 <marios> though this may just get complicated
19:53:00 <jdob> not just a matter of driving it, the bot only listens to certain people, no?
19:53:18 <tchaypo> The whole point is to get a meeting where I need less coffee in order to do simple math...
19:53:23 <bnemec> The bot listens to whomever started the meeting.
19:53:25 <bnemec> (I think)
19:53:38 <jdob> i thought a while ago slagle tried to run one but the bot wouldn't listen and he had to get perms
19:53:44 <jdob> but i could be totally wrong
19:54:10 <tchaypo> marios: so you're suggesting have two meetings each week, one of them just for reviews?
19:54:18 <slagle> you don't need any special perms afaik as long as you're the one to #startmeeting
19:54:28 <jdob> gotcha, ignore me then
19:55:13 <marios> tchaypo: well yeah if we want to alternate the actual meeting time then we have an extra slot each week
19:55:58 <marios> tchaypo: vs just duplicating this meeting into 2 slots
19:56:49 <tchaypo> So this meeting's agenda would be the same but minus reviews, and we'd have an hour to go over the review stats?
19:56:58 <lifeless> uhm
19:57:14 <lifeless> so whats the benefit of two meetings a week? We don't usually run out of time :)
19:57:55 <slagle> i *think* marios was suggesting a meeting to go over reviews like ironic did for a while
19:57:58 <Ng> Is there a way to get meeting logs emailed to yourself? I'm unlikely to make the alt time :)
19:58:02 <marios> tchaypo: not stats.i mean actually attack a queue of reviews and discus/resolve in place
19:58:24 <slagle> which actually, i don't really want to do, b/c i don't think our reviews are really all that contentious. most of the time :)
19:58:24 <tchaypo> ng: yes, go to the page, copy, paste...
19:58:31 <Ng> ;)
19:58:38 <giulivo> I'd +1 Ng's idea if we are to run with alternate
19:58:46 <giulivo> maybe I can check that
19:59:13 <tchaypo> marios: it;s not clear to me what we'd gain over just doing them in-channel whenever they come up
19:59:24 <Ng> It might make sense for the prettified meeting logs to get mailed to -dev
19:59:37 <lifeless> Ng: gosh no
19:59:42 <tchaypo> but since ironic was doing it, it sounds like other people have actual experience that would trump my speculation
19:59:57 <lifeless> Ng: there are waaaaay to many meetings for that to be anything but destructive to the S/N ratio
20:00:06 <lifeless> slagle: I'm with you
20:00:09 <greghaynes> -meetings
20:00:14 <tchaypo> Ng: I've noticed that pleia2 does that for the infra meetings - a followup to the "reminder: meeting is on tomorrow" that has a link to the logs
20:00:18 <Ng> lifeless: Pff, it's such a quiet list, ;)
20:00:22 <marios> tchaypo: well would let you show up and pimp your pending reviews for focused attention for example
20:00:24 <lifeless> ok, we're out of time
20:00:34 <lifeless> #action tchaypo to action alternating meetings thing
20:00:37 <marios> tchaypo: but anyway just a suggestion/thoughr
20:00:37 <lifeless> #endmeeting