07:00:26 <tchaypo> #startmeeting tripleo
07:00:27 <openstack> Meeting started Wed May 28 07:00:26 2014 UTC and is due to finish in 60 minutes.  The chair is tchaypo. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:00:30 <openstack> The meeting name has been set to 'tripleo'
07:00:39 <GheRivero> o/
07:00:41 <lsmola> hello
07:01:00 <tchaypo> Ooh, we have people here already, that's exciting
07:01:06 <lsmola> :-)
07:01:14 <greghaynes> O/
07:01:22 <lsmola> not many it seems :-)
07:02:17 <GheRivero> yeah. not really crowded
07:02:31 <tchaypo> true. But it's the first one at this time, and it's my first time driving meetbot, so it's very exciting anyway
07:02:33 <tchaypo> for me at last
07:03:07 <tchaypo> #topic agenda
07:03:16 <tchaypo> bugs
07:03:19 <tchaypo> reviews
07:03:21 <tchaypo> Projects needing releases
07:03:23 <tchaypo> CD Cloud status
07:03:25 <tchaypo> CI
07:03:27 <tchaypo> Insert one-off agenda items here
07:03:29 <tchaypo> open discussion
07:03:38 <tchaypo> Anything else?
07:03:57 <tchaypo> We had a few action items last week - http://eavesdrop.openstack.org/meetings/tripleo/2014/tripleo.2014-05-20-19.01.txt
07:04:13 <tchaypo> but I'm guessing bnemec and rpodolyaka aren't here, so we can carry those over to next week.
07:04:21 <rpodolyaka> tchaypo: I'm here
07:04:25 <tchaypo> The third item was to have a meeting at this time and I seem to have managed that
07:04:33 <tchaypo> rpodolyaka: excellent :)
07:04:45 <tchaypo> No other items?
07:05:08 <tchaypo> #topic bugs
07:05:12 <tchaypo> https://bugs.launchpad.net/tripleo/
07:05:15 <tchaypo> https://bugs.launchpad.net/diskimage-builder/
07:05:17 <tchaypo> https://bugs.launchpad.net/os-refresh-config
07:05:19 <tchaypo> https://bugs.launchpad.net/os-apply-config
07:05:21 <tchaypo> https://bugs.launchpad.net/os-cloud-config
07:05:23 <tchaypo> https://bugs.launchpad.net/os-collect-config
07:05:25 <tchaypo> https://bugs.launchpad.net/tuskar
07:05:27 <tchaypo> https://bugs.launchpad.net/python-tuskarclient
07:05:37 <greghaynes> oh wow, serious red for tripleo bugs :(
07:06:10 <lifeless> o/
07:06:14 <jistr> o/
07:06:15 <lifeless> baby in bed
07:06:17 <GheRivero> it's been a complicated week :)
07:06:27 <tchaypo> Yeah, 5 new unassigned undecided
07:07:05 <tchaypo> one in os-cloud-config - StevenK could you jump on that one?
07:08:15 <tchaypo> it looks like tripleo is the one project that needs some serious attention though.
07:08:24 <greghaynes> closed https://bugs.launchpad.net/tripleo/+bug/1319978
07:09:22 <tchaypo> StevenK and I are planning to spend friday in the office together; it would be good to clear them up before then, but we can plan to bash on them together then if they're still open
07:10:42 <tchaypo> #info tripleo project has 12 new/incomplete bugs, many of them unassigned. This needs some attention
07:11:05 <tchaypo> Anything else to add before we move on?
07:11:48 <tchaypo> #topic reviews
07:12:44 <tchaypo> http://russellbryant.net/openstack-stats/tripleo-openreviews.html still seems to be blank
07:12:51 <greghaynes> I think this had a vote last meeting?
07:12:52 <lifeless> bnemec has a url
07:13:07 <derekh_> www.nemebean.com/reviewstats/tripleo-open.html
07:13:23 <jistr> 12 days \o/
07:13:36 <tchaypo> I think meetbot grabs anything with a url and I don't need to mention those with #link
07:13:37 <lifeless> we had a goal last week to bring it down
07:13:40 <tchaypo> so I'm just leaving that be
07:13:47 <tchaypo> Notes are at http://eavesdrop.openstack.org/meetings/tripleo/2014/tripleo.2014-05-20-19.01.txt
07:14:09 <tchaypo> The group goal was to hit 12 days
07:14:22 <lifeless> which we have \o/
07:14:54 <tchaypo> I must be dense, I'm not seeing where to read that
07:15:11 <pblaho> o/
07:15:24 <lifeless> tchaypo:
07:15:24 <jistr> tchaypo: since the last revision without -1 or -2, 3rd quartile
07:15:25 <lifeless> Stats since the last revision without -1 or -2 :
07:15:25 <lifeless> Average wait time: 8 days, 17 hours, 38 minutes
07:15:25 <lifeless> 1rd quartile wait time: 2 days, 3 hours, 11 minutes
07:15:25 <lifeless> Median wait time: 6 days, 15 hours, 39 minutes
07:15:27 <lifeless> 3rd quartile wait time: 12 days, 2 hours, 48 minutes
07:15:29 <tchaypo> lo pblaho
07:15:45 <tchaypo> oh, of course, that's "since-negative-review"
07:16:01 <tchaypo> I was looking for the words "since negative review" #tooliteral
07:16:42 <tchaypo> I'm not going to propose a new vote - I think we have too few people, and my understanding is that the meetings aren't the best place for a decision anyway
07:16:44 <tchaypo> but
07:17:09 <tchaypo> #info Target from last meeting - 3rd quartile wait time since last negative review - has been achieved
07:17:21 <tchaypo> #info Let's aim for 11 days next week!
07:17:35 <marios> o/ woops. you'd think i'd remember the first meeting at an actually convenient time
07:18:31 <tchaypo> I planned to be online 12 hours ago just in case there was confusion, but I managed to sleep in for a change. it was lovely :)
07:18:43 <marios> tchaypo: lol :)
07:18:43 <tchaypo> Okay, unless we have anything further to say about reviews...
07:19:14 <tchaypo> #topic Projects needing releases
07:19:30 <rpodolyaka> not a problem, I can volunteer this week too
07:19:40 <lsmola> tchaypo: 12 hours ago, there was just me and jrist :-D
07:19:50 <tchaypo> #info rpodolyaka to save our bacon once again
07:20:00 <tchaypo> Actually
07:20:06 <marios> rpodolyaka: you got a link to those notes you made for the release process? seems like if you or slagle are away would be good to have backup
07:20:16 <tchaypo> #action see above
07:20:17 <marios> rpodolyaka: does it take a lot of time in your week?
07:20:26 <rpodolyaka> marios: 1-2 hours
07:20:51 <rpodolyaka> marios: mostly reading the changes, deciding what part of the version to bump
07:21:05 <rpodolyaka> marios: https://wiki.openstack.org/wiki/TripleO/ReleaseManagement
07:21:05 <marios> rpodolyaka: i think you documented it somewhere no?
07:21:09 <marios> rpodolyaka: great thanks mate
07:21:13 <rpodolyaka> marios: np
07:22:07 <tchaypo> So...
07:22:10 <tchaypo> coing up next...
07:22:19 <tchaypo> #topic CD Cloud status
07:22:28 <tchaypo> lifeless: I hear tell this hasn't been swell
07:25:05 <lifeless> its been rocky
07:25:12 <lifeless> so there is an etherpad
07:25:20 <lifeless> https://etherpad.openstack.org/p/tripleo-ci-r1-trusty
07:25:32 <lifeless> which is about getting hp1 entirely onto trusty
07:25:39 <lifeless> without that we should expect more issues still
07:26:55 <lifeless> we've also hit the stuck session in nodepool again
07:27:04 <derekh_> lifeless: so R1 isn't currently being used by nodepool,
07:27:05 <lifeless> filed a bug for that on novaclient and made a (little) fuss about it
07:27:11 <lifeless> derekh_: rh1 ?
07:27:20 <derekh_> lifeless: should we just leave it that way until we get to trust ?
07:27:45 <SpamapS> derekh_: IMO yes
07:27:51 <derekh_> lifeless: R2 is running ok, but struggle to keep up with the full load in the absense of R1
07:28:16 <derekh_> lifeless: # worker nodes was finially increased from 10 to 18 last night
07:28:25 <lifeless> derekh_: nodepool has ~ 60 active slaves in hp1
07:28:35 <lifeless> derekh_: why do you say its not being used ?
07:28:47 <lifeless> ah, they are mostly missing public ips
07:28:51 <derekh_> lets see if that helps and if it doesn't maybe we should get rid of an overcloud job for a bit
07:29:00 <SpamapS> lifeless: I don' think they're reaching READY
07:29:12 <SpamapS> lifeless: when I boot an instance, it never fully establishes an SSH connection
07:29:26 <lifeless> SpamapS: I tested instances with ssh just fine
07:29:29 <derekh_> lifeless: nodepool most be spinning thme up without deciding their usable
07:29:30 <SpamapS> interesting
07:29:37 <SpamapS> perhaps it was just one bad compute node?
07:29:42 <derekh_> lifeless: none are getting used goodsquishy.com/downloads/s_tripleo-jobs.html
07:29:53 <SpamapS> lifeless: did you actually SSH in, or just telnet to port 22?
07:30:11 <lifeless> SpamapS: ssh in
07:30:13 <lifeless> SpamapS: sudo'd
07:30:13 <SpamapS> lifeless: I got fails after connection, traffic would stop flowing
07:30:16 <lifeless> SpamapS: apt-get updated
07:31:04 <derekh_> lifeless: perhapes those 19 jobs in the ? region were on R1, ? means they failed befor the log entry allowing me to decipher the region
07:31:08 <lifeless> lets -> #tripleo for details
07:31:21 <lifeless> its clearly bong, since only one node has a public IP
07:31:28 * derekh_ nods
07:31:30 <lifeless> we'll likely need infra logs to see whats up
07:31:40 <lifeless> public IP is pretty much the first thing that nodepool should be doing
07:32:14 <tchaypo> Do we have a specific action item to record here?
07:32:56 <lifeless> no
07:32:58 <derekh_> tchaypo: action have a side meeting about R1 in #tripleo after main meeting
07:33:03 <lifeless> or yues :)
07:33:41 <tchaypo> #action derekh_ SpamapS lifeless to discuss CD in R1 further
07:33:54 <tchaypo> #info it's been a rocky week
07:34:06 <tchaypo> #topic CI
07:34:22 <tchaypo> I feel like this isn't going to be much different
07:35:05 <tchaypo> derekh_: there was an action item from last week for bnemec to follow up with you about ci improvements and spec - did that happen?
07:35:17 <derekh_> tchaypo: spec for ci improvements is up, finding link
07:35:35 <derekh_> https://review.openstack.org/#/c/95026/
07:35:56 <derekh_> reviews welcome :-)
07:36:06 <tchaypo> #info As per action item from last week, https://review.openstack.org/#/c/95026/ is a spec for ci improvements
07:36:43 <tchaypo> #info derekh_ welcomes reviews :)
07:36:46 <tchaypo> anything else?
07:37:59 <tchaypo> #topic Insert one-off agenda items here
07:38:34 <tchaypo> #info all the action items from last week have already been covered #yay
07:38:37 <derekh_> Oh I had something I wanted to mention
07:38:49 <tchaypo> The floor is yours :)
07:38:52 <derekh_> gerrit no longer does auto abandon of patches,
07:38:59 <tchaypo> bahahahaha
07:39:02 <tchaypo> that's quite a change
07:39:16 <derekh_> could people look through old patchs and abandon things that are irrelevant
07:39:24 <tchaypo> Could you say that again with an hashtag-info ?
07:39:27 <marios> derekh_: didn't know that. it's both a good and a bad thing though.
07:39:37 <derekh_> #info could people look through old patchs and abandon things that are irrelevant
07:39:49 <tchaypo> #info as Gerrit doesn't auto-abandon any more
07:40:08 <tchaypo> #topic open discussion
07:40:09 <marios> tchaypo: are we going to try and match (upcoming) specs to juno release schedule? do we want to think (or already have) a date for specs to be in by?
07:40:33 <tchaypo> marios: I feel like that's a question we should ask elsewhere
07:40:39 <derekh_> marios: ya its a little good but I think its mostly bad as stale patches will end up staying around and taking up peoples time
07:40:54 <marios> tchaypo: yeah, mostly rhetorical. don't expect full discussion/decisions here
07:40:55 <lifeless> so core can mark patches as WIP
07:41:00 <tchaypo> either on the mailing list, or simply by proposing a spec that says we match the specs to the release schedule and see how that goes
07:41:01 <lifeless> but I don't think thats sufficient
07:41:10 <lifeless> but we can review with WIP hidden
07:41:16 <lifeless> as an interim measure
07:41:43 <marios> lifeless: just bringing it up as it's something i saw in neutron
07:41:54 <derekh_> lifeless: agreed WIP isn't sufficient, if we start reviewing with WIP's hidden then whats the point of people using WIP at all for get feedback
07:41:57 <marios> lifeless: juno-1 has been made up with all expected bugs/reviews etc
07:42:06 <tchaypo> We seem to be near the end of my first meeting, and lifeless hasn't felt the need to use the second set of pedals yet. Iguess that means I can graduate to p-plates next time?
07:42:09 <lifeless> derekh_: WIP is for 'don't review yet' :)
07:42:11 <marios> lifeless: any specs from now on will be taken per case etc
07:42:12 <lifeless> derekh_: explicitly so
07:42:27 <lifeless> marios: sorry, I don't quite follow the question
07:42:43 <marios> lifeless: are we going to try and match (upcoming) specs to juno release schedule?
07:42:51 <marios> do we want to  think (or already have) a date for specs to be in by?
07:42:53 <lifeless> marios: what does that mean ?
07:42:58 <marios> haha
07:43:03 <marios> lifeless: we have specs
07:43:11 <marios> lifeless: (either approved or under discussion)
07:43:17 <marios> lifeless: we have a juno release schedule
07:43:51 <marios> lifeless: do we want to make a list of when we expect certain specs to have been implemented, bugs closed etc, for juno release schdule
07:44:11 <derekh_> lifeless: I though WIP was more of a "here is the direction I'm going in if ya wanna take a look but don't review in detail yet cause I not finished" button
07:44:23 <tchaypo> So we have a juno folder in the specs repo; I had been assuming that anything in there was targetted at Juno release, but we can move things if they slip
07:45:16 <marios> tchaypo: sure, i meant more like 'juno-1' we try and concentrate on these things, if they land ok juno-2 will be this and this etc etc
07:45:56 <lifeless> marios: so, I generally think that organising every little thing like that is a boiling-the-ocean problem
07:45:59 <derekh_> Do we know when the mid cycle sprint is ?
07:46:01 <marios> e.g. like this https://launchpad.net/neutron/+milestone/juno-1
07:46:05 <tchaypo> Mayhap it would be useful to make juno/1, juno/2 and so on?
07:46:07 <lifeless> derekh_: I'm waiting on jcoufal for that
07:46:19 <tchaypo> To me it sounds like it would realy be useful to have a spec describin how the spec repo operates
07:46:24 <lifeless> derekh_: though if he doesn't post to the list soon I'm going to have to find alternate venues since folk won't have time to book
07:46:25 <derekh_> lifeless: ok
07:46:25 <marios> lifeless: just a question/suggestion as i hadn't come across it before and thought it was possibly a useful resource to refer to during the cycle
07:46:30 <jcoufal> lifeless: derekh_ I will send some updates today or tomorrow the latest
07:46:30 <lifeless> jcoufal: hint, hint
07:46:46 <derekh_> jcoufal: cool, thanks
07:47:01 <lifeless> marios: I'
07:48:10 <tchaypo> marios: do you know if nova have done that kind of targeting of specs to milestone releases?
07:48:17 <lifeless> marios: that said, part of approving a blueprint will be identifying if its current work or future work
07:48:26 <lifeless> marios: so we can certainly target the next bit of work
07:48:31 <tchaypo> If they have maybe we can copy them; if they haven't, maybe there's a reason they haven't.
07:48:35 <marios> lifeless: sure
07:48:40 <lifeless> I'm very much against having large numbers of idle unimplemented specs
07:48:49 <lifeless> neutron has quite a different situation to us
07:49:05 <lifeless> lots of vendors with very specific axes to grind
07:49:10 <marios> right
07:49:22 <lifeless> and a relative paucity of work-in-the-core feeling
07:49:27 <lifeless> they're trying to change that
07:49:56 <marios> (indeed, the axes are becoming much less specific from what i can see)
07:51:30 <tchaypo> #action jcoufal to send an update on mid-cycle dates today or tomorrow
07:53:15 <tchaypo> lifeless: so if I can summarise, it sounds like you don't want us to have idle specs; that's going to need scheduling decisions when specs are approved, but will probably need review after that as well. Do you want to own deciding on how we do that review and how specific we want to be with targetting work (to milestones, or just to releases, or somethign else)?
07:53:41 <lifeless> tchaypo: its on me for now I think
07:53:45 <tchaypo> We still have 6 minutes left, is there anything else anyone wants to bring up?
07:54:20 <tchaypo> #action lifeless to follow up on process for review and (re-)scheduling/targetting of specs
07:55:41 <lifeless> tchaypo: actually I was proposing to do nothing
07:55:49 <marios> lol
07:55:50 <lifeless> tchaypo: #undo will remove the last #command :)
07:55:55 <tchaypo> #undo
07:55:56 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x24edc10>
07:56:00 <tchaypo> haha
07:56:11 <tchaypo> $action lifeless to sit on his hands
07:56:16 <tchaypo> ;)
07:56:33 <tchaypo> If there's nothing else I'm going to call time
07:56:53 <marios> thanks to those that pushed for the alternate time
07:57:05 <marios> its great to be making coffee vs going to bed
07:57:17 <StevenK> Heh
07:57:29 <tchaypo> #agreed that those of us present love the alternate meeting time, those not present probably don't love it as much
07:57:41 <marios> hehe
07:57:46 <TheJulia> heh
07:57:47 <tchaypo> #endmeeting