19:01:14 <lifeless> #startmeeting tripleo
19:01:15 <openstack> Meeting started Tue Jun  3 19:01:14 2014 UTC and is due to finish in 60 minutes.  The chair is lifeless. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:18 <openstack> The meeting name has been set to 'tripleo'
19:01:23 <Ng> .o/
19:01:26 <greghaynes> O/
19:01:30 <lifeless> #topic agenda
19:01:31 <jcoufal> o/
19:01:32 <lifeless> bugs
19:01:32 <lifeless> reviews
19:01:32 <lifeless> Projects needing releases
19:01:32 <lifeless> CD Cloud status
19:01:34 <lifeless> CI
19:01:37 <lifeless> Tuskar
19:01:39 <lifeless> Insert one-off agenda items here
19:01:42 <lifeless> open discussion
19:01:44 <lifeless> #topic bugs
19:01:59 <lifeless> #link https://bugs.launchpad.net/tripleo/
19:01:59 <lifeless> #link https://bugs.launchpad.net/diskimage-builder/
19:01:59 <lifeless> #link https://bugs.launchpad.net/os-refresh-config
19:02:00 <lifeless> #link https://bugs.launchpad.net/os-apply-config
19:02:00 <lifeless> #link https://bugs.launchpad.net/os-collect-config
19:02:02 <lifeless> #link https://bugs.launchpad.net/os-cloud-config
19:02:04 <lifeless> #link https://bugs.launchpad.net/tuskar
19:02:07 <lifeless> #link https://bugs.launchpad.net/python-tuskarclient
19:02:39 <rwsu> hi
19:02:47 <derekh_> hi
19:02:58 <matty_dubs> o/
19:03:02 <slagle> hello
19:03:02 <jistr> o/
19:03:11 <dprince> hello TripleO
19:03:14 <shadower> hey
19:03:24 <SpamapS> o/
19:03:59 <jrist> o/
19:04:11 <tchaypo> applmorgens
19:04:21 <lifeless> triage is looking a lot better. thank you to the folk that got on top of it!
19:04:52 <tchaypo> stevek and i got through a bunch in an office together last friday
19:05:22 <lifeless> looks like a bunch of the criticals will be fixed by the next release
19:05:27 <lifeless> but their bug state isn't quite right
19:06:31 <lifeless> e.g. why is https://bugs.launchpad.net/tripleo/+bug/1318039 a partial fix?
19:06:35 <lifeless> dprince: ^
19:07:23 <dprince> lifeless: it should be fully fixed by my patch I think
19:07:42 <lifeless> ok, will tweak to fix committed
19:07:49 <dprince> lifeless: Initially I thought we might do both...
19:08:08 <lifeless> could folk take just a minute and review the criticals list particularly in the tripleo bug container
19:08:27 <lifeless> and if anything there is incorrect or stale fix it?
19:08:42 * dprince marks 1318039 as fix committed
19:10:12 <tchaypo> as far as I can tell mestery's fix for https://bugs.launchpad.net/tripleo/+bug/1290486 is working well, we've had a few other people comment to say that it's fixed for them.
19:10:35 <mestery> tchaypo: Yay!
19:11:37 <lifeless> cool, was that in Neutron? can we close our end of it ?
19:12:10 <SpamapS> https://bugs.launchpad.net/tripleo/+bug/1317056 needs a volunteer
19:12:23 <tchaypo> our end is marked "fix commited" which i think is right
19:12:37 <rpodolyaka1> SpamapS:  just assigned it to myself :)
19:13:36 <lifeless> tchaypo: ah no
19:13:41 <SpamapS> rpodolyaka1: \o/
19:13:47 <lifeless> tchaypo: fix committed means 'the next release of that project will fix the issue'
19:13:54 <lifeless> tchaypo: AIUI the change is not in a tripleo codebase
19:14:46 <tchaypo> lifeless: ah, good point. in progress then?
19:14:54 <lifeless> tchaypo: so theres some idiomatic use of the tracker here; if the bug shows up in tripleo we have a task for it; once fixed and we don't need to see it anymore, then we typically close it
19:15:29 <lifeless> I'd close fix released (as good as anything really)
19:15:34 <lifeless> rpodolyaka1: \o/
19:15:53 <lifeless> ok, any more bug discussion ?
19:16:51 <lifeless> #topic reviews
19:17:10 <lifeless> http://www.nemebean.com/reviewstats/tripleo-open.html
19:17:17 <lifeless> ulp
19:17:20 <lifeless> no worse
19:17:23 <lifeless> but also no better
19:17:26 <lifeless> 
19:17:26 <lifeless> Stats since the last revision without -1 or -2 :
19:17:26 <lifeless> Average wait time: 9 days, 17 hours, 20 minutes
19:17:26 <lifeless> 1rd quartile wait time: 3 days, 7 hours, 25 minutes
19:17:28 <lifeless> Median wait time: 5 days, 19 hours, 43 minutes
19:17:31 <lifeless> 3rd quartile wait time: 12 days, 7 hours, 32 minutes
19:18:26 <lifeless> stats are a few days old but close enough I think
19:18:48 <lifeless> lets try for 11 next week? I"ll be doing a reviewer roundup this week, since its the first of the month
19:19:06 <bnemec> Oh, sorry.  Updated my web server and I may have broken the file transfer...
19:19:42 <shadower> my reviews dropped in the last few weeks because reasons, will start doing them again properly now
19:20:19 <lifeless> ok, cool
19:20:24 <lifeless> design reviews
19:20:30 <jdob> i've been too heads down on specs too, I need to resurface and look at normal reviews
19:20:32 <lifeless> I'm not seeing enough folk comment on the specs
19:20:53 <jdob> is there a full policy on when a spec will be accepted? (or want me to hold that until open discussion?)
19:21:08 <jdob> i know we're leaving the +A for lifeless but not sure when he pulls that trigger
19:21:15 <tchaypo> I commented on a few but I haven't followed up. Will try to do that today. I have seen a few items that should be specs but haven't written any of them up
19:21:36 <lifeless> jdob: so at the moment I am feeling my way
19:21:42 <lifeless> how long to wait for ops input
19:21:52 <lifeless> how much consensus amongst the review community is needed
19:21:57 <lifeless> I don't have an algorithm yet
19:22:00 <jdob> word, that totally makes sense since it's a new process
19:22:10 <lifeless> its a very good question
19:22:28 <lifeless> and one of the ways we can learn is us as a group saying 'hey, that needed to bake longer', and 'oi, get that one off the stove'
19:23:21 <lifeless> I thinkk the general process though is draft-> core reviews until broadlyhappy, ops and user reviews, final polish, +A
19:23:43 <jdob> and related to specs, can we get someone to write up specs/blueprints for the tht changes? ive seen it referenced in 3 reviews now without a link to it
19:23:54 <jdob> personally, I could really use a summary of what the changes will look like
19:24:06 <jdob> outside of the email outlining the high level steps
19:24:12 <lifeless> the tht changes ?
19:24:26 <shadower> jdob: you mean stuff like the HOT conversion, reducing merge.py impact etc?
19:24:26 <jdob> conversion to HOT templates, pulling out provider resources, etc
19:24:33 <jdob> (got lazy in my typing, sorry)
19:24:41 <jdob> shadower: ya, that's it
19:25:01 <lifeless> +1, love to see some prose around that
19:25:04 <shadower> we've kind of hashed that out on the mailing list, I could specify
19:25:12 <shadower> spec'ify
19:25:13 <jdob> it's important for Tuskar and i'd like to have something to point the people who pay me at to say "This is a dependency"
19:25:23 <shadower> k, will do
19:25:28 <jdob> hopefully it'll be easy then if its just converting the email into spec
19:25:33 <jdob> thanks shadower  :D
19:25:43 <jdob> last comment on this topic, I really dig this spec process
19:25:50 <shadower> +1
19:26:19 <shadower> I'm not a fan of gerrit's UI but it sure beats launchpad blueprints for discussions
19:26:31 <jdob> same on both accounts
19:26:36 <jdob> both counts?
19:26:41 <jdob> not actually sure what the real phrase is
19:26:55 <lifeless> counts
19:27:04 <slagle> need gerrit to actually render the rst
19:27:07 <jdob> good to know :)
19:27:09 <jdob> dude, yes
19:27:16 <lifeless> I belive its a reference to double-counting systems like votes
19:27:18 * SpamapS doesn't understand why people hate on Gerrit.. but w'ever. :)
19:27:25 <jrist> early and often?
19:27:28 <jdob> i've been checking them out because it's way easier to generate and read them
19:27:33 <lifeless> where two groups that don't trust each other cross-check :)
19:27:34 <shadower> SpamapS: not hate, but it's got its warts
19:27:50 <jdob> appropriate phrase to use around here then :)
19:28:02 <derekh_> the gate-tripleo-specs-docs generates the docs doesn't it
19:28:26 <jdob> er, meaning to read them that way
19:28:29 <derekh_> but it would be noce to comment agains a rendered rst... ponys
19:28:32 <jdob> as compared to straight rst
19:28:45 <jdob> which, despite their claims of being WYSIWYG, is exactly not that (but I digress)
19:29:26 <slagle> derekh_: oh does it?
19:29:43 <derekh_> slagle: http://docs-draft.openstack.org/26/95026/2/check/gate-tripleo-specs-docs/ad3398a/doc/build/html/specs/juno/tripleo-juno-ci-improvements.html
19:30:00 <lifeless> ok
19:30:03 <jdob> oh crap, that's handy
19:30:08 <lifeless> moving on
19:30:17 <lifeless> #topic projects needing releases
19:30:23 <rpodolyaka1> you can count on me
19:30:33 <tchaypo> you can find the generated RST from the "gate-tripleo-specs-docs" link in the jenkins comment
19:30:40 <lifeless> \o/
19:30:51 <lifeless> #action rpodolyaka1 to save the universe^W^W^Wrelease the world
19:31:01 <lifeless> #topic CD Cloud Status
19:31:08 <lifeless> HP region one is mid rebuild
19:31:44 <lifeless> AFAIK the RH region one is fine
19:31:59 <derekh_> lifeless: yup, R2 seems to be tocking along ok
19:32:05 <lifeless> #topic CI
19:32:34 <lifeless> joe gordon is gluing our logs into elastic-recheck at the moment
19:32:45 <derekh_> new version of CI spec is out there,
19:32:48 <lifeless> this should help us get more figures on specific failures
19:32:55 <lifeless> derekh_: cool!
19:33:14 <lifeless> I'd also like to say word up to pcrews who has joined TripleO within HP
19:33:17 <SpamapS> we did have one weird thing where swift/glance broke nodepool btw
19:33:19 <derekh_> lifeless: it wont include the fedora logs, I looked into that today and can add systemd support on top of it when he has it finished
19:33:26 <lifeless> and is apparently very interested in CI things :)
19:33:29 <SpamapS> but I believe infra is working on a fix and it was a temporary problem
19:33:38 * pcrews waves and is happy to join the party :)
19:33:49 <pcrews> and also does love CI tinkering in general
19:33:52 <lifeless> also tchaypo has applied to be a tripleo-cd-admin
19:34:01 <SpamapS> derekh_: we could just turn off binary journalling and use those crazy text based logs. ;)
19:34:03 * tchaypo is a sucker
19:34:12 <dprince> SpamapS: yeah, last we talked that was a temporary image upload fluke right?
19:34:22 <lifeless> so let me remind all the tripleo-cd-admins we look for much more than 2x+2 - please indicate your support on his self-adding-proposal
19:34:34 <derekh_> SpamapS: k, didn't know that was possible
19:34:54 <derekh_> SpamapS: I was just gonns write the logs out to unit specific files at the end of the ci run
19:35:00 <lifeless> (or your lack of support if appropriate :))
19:35:03 <lifeless> tchaypo: whats the url ?
19:35:18 <lifeless> derekh_: whatever works
19:36:03 <derekh_> lifeless: tchaypo https://review.openstack.org/#/c/95614/
19:36:45 <lifeless> pcrews: so derekh_ is a great person with fairly large tz overlap with you to find CI things to poke at
19:37:07 <SpamapS> derekh_: I believe you can teach rsyslogd to read from the systemd journal
19:37:14 <lifeless> pcrews: once you've got some experience with the particulars you might also consider being an admin
19:37:31 <pcrews> cool and ++.
19:37:56 <derekh_> pcrews: lifeless I'm also currently writing some docs on how CI is put together so should have something for you to read up on soon
19:38:04 <lifeless> pcrews: taking his 'fix CI' spec from the tripleo-specs review queue and a) thoughtfully reviewing and b) starting to action stuff in parallel would be great
19:38:10 <derekh_> pcrews: but feel free to poke me with questions
19:38:29 <lifeless> ok, moving on ?
19:38:48 <lifeless> #topic Tuskar
19:38:49 <derekh_> SpamapS: ok cool, will see if it makes more sense
19:38:59 <jdob> https://review.openstack.org/#/c/94720
19:39:08 <jdob> i'd very much appreciate eyes on that, it's the Tuskar REST API spec
19:39:15 <jdob> that's kinda gonna drive everything for Juno
19:39:18 <lifeless> jcoufal requested this section. jcoufal - please let us know what you want touched on, if there is anything specific
19:39:29 <jdob> also recently submitted is https://review.openstack.org/#/c/97553/, which is the new storage backend for Tuskar
19:39:54 <jdob> those are the big two Tuskar could use eyes on, and like I already requested, some notes on the template conversion (which was resolved earlier in the meeting)
19:40:56 <jcoufal> lifeless: I wanted to have this topic regularly, not just today with some specifics. In general I would like us to discuss progress, news and what needs attention in Tuskar (e.g. reviews, blockers, etc)
19:41:53 <lifeless> jcoufal: thats fine - I realised you wanted a regular section
19:42:09 <tchaypo> So what's news in Tuskar-land?
19:42:11 <lifeless> that said, reviews and bugs should happen in the reviews and bugs sections IMO
19:42:20 <lifeless> jcoufal: anyhow,  you have the stage :)
19:42:30 <tchaypo> no pressure ;)
19:42:50 <jdob> lifeless: sorry, I wasnt sure where to drop that request for eyes, here or the reviews section
19:43:13 <jcoufal> yeah, I think majority is covered in jdob specs
19:43:27 <jcoufal> jdob: would you mind to cover the progress there in few words?
19:43:38 <jdob> ok, quick summary:
19:43:53 <jdob> the REST API spec changes the model of Tuskar talking to Heat to making Tuskar more of a planning service
19:44:03 <jdob> for saving, configuring, organizing, etc the heat templates
19:44:10 <jdob> thats in https://review.openstack.org/#/c/94720
19:44:24 <jdob> to anyone who has looked, it's changed quite a bit last friday, so worth another look
19:44:51 <jdob> the second major change is instead of having a database backend and a special domain model, it's going to be much closer tied to HOT
19:44:56 <jdob> that's in https://review.openstack.org/#/c/97553/ which was just posted this morning
19:45:20 <jdob> i haven't read it yet, but my understanding is that it talks about using other OpenStack options for storing the heat templates and environment files
19:45:34 <jdob> those two things are the major driving changes in Juno
19:45:38 * tchaypo stars reviews for review post-caffeine
19:45:50 <jdob> the third piece, the one that assembles the Heat templates inside of the Tuskar service, is a WIP
19:45:56 <jdob> that i'm currently working on
19:46:02 <jdob> when not banging my head against a keyboard
19:46:11 <jcoufal> thanks jdob for the summary
19:46:14 <tchaypo> Both of the first two reviews you linked also seem to be workflow -1
19:46:30 <jdob> oh crud, I need to remove the -1 from the REST API
19:46:34 <tchaypo> which my understanding is equivalent to "WIP" or "not yet ready for review"
19:46:39 <jdob> not sure about the latter, I'll take that up with dmakogon_
19:46:55 <tchaypo> at least, i think that's what the red X in the workflow column means
19:46:56 <jdob> er, dougal
19:47:15 <jdob> i can see why you'd think that. i've still reviewed those for specs
19:47:29 <jdob> figuring people are claiming they have stuff that warrants eyes but isn't intended to be merged yet
19:48:07 <jdob> though that might just be me interpretting things differently in the spec repo
19:48:11 <lifeless> -1 workflow == WIP == draft == cannot merge => lower review priority
19:48:31 <jdob> regardless, in this case, I'm requesting eyes on both and I'll get the -1 workflow sorted out
19:48:36 <lifeless> kk
19:48:41 <jdob> thanks :D
19:48:48 <lifeless> anything more tuskar specific?
19:49:07 <jdob> not from my end, everything I've been doing is in spec-form
19:49:07 <jcoufal> regarding tripleo/tuskar-ui, I am not going to talk a lot about it since it falls under Horizon now, but it is topic relevant. Anyway, no updates here :)
19:49:27 <d0ugal> jdob, tchaypo - the second is ready for review - I just need to do a few minor tweaks. Mostly to do with wording etc.
19:51:12 <lifeless> ok
19:51:16 <lifeless> #tpoic open discussion
19:51:21 <lifeless> #topic open discussion
19:51:24 <tchaypo> mid-cycle meetup dates
19:51:33 <jcoufal> here we go :)
19:51:38 <lifeless> so yeah
19:51:48 <lifeless> I've chatted with devananda and mikal
19:51:59 <lifeless> we don't want TripleO to overlap with Nova
19:52:07 <lifeless> too many folk need to be at both
19:52:23 <lifeless> and we don't want to colocate - Nova has a very full schedule already and its quite a different sort of meetup
19:52:35 <jcoufal> lifeless: when do they plan to have it?
19:52:37 <lifeless> less do-y more design-y-only
19:53:59 <tchaypo> So that rules out the mid-July date?
19:54:03 <jcoufal> based on devananda's comment it looks that all three dates overlap
19:54:28 <jcoufal> And thinking about August, it is very close to the end of the cycle
19:54:39 <tchaypo> they all seem to overlp with something, except for the mid-august date, and that's very late in the cycle.
19:54:56 <jcoufal> tchaypo: exactly
19:54:59 <jcoufal> any suggestions?
19:55:31 <lifeless> https://etherpad.openstack.org/p/juno-nova-midcycle-options
19:55:55 <lifeless> I'd rather be near the end of the cycle than not at all
19:55:56 <tchaypo> If we could bring back concorde so that people could get between raleigh and pycon-au easier...
19:56:36 <lifeless> so I'd like to suggest that the 11th august makes the most sense to me
19:56:37 * greghaynes adds bring back concorde to trello
19:56:54 <jdob> I can do august 11
19:57:02 <jcoufal> so we are thinking Aug11?
19:57:37 <greghaynes> Add that date to the etherpad?
19:57:52 <jcoufal> I will
19:58:43 <jdob> want to put a deadline on voting so we can settle on something?
19:58:47 <derekh_> Can we have a cut off for new days being added to the etherpad
19:58:56 <jcoufal> done
19:58:57 <greghaynes> yesplz
19:58:58 <bnemec> https://etherpad.openstack.org/p/juno-midcycle-meetup
19:59:03 <derekh_> jdob: +1
19:59:34 <jcoufal> jdob: I will leave a bit more time there and we will see how it goes
19:59:48 <jdob> sure, but set an end
19:59:48 <jcoufal> after we might put a deadline
19:59:50 <jdob> thursday?
19:59:55 <jdob> end of week?
19:59:56 <jcoufal> jdob: too early
19:59:58 <jdob> kk
20:00:11 <jcoufal> let's wait until next weeks meeting
20:00:24 <jcoufal> and we can set a deadline there
20:00:42 <jcoufal> I will write the update to the mailing list
20:00:49 <lifeless> ok, we're out of time. Thanks for playing, have a good day / night/whatever :))
20:00:54 <lifeless> jcoufal: thanks!
20:00:56 <lifeless> #endmeeting