06:59:56 <tchaypo> #startmeeting tripleo
06:59:57 <openstack> Meeting started Wed Jun 25 06:59:56 2014 UTC and is due to finish in 60 minutes. The chair is tchaypo. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:59:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:00:00 <openstack> The meeting name has been set to 'tripleo'
07:00:04 <tchaypo> Welcome everyone!
07:00:06 <lsmola> hello
07:00:22 <tchaypo> I'd like to start this week with a reminder that anyone can use #info and #link to get notes into the meeting minutes
07:00:26 <GheRivero> morning! o/
07:00:46 <tchaypo> I'm happy to summarise lengthy discussions, but if you've just got something quick to say and you'd like it to be noted, please feel free to tag it yourself :)
07:01:16 <tchaypo> We're following the agenda at https://wiki.openstack.org/wiki/Meetings/TripleO#Agenda_for_next_meeting which I'm not going to paste here
07:01:20 <tchaypo> #topic bugs
07:01:29 <tchaypo> #link https://bugs.launchpad.net/tripleo/
07:01:32 <tchaypo> #link https://bugs.launchpad.net/diskimage-builder/
07:01:34 <tchaypo> #link https://bugs.launchpad.net/os-refresh-config
07:01:36 <tchaypo> #link https://bugs.launchpad.net/os-apply-config
07:01:38 <tchaypo> #link https://bugs.launchpad.net/os-collect-config
07:01:40 <tchaypo> #link https://bugs.launchpad.net/os-cloud-config
07:01:42 <tchaypo> #link https://bugs.launchpad.net/tuskar
07:01:44 <tchaypo> #link https://bugs.launchpad.net/python-tuskarclient
07:01:56 <tchaypo> How are we going this week?
07:03:53 <tchaypo> I'm not seeing any unassigned criticals on incubator
07:04:21 <tchaypo> GheRivero: do you have an update for bug 1319979 ?
07:04:22 <uvirtbot> Launchpad bug 1319979 in tripleo "rabbitmq-server fails to restart in check-tripleo-overcloud-precise" [Critical,Triaged] https://launchpad.net/bugs/1319979
07:05:11 <tchaypo> or bug 1316985 ?
07:05:12 <uvirtbot> Launchpad bug 1316985 in tripleo "set -eu may spuriously break dkms module" [Critical,In progress] https://launchpad.net/bugs/1316985
07:05:13 <GheRivero> tchaypo: I'm going to close it. We haven't hit it in a long time
07:05:48 <GheRivero> for 1316985: waiting for the select-boot-kernel element to land...
07:05:54 <tchaypo> GheRivero: woot, thanks
07:06:07 <GheRivero> https://review.openstack.org/#/c/98758/
07:06:12 <tchaypo> So that leaves 4 other criticals on -incubator and one on DIB that I can see
07:06:35 <tchaypo> not terrible
07:06:44 <tchaypo> Does anyone have any bugs they want to talk about?
07:07:36 <tchaypo> I'm taking that as a no.
07:07:40 <tchaypo> #topic reviews
07:07:44 <tchaypo> #info There's a new dashboard linked from https://wiki.openstack.org/wiki/TripleO#Review_team - look for "TripleO Inbox Dashboard"
07:07:47 <tchaypo> #link http://russellbryant.net/openstack-stats/tripleo-openreviews.html
07:07:49 <tchaypo> #link http://russellbryant.net/openstack-stats/tripleo-reviewers-30.txt
07:07:51 <tchaypo> #link http://russellbryant.net/openstack-stats/tripleo-reviewers-90.txt
07:08:06 <tchaypo> Looking at http://russellbryant.net/openstack-stats/tripleo-openreviews.html
07:08:15 <tchaypo> Stats since the last revision without -1 or -2 :
07:08:18 <tchaypo> Average wait time: 8 days, 23 hours, 32 minutes
07:08:20 <tchaypo> 1st quartile wait time: 1 days, 12 hours, 33 minutes
07:08:22 <tchaypo> Median wait time: 5 days, 23 hours, 56 minutes
07:08:24 <tchaypo> 3rd quartile wait time: 11 days, 21 hours, 38 minutes
07:08:38 <tchaypo> It seems like the 3rd quartile hasn't changed much since last week, but the average is much higher than my memory
07:09:31 <tchaypo> but http://eavesdrop.openstack.org/meetings/tripleo/2014/tripleo.2014-06-17-19.01.log.txt says my memory is wrong
07:10:00 <lsmola> vacation time starts, so it will get worse :-)
07:10:04 <greghaynes> -2 days on 3q
07:10:08 <greghaynes> which is good
07:10:20 <tchaypo> #info 3rd quartile has dropped from 13 days 12 hours to 11 days 21 hours over the last week, other quartiles roughly unchanged
07:10:41 <tchaypo> Have people been using the dashboard?
07:10:44 <tchaypo> or gertty?
07:10:58 <greghaynes> Also reviewing from longest waiting without -1
07:11:50 <GheRivero> gertty! I'm loving it!
07:12:00 <d0ugal> gerrty? I've missed what this is.
07:12:21 <xuhaiwei_> don't know gerrty too
07:12:25 <shadower> yea I've been using the dashboard
07:12:30 <greghaynes> stackforge/gertty
07:12:35 <d0ugal> greghaynes: thanks
07:12:43 <d0ugal> I have been using the dashboard tho', its nice.
07:12:50 <marios_> damit... sorry am late
07:13:04 <StevenK> marios_: Where is your note? :-P
07:13:05 <tchaypo> marios_: greetings!
07:13:30 <marios_> morning all :)
07:13:36 <tchaypo> I've been using gertty too
07:14:00 <tchaypo> but unless we have anything else to note here, I'll move along
07:14:04 <StevenK> I haven't, I've been doing reviews with a bookmark I have.
07:14:41 <tchaypo> #info stackforge/gertty is a tty-based locally-caching client for gerrit, so you can do reviews on a plane
07:14:57 <marios_> so our efforts to clear older patches don't seem to have made much of a dent yet :(
07:15:25 <marios_> any ideas?
07:15:54 <tchaypo> marios_: we've dropped the 3rd quartile by about 1.5 days over the last week, even though many in the US are on vacation.
07:16:11 <marios_> tchaypo: ah, i missed that bit, i thought it was much of the same
07:16:26 <marios_>
07:10 < greghaynes> -2 days on 3q
07:16:30 <marios_> cool
07:16:31 <tchaypo> the other quartiles are much the same :)
07:16:42 <tchaypo> I think that suggest we've been hitting hardest on the oldest ones
07:17:44 <tchaypo> I've been trying to do some reviews in projects/repos I'm less comfortable with, to try to learn something about those projects
07:18:20 <tchaypo> #topic Projects needing releases
07:18:27 <tchaypo> Do we have a volunteer?
07:18:58 <tchaypo> StevenK: maybe we could bash this out together on friday?
07:19:10 <StevenK> tchaypo: Neither of us have the access to do so.
07:19:17 <tchaypo> StevenK: then let's not
07:19:28 <marios_> StevenK: what access?
07:19:30 <tchaypo> What access is required?
07:19:36 <marios_> i've never donw it before and am scared it would eat my week
07:19:50 <d0ugal> marios_: my thoughts exactly :)
07:20:07 <StevenK> You need to be able to push signed tags, which requires you to be a member of the tripleo-ptl group on gerrit
07:20:18 <tchaypo> and the members of that group are..
07:20:18 <shadower> where's rpodolyaka and jdob when you need them
07:20:27 <shadower> I'll do it. Have access already
07:20:37 <marios_> tchaypo: does that mean all cores?
07:20:43 <marios_> shadower: or did you have to do something else?
07:20:49 <StevenK> It doesn't mean all cores
07:20:52 <shadower> marios_: there's a different group for doing releases
07:21:03 <shadower> #note shadower will release all the things
07:21:05 <shadower> moving on
07:21:10 <marios_> shadower: ah... will ask you after
07:21:15 <StevenK> List is https://review.openstack.org/#/admin/groups/200,members
07:21:41 <tchaypo> Does that command work?
07:21:46 <shadower> #info shadower will release all the things
07:21:51 <shadower> (sorry)
07:22:04 <marios_> shadower: fyi https://wiki.openstack.org/wiki/TripleO/ReleaseManagement
07:22:12 <tchaypo> It's going to be in the notes at least once now :)
07:22:18 <shadower> marios_: I know, I've done a release before
07:22:24 <tchaypo> #link https://wiki.openstack.org/wiki/TripleO/ReleaseManagement
07:22:26 <StevenK> There's a dib-utils patch that should land before releasing
07:22:29 <marios_> shadower: ah apologies :)
07:22:33 <shadower> StevenK: link?
07:22:37 <tchaypo> #topic CD Cloud status
07:22:56 <StevenK> shadower: https://review.openstack.org/#/c/102291/
07:23:04 <shadower> thx
07:23:18 <shadower> #info https://review.openstack.org/#/c/102291/ should land before releasing dif-utils
07:24:28 <tchaypo> Do we have anyone who can talk about the CD cloud status? I have a feeling we don't have anyone in this timezone at the moment who knows the current state
07:25:11 <marios_> derekh around?
07:25:19 <marios_> no, seems. he sometimes is this time of day
07:25:29 <jprovazn> he has PTO
07:25:33 <marios_> ah
07:25:36 <marios_> lazy
07:25:48 <lsmola__> lol
07:26:06 <tchaypo> I'm going to note that lifeless mentioned last week that https://bugs.launchpad.net/tripleo/+bug/1325114 was in the way, and that seems to be unresolved
07:26:08 <uvirtbot> Launchpad bug 1325114 in tripleo "can't deploy underclouds with VLAN API endpoints" [High,Triaged]
07:26:28 <tchaypo> I believe ng has made some progress toward getting hp1 operation
07:27:24 <tchaypo> and I believe jerryz is in the early stages of getting a third region for us, provided by huawei
07:28:04 <tchaypo> #link https://etherpad.openstack.org/p/tripleo-ci-hp1-rebuild still in progress
07:28:41 <StevenK> \o/
07:29:05 <tchaypo> #info quaoting lifeless from last week: please help with restoring vlan and public endpoint support so that we can get hp1.tripleo.orgback online and > double our CI capacity
07:29:09 <tchaypo> Moving on...
07:29:25 <tchaypo> #topic CI
07:29:29 <tchaypo> #link http://goodsquishy.com/downloads/s_tripleo-jobs.html
07:30:20 <tchaypo> We had some bad times with CI this week which clarkb was isntrumental in helping us get to the bottom of
07:30:47 <tchaypo> I believe we still have a temprevert in tock_devtest.sh because of a commit in neutron
07:31:03 <StevenK> The revert to neutron hasn't landed?
07:31:42 <tchaypo> #link https://review.openstack.org/#/c/101395/ seems to have landed
07:31:51 <tchaypo> #info so I think we can remove the temprevert now
07:32:30 <tchaypo> #action tchaypo will prepare a patch to revert the temprevert
07:33:06 <tchaypo> Anything else?
07:33:19 <tchaypo> The summary on goodsquishy looks good, but I'd love if it went back further in time
07:33:48 <StevenK> tchaypo: You should talk to derekh about that.
07:34:22 <tchaypo> StevenK: not while he's on PTO
07:34:38 <StevenK> Of course. There was an unspoken "when he's around"
07:34:39 <tchaypo> #topic tuskar
07:35:29 <marios_> guys the juno specs still need to land
07:35:39 <marios_> this is a priority
07:35:40 <marios_> sec
07:35:57 <d0ugal> marios_: +1
07:36:03 <marios_> https://review.openstack.org/94720
07:36:03 <tchaypo> I was about to say...
07:36:11 <tchaypo> #link https://review.openstack.org/#/q/status:open+project:openstack/tripleo-specs,n,z
07:36:16 <greghaynes> I should have another swing at that
07:36:17 <marios_> https://review.openstack.org/97553
07:36:19 <d0ugal> and https://review.openstack.org/#/c/97553/
07:36:25 <tchaypo> #Info we still have several specs that need urgent attention
07:36:27 <marios_> shadower: the mergepy one?
07:36:39 <tchaypo> #link https://review.openstack.org/94720
07:36:42 <marios_> (kinda relevant to tuskar as it will be a consumer right?)
07:36:49 <d0ugal> #link https://review.openstack.org/#/c/97553/
07:36:49 <tchaypo> #link https://review.openstack.org/97553
07:36:58 <d0ugal> oops
07:37:11 <tchaypo> heh
07:37:16 <marios_> anyhow, we've mostly had red hat eyes on those so far
07:37:22 <shadower> https://review.openstack.org/#/c/97939/
07:37:34 <marios_> i think we've got them to a good state but would be best to get more eyes please. but time is critical
07:37:35 <tchaypo> marios_: worth a mail to the list reminding people that we need to land these?
07:38:21 <greghaynes> we got a new iteration on the tuscar one less than a day ago so it looks like its moving again
07:38:36 <tchaypo> shadower: I think that's not related to tuskar
07:38:37 <tchaypo> however
07:38:42 <marios_> tchaypo: sure, i'll give it till this afternoon when jdob is around, i think he may have already pinged lifeless about them
07:38:45 <tchaypo> i think we should add a "specs" section to the agenda
07:38:52 <marios_> tchaypo: +1
07:38:57 <shadower> tchaypo: iiuic, the tuskar specs kind of rely on it
07:39:13 <shadower> I know the API spec does
07:39:25 <shadower> +1 for specs in the agenda
07:40:04 <tchaypo> #info tuskar API spec (at least, possibly other tuskar things) also depend on https://review.openstack.org/#/c/97939/
07:40:25 <tchaypo> Do we have other notes about tuskar?
07:40:56 <tchaypo> #topic one-off agenda items
07:41:16 <tchaypo> #info For those attending the TripleO mid-cycle sprint in Raleigh, the hotel details have been posted to the etherpad
07:41:19 <tchaypo> #link https://etherpad.openstack.org/p/juno-midcycle-meetup
07:41:34 <marios_> yeah... so in the end I am not going to mid-cycle, fwiw
07:41:39 <greghaynes> chmod 600 $TRIPLEO_ROOT/*-env.json
07:41:40 <marios_> got approval yesterday, but after looking at flights so late now, I told my manager it really doesn't make sense :(
07:41:41 <tchaypo> #info please make your booking ASAP, the group booking expires very very soon
07:41:56 <marios_> you will have to wait till november to see my ugly mug.
07:42:00 <tchaypo> greghaynes: can you hash-info that?
07:42:11 <greghaynes> #info chmod 600 $TRIPLEO_ROOT/*-env.json
07:42:17 <tchaypo> marios_: This is a sadness
07:42:23 <marios_> tchaypo: lol. hang in there mate
07:42:25 <tchaypo> greghaynes: could you explain why? :p
07:42:30 <marios_> greghaynes: what is that?
07:42:44 <greghaynes> Well, if you dont, youll find out why very quickly :p
07:42:49 <d0ugal> marios_: maybe you could arrange a hangout for folks to see you before then ;)
07:43:01 <marios_> d0ugal: mate, why would i want to do that to them?
07:43:06 <greghaynes> Basically we need to enforce those permissions on that file because we are storing secrets there now
07:43:12 <d0ugal> marios_: lol
07:43:31 <greghaynes> that chane was merged recently... so if you dont then your devtest runs will fail
07:43:41 <tchaypo> #info we need to enforce those permissions on that file because we are storing secrets there now. Scripts don't chown for you, they just abort.
07:44:16 <StevenK> chmod
07:44:21 <StevenK> chown changes ownership
07:44:24 <tchaypo> #undo
07:44:25 <openstack> Removing item from minutes: <ircmeeting.items.Info object at 0x2fe1510>
07:44:37 <tchaypo> #info we need to enforce those permissions on that file because we are storing secrets there now. Scripts don't chmod for you, they just abort
07:44:40 <tchaypo> sigh
07:44:46 <greghaynes> oh great, we got the object id. how useful!
07:44:52 <StevenK> Yeah
07:44:52 <tchaypo> The thing I wanted to bring up is around under/overcloud password files.
07:45:02 <StevenK> greghaynes: __repr__ is hard, news at 11.
07:45:06 <tchaypo> At present the scripts look for them in $PWD, then in $TRIPLEO_ROOT
07:45:15 <tchaypo> https://review.openstack.org/#/c/97657/ / https://review.openstack.org/#/c/93981/ are two patchsets open to change this
07:45:26 <tchaypo> One of them is xuhaiwei_ 's
07:46:01 <tchaypo> they both at the moment just check $TRIPLEO_ROOT, some people have suggested to xuhaiwei_ that we should accept a parameter for the location, which defaults to $TRIPLEO_ROOT
07:46:26 <StevenK> I think we should bring it up on the list
07:46:50 <StevenK> Because I'd also like input from sleeping people
07:47:09 <tchaypo> Do we have any input from awake people first?
07:47:17 <tchaypo> I've got an email drafted already
07:47:29 <StevenK> I'm happy enough to drop the $PWD check
07:47:47 <StevenK> Well, $CWD to be pedantic
07:49:36 <tchaypo> Okay, no other comments,I'll take it to the list
07:49:42 <tchaypo> Anything else?
07:50:06 <marios_> StevenK: +1 to list
07:50:10 <tchaypo> #topic open discussion
07:50:17 <xuhaiwei_> sorry, to what list?
07:50:26 <marios_> xuhaiwei_: mailing list
07:50:28 <StevenK> xuhaiwei_: openstack-dev
07:50:31 <xuhaiwei_> ok
07:50:57 <marios_> xuhaiwei_: openstack-dev@lists.openstack.org [Tripleo]
07:51:02 <StevenK> tchaypo: Ten minute early mark? Sounds fantastic. /part
07:51:37 <xuhaiwei_> marios, StevenK: thanks
07:52:45 <tchaypo> email sent
07:53:00 <tchaypo> I'll close the meeting in 60 seconds if we don't have anything else..
07:53:03 <xuhaiwei_> so fast
07:53:18 <xuhaiwei_> I say the mail *)
07:53:52 <tchaypo> I wrote it yesterday, just had to hit send :)
07:54:21 <tchaypo> #endmeeting