07:00:42 <tchaypo> #startmeeting tripleo
07:00:42 <openstack> Meeting started Wed Jul  9 07:00:42 2014 UTC and is due to finish in 60 minutes.  The chair is tchaypo. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:00:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:00:45 <openstack> The meeting name has been set to 'tripleo'
07:01:19 <tchaypo> I don't know if anyone but me is here, so this might be a lot of fun
07:01:29 <shadower> I'm here
07:01:44 <greghaynes> O/
07:01:46 * StevenK just got here
07:01:53 <pcrews> o/
07:01:54 <greghaynes> Although I might fall asleep at any moment ;)
07:02:08 <tchaypo> greghaynes: if we hear snoring we'll know who to blame
07:02:15 <StevenK> greghaynes: Pft, isn't it like 1400 in GST?
07:02:28 <greghaynes> Yes, siesta time.
07:03:05 <StevenK> Haha
07:03:15 <tchaypo> Remember that anyone can use the link and info commands, not just the moderator - if you have something worth noting in the meeting minutes feel free to tag it
07:03:21 <marios> hi guys
07:03:24 <d0ugal> o/
07:03:42 <tchaypo> Agenda is at https://wiki.openstack.org/wiki/Meetings/TripleO#Agenda_for_next_meeting
07:03:46 <tchaypo> #topic bugs
07:03:56 <tchaypo> #link https://bugs.launchpad.net/tripleo/
07:03:59 <tchaypo> #link https://bugs.launchpad.net/diskimage-builder/
07:04:01 <tchaypo> #link https://bugs.launchpad.net/os-refresh-config
07:04:03 <tchaypo> #link https://bugs.launchpad.net/os-apply-config
07:04:05 <tchaypo> #link https://bugs.launchpad.net/os-collect-config
07:04:07 <tchaypo> #link https://bugs.launchpad.net/os-cloud-config
07:04:09 <tchaypo> #link https://bugs.launchpad.net/tuskar
07:04:11 <tchaypo> #link https://bugs.launchpad.net/python-tuskarclient
07:04:15 <tchaypo> I've taken a quick look =  DIB has one critical, but it's fix-committed. We have 4 red in tripleo
07:05:05 <greghaynes> Looks like a revert got merged for that
07:05:13 <greghaynes> https://review.openstack.org/#/c/105480/
07:06:00 <greghaynes> So might be in need of re-importancing
07:06:15 <tchaypo> greghaynes: the d-i-b one?
07:06:18 <greghaynes> yes
07:07:29 <tchaypo> if I'm reading the bug correctly, 105480 is the fix
07:07:39 <tchaypo> so fix-committed seems apropos
07:07:49 <greghaynes> ah, right ;)
07:07:55 <greghaynes> its late, I have an excuse
07:08:31 <tchaypo> GheRivero: are you around?
07:09:23 <tchaypo> Bug #1316895 has https://review.openstack.org/#/c/95151/ proposed, several months old
07:09:52 <tchaypo> #info https://review.openstack.org/#/c/95151/ has ben open to fix https://bugs.launchpad.net/tripleo/+bug/1316985 for over a month, could do with some review action
07:09:53 <uvirtbot> Launchpad bug 1316985 in tripleo "set -eu may spuriously break dkms module" [Critical,In progress]
07:10:01 <tchaypo> I don't see much else to chase here so I propose we move on
07:10:33 <tchaypo> #topic reviews
07:10:40 <tchaypo> #info There's a new dashboard linked from https://wiki.openstack.org/wiki/TripleO#Review_team - look for "TripleO Inbox Dashboard"
07:10:42 <tchaypo> #link http://russellbryant.net/openstack-stats/tripleo-openreviews.html
07:10:44 <tchaypo> #link http://russellbryant.net/openstack-stats/tripleo-reviewers-30.txt
07:10:46 <tchaypo> #link http://russellbryant.net/openstack-stats/tripleo-reviewers-90.txt
07:11:25 <tchaypo> Last week:
07:11:27 <tchaypo> 19:22:00 <lifeless> Stats since the last revision without -1 or -2 :
07:11:30 <tchaypo> 19:22:00 <lifeless> Average wait time: 9 days, 10 hours, 55 minutes
07:11:32 <tchaypo> 19:22:00 <lifeless> 1st quartile wait time: 1 days, 6 hours, 51 minutes
07:11:34 <tchaypo> 19:22:00 <lifeless> Median wait time: 5 days, 18 hours, 17 minutes
07:11:36 <tchaypo> 19:22:00 <lifeless> 3rd quartile wait time: 13 days, 11 hours, 45 minutes
07:11:40 <tchaypo> This week:
07:11:42 <tchaypo> Stats since the last revision without -1 or -2 :
07:11:45 <tchaypo> Average wait time: 9 days, 1 hours, 38 minutes
07:11:47 <tchaypo> 1st quartile wait time: 1 days, 15 hours, 34 minutes
07:11:49 <tchaypo> Median wait time: 5 days, 23 hours, 37 minutes
07:11:51 <tchaypo> 3rd quartile wait time: 9 days, 2 hours, 1 minutes
07:12:00 <marios> same same i'd say
07:12:11 <marios> apart from 3rd
07:12:15 <tchaypo> #info 3rd quartile has dropped from 13d11h45m to 9d2h1m - hurrah!
07:12:39 <tchaypo> #info other quartiles and median are unchanged
07:12:39 <marios> i always forget which one we're interested in :)
07:13:09 <tchaypo> I'm confused by the difference between average and median.
07:13:10 <marios> cos e.g. the avg wait time seems same to me
07:13:14 <marios> right
07:13:33 <tchaypo> Clearly average isn't median, it must be mean? so that would suggest a small number of reviews with very lengthy waits?
07:13:52 <GheRivero> morning all. o/
07:13:57 <tchaypo> lo GheRivero
07:14:59 <tchaypo> #info I think the stats suggest we now have a small number of very old reviews, which are rasing the average (mean, I assume) but not the median or 3rd quartile. I think.
07:16:07 <tchaypo> http://russellbryant.net/openstack-stats/tripleo-reviewers-90.txt says lifeless has done 404 reviews in the last 90 days
07:16:29 <greghaynes> wow
07:16:49 <tchaypo> greghaynes has done a measly 308
07:17:09 <StevenK> "measly"
07:17:26 <tchaypo> #link http://www.stackalytics.com/report/reviews/tripleo-group/open
07:17:54 <tchaypo> #info the stackalytics graph shows most reviews getting hit within a day, but a long tail stretching out to 47 days
07:17:59 <tchaypo> StevenK: compared to lifeless
07:18:06 <tchaypo> still more than any sane mortal
07:19:10 <tchaypo> Is there anything more to discuss here?
07:19:30 <tchaypo> I think the stats show we're moving in the right direction but really need to nail some of the older reviews
07:20:58 <tchaypo> Hrm. Looking at the TripleO Inbox Dashboard it seems to be sorted with most-recent-first
07:21:08 <tchaypo> perhaps we could change that to encourage the oldest reviews to be looked at
07:21:13 <greghaynes> +1
07:21:19 <tchaypo> Is there anyone who wants to take that on?
07:21:48 <tchaypo> https://github.com/stackforge/gerrit-dash-creator/blob/master/dashboards/tripleo.dash seems to have the source for the link
07:22:10 <d0ugal> tchaypo: I can try to change it
07:22:27 <tchaypo> not even actually sure if it's possible
07:22:30 <tchaypo> https://code.google.com/p/gerrit/issues/detail?id=536
07:22:38 <d0ugal> ah
07:23:51 <tchaypo> http://www.mediawiki.org/wiki/Git/Gerrit_evaluation
07:24:00 <tchaypo> It is not possible to alter the sort order in which changes are listed.[3] Changes are listed by last update date, so the changes that have been neglected the longest are also the hardest to see. A feature request for parametrizing the sort order was accepted in 2010, but no progress has been made as of July 2012.[4].
07:24:03 <tchaypo> *sigh*
07:24:27 <d0ugal> d'oh
07:24:29 <tchaypo> okay, I don't think it's worth pursuing that
07:24:41 <StevenK> We can't have nice things.
07:24:46 <tchaypo> maybe it would be better to pursue a change in gertty?
07:25:17 <tchaypo> gertty seems to sort by review number, which is not the same thing
07:25:51 <tchaypo> #info It seems like we can't change the sort order on the dashboard because gerrit doesn't support sorting. Maybe gertty could be tweaked to show oldest-without-negative-review first?
07:26:24 <tchaypo> I think we need to move on now, we're almost at halftime
07:26:27 <tchaypo> so
07:26:36 <tchaypo> #topic Projects needing releases
07:26:49 <tchaypo> StevenK: I believe you had something to say about this?
07:27:13 <StevenK> Only inasmuch as it's a good thing, and we should totally do it.
07:27:24 <greghaynes> haha
07:27:30 <tchaypo> +1
07:27:34 <greghaynes> Well, we did get os-cloud-config released today
07:27:44 <greghaynes> so whoever takes this might not need to do that one
07:27:46 <tchaypo> is there anyone here who has the access rights to do the releases?
07:28:06 <shadower> yea me
07:28:21 <marios> tchaypo: haha was that you volunteering StevenK then?
07:28:41 <tchaypo> I don't believe stevenk has enough access to do the releases
07:28:55 * marios neither... didn't chase it up last time
07:28:55 <tchaypo> so unless he wants to hurry up and get them I think I'll volunteer shadower
07:29:05 <shadower> yeah, lets
07:29:27 <tchaypo> #action shadower to release all the things (but maybe not os-cloud-config)
07:29:30 <shadower> but it'd be great if someone else from this meet time could do it too
07:29:34 <shadower> I won't be here every time
07:29:39 <shadower> hint hint
07:29:50 <d0ugal> lol
07:29:53 <greghaynes> ^ action
07:29:59 <marios> shadower: i'm not clear, what are you hinting at?
07:30:10 <greghaynes> someone who is around at this meeting time get access this week
07:30:14 <greghaynes> #action someone who is around at this meeting time get access this week
07:30:18 <tchaypo> #action some other people from this timezone to get themselves access so we're not reliant on shadower to be around every time
07:30:23 <greghaynes> double action
07:30:34 <tchaypo> nope, that's one of the things only the chair can do, i think
07:30:37 <marios> is it a 'ping lifeless' job?
07:30:45 <shadower> marios: yeah
07:30:46 <marios> or, how do we get access?
07:30:53 <marios> shadower: thanks, pretty sure i did last time
07:31:00 <marios> shadower: but will try again
07:31:25 <tchaypo> <3 marios
07:31:36 <tchaypo> okay, next we have
07:31:39 <tchaypo> #topic CD Cloud status
07:32:41 <tchaypo> A coalition of the thrilling (led by lifeless) has been working on code changes needed to VLAN support working so that we can bring up the HP regions
07:32:57 <tchaypo> That's starting to get close - I *think* all the patches are prepared, we're just working out a few kinks
07:33:56 <tchaypo> Unless anyone eles has any news...
07:34:48 <tchaypo> #info Code changes required to get VLAN support so we can get HP regions back online are nearing completion.
07:34:56 <tchaypo> #topic CI
07:35:36 <tchaypo> I have no idea what's been happening here.
07:36:49 <tchaypo> bueller? bueller?
07:37:06 <marios> qe ?
07:38:28 <tchaypo> I think I'm just going to note that no-one had any updates
07:39:26 <tchaypo> #info no-one had any updates
07:39:33 <tchaypo> #topic Tuskar
07:41:09 <marios> anyone want to give an update? shadower ? template stuff from sbaker and the template munging from jay?
07:41:20 <marios> i think the most pending issue was until now the specs landing which has now happened
07:41:35 <d0ugal> Yeah, we are mostly busy starting implementations now
07:42:06 <shadower> yea, jdob started working on implementing the tuskar API stuff
07:42:21 <marios> jcoufal: do you have link to latest UI wireframes handy? haven't followed those for a while
07:42:25 <shadower> and stevebaker posted a series of patches converting THT to HOT
07:42:39 <tchaypo> (please feel free to add hash-info tags to anything you want recorded in the notes ;)
07:42:49 <shadower> if we could get some eyeballs on those, that would be fantastic
07:44:54 <tchaypo> #info Specs have landed, implementations are starting. jdob is working on tuskar API stuff, stevebaker, posted a series of patches converting THT to HOT - eyeballs on those would be fantastic
07:45:08 <tchaypo> Moving on to a new topic
07:45:14 <tchaypo> #topic specs
07:45:31 <greghaynes> ssl-pki: https://review.openstack.org/#/c/103692/
07:45:44 <greghaynes> That one id like to get merged soonish as its blocking a bunch of stuff
07:46:03 <tchaypo> #link https://review.openstack.org/#/q/status:open+project:openstack/tripleo-specs,n,z
07:46:10 <tchaypo> #info 24 open specs (including WIPs)
07:46:10 <greghaynes> so, eyeballs please :)
07:46:24 <tchaypo> greghaynes: can you add tags?
07:46:34 <tchaypo> link and info work for everyone
07:46:46 <greghaynes> #link https://review.openstack.org/#/c/103692/
07:46:58 <greghaynes> #info please review ssl-pki patch so we can progress on HA work
07:47:19 * tchaypo is too lazy to copy and paste again
07:47:20 <tchaypo> thanks :)
07:47:22 <jcoufal> marios: just uploading them, few minutes
07:47:44 <marios> jcoufal: thanks mate, maybe do info here for the minutes if you get them in time
07:48:00 <tchaypo> Any more about specs?
07:48:42 <tchaypo> #topic one-off agenda items
07:48:54 <tchaypo> #link https://etherpad.openstack.org/p/juno-midcycle-meetup
07:48:56 <greghaynes> two weeks to meetup!
07:49:04 <tchaypo> #info Please start adding agenda items to the agenda etherpad
07:49:58 <jcoufal> latest wireframes: http://people.redhat.com/~jcoufal/openstack/juno/
07:50:13 <jcoufal> I am writing an e-mail to the mailing list as well
07:50:23 <tchaypo> #info jcoufal provides the latest wireframes for Tuskar
07:50:31 <tchaypo> #link http://people.redhat.com/~jcoufal/openstack/juno/
07:51:32 <tchaypo> #topic open discussion
07:54:27 <tchaypo> okay, I have to run, so I'm going to wrap it up here
07:54:30 <tchaypo> thanks for coming everyone
07:54:32 <tchaypo> #endmeeting