08:00:13 <shadower> #startmeeting tripleo
08:00:15 <openstack> Meeting started Wed Sep 17 08:00:13 2014 UTC and is due to finish in 60 minutes.  The chair is shadower. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:18 <openstack> The meeting name has been set to 'tripleo'
08:00:39 <d0ugal> o/
08:00:46 <marios> morning all
08:00:53 <lsmola2> o/
08:00:56 <d0ugal> morning
08:01:04 <StevenK> o/
08:01:28 <shadower> \o
08:01:34 * shadower is left-handed
08:01:37 <shadower> #topic agenda
08:01:38 <shadower> * bugs
08:01:38 <shadower> * reviews
08:01:38 <shadower> * Projects needing releases
08:01:38 <shadower> * CD Cloud status
08:01:40 <shadower> * CI
08:01:42 <shadower> * Tuskar
08:01:45 <shadower> * Specs
08:01:47 <shadower> * open discussion
08:01:50 <shadower> Remember that you can and should use the #info and #link commands, too!
08:02:03 <shadower> #topic bugs
08:02:13 <shadower> #link https://bugs.launchpad.net/tripleo/
08:02:13 <shadower> #link https://bugs.launchpad.net/diskimage-builder/
08:02:13 <shadower> #link https://bugs.launchpad.net/os-refresh-config
08:02:13 <shadower> #link https://bugs.launchpad.net/os-apply-config
08:02:13 <shadower> #link https://bugs.launchpad.net/os-collect-config
08:02:14 <pblaho> o/
08:02:16 <shadower> #link https://bugs.launchpad.net/os-cloud-config
08:02:18 <shadower> #link https://bugs.launchpad.net/tuskar
08:02:21 <shadower> #link https://bugs.launchpad.net/python-tuskarclient
08:02:27 * StevenK notes shadower is already telling lies, since the meeting is not in all caps
08:02:31 <shadower> Oh no! We've got bugs!
08:02:41 <shadower> (this is not a lie)
08:02:47 <shadower> https://bugs.launchpad.net/tripleo/+bug/1263294
08:02:48 <uvirtbot> Launchpad bug 1263294 in tripleo "ephemeral0 of /dev/sda1 triggers 'did not find entry for sda1 in /sys/block'" [Critical,In progress]
08:02:52 <shadower> https://bugs.launchpad.net/tripleo/+bug/1361235
08:02:53 <uvirtbot> Launchpad bug 1361235 in tripleo "visit horizon failure because of import module failure" [Critical,In progress]
08:02:56 <shadower> https://bugs.launchpad.net/tripleo/+bug/1369381
08:02:58 <uvirtbot> Launchpad bug 1369381 in tripleo "Neutron iptables-restore ipset commands failing" [Critical,In progress]
08:03:04 <shadower> that's all the criticals for this week
08:03:09 <shadower> people seem to be working on them
08:03:24 <shadower> anyone has anything to say about these?
08:03:33 <d0ugal> Should those be #link'ed?
08:03:52 <shadower> d0ugal: feel free to link them ;-)
08:04:10 <d0ugal> #link https://bugs.launchpad.net/tripleo/+bug/1263294
08:04:12 <uvirtbot> Launchpad bug 1263294 in tripleo "ephemeral0 of /dev/sda1 triggers 'did not find entry for sda1 in /sys/block'" [Critical,In progress]
08:04:15 <marios> so +bug/1263294 - fixes have both merged seems?
08:04:16 <d0ugal> #link https://bugs.launchpad.net/tripleo/+bug/1361235
08:04:17 <uvirtbot> Launchpad bug 1361235 in tripleo "visit horizon failure because of import module failure" [Critical,In progress]
08:04:20 <d0ugal> #link https://bugs.launchpad.net/tripleo/+bug/1369381
08:04:21 <uvirtbot> Launchpad bug 1369381 in tripleo "Neutron iptables-restore ipset commands failing" [Critical,In progress]
08:04:34 <shadower> looks like the people working on the bugs are all asleep now (or at least should be)
08:04:42 <shadower> any other bugs anyone wants to discuss?
08:05:14 <shadower> moving swiftly along, then
08:05:16 <shadower> #topic reviews
08:05:25 <shadower> #info There's a new dashboard linked from https://wiki.openstack.org/wiki/TripleO#Review_team - look for "TripleO Inbox Dashboard"
08:05:28 <shadower> #link http://russellbryant.net/openstack-stats/tripleo-openreviews.html
08:05:31 <shadower> #link http://russellbryant.net/openstack-stats/tripleo-reviewers-30.txt
08:05:34 <shadower> #link http://russellbryant.net/openstack-stats/tripleo-reviewers-90.txt
08:05:44 <shadower> Stats since the last revision without -1 or -2 :
08:05:45 <shadower> Average wait time: 7 days, 16 hours, 34 minutes
08:05:45 <shadower> 1st quartile wait time: 1 days, 3 hours, 7 minutes
08:05:45 <shadower> Median wait time: 5 days, 19 hours, 23 minutes
08:05:45 <shadower> 3rd quartile wait time: 12 days, 10 hours, 16 minutes
08:06:14 <shadower> I don't actually know what the stat terms are about but I'll hazard a guess that it's bad as always
08:06:17 <derekh> This looks like its improving :   Queue growth in the last 30 days: 31 (1.0/day)
08:06:19 <marios> is that an improvement on 3rd quartile?
08:06:28 <shadower> oh, really?
08:06:29 <shadower> cool
08:06:31 <shadower> Don't forget that if a review makes our stats bad, you can mark it as WIP.
08:06:37 <shadower> Bonus points if a core gave it -1 and there's been no reply for 14 days
08:07:00 * tchaypo waves
08:07:05 <tchaypo> that's actually down on last week
08:07:16 <marios> yeah last week was: 19:33:27 <tchaypo> 3rd quartile wait time: 15 days, 19 hours, 38 minutes
08:07:48 <marios> shadower: I feel like we should send something out to list about that
08:07:55 <marios> shadower: about the -1 of patches
08:08:05 <marios> shadower: it was discussed last week but afaik no action was taken
08:08:05 <d0ugal> marios: sounds like a good idea
08:08:17 <d0ugal> Yeah, I missed the last meeting so this is new to me
08:08:17 <shadower> any volunteers?
08:08:26 <marios> i'll do it
08:08:49 <shadower> #action marios to email the list about WIPing patches that mess up our stats
08:08:49 <tchaypo> oh nice, that'll be a change from it being me talking about it :)
08:09:00 <tchaypo> I can't WIP things though, not being core, which makes me sad
08:09:15 <d0ugal> tchaypo: likewise :)
08:09:21 <d0ugal> I mean :(
08:09:25 * StevenK is *almost* a core
08:09:29 <shadower> just ping a core and point them to a WIPable patches
08:09:34 <d0ugal> StevenK: half core?
08:09:37 <shadower> that's a couple clicks worth of work
08:09:50 <marios> tchaypo: you can put it in the comments though which should have similar effect (at least until someone sees it and -1 it)
08:09:59 <derekh> shadower: marios lets not start using language that suggest we're doing this to manipulate stats
08:09:59 <shadower> or that
08:10:11 <StevenK> d0ugal: When I spoke to lifeless over the weekend he said I have enough votes, just needs him to tell gerrit that I am
08:10:12 <shadower> derekh: okay
08:10:23 <d0ugal> StevenK: Nice :)
08:10:27 <marios> tchaypo: derekh: sure. imo it's just good housekeeping to enforce some kind of order on the review queue
08:10:28 <tchaypo> Yeah, I've been doing that
08:10:39 <derekh> rather we are doing this to to avoid stale reviews gathering up, at leats thats the way I see it
08:10:47 <shadower> #note for the record, shadower mas making jokes about us manipulating stats. Doing that was not anyone's intention
08:10:52 <tchaypo> d0ugal: you actually have the numbers to potentially be core though, I don't (yet)
08:11:04 <d0ugal> tchaypo: heh, yeah, took a while to get there.
08:11:34 <marios> StevenK: congrats :)
08:11:56 <StevenK> Oh, nice. d0ugal is just below me
08:12:02 <StevenK> 291 vs 277
08:12:37 <marios> :( please don't start doing that with the review numbers.
08:12:57 <shadower> bnemec: you here by any chance? Last meeting notes you might look into adding a report of items that have a -1 from a core but no response for 14 days
08:13:03 <d0ugal> StevenK: Oh yeah, I hadn't looked at that report for a while. neat.
08:13:07 <StevenK> marios: Not my intent to shame/brag
08:13:39 <d0ugal> FWIW, I didn't take it that way :)
08:13:45 <marios> StevenK: i know, a bit unfar shouldn't be directed at your comment per se, just echoing what others are saying lately about us paying too much attention to the review queue and stats
08:13:51 <marios> s/unfar/unfair
08:14:14 <shadower> shall we move on?
08:14:14 <marios> and given that, your comment may well be mistaken as such by someone looking at the minutes
08:14:28 <d0ugal> shadower: +1
08:14:32 <shadower> #topic Projects needing releases
08:14:40 <shadower> that'd be all of 'em again
08:14:44 <shadower> any volunteers?
08:14:52 <tchaypo> to be clear, my comment about the numbers only meant that the numbers are a neccessary condition for becoming core, they're not a sufficient condition
08:15:04 <marios> shadower: put me down unless someone else wants to try it
08:15:19 <marios> i'd encourage someone that hasn't done this yet to plan to. it is really easy
08:15:23 <tchaypo> thanks marios
08:15:34 <shadower> #action marios will release all the things again because he's awesome
08:15:38 <StevenK> EPERM for me, but I'm hoping to do so before Paris
08:15:43 <tchaypo> StevenK has expressed interest but I don't think he's able to do it
08:16:14 <shadower> #topic CD Cloud status
08:16:17 <StevenK> Need to be a member of tripleo-ptl on gerrit to do so. Let me get at least a few weeks of core under my belt before I ask
08:16:23 <shadower> derekh: anything to say here?
08:16:49 <shadower> StevenK: afaik any core can make you a tripleo-ptl, no need to wait for lifeless once you decide to go for it
08:17:01 <derekh> hp1 just about ready to turn back running CI, just want to try out the suggestion for greg
08:17:10 <tchaypo> HP2 is starting to look slightly healthier - a lot of the patches we were carrying have landed, and other bugs are being fixed as I find them
08:17:14 <derekh> see my mail for more details
08:17:31 <derekh> rh1 seems ok at the moment,
08:17:35 <tchaypo> it turns out that trying to build a cloud from trunk is (A) difficult, and (B) a moving target
08:17:53 <shadower> I would have never guessed
08:17:56 <derekh> although last night this happened https://bugs.launchpad.net/tripleo/+bug/1370275
08:17:57 <uvirtbot> Launchpad bug 1370275 in tripleo "Jenkins nodes being reused" [High,Triaged]
08:18:03 <derekh> I hope it isn't a rh1 problems
08:18:30 <derekh> to that end, can I get some eyes on https://review.openstack.org/#/c/122018/
08:18:56 * derekh over
08:19:02 <shadower> thanks
08:19:40 <shadower> #note we need some eyballs on https://review.openstack.org/#/c/122018/
08:19:50 <shadower> #topic CI
08:20:33 <shadower> anyone have anything to say?
08:21:01 <derekh> on CI we have had a least 4 (If not more) seperate sets of CI probelems due to the ironic driver to nova tree
08:21:20 <shadower> :-(
08:21:33 <derekh> but those seem to be stabalized now, basically things were broke more then normal for the last week
08:22:04 <derekh> Aksi check-tripleo-novabm-overcloud-precise-nonha seems to be failing a lot
08:22:23 <derekh> but tripleo isn't voting on it, anybody know why ?
08:22:33 <shadower> because it's failing a lot?
08:22:52 <shadower> I do remember someone asking reviewers to try and pay attention to it
08:22:53 <StevenK> It's a non-HA job, it should be voting ?
08:23:01 <shadower> oh non-ha
08:23:03 <shadower> I misread that
08:23:10 <shadower> no idea
08:23:26 <derekh> We don't run it, it was removed when hp1 was taken down
08:23:35 <derekh> but other projects run it
08:23:50 <derekh> I might just turn it back on non voting
08:24:04 <derekh> so people see it failing, somebody will fix it :-)
08:24:16 <shadower> good thinking
08:24:40 <shadower> yeah I've seen it in Heat checks
08:24:41 <derekh> ok, that all from me, /action derekh will turn back on the precise overcloud job for tripleo projects
08:24:57 <shadower> #action derekh will turn back on the precise overcloud job for tripleo projects
08:25:00 <shadower> thanks
08:25:01 <derekh> yup, heat would be seeing the failures a lot but tripleo don't
08:25:09 <shadower> yea
08:25:12 <shadower> #topic Tuskar
08:25:24 <shadower> d0ugal, lsmola ?
08:25:53 <d0ugal> Nothing specific to report from me.
08:26:29 <shadower> ok
08:26:50 <shadower> afaik, jdob is working on handling top-level resources, parameters and outputs in Tuskar
08:26:57 <shadower> that's all I know
08:27:05 <d0ugal> I'm working on the updated Tuskar element
08:27:13 <shadower> cool
08:27:28 <d0ugal> but yeah, basically working towards full end to end testing - reviews etc. are looking pretty good.
08:27:45 <lsmola> shadower: nothing from my side
08:27:50 <shadower> any reviews you want to highlight?
08:28:29 <shadower> okay, moving on
08:28:31 <d0ugal> I don't think so, our reviews are moving fairly fast at the moment
08:28:48 * shadower will have to increase the timeouts
08:28:54 <shadower> #topic Specs
08:28:55 <d0ugal> Oh, this should ideally be merged - https://review.openstack.org/#/c/116416/
08:29:08 <d0ugal> Tuskar install is a bit broken otherwise I think.
08:29:27 <d0ugal> sorry, a bit late :)
08:29:33 <shadower> #note some eyballs on https://review.openstack.org/#/c/116416/ too, please
08:29:34 <tchaypo> that one is barely a few weeks old
08:29:43 <tchaypo> heat managed to land one today dating from july
08:29:49 <tchaypo> it was on the 60th revision
08:29:56 <shadower> wow
08:30:06 <d0ugal> tchaypo: heh, nice, the age is less relevant than the impact in this case :)
08:30:47 <shadower> so, specs
08:31:38 <shadower> nothing new landed as far as can see
08:31:49 <shadower> anyone want to discuss their favourite spec?
08:32:25 <d0ugal> Don't specs need to wait for K now?
08:33:23 <shadower> okay, moving on
08:33:29 <tchaypo> I thought tripleo didn't follow the release cycle/didn't have a freeze?
08:33:29 <shadower> #topic open discussion
08:33:36 <shadower> or not
08:33:47 <shadower> tchaypo: yea me too, but maybe we do for specs?
08:33:50 <lsmola> still the specs are under /juno/
08:33:51 <shadower> I honestly don't know
08:33:56 <lsmola> that should probably change
08:34:01 <tchaypo> We should probably at least move them all to /kilo/
08:34:06 <d0ugal> +1
08:34:16 <lsmola> yeah
08:34:23 <derekh> fwiw I put them under juno when I was creating the specs repo, mainly because I copied the nova repo
08:36:27 <shadower> ok, open discussion take two
08:36:31 <shadower> Ironic developers: congrats for graduating!
08:36:38 <tchaypo> +1
08:37:03 <d0ugal> \o/
08:37:39 <StevenK> \o/
08:37:53 <derekh> I'd like to get os-collect-config properly into logstash this week, so can somebody take a look at https://review.openstack.org/#/c/120394/ please
08:38:02 <derekh> o and grats ironic :-)
08:38:40 <shadower> #note eyballs on https://review.openstack.org/#/c/120394/ to get os-collect-config into logstash
08:38:51 <tchaypo> At the mid-cycle, I felt like we had a lot of discussions that came down to devs/ops having different needs when they're dstarting out with tripleo
08:39:14 <tchaypo> I'd like to start talking more about getting better docs/scripts/etc to give clearer landing-strips for both
08:40:49 <tchaypo> For ops, who want to get a cloud up quickly with minimum fuss, I kinda like the way helion distributes a pre-built seed
08:41:15 <tchaypo> (although I don't like helion's heft hardware requirements)
08:41:59 <tchaypo> for devs, lifeless posted https://review.openstack.org/#/c/85636/ a long time ago; but my current feeling is that it isn't quite what we need
08:43:05 <tchaypo> cinerama has done some work on writing tripleorc earlier (https://review.openstack.org/#/c/108801/) so that devs can start changing settings inside that instead of a seperate little-documented .devtestrc
08:43:47 <tchaypo> I think that needs some more work before it's ready - if nothing else, we have lots of info to put into that file that isn't ready when devtest_variables is first run so we probably need some way to append to that as we go
08:47:24 <shadower> okay, shall we wrap this up?
08:48:36 <shadower> tchaypo: I agree, better docs will be quite important especially as we start getting more users
08:48:53 <shadower> not just for the initial installation but also for updates & keeping it alive
08:49:07 <tchaypo> Oh, the other thing is
08:49:43 <tchaypo> StevenK: can i poke you tomorrow about starting the process of getting prep_source_repos on-boarded as a project?
08:49:55 <tchaypo> Probably under stackforge at this point
08:50:11 <StevenK> tchaypo: I guess? But I have no idea either
08:50:27 <tchaypo> k.
08:51:31 <tchaypo> cool, let's go. Thanks shadower
08:51:40 <shadower> no problem
08:51:49 <shadower> #endmeeting