19:02:58 <SpamapS> #startmeeting tripleo
19:02:59 <openstack> Meeting started Tue Oct  7 19:02:58 2014 UTC and is due to finish in 60 minutes.  The chair is SpamapS. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:03:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:03:03 <openstack> The meeting name has been set to 'tripleo'
19:03:08 <SpamapS> Didn't realize it would fix itself
19:03:37 <SpamapS> #topic agenda
19:03:45 <tchaypo> All hail the new overlord!
19:04:00 <SpamapS> * bugs
19:04:00 <SpamapS> * reviews
19:04:00 <SpamapS> * Projects needing releases
19:04:00 <SpamapS> * CD Cloud status
19:04:00 <SpamapS> * CI
19:04:03 <SpamapS> * Tuskar
19:04:05 <SpamapS> * Specs
19:04:08 <SpamapS> * open discussion
19:04:10 <SpamapS> does anyone want to add anything to that?
19:05:23 <SpamapS> #bugs
19:05:33 <SpamapS> #topic bugs
19:06:00 <SpamapS> #link https://bugs.launchpad.net/tripleo/
19:06:01 <SpamapS> #link https://bugs.launchpad.net/diskimage-builder/
19:06:01 <SpamapS> #link https://bugs.launchpad.net/os-refresh-config
19:06:01 <SpamapS> #link https://bugs.launchpad.net/os-apply-config
19:06:01 <SpamapS> #link https://bugs.launchpad.net/os-collect-config
19:06:03 <SpamapS> #link https://bugs.launchpad.net/os-cloud-config
19:06:05 <SpamapS> #link https://bugs.launchpad.net/tuskar
19:06:08 <SpamapS> #link https://bugs.launchpad.net/python-tuskarclient
19:06:37 <SpamapS> three criticals with no assignee in tripleo
19:06:53 <SpamapS> actually I'll take https://bugs.launchpad.net/tripleo/+bug/1374626
19:06:55 <uvirtbot> Launchpad bug 1374626 in tripleo "UIDs of data-owning users might change between deployed images" [Critical,Triaged]
19:07:11 <SpamapS> Need people for https://bugs.launchpad.net/tripleo/+bug/1375641
19:07:12 <uvirtbot> Launchpad bug 1375641 in ironic "Error contacting Ironic server for 'node.update'" [Critical,Fix released]
19:07:37 <SpamapS> and https://bugs.launchpad.net/tripleo/+bug/1263294
19:07:39 <uvirtbot> Launchpad bug 1263294 in tripleo "ephemeral0 of /dev/sda1 triggers 'did not find entry for sda1 in /sys/block'" [Critical,In progress]
19:08:06 <tchaypo> https://bugs.launchpad.net/tripleo/+bug/1263294 has been critical since may
19:08:16 <tchaypo> with no progress, but it doesn't seem to be getting inour way
19:08:29 <bnemec> https://bugs.launchpad.net/tripleo/+bug/1375641 is fixed, isn't it?
19:08:30 <uvirtbot> Launchpad bug 1375641 in ironic "Error contacting Ironic server for 'node.update'" [Critical,Fix released]
19:08:31 <tchaypo> Is it possible that it's not actually critical?
19:09:38 <slagle> i closed https://bugs.launchpad.net/tripleo/+bug/1373430, it was fixed in horizon
19:09:39 <SpamapS> tchaypo: how are we working around it?
19:09:41 <uvirtbot> Launchpad bug 1373430 in tripleo "Error while compressing files" [Critical,Fix released]
19:10:17 <SpamapS> oh right, we work around it by forcibly mounting ephemeral in o-r-c
19:10:30 <GheRivero> tchaypo: we have a workaround while waiting for the fix in cloud-init I will decrease its importance
19:10:52 <SpamapS> I think since it has a workaround, it is by definition 'High' not 'Critical'
19:10:55 * SpamapS drops it
19:12:13 <SpamapS> GheRivero: well one of us dropped it anyway. :)
19:12:45 <SpamapS> bnemec: indeed it is fixed in Ironic
19:12:49 <SpamapS> can we revert https://review.openstack.org/#/c/124994/ ?
19:13:06 <SpamapS> err wait n/m
19:13:08 <SpamapS> misunderstood
19:13:41 <SpamapS> closed bug 1375641 .. it was indeed fixed in Ironic
19:13:47 <uvirtbot> Launchpad bug 1375641 in ironic "Error contacting Ironic server for 'node.update'" [Critical,Fix released] https://launchpad.net/bugs/1375641
19:14:17 <SpamapS> Ok that just puts the one critical on me. :) anybody want to bring up any specific bugs before we move on?
19:15:34 <SpamapS> BTW, great job triaging everybody!
19:15:46 <SpamapS> #topic reviews
19:16:05 <SpamapS> #info There's a new dashboard linked from https://wiki.openstack.org/wiki/TripleO#Review_team - look for "TripleO Inbox Dashboard"
19:16:08 <SpamapS> #link http://russellbryant.net/openstack-stats/tripleo-openreviews.html
19:16:12 <SpamapS> #link http://russellbryant.net/openstack-stats/tripleo-reviewers-30.txt
19:16:15 <SpamapS> #link http://russellbryant.net/openstack-stats/tripleo-reviewers-90.txt
19:16:48 <tchaypo> 9 people at 60 or higher on http://russellbryant.net/openstack-stats/tripleo-reviewers-30.txt right now
19:17:03 <tchaypo> Queue growth in the last 30 days: 0 (0.0/day)
19:17:19 <tchaypo> New changes in the last 30 days: 212 (7.1/day)
19:17:21 <tchaypo> Changes merged in the last 30 days: 199 (6.6/day)
19:17:43 <slagle> do we still feel like 3 reviews a work day is a reasonable commitment?
19:17:55 <SpamapS> way to go people. I am somewhat ashamed of my 1/day rate the last 90 days, but you will see that climb hopefully soon.
19:18:09 <tchaypo> to revert to the traditional statistic
19:18:11 <tchaypo> 3rd quartile wait time: 19 days, 7 hours, 13 minutes
19:18:41 <SpamapS> slagle: seems like it is right in the sweet spot really.
19:18:52 <tchaypo> Quoting monty's TC email - "OpenStack is optimized for high-throughput at the expense of individual
19:18:54 <tchaypo> patch latency.
19:18:56 <tchaypo> "
19:19:27 <SpamapS> We could drive wait time down more of course, but I see more patches waiting on submitter than reviewers.. so I think there's not much point in that.
19:19:44 <slagle> SpamapS: yea, i don't have a problem really with people not meeting it
19:19:51 <tchaypo> we seems to be fitting that pattern - individual patches take literal weeks to land, but we seem to be keeping up with what's coming in fairly well
19:20:05 <slagle> just more curious if maybe we ask too much, if lots of people are finding it hard to achieve
19:20:20 <SpamapS> tchaypo: there's also the dispair effect to consider.. as it takes longer to land them, less people even bother submitting.
19:20:29 <tchaypo> The only problem I have with the high throughput is the effect on new committeres
19:20:32 <slagle> but i don't really think there's anything actionable either way
19:20:34 <SpamapS> despair? :-P
19:21:03 <Ng> dispair, datpear, it's all the same
19:21:09 <SpamapS> tchaypo: I've always felt that we should have a little priority mark on somebody's first 2 or 3 patches.
19:21:34 <tchaypo> SpamapS: yeah, good point. Probably especially bad for new committers if we turn them off after their first attempt to help us, but it's also bad if it means people just don't bother providing updates because it takes too much time or effort to get them through
19:21:41 <SpamapS> BUt we don't want to make them too special.. or they'll get a false sense of how things work.
19:22:02 <SpamapS> Anyway, I feel like reviews are working o-k right now and we have bigger fish to fry.
19:22:15 <SpamapS> next topic in 10.. 9...
19:22:19 <tchaypo> I wonder if the "Thanks for your first patch" message could be adapted to look up an irc channel and suggest they go hang out there
19:22:42 <alexisli> So this is the first meeting I remember where the queue hasn't grown. Go us :)
19:22:43 <tchaypo> I feel like we tend to do okay at pushing through urgent patches, but that's largely because if it's urgent people jump in IRC and hassle cores
19:23:10 <SpamapS> alexisli: one reason for that might be that OpenStack has stopped changing under us for the last 2 weeks.. ;)
19:23:48 <bnemec> Yeah, we also had relatively few CI issues this week because of that.
19:23:58 <tchaypo> Shall I follow up on the list with a suggestion that we start paying more attention to throughput than to latency?
19:24:18 <SpamapS> tchaypo: it would be good if the metrics included that
19:24:29 <SpamapS> would be a rather nice graph really
19:24:39 <tchaypo> or at least, paying equal attention to both, with an unresolved question about special welcome for new contributors
19:26:00 <SpamapS> #topic Projects needing releases
19:26:47 <SpamapS> I feel like we automated this, but I know that there is just at least one excellent human doing a good job of fooling me into thinking they're a robot here..
19:27:09 <jdob> i'll do it
19:27:45 <SpamapS> jdob: ^5
19:27:55 <SpamapS> #topic CI
19:28:10 <tchaypo> SpamapS: actually it's relatively dispersed, there's probably 4 or so people who do it regularly
19:31:20 <bnemec> I guess CI is quiet? :-)
19:31:44 <SpamapS> I don't believe it. :)
19:31:48 <SpamapS> tchaypo: HP region status?
19:31:53 <SpamapS> regions I should say
19:33:12 <tchaypo> I don't know, was on leave last week and public holiday monday
19:33:33 <tchaypo> I assume that means no progress on hp2 since last week...
19:33:59 <tchaypo> thanks to help from morganfainberg we have keystone working a bit better; so now it's clear that the bug preventing >4 nodes coming up lies elsewhere
19:34:17 <tchaypo> but I don't think it's the nova scheduler race either...
19:34:18 <morganfainberg> tchaypo, aww :( was hoping that'd be easy.
19:34:25 <tchaypo> I'll be grovelling in logs today
19:34:38 <tchaypo> PS: our default log levels are useless for figuring out what's happening
19:34:40 <SpamapS> ok
19:34:54 <SpamapS> Sounds good
19:35:20 <SpamapS> #topic Tuskar
19:37:24 <SpamapS> hellleewww?
19:37:35 <SpamapS> jdob: ?
19:37:43 <jdob> sorry, nothing major to report
19:37:56 <shadower> slackers
19:38:14 <jdob> its just that things are so perfect there's no need to waste time in the meeting reiterating that :)
19:39:11 <tzumainn> lol
19:39:42 <lsmola_> hehe
19:41:05 <SpamapS> #topic Specs
19:41:14 <SpamapS> It's _OCTOBER_
19:41:21 <SpamapS> the summit is in _1 month_
19:41:55 <SpamapS> I would like to impress upon everyone that the summit is where we resolve things we couldn't resolve via normal communication methods.
19:42:22 <SpamapS> We should have no surprises in what is brought up at the summit. We should already have been talking about these things in IRC, here at the meeting, and on openstack-dev.
19:42:56 <bnemec> Spoilers!
19:43:02 <gfidente> SpamapS, so one thing I wanted to ask actually is
19:43:06 <SpamapS> Submit your specs early if you like. Let us get to a point where we just get into the room to hash out details and resolve hard to communicate points at the summit.
19:43:21 <SpamapS> bnemec: the image gets rebuilt in the end.
19:43:23 <gfidente> I read about ansible for cloud updates
19:43:36 <bnemec> Heh
19:43:50 <SpamapS> gfidente: yes I am working on a spec for an ansible-based TripleO cloud right now actually. :-D
19:43:55 <Ng> SpamapS: I kinda think the static UID/GID thing needs a spec and a "omg what?!" discussion at the summit ;)
19:44:05 <gfidente> oh yeah I wanted to ask who was going to discuss that, seems interesting
19:44:08 <Ng> (note, I'm not volunteering you to write a spec)
19:44:42 <SpamapS> Ng: I hope we will have patches landed by then.
19:44:53 <SpamapS> But a spec might be in order nonetheless.
19:45:07 <SpamapS> 4 bullet points a spec make.
19:45:42 <tchaypo> I think a spec is certainly in order.
19:45:51 <gfidente> so one more topic I wanted to bring up, just to ping people, not sure if this is right place to discuss
19:45:56 <Ng> I'd also like some fedora folk to weigh in on at least the mailing list thread about it, in case we ubuntunites are missing some crucial twist in the land of rouge headwear
19:46:59 <tchaypo> I'd like to see details of how any defaults can be overridden, or oids could be pre-assigned by an operator
19:47:41 <SpamapS> gfidente: if it is not about specs in general, we'll do open discussion next. :)
19:48:02 * bnemec will try to catch up on the uid discussion today
19:48:07 <gfidente> SpamapS, yeah open discussion probably more appropriate
19:48:56 <SpamapS> #info Specs are forthcoming for UID+GID preservation and Ansible integration
19:49:00 <SpamapS> #topic Open Discussion
19:49:55 <bnemec> QuintupleO update coming soon.
19:49:57 <slagle> i know there are some folks ramping up on tripleo-puppet-elements as well
19:50:06 <bnemec> I have a blog post in the works.
19:50:06 <slagle> but i'm unaware of the details
19:54:29 <SpamapS> bnemec: nice
19:54:50 <SpamapS> slagle: we may need to reach out and make sure they have time allotted here at the meeting if they want it. :)
19:55:04 <tchaypo> I believe that tripleo-puppet-elements is now somewhat under the tripleo umbrella
19:55:08 <SpamapS> Also I wouldn't mind having a quick Kolla update each time, even though they have their own meeting.
19:55:18 <SpamapS> Oh
19:55:19 <tchaypo> in the sense that we'll see reviews in the IRC room at least
19:55:24 <SpamapS> So the alt meeting time is _REALLY_ bad for me.
19:55:42 <tchaypo> does that mean that contributors to tripleo-puppet-elements get to vote in the next PTL election?
19:55:51 <SpamapS> Can we just agree to have a rotating meeting moderator for that time slot?
19:56:08 <SpamapS> tchaypo: it should. If it does not, we should change that.
19:56:22 <slagle> tchaypo: i think so, since it's under openstack/ now
19:56:27 <bnemec> I thought tchaypo and shadower were generally running the alt meetings.
19:56:29 <tchaypo> That's been happening in practice - I've been doing most of them until it switched to europe
19:56:36 <SpamapS> #action SpamapS to make sure tripleo-puppet-elements and kolla contributors get TripleO ATC status.
19:56:45 <tchaypo> by coincidence I haven't been available to run either meeting since then, so shadower and/or marios have run it
19:56:47 <shadower> mostly tchaypo but I'm happy to help out
19:56:48 <SpamapS> tchaypo: cool
19:57:08 <tchaypo> I'm happy to keep running with that'
19:57:08 * shadower has actually ran it only once
19:57:20 <shadower> but I'll do more if need be
19:57:25 <tchaypo> shadower: when DST changes for you guys, perhaps we can/should re-evaluate the time?
19:57:43 <SpamapS> ok just making sure that is handled.
19:58:08 <tchaypo> this meeting is now at 6am for me, which is manageable; the alternate meeting is now 7pm, which is getting into food time
19:58:51 <SpamapS> Regarding Ansible for updating cloud: stackforge/tripleo-ansible is there.. but it is pretty out of date as we've been forced to move forward downstream. We do intend to reverse flow and start merging patches in the stackforge repo first as soon as we actually use it for real things.
19:59:40 <SpamapS> with 60s left, I think I will bid you all a broad "Thank you for your votes" and also thank you to slagle for providing everyone with a choice.
20:00:10 <SpamapS> #endmeeting