08:04:09 <tchaypo> #startmeeting tripleo
08:04:10 <openstack> Meeting started Wed Nov 26 08:04:09 2014 UTC and is due to finish in 60 minutes.  The chair is tchaypo. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:04:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:04:13 <openstack> The meeting name has been set to 'tripleo'
08:04:17 * marios_ dejavu
08:04:41 <tchaypo> Did someone do that earlier and I didn’t notice?
08:04:44 <tchaypo> I’m very confuse
08:04:58 <GheRivero> let me check the logs..
08:05:08 <gfidente> tchaypo, I joined at .55 and topic was already set to it
08:05:26 <marios_> 06:19 < jiangfei> #startmeeting tripleo
08:05:33 <GheRivero> someone two hours ago started the meeting
08:05:36 <marios_> jiangfei had a tripleo meeting couple hours ago
08:05:42 <tchaypo> I noticed this morning that https://wiki.openstack.org/wiki/Meetings said the meeting started at 0700UTC
08:05:44 <d0ugal> lol
08:05:47 <tchaypo> while the ical said 0800 UTC
08:05:51 <StevenK> And he didn't even invite us
08:05:54 <tchaypo> so I was going to raise that as the first issue in the meeting
08:06:17 <StevenK> It's now 7pm, I'd prefer the meeting be two hours earlier
08:06:19 <tchaypo> I’ve fixed the wiki to match the iCal which matches https://wiki.openstack.org/wiki/Meetings/TripleO which matches the email sent in september
08:06:27 <gfidente> yeah I think we should strip the part where it says: 'Next meeting scheduled for' from wiki as that is never accurate
08:06:46 <tchaypo> stevenk: it’s now 9am CET, 8AM GMT
08:06:47 <marios_> StevenK: 2 hrs is a bit harsh for EU though, would make it 0700 for them
08:06:58 <marios_> StevenK: which is kinda the point of having this meeting (eu friendly)
08:07:03 <d0ugal> marios_: or 0600 for the UK
08:07:13 <marios_> d0ugal: right, thx
08:07:18 <tchaypo> that said - I think we used to have better attendance when this meeting was an hour earlier
08:07:39 <StevenK> Just makes it difficult to organise anything on Wednesday night every fortnight
08:07:56 <StevenK> Since I'm effectively blocked from 7pm until 8pm
08:07:56 <gfidente> well if I can spare mine, 9am is not good even though it is supposedly to help people in EU
08:07:58 <d0ugal> StevenK: That's the issue we have on Tuesday nights :)
08:08:11 <tchaypo> StevenK: so don’t, attend the other meeting instead
08:08:22 <gfidente> and the alternating schedule always makes me miss some meetings
08:08:25 <marios_> StevenK: heh yeah, my tripleo alternate is at 2100 and neutron is at 2300 :/
08:08:36 <gfidente> if we were to vote again, I'd drop the alternating schedule
08:08:44 <tchaypo> How about we kick this off on the list again?
08:08:50 <d0ugal> =1
08:08:51 <d0ugal> +1
08:08:55 <tchaypo> or even perhaps
08:08:56 <marios_> +=1
08:09:03 <tchaypo> revisit what the meeting is for?
08:09:04 <shardy> fwiw we've been through this multiple times with heat, and it's impossible to please everyone
08:09:24 <shardy> at least with an alternating schedule you're not permanently excluding some tz's
08:09:26 <StevenK> Indeed
08:09:31 <StevenK> We cover most of the world
08:09:35 <shardy> My .02 GPB FWIW ;)
08:09:37 <tchaypo> a lot of what we do seem to be simple status updates - perhaps we could just delegate one person to give a weekly report to the list, and save the meeting for something more focused like hitting the top priority reviews?
08:09:48 <StevenK> tchaypo: +2 +A
08:09:53 <GheRivero> +1
08:09:58 <greghaynes> Maybe even make a doodle :)
08:10:12 <gfidente> I had some one-off topic though
08:10:16 <StevenK> tchaypo: Bring that up on the list too, it could also make meetings quicker
08:10:17 <tchaypo> at my second-last job we solved this problem by splitting the team in 13 pieces, each separated by no more than ~10 hours, so that it was possible for each team to find one single weekly meeting time
08:10:17 <gfidente> at least today
08:10:26 <tchaypo> unfortunately that doesn’t work for this kind of team :)
08:10:33 <tchaypo> okay
08:10:43 <tchaypo> #action tchaypo to raise meeting time and purpose on list
08:10:51 <tchaypo> now let’s get started
08:10:59 <d0ugal> \o/
08:11:12 <tchaypo> #topic agenda
08:11:12 <tchaypo> * bugs
08:11:12 <tchaypo> * reviews
08:11:12 <tchaypo> * Projects needing releases
08:11:12 <tchaypo> * CD Cloud status
08:11:12 <tchaypo> * CI
08:11:12 <tchaypo> * Tuskar
08:11:13 <tchaypo> * Specs
08:11:13 <tchaypo> * open discussion
08:11:14 <tchaypo> Remember that anyone can use the link and info commands, not just the moderator - if you have something worth noting in the meeting minutes feel free to tag it
08:11:14 <tchaypo> #topic bugs
08:11:26 <tchaypo> I’ve noticed the untriaged bot has been very noisy lately
08:11:43 <tchaypo> I think it would be valuable if we could tidy that up right now
08:11:52 <marios_> tchaypo: apologies I will hopefully have more time to look at +bug/1188067 later today
08:13:22 <tchaypo> I was about to say something similar - I think the dnsmasq issue i saw in hp2 may have been me manually misconfiguring something. If so I think we can drop that back to high
08:13:48 <marios_> tchaypo: (sure, i meant more generally think about it and then we can discuss, perhaps we need a spec(s))
08:14:06 <tchaypo> +bug/1374626 - changing uids - owned by spamaps -
08:15:06 <GheRivero> we never discuss that in the summit. It's a hard topic
08:15:56 <tchaypo> Yeah. I’ll ping spamaps and ask for an update on the bug
08:16:13 <greghaynes> We had a good ml discussion about that a while back, im not sure if any progress was made on implementing it
08:16:47 <greghaynes> but yes, clint or ng would probably know that
08:16:53 <tchaypo> https://review.openstack.org/136894 just landed which should close off https://bugs.launchpad.net/tripleo/+bug/1394956
08:16:57 <uvirtbot> Launchpad bug 1394956 in tripleo "ConfigFileValueError: IP address cannot be an empty string" [Critical,Fix committed]
08:17:17 <StevenK> \o/
08:18:23 <tchaypo> Switching tracks slightly - I’m looking at the list of things the bot is complaining about
08:18:24 <tchaypo> https://bugs.launchpad.net/tripleo/+bug/1391218
08:18:26 <uvirtbot> Launchpad bug 1391218 in tripleo "Configuration Dependent on HAProxy" [High,In progress]
08:18:37 <tchaypo> had no importance, so I’ve set it to high
08:19:15 <greghaynes> hrm, I dont think thats a high, I think thats just an issue where were bad at naming things
08:19:15 <StevenK> Yes, triage involves *both* Importance and Status
08:19:50 <StevenK> greghaynes: Then fix it, dear Henry?
08:19:50 * greghaynes will comment on bug
08:20:52 <tchaypo> https://bugs.launchpad.net/tripleo/+bug/1387061 is unassigned and has no priority
08:20:53 <uvirtbot> Launchpad bug 1387061 in tripleo "deploy under cloud failure due to pacemaker " [Undecided,New]
08:22:07 <tchaypo> I’m not sure what to do with that.
08:22:12 <tchaypo> any suggestions?
08:22:41 <GheRivero> I can take a look to it after the meeting
08:23:29 <tchaypo> thanks ghe
08:23:40 <tchaypo> https://bugs.launchpad.net/tripleo/+bug/1393643 had an assignee but no priority, I’ve set it to high
08:23:41 <uvirtbot> Launchpad bug 1393643 in tripleo "haproxy start failed loop with 'Starting proxy horizon: cannot bind socket'" [High,New]
08:24:50 <StevenK> tchaypo: You need to move it from New as well
08:24:52 <tchaypo> same with https://bugs.launchpad.net/tripleo/+bug/1391412 - i wish jiangfei was still around, because i think i hit the same issue myself this morning. I’ll follow up on that
08:24:53 <uvirtbot> Launchpad bug 1391412 in tripleo "devtest  deploy overcloud successfully,but there have one baremetal in  Maintenance state" [Undecided,New]
08:25:14 <StevenK> If they stay New, the untriaged bot will keep bringing it up
08:25:37 <tchaypo> thanks StevenK
08:26:28 <tchaypo> https://bugs.launchpad.net/tripleo/+bug/1387487 seems to be tuskar, so I’m changing the component
08:26:30 <uvirtbot> Launchpad bug 1387487 in tripleo "tripleo-image-elements/elements/tuskar-ui /os-refresh-config /post-configure.d/101-tuskar-ui  needs authentication from Keystone" [Undecided,New]
08:27:05 <StevenK> tchaypo: But it talks about t-i-e?
08:28:12 <tchaypo> *hand-waggle* I dunno. I’m open to other suggestions.
08:28:53 <tchaypo> d0ugal: any comments?
08:29:42 <d0ugal> tchaypo: hmm, I can take a look into it
08:29:59 <StevenK> So, the metting is half over, can haz moving on?
08:30:11 <marios_> d0ugal: yeah so i think this isn't a tuskar one
08:30:18 <marios_> StevenK: err sorry i meant tchaypo ^^
08:30:26 <StevenK> Hah
08:30:29 <marios_> lol
08:30:33 * marios_ puts keyboard down, enough
08:30:55 <d0ugal> lol
08:31:03 <marios_> tchaypo: i mean sounds like this could be about the tuskar-ui element
08:31:12 <d0ugal> marios_: Yeah, that's what I thought
08:32:11 <tchaypo> https://bugs.launchpad.net/tripleo/+bug/1393304 - I’ve given it an assignee and a priority
08:32:12 <uvirtbot> Launchpad bug 1393304 in tripleo "create-nodes failure for customised pool" [High,Confirmed]
08:32:33 <marios_> tchaypo: will try and circle back to +bug/1387487 later this week
08:32:45 <StevenK> tchaypo: Looks good, re that bug
08:32:45 <tchaypo> yes, let’s move on. Do we have any other criticals that need to be discussed?
08:33:33 <tchaypo> #info There's a new dashboard linked from https://wiki.openstack.org/wiki/TripleO#Review_team - look for "TripleO Inbox Dashboard"
08:33:33 <tchaypo> #link http://russellbryant.net/openstack-stats/tripleo-openreviews.html
08:33:33 <tchaypo> #link http://russellbryant.net/openstack-stats/tripleo-reviewers-30.txt
08:33:33 <tchaypo> #link http://russellbryant.net/openstack-stats/tripleo-reviewers-90.txt
08:33:48 <tchaypo> Stats since the last revision without -1 or -2 :
08:33:48 <tchaypo> Average wait time: 6 days, 15 hours, 58 minutes
08:33:48 <tchaypo> 1st quartile wait time: 0 days, 19 hours, 58 minutes
08:33:48 <tchaypo> Median wait time: 4 days, 20 hours, 39 minutes
08:33:48 <tchaypo> 3rd quartile wait time: 7 days, 6 hours, 53 minutes
08:34:10 <tchaypo> which is great.
08:34:11 <tchaypo> Queue growth in the last 30 days: 49 (1.6/day)
08:34:14 <tchaypo> not so great.
08:35:01 <tchaypo> As per discussion at mid-cycle, we’re planning to find 5 reviews that need help and assign them to people for action, whether that’s shepherding them to completion or marking them as abandoned.
08:35:08 <StevenK> tchaypo: Change the meeting topic?
08:35:15 <StevenK> Since it's still bugs, but you've moved on
08:36:44 <tchaypo> #topic reviews
08:36:52 <tchaypo> whee.
08:37:12 <tchaypo> I can’t find the link we used two weeks ago to find reviews to assign, and it seems like last week they brushed past it
08:37:48 <StevenK> hashaction tchaypo to bookmark a link on the wiki ... ?
08:38:37 <tchaypo> #action tchaypo to follow up  to list about finding old reviews
08:38:52 <tchaypo> I think we used the “based on latest revision” on http://russellbryant.net/openstack-stats/tripleo-openreviews.html
08:39:51 <tchaypo> 19 days, 14 hours, 43 minutes https://review.openstack.org/133094 (Specify a signal transport for the SwiftStorageDeployment)
08:39:51 <tchaypo> 15 days, 21 hours, 6 minutes https://review.openstack.org/133435 (Don't replace OS::Neutron::Port on update of undercloud)
08:39:51 <tchaypo> 15 days, 18 hours, 43 minutes https://review.openstack.org/118220 (Added a MySQL logrotate configuration)
08:39:51 <tchaypo> 14 days, 14 hours, 56 minutes https://review.openstack.org/133755 (Tuskar role components spec)
08:39:51 <tchaypo> 13 days, 14 hours, 53 minutes https://review.openstack.org/133554 (Add Overview subsection to Proposed Change section)
08:40:04 <tchaypo> Could we get some volunteers to push those along?
08:40:21 <marios_> tchaypo: just landed the #/c/133435/
08:41:26 <tchaypo> woo
08:41:34 <StevenK> tchaypo: /133094 has been rechecked
08:42:01 <marios_> re the logrotate one, alexis comments are outstanding (graham are those suggestions required?)
08:42:07 <marios_> #/c/118220/
08:42:29 <tchaypo> Given the time I think we need to move on
08:42:33 <tchaypo> #topic Projects needing releases
08:42:35 <tchaypo> volunteer?
08:42:49 <marios_> o/ i can do it, though i'd prefer someone new to learn
08:42:54 <marios_> (and I can help them)
08:43:36 <tchaypo> i believe StevenK has been wanting to do it for a while, but would need to be given permissions so he can do it
08:43:54 <marios_> i can give perms if he wanted to do so this week
08:44:31 <StevenK> Sure, why not
08:44:51 <greghaynes> its super easy, you can also ping me if you need info on how
08:44:56 <tchaypo> #topic CD Cloud status
08:45:08 <StevenK> I can look at it tomorrow if marios_ grants access tonight
08:45:11 <marios_> StevenK: exactly what greghaynes said, you will wonder what the issue was about
08:45:16 <marios_> StevenK: feel free to ping
08:45:31 <tchaypo> hp2 is an ongoing hamster wheel, every time I work around one bug I find another.
08:46:14 <StevenK> I'm not sure if hp1 is being used yet
08:47:13 <tchaypo> This is an example of something where I feel like a weekly update email would give us more value - there’s really nothing to discuss in the meeting
08:47:25 <tchaypo> Same for CI, so I’m going to jump to
08:47:28 <tchaypo> #topic Tuskar
08:48:04 <tchaypo> marios_: I here tripleo people have been shoving bugs that have nothing to do with you over the fence and trying to make them your problem. how do you feel about that?
08:48:25 <marios_> tchaypo: sorry was distracted momentarily, reads back
08:48:41 <marios_> tchaypo: heh, what do you mean?
08:49:06 <marios_> oh you mean with the tie one :)
08:49:12 <tchaypo> yes :)
08:49:23 <marios_> i've only had 3 shots of espresso so forgive me
08:50:14 <marios_> StevenK: you should now have the necessary perms for release
08:50:24 <StevenK> \o/
08:50:30 * marios_ imagines what he would look like with a perm
08:50:57 <tchaypo> Any other tuskar news? :p
08:51:00 <StevenK> marios_: The 80's are calling
08:51:49 <shardy> tuskar-api support is coming to devstack https://review.openstack.org/#/c/131218/
08:52:04 <shardy> If anyone's interested in hacking on it via devstack ;)
08:52:14 <tchaypo> Huzzah!
08:52:14 <marios_> shardy: that's excellent
08:52:36 <d0ugal> Awesome
08:52:38 <tchaypo> Sorry to rush things along, but I know gfidente has a one-off item and we’re running out of time
08:52:41 <shardy> personally I found it more convenient for quick tests and hacking vs devtest
08:52:58 <StevenK> But devtest is fast
08:53:01 <gfidente> not a very long one though, no worries
08:53:04 <tchaypo> #topic specs
08:53:07 <tchaypo> Anything?
08:53:10 <StevenK> Mind you, I have eight cores and 24GiB of RAM
08:53:14 <gfidente> yes on specs
08:53:37 <gfidente> the cinder/ha stuff, I started pushing some template/tie changes
08:53:47 <gfidente> I updated the spec too after summit but isn't approved yet,
08:54:10 <gfidente> so please leave there your comments or upvote it
08:54:26 <gfidente> (the spec)
08:54:39 <gfidente> https://review.openstack.org/101237
08:54:40 <tchaypo> link?
08:54:43 <tchaypo> thanks
08:54:49 <StevenK> #link https://review.openstack.org/101237
08:54:56 <StevenK> ... I think?
08:55:03 <tchaypo> #info  https://review.openstack.org/101237 (spec for cinder/ha stuff) desperately needs reviews
08:55:28 <tchaypo> #topic open discussion
08:56:05 <gfidente> the one-off topic I had is, again cinder/ha, but this time I'm talking about my actual code submissions
08:56:44 <gfidente> do we want cinder/ceph be the default for controlscale>1 ? to test it in CI ? with an isolated ceph-osd node or with ceph-osd running on controllers too ?
08:57:13 <StevenK> I think that should be on the list for a wider audience
08:57:15 <gfidente> better to send email to the list maybe ?
08:57:24 <gfidente> okay :)
08:58:12 <gfidente> so for people interested, you could track progress here https://blueprints.launchpad.net/tripleo/+spec/tripleo-kilo-cinder-ha
09:00:47 <StevenK> Hmm, where has tchaypo gone
09:01:11 <tchaypo> #endmeeting