19:01:02 <slagle> #startmeeting tripleo
19:01:03 <openstack> Meeting started Tue Feb 24 19:01:02 2015 UTC and is due to finish in 60 minutes.  The chair is slagle. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:07 <openstack> The meeting name has been set to 'tripleo'
19:01:50 <slagle> #link https://wiki.openstack.org/wiki/Meetings/TripleO looks a little stale
19:02:30 <slagle> i'll have a go at updating it
19:02:45 <slagle> #topic agenda
19:02:55 <slagle> * bugs
19:02:56 <slagle> * reviews
19:02:56 <slagle> * Projects needing releases
19:02:56 <slagle> * CD Cloud status
19:02:56 <slagle> * CI
19:02:58 <slagle> * Specs
19:03:00 <slagle> * open discussion
19:03:30 <slagle> when i update the meeting page, i anticipate removing CD Cloud and Specs as standing agenda items if there's no objection to that
19:03:40 <bnemec> \o
19:03:42 <SpamapS> and specs?
19:04:02 <slagle> SpamapS: i'm kinda feeling like it falls under open discussion
19:04:09 <slagle> but, meh
19:04:26 <bnemec> Or reviews
19:04:30 <slagle> I had *thought* we added that when we wanted to talk about spec process
19:04:44 <SpamapS> Yeah, it doesn't ever get any discussion either
19:04:44 <SpamapS> so yeah
19:05:32 <slagle> #topic bugs
19:05:47 <slagle> #link https://bugs.launchpad.net/tripleo/
19:05:47 <slagle> #link https://bugs.launchpad.net/diskimage-builder/
19:05:47 <slagle> #link https://bugs.launchpad.net/os-refresh-config
19:05:47 <slagle> #link https://bugs.launchpad.net/os-apply-config
19:05:47 <slagle> #link https://bugs.launchpad.net/os-collect-config
19:05:49 <slagle> #link https://bugs.launchpad.net/os-cloud-config
19:05:52 <slagle> #link https://bugs.launchpad.net/os-net-config
19:05:54 <slagle> #link https://bugs.launchpad.net/tuskar
19:05:57 <slagle> #link https://bugs.launchpad.net/python-tuskarclient
19:06:21 <slagle> i should have looked at the bug list before volunteering for this
19:06:30 <slagle> i'm seeing a lot of red
19:06:31 <bnemec> heh
19:06:38 <lsmola2> hehe
19:06:47 <SpamapS> hahaha
19:06:57 * SpamapS whistles and strolls
19:07:04 <jdob> meanwhile, dprince is sitting there smiling at his screen
19:07:41 <slagle> so everything is triaged
19:07:48 <SpamapS> I'm dropping https://bugs.launchpad.net/tripleo/+bug/1374626 to High
19:07:49 <openstack> Launchpad bug 1374626 in tripleo "UIDs of data-owning users might change between deployed images" [High,Triaged]
19:07:51 <slagle> and i suspect some of those are even in progress
19:07:54 <SpamapS> nobody seems to care about image updates
19:07:59 <SpamapS> and I'm also unassigning myself
19:08:08 <slagle> ok
19:09:05 <SpamapS> This one _does_ need work https://bugs.launchpad.net/tripleo/+bug/1401617
19:09:05 <openstack> Launchpad bug 1401617 in tripleo "Flavor based ramdisk/kernel ID is deprecated in Ironic since Juno" [Critical,In progress] - Assigned to Clint Byrum (clint-fewbar)
19:09:12 <SpamapS> I may still find time to work on it soon.
19:10:48 <slagle> SpamapS: k, thanks. i can pick that up or maybe convince someone else too if you need to drop it
19:11:01 * slagle eyes bnemec
19:11:04 <SpamapS> slagle: we'll see, I think it's 90% done anyway
19:11:09 <slagle> k
19:11:20 <bnemec> slagle: If I touch it, it will break.
19:11:20 <slagle> this has no assignee: https://bugs.launchpad.net/tripleo/+bug/1401300
19:11:21 <openstack> Launchpad bug 1401300 in tripleo "Keystone Private Key not securely sent to host" [Critical,Confirmed]
19:11:24 <bnemec> Guaranteed. :-P
19:12:58 <bnemec> slagle: It seems like there's some debate over the actual severity of that one.
19:13:15 <slagle> bnemec: yea, i see that. i'm not opposed to dropping it to high
19:13:26 <slagle> https://bugs.launchpad.net/tripleo/+bug/1411809 is already in a release it looks like
19:13:27 <openstack> Launchpad bug 1411809 in tripleo "Ironic fails to start: Unable to import proliantutils library." [Critical,Fix committed] - Assigned to Dan Prince (dan-prince)
19:14:01 <greghaynes> so, it was suggested that private key one get deescelated to medium
19:15:30 <greghaynes> oh, looks like that got codified in the ticket
19:15:50 <slagle> bnemec: can you assign https://bugs.launchpad.net/tripleo/+bug/1421835 to yourself? given derek is day to day
19:15:51 <openstack> Launchpad bug 1421835 in neutron "Timeout reached while waiting for callback for node" [Undecided,In progress]
19:15:52 <greghaynes> er, right, high instead of critical. Im kind of +1 on that at this point actually
19:16:05 <slagle> greghaynes: cool, let's make it high
19:16:20 <bnemec> slagle: Yeah
19:16:22 * SpamapS will make sure to remember that the best time to sniff on a tripleo network is in the early days when no security measures have been setup and PXE is flying around everywhere. ;)
19:17:27 <slagle> looks like the fix for https://bugs.launchpad.net/tripleo/+bug/1423228 is in flight
19:17:29 <openstack> Launchpad bug 1423228 in tripleo "L3 agent for nova compute could not be found" [Critical,Triaged] - Assigned to Derek Higgins (derekh)
19:18:23 <dprince> slagle: yes, 1411809 was fixed several weeks back
19:18:33 <slagle> jdob: hi! i see a comment from you on https://bugs.launchpad.net/tripleo/+bug/1425238
19:18:34 <openstack> Launchpad bug 1425238 in tripleo "Heat: Failed to validate parameter errors" [Critical,Triaged]
19:18:44 <slagle> jdob: can you or dan assign that one?
19:19:12 <dprince> slagle: yes, still trying to confirm when exactly it started breaking. I suspect a heat commit or something
19:19:14 <slagle> note for folks going forward, don't comment on bugs if you don't want to end up the assignee
19:19:19 <slagle> j/k
19:19:35 <jdob> haha
19:19:50 <jdob> it's blocking me too, so i'm willing to help out with whatever dprince needs
19:20:07 <bnemec> It's the internet version of "don't make eye contact" ;-)
19:20:17 <slagle> there are 3 untriaged bugs for os-cloud-config
19:20:24 <slagle> anyone want to triage those?
19:20:37 <slagle> 1 in os-collect-config
19:20:57 <slagle> 1 in tuskar
19:21:06 <jdob> i'll look at the tuskar one
19:21:10 <slagle> thx
19:21:43 <slagle> #action slagle to triage os-cloud-config and os-collect-config bugs
19:21:52 <slagle> #action jdob to triage tuskar bugs
19:22:17 <slagle> i think that's it for bugs
19:22:27 <slagle> anything else to draw attention to here?
19:22:44 <slagle> #topic reviews
19:23:13 <slagle> #info There's a dashboard linked from https://wiki.openstack.org/wiki/TripleO#Review_team - look for "TripleO Inbox Dashboard"
19:23:16 <slagle> #link http://russellbryant.net/openstack-stats/tripleo-openreviews.html
19:23:19 <slagle> #link http://russellbryant.net/openstack-stats/tripleo-reviewers-30.txt
19:23:22 <slagle> #link http://russellbryant.net/openstack-stats/tripleo-reviewers-90.txt
19:23:54 <slagle> i'm not sure what to say
19:24:08 <slagle> our wait times look kind of bad
19:24:31 <SpamapS> I've been a little distracted from everything.. reviews is an equal opportunity loss in that.
19:24:45 <slagle> are there any reviews people would like some attention on?
19:26:27 <slagle> well; ok. keep reviewing everyone.
19:26:51 <slagle> if you struggle to wonder how to prioritize reviews use the tripleo dashboard
19:27:00 <slagle> or ask in #tripleo
19:27:09 <slagle> #topic Projects needing releases
19:27:37 <slagle> looks like it's been 2 weeks from some projects since releases
19:28:02 <slagle> any volunteers to do releases?
19:28:41 <slagle> #action slagle to do releases
19:29:06 <slagle> #topic CI
19:29:37 <dprince> we are having stability issues, finding good real upstream breakages though
19:29:48 <slagle> #link http://goodsquishy.com/downloads/tripleo-jobs.html
19:29:57 <slagle> what's up with the overcloud-f20-nonha job?
19:30:03 <slagle> has anyone started looking into that?
19:30:17 <dprince> slagle: I think it is this https://bugs.launchpad.net/tripleo/+bug/1425238
19:30:19 <openstack> Launchpad bug 1425238 in tripleo "Heat: Failed to validate parameter errors" [Critical,Triaged]
19:30:26 <slagle> k, i figured so
19:30:35 <dprince> slagle: I haven't found a smoking gun yet
19:30:51 <dprince> slagle: but nothing has changed in our templates to cause it so I expect a heat regression
19:31:23 <slagle> maybe we should point shardy_afk at it so he can pick it up when he's back
19:31:34 <slagle> maybe i just did :)
19:31:46 <dprince> yeah, I mentioned it to him on IRC as well
19:31:50 <slagle> ok, cool
19:31:57 <jdob> slagle: I looked away during the release section, but ping me if you want me to handle them instead
19:32:01 <dprince> slagle: actually going to test a revert of his commit, so we'll see how this goes
19:32:07 <slagle> jdob: ack, thx
19:32:44 <slagle> sounds like CI is up to its usual shenanigans then :)
19:32:47 <slagle> anything else to report?
19:33:29 <jdob> not sure if you want to record the neutron bug too
19:34:01 * tchaypo is distracted this week but plans to poke at CI on the weekend, if it's not fixed by then
19:34:10 <slagle> yea there's actually 2
19:34:30 <slagle> we have both reverted i believe
19:34:41 <jdob> two neutron bugs?
19:34:51 <slagle> #link https://bugs.launchpad.net/tripleo/+bug/1421835
19:34:51 <openstack> Launchpad bug 1421835 in neutron "Timeout reached while waiting for callback for node" [Undecided,In progress]
19:34:56 <jdob> good to know, I only knew of the callback one
19:34:59 <slagle> #link https://bugs.launchpad.net/tripleo/+bug/1423228
19:35:00 <openstack> Launchpad bug 1423228 in tripleo "L3 agent for nova compute could not be found" [Critical,Triaged] - Assigned to Derek Higgins (derekh)
19:35:18 <slagle> the latter only affects the overcloud
19:35:44 <slagle> #topic Specs
19:37:37 * slagle was just looking at tripleo-specs to understand the state of the world
19:37:49 <slagle> we have 8 specs
19:37:54 <slagle> 5 are either -2'd or WIP'd
19:38:27 <slagle> the other 3 are:
19:38:34 <slagle> #link https://review.openstack.org/#/c/108168/ (SELinux)
19:38:50 <slagle> #link https://review.openstack.org/#/c/133755/ (Tuskar role components)
19:38:58 <slagle> jdob: are you still driving that ^
19:39:10 <jdob> its not needed in the immediate future
19:39:13 <slagle> #link https://review.openstack.org/#/c/97939/ (Remove merge.py)
19:39:19 <jdob> been meaning to go back and, at least, move it out of kilo
19:39:26 <slagle> jdob: can you WIP it or something?
19:39:27 <jdob> maybe make an unaligned folder or something
19:39:29 <jdob> ya, WIP works
19:39:31 <slagle> k
19:39:37 <slagle> i'd like to see the merge.py one land
19:39:58 <slagle> let's try to get that reviewed
19:40:26 <slagle> it probably needs some updates, especially since it's aligned against juno
19:40:35 <jdob> there needs to be a mercy rule for specs that havent landed within 6 months of the code landing :)
19:41:16 <slagle> shadower: if you see this, and you have some cycles, would you be able to update https://review.openstack.org/#/c/97939/ ?
19:41:27 <jdob> he's on PTO this week, I'll ask him about it next week
19:41:33 <slagle> ah, k
19:41:33 <slagle> thx
19:41:50 <jdob> i'll add a card for next sprint actually
19:42:23 <slagle> any other spec business?
19:42:33 <slagle> #topic open discussion
19:43:16 <slagle> thanks to HP for hosting the midcycle last week
19:43:24 <slagle> i sent a summary to the list
19:43:30 <slagle> #link http://lists.openstack.org/pipermail/openstack-dev/2015-February/057656.html
19:43:51 <slagle> if i can expand on anything, let me know
19:43:56 <tchaypo> Thanks for the summary
19:44:09 <slagle> bnemec was already nice enough to remind me that my memory is apparently only 6 months
19:45:16 <slagle> tchaypo: while you're here....have you (and are you) going to be running the alternate meeting time slot?
19:45:31 <jdob> +1 to sending that out
19:45:43 <tchaypo> Will be easier once I get back to aus
19:45:47 <tchaypo> I've, next week
19:46:16 <tchaypo> But it's still not great for me - it has shifted toward being EU friendly rather than AU friendly
19:46:40 <SpamapS> slagle: thanks for coming out to Seattle
19:46:56 <SpamapS> slagle: and taking over the mantle. It is not a happy thing to have to step down, but I am happy that it's still in good hands.
19:47:02 <tchaypo> I think it makes more sense to look for someone in EU, or maybe reconsidering the need for the alternate meeting
19:47:03 <slagle> tchaypo: ok. don't kill yourself if you can't run it, i'm hoping someone else will step up and do it
19:47:03 <jdob> slagle: i think i have someone who can run that, i just dont want to speak for him and he's gone for the day
19:47:12 <jdob> i'll ping him tomorrow and let you know
19:47:20 <slagle> alright thanks
19:47:53 <slagle> SpamapS: thanks :).
19:48:37 <slagle> any other business?
19:49:12 <slagle> cheers! i'm going back to shoveling snow
19:49:15 <slagle> #endmeeting