19:00:37 <slagle> #startmeeting tripleo
19:00:39 <openstack> Meeting started Tue Mar 10 19:00:37 2015 UTC and is due to finish in 60 minutes.  The chair is slagle. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:43 <openstack> The meeting name has been set to 'tripleo'
19:00:51 <slagle> hi folks
19:01:30 <lifeless> o/
19:01:46 <jdob> o/
19:02:03 * jdob is entirely too proud of himself for not messing up with the DST change
19:02:03 <dprince> hello
19:02:30 <slagle> this would be the first time i've made a tripleo meeting the first time after DST
19:02:55 <slagle> i won't lie about how long i spent double checking and confirming what time it would actually be at
19:03:25 <SpamapS> o/
19:03:35 <slagle> #topic agenda
19:03:35 <slagle> * bugs
19:03:35 <slagle> * reviews
19:03:35 <slagle> * Projects needing releases
19:03:35 <slagle> * CI
19:03:37 <slagle> * Specs
19:03:40 <slagle> * open discussion
19:04:08 <slagle> the astute among you will notice i've removed the CD cloud from the agenda items
19:04:33 <slagle> #topic bugs
19:04:42 <slagle> #link https://bugs.launchpad.net/tripleo/
19:04:42 <slagle> #link https://bugs.launchpad.net/diskimage-builder/
19:04:42 <slagle> #link https://bugs.launchpad.net/os-refresh-config
19:04:42 <slagle> #link https://bugs.launchpad.net/os-apply-config
19:04:42 <slagle> #link https://bugs.launchpad.net/os-collect-config
19:04:44 <slagle> #link https://bugs.launchpad.net/os-cloud-config
19:04:47 <slagle> #link https://bugs.launchpad.net/os-net-config
19:04:49 <slagle> #link https://bugs.launchpad.net/tuskar
19:04:52 <slagle> #link https://bugs.launchpad.net/python-tuskarclient
19:05:34 <slagle> jdob: wasn't someone working on this for tuskar? https://bugs.launchpad.net/tripleo/+bug/1401617
19:05:34 <openstack> Launchpad bug 1401617 in tripleo "Flavor based ramdisk/kernel ID is deprecated in Ironic since Juno" [Critical,In progress] - Assigned to Clint Byrum (clint-fewbar)
19:05:53 <slagle> i thought i saw some commits from someone
19:06:19 * jdob looking
19:06:35 <slagle> ah yea, this: https://review.openstack.org/#/c/160528/
19:06:49 <jdob> ya, that's UI's jurisdiction
19:07:00 <jdob> not trying to blow you off, just that it's not something I've looked at
19:07:16 <slagle> yea, too bad the UI doesn't use os-cloud-config
19:08:22 <slagle> https://bugs.launchpad.net/tripleo/+bug/1421835 is fix committed, the neutron revert landed
19:08:22 <openstack> Launchpad bug 1421835 in tripleo "Timeout reached while waiting for callback for node" [Critical,Fix committed] - Assigned to Ben Nemec (bnemec)
19:08:48 <dprince> slagle: we need to remove the cherrypick fix though
19:09:17 <dprince> slagle: https://review.openstack.org/#/c/162212/
19:10:26 <slagle> ok, i added a comment in the bug that's it pending that
19:11:29 * bnemec thanks openstack for the reminder that he was missing the meeting
19:11:37 <dprince> slagle: oh, I think we can close the bug now. Just would like to get the cherrypick nuked too
19:11:50 <slagle> https://bugs.launchpad.net/tripleo/+bug/1423228 should be fix committed as well?
19:11:50 <openstack> Launchpad bug 1423228 in tripleo "L3 agent for nova compute could not be found" [Critical,Triaged] - Assigned to Derek Higgins (derekh)
19:11:55 <slagle> the fix has merged
19:12:16 <slagle> https://bugs.launchpad.net/tripleo/+bug/1425238 too
19:12:16 <openstack> Launchpad bug 1425238 in tripleo "Heat: Failed to validate parameter errors" [Critical,Triaged]
19:12:39 <slagle> man, great meetnig so far. just closed 3 crits
19:13:20 <jdob> \o/
19:13:37 <slagle> please review: https://review.openstack.org/#/c/161836/
19:13:42 <slagle> it should help with getting f21 going
19:14:16 <slagle> same for https://review.openstack.org/#/c/162442/
19:14:37 <slagle> dprince: while we're on the subject, are there any other f21 related reviews to prioritize?
19:15:00 * dprince looks
19:15:17 <dprince> https://review.openstack.org/#/c/162443/ (kernel-modules) package
19:15:37 <dprince> ^^^ I'm actually not 100% installing it there is the right spot, but it seemed reasonable
19:15:59 <dprince> and this: https://review.openstack.org/#/c/162442/ (tftp fix)
19:16:15 <dprince> These last two cause the most cryptic errors (if you don't have the fixes in place)
19:16:28 <bnemec> Already merged^
19:16:30 <dprince> I filed tickets which describe the issues though so it should be straightforward.
19:16:31 <bnemec> :-)
19:16:32 <slagle> i don't think there is a kernel-modules for f20
19:16:43 <dprince> bnemec: I'm behind man :)
19:16:45 <slagle> so yea, that might not be the right thing
19:17:00 <bnemec> It's all good, yum is stupid and will continue even if it's missing packages.
19:17:01 <dprince> slagle: right, there isn't a kernel-modules for f20... but it doesn't break anything
19:17:10 <slagle> ah, yes
19:17:14 <slagle> relying on yum being stupid
19:17:15 <slagle> wfm
19:17:21 <dprince> slagle: and I think both RHEL and fedora will eventually do this
19:18:13 <slagle> k, i think that's it for bugs
19:18:20 <dprince> anyways, that is all of my F21 concerns for now. proceed
19:18:31 <slagle> there were only a few other untriaged bugs, which i just did
19:18:38 <dprince> FWIW with those fixes and a new qemu patch the CI job would pass I think (with packages)
19:19:02 <slagle> #topic reviews
19:19:13 * bnemec doesn't want to look
19:19:51 <jdob> ya, i already know i'm not keeping up my pace lately
19:20:47 <dprince> so long as you guys review my patches I think we are doing fine
19:20:52 <slagle> haha
19:20:53 <jdob> haha
19:21:06 <jdob> so the take away here is that dprince's patches count 3x towards our minimums
19:21:16 <slagle> well, yea, unfortunately i think we are in a bit of a bad habit of each only reviewing the stuff we immediately care about
19:21:20 <slagle> if i had to guess
19:21:24 * slagle has no evidence
19:21:39 <jdob> guilty
19:21:51 * jdob will make a better effort
19:21:55 <bnemec> I'm just not reviewing anything anymore.
19:22:07 <bnemec> Except during the meeting so it looks like I'm doing something. ;-)
19:22:08 <slagle> bnemec: so you don't care about anything :)
19:22:59 <slagle> anyway, i'll take a closer look at reviews myself this week and see if there's anything that can be prioritized
19:23:34 <slagle> #topic Projects needing releases
19:24:19 <slagle> i think it's been a couple weeks since releases, so it's probably worth taking a look and releasing what's needed
19:24:27 <slagle> i can do it if there are no volunteers
19:24:51 <jdob> i'll do it
19:25:05 <slagle> cool, thx
19:25:12 <slagle> #action jdob to do releases
19:25:20 <slagle> #topic CI
19:25:52 <slagle> i think CI has been looking pretty good the last few days
19:26:07 <slagle> we haven't had to revert anything in 3 or 4 days now :)
19:26:37 <slagle> #link http://goodsquishy.com/downloads/s_tripleo-jobs.html
19:26:38 <jdob> we need a sign "Days since last revert" :)
19:26:48 <slagle> #link http://goodsquishy.com/downloads/tripleo-jobs.html
19:27:33 <slagle> #topic Specs
19:27:45 <SpamapS> o/
19:28:03 <SpamapS> I posted a spec for making diskimage builder elements have sane argument encapsulation
19:28:24 <slagle> i was just about say, we have a new spec!
19:28:26 <dprince> FWIW the tripleo 'check experimental' job is proving useful in prevent regressions too: https://review.openstack.org/#/c/162260/3
19:28:57 <dprince> ^^^ this is meant to fix the intial missing tftp options fix that took 2 weeks to get reverted.
19:29:08 <SpamapS> Anyway, review when you have time. It is a non-urgent task to try and start reigning in the blatant abuse of global namespace that we have now.
19:29:08 <slagle> SpamapS: nice, i'll review it
19:30:10 <slagle> #topic open discussion
19:30:14 <dprince> SpamapS: sounds like a good thing to work on
19:31:05 <slagle> any other open items to discuss?
19:31:18 <greghaynes> *crickets*
19:31:23 <dprince> i've got some
19:31:28 <greghaynes> ++ on the namespacing vars spec
19:31:38 <dprince> so we've got a growing list of deprecation warnings in our logs
19:32:03 <dprince> I would like to make a pass at squashing those... but before I do I would like agreement about what are targets are
19:32:22 <dprince> i.e. if I start using a new Kilo config option I don't want someone -1'ing all my patches
19:32:48 <SpamapS> IMO kilo opts are entirely on the table
19:32:49 <dprince> and if we choose not to do this I suppose we can just get broken at some point later when the options are removed after the release
19:33:28 <dprince> SpamapS: I would agree
19:33:38 <slagle> yea, i'm in agreement we need to move forward
19:34:06 <dprince> anyways, looking at the logs is a bit concerning. Its like 10-20 warnings... and then what you actually want to see in some cases.
19:34:29 <slagle> i think it would be reasonable to revisit the backwards compat (perhaps with the stable branches again) at a later date
19:34:32 <SpamapS> Perhaps that needs to start becoming a whitelist and any new ones get a test fail.
19:34:33 <dprince> mostly oslo and keystoneclient auth_token settings
19:34:55 <dprince> but there may be some other odd deprecations in the mix too
19:34:59 <slagle> i noticed os-cloud-config was throwing a few too while using novaclient 1.1
19:35:12 <dprince> anyways, I notice these when I started the F21 stuff on Friday
19:35:38 <dprince> seems like we have tentative agreement that using new Kilo options is acceptable to get clean logs
19:35:51 <slagle> dprince: sounds like a good plan to me
19:36:08 <greghaynes> probably a good thing to let the list know
19:36:19 <dprince> Another thing I'd like to bring up in CI jobs...
19:36:50 <dprince> I'd like to thing about possibly restructuring a few of the jobs to help increase our coverage outside of TripleO
19:36:56 <dprince> For example heat.
19:36:57 <greghaynes> Id be fine without 'asking the list', but a 'hey, were going to start using kilo config options' is good
19:37:29 <dprince> The overcloud-without-mergepy job is proving to be really useful at finding Heat regressions
19:37:52 <dprince> The new heat templates use a ton more Heat features, nested stacks, parameter types, etc.
19:38:05 <dprince> Especially the puppet job
19:38:45 <dprince> So for the puppet job if we were to build the seed with 'source', but the overcloud with 'packages' we could provided coverage on these things in Heat
19:38:49 <dprince> make sense?
19:39:10 <dprince> Right now, the way I did the initial puppet job was to use packages for both the seed and the overcloud.
19:39:38 <dprince> Eventually I think our upstream packages would support building an inline Heat package, but we aren't there yet.
19:39:55 <dprince> So until then using a source built seed would solve this and give us the ability to increase the CI coverage a bit
19:40:02 <slagle> yea makes sense to me
19:40:14 <bnemec> Can't we run an all-source without-mergepy job?
19:40:31 <bnemec> The mergepy templates are deprecated, so we need one of those at some point anyway.
19:40:46 <slagle> i think what he's saying is that the puppet job uses more heat features in the templates
19:40:47 <dprince> bnemec: yes, but the puppet stuff is specifically doing some new patterns which we are finding aren't covered well in Heat
19:41:19 <bnemec> Okay, so we specifically need the puppet nomergpy stuff.
19:41:21 <bnemec> WFM
19:41:25 <dprince> Okay. I may ask the Heat crew and see what they think about this
19:42:00 <dprince> On a similar note I would like to re-work some of other CI jobs to use overcloud-without-mergepy as well.
19:42:03 <dprince> Ironic for example.
19:42:43 <dprince> This seems reasonable because mergepy is deprecated now... I would like almost all of the CI to be using overcloud-without-mergepy I think.
19:42:54 <bnemec> +1
19:43:01 <slagle> sure, i think now that it's dperecated, we can get away with just 1 overcloud job that uses mergepy
19:43:18 <slagle> or perhaps none. still, it'd be nice to know if we do break it
19:43:21 <greghaynes> ++, I thought we decided at the meetup that we were going to allow adding new heat features that do not work in the -with-mergepy templates?
19:43:31 <greghaynes> which seems like wed have to basically stop CIing it to move foward
19:44:00 <slagle> i guess it depends if those features are only in the non-mergepy templates
19:44:17 <dprince> greghaynes: we did, I'm with regards to Heat I was talking about them breaking features we were using in overcloud-without-mergepy
19:44:44 <dprince> greghaynes: I believe heat would allow us to swap this into their check job and then we'd catch things before they land there (potentially)
19:45:25 <greghaynes> ooo
19:45:40 <greghaynes> as long as they actually check it ;)
19:46:43 <greghaynes> but yes, ++ on doing less without-mergepy CI
19:47:05 <bnemec> *more?
19:47:23 <greghaynes> argh, right
19:47:30 <greghaynes> less with-mergepy, more without
19:47:37 <bnemec> Just checking. :-)
19:48:54 <slagle> in other business, i did send an email to the list entitled "getting to a 1.0". just trying to refocus our efforts a bit, and see if there are any other over-arching themes people want to bring up
19:49:56 <slagle> and see if we can/should draw some conclusions about the direction we're headed
19:50:13 <slagle> have a look if you're interested
19:50:31 <slagle> anything else folks want to bring up?
19:51:15 <slagle> k, if not, then we'll call it early!
19:51:17 <slagle> thx everyone
19:51:21 <slagle> #endmeeting