19:00:47 <slagle> #startmeeting tripleo
19:00:48 <openstack> Meeting started Tue Apr  7 19:00:47 2015 UTC and is due to finish in 60 minutes.  The chair is slagle. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:53 <openstack> The meeting name has been set to 'tripleo'
19:00:53 <slagle> hi everyone
19:01:01 <jdob> o/
19:01:15 <dprince> hello
19:01:48 <slagle> let me remind folks in tripleo...
19:02:31 <tchaypo> Welcome to 5am!
19:02:38 <slagle> howdy tchaypo
19:02:54 <slagle> let's get rolling
19:02:59 <slagle> #topic agenda
19:03:00 <slagle> * bugs
19:03:00 <slagle> * reviews
19:03:00 <slagle> * Projects needing releases
19:03:00 <slagle> * CI
19:03:00 <bnemec> o/
19:03:02 <slagle> * Specs
19:03:08 <slagle> * Meeting time
19:03:11 <slagle> * open discussion
19:03:18 <bnemec> Aw, I broke the agenda
19:03:20 <slagle> i added a meeting time agenda item
19:04:07 <gfidente> spredzy ! ;)
19:04:26 <slagle> #topic bugs
19:04:36 <slagle> i know we have a few untriaged bugs
19:04:43 <slagle> let's see if we can knock those out right now
19:04:48 * bnemec just squashed one
19:04:52 <slagle> #link https://bugs.launchpad.net/tripleo/
19:04:52 <slagle> #link https://bugs.launchpad.net/diskimage-builder/
19:04:52 <slagle> #link https://bugs.launchpad.net/os-refresh-config
19:04:52 <slagle> #link https://bugs.launchpad.net/os-apply-config
19:04:52 <slagle> #link https://bugs.launchpad.net/os-collect-config
19:04:55 <slagle> #link https://bugs.launchpad.net/os-cloud-config
19:04:57 <slagle> #link https://bugs.launchpad.net/os-net-config
19:05:00 <slagle> #link https://bugs.launchpad.net/tuskar
19:05:02 <slagle> #link https://bugs.launchpad.net/python-tuskarclient
19:06:59 <slagle> i'll reassign https://bugs.launchpad.net/tripleo/+bug/1401617 to myself
19:07:01 <openstack> Launchpad bug 1401617 in tripleo "Flavor based ramdisk/kernel ID is deprecated in Ironic since Juno" [Critical,In progress] - Assigned to Clint Byrum (clint-fewbar)
19:08:28 <slagle> looks like all the other crits are fix committed for tripleo
19:09:12 <slagle> jdob: can you triage this one? https://bugs.launchpad.net/tripleo/+bug/1439567
19:09:13 <openstack> Launchpad bug 1439567 in tripleo "[tuskar] wrong URL for tuskar in default installation of TripleO " [Undecided,New]
19:09:45 <jdob> ya, I think I fixed that already
19:10:03 <bnemec> I think I triaged all of the other untriaged bugs.
19:10:34 <slagle> indeed, i don't see any others. thanks!
19:10:42 <gfidente> slagle, just wanted to point out there is this https://bugs.launchpad.net/tripleo/+bug/1441170 currently blocking puppet job in ci, fix should be on the way though
19:10:42 <openstack> Launchpad bug 1441170 in tripleo "ironicclient "Not Acceptable" error" [Critical,Confirmed]
19:11:00 <slagle> there are a bunch of crits in tripleo that are Fix Committed that need to be gone through and possible moved to Fix Released
19:11:07 <slagle> i can do that
19:11:29 <slagle> #action slagle review tripleo critical Fix Committed bugs to see if any have been releaesd
19:12:03 <slagle> gfidente: k, thx. who should the assignee be?
19:12:32 <slagle> this is the one that's going to be fixed by updating to the later delorean trunk repo?
19:12:38 <gfidente> yep
19:12:48 <slagle> gfidente: can you link to that review in the bug?
19:12:59 <gfidente> dprince has a change for it yes looking for it
19:13:04 <slagle> and assign to whomever opened that reivew (dprince i believe)
19:13:14 <slagle> gfidente: ok, thanks!
19:13:31 <slagle> any other bug business?
19:13:50 <slagle> #topic reviews
19:14:18 <dprince> slagle: sure, assign to me
19:14:18 <slagle> #info There's a dashboard linked from https://wiki.openstack.org/wiki/TripleO#Review_team - look for "TripleO Inbox Dashboard"
19:14:21 <slagle> #link http://russellbryant.net/openstack-stats/tripleo-openreviews.html
19:14:24 <slagle> #link http://russellbryant.net/openstack-stats/tripleo-reviewers-30.txt
19:14:28 <slagle> #link http://russellbryant.net/openstack-stats/tripleo-reviewers-90.txt
19:15:06 <slagle> instead of lamenting about stats, are there any reviews that people would like to draw attention to?
19:16:03 <dprince> slagle: the most pressing thing ATM is to unblock the puppet CI job
19:16:03 <greghaynes> I have a dib bomb of a patch (sorry)
19:16:09 <slagle> i see a lot of puppet/template reviews, and dib improvements that folks are working on
19:16:26 <greghaynes> https://review.openstack.org/#/c/167003/
19:16:37 <dprince> slagle: but tthose patches have +2's on them so once we see another passing CI run we should be a go
19:16:59 <greghaynes> Theres some other dib smaller ones that are less important, but I just wanted to point this one out since its not a small amount of effort to review
19:17:21 <slagle> hmm, yea 8 new patchsets since i last reviewed it :)
19:17:25 <slagle> i'll take another look myself
19:17:40 <dprince> greghaynes: that is a bomb! almost 2k lines
19:17:44 <greghaynes> there are actual tests though! so hopefully it helps
19:17:47 <greghaynes> yeaaa
19:17:51 <greghaynes> a lot of that is test / fixtures though
19:19:01 <slagle> #info need to unblock Puppet CI job
19:19:21 <dprince> greghaynes: at some point it might make sense to have simple-init be its own project and just have DIB install it?
19:19:29 <slagle> #info need reviews on https://review.openstack.org/#/c/167003/
19:19:38 <greghaynes> Yep, it was actually, we undid that so we could make progress on it
19:19:41 <greghaynes> agreed though
19:20:00 <slagle> dprince: is anything needed to unblock the puppet ci job other than the delorean trunk repo update?
19:20:10 <dprince> greghaynes: sure, we may as well increase the size of our .git directories in the meantime
19:20:32 <dprince> slagle: no, just waiting to see if the latest recheck passes like the last one did
19:20:40 * dprince has hope
19:21:01 <slagle> dprince: this one? https://review.openstack.org/#/c/162666/
19:21:13 <dprince> slagle: a bit of a surprise that an ironicclient bug is what bit us here
19:21:34 <dprince> slagle: actually this one: https://review.openstack.org/#/c/161277/
19:21:53 <slagle> ah, k
19:21:53 <dprince> slagle: although I would take either of them I'd rather upgrade to F21 at this point
19:21:59 <greghaynes> dprince: hah, if its an issue id be fine with revisiting that before it merges
19:22:29 <slagle> #info https://review.openstack.org/#/c/161277 needed to unblock Puppet CI job
19:22:42 <dprince> greghaynes: not trying to nit pick you. Just wondering if DIB *is* the right place for all that code
19:24:12 <slagle> ok, any other review business?
19:24:15 <greghaynes> Yea, Id lean towards no but lets chat about that with the others who have been working on it later
19:24:36 <dprince> greghaynes: sounds goo
19:24:40 <dprince> greghaynes: d
19:24:41 <slagle> #topic Projects needing releases
19:25:18 <slagle> so, a note about releases...if you need one, ask someone to do one for you :)
19:25:27 <slagle> i don't want to see folks blocked on waiting for a release
19:25:40 <slagle> since i feel we've been a bit lax about doing them weekly
19:25:44 <jdob> is that a new approach instead of the semi-weekly ones we've been doing?
19:25:48 <slagle> jdob: no
19:25:49 <jdob> nm, you just kinda answered that
19:26:00 <slagle> i just want folks to know that they can ask anytime
19:26:04 <jdob> gotcha
19:26:32 <slagle> are there any volunteers to do them this week?
19:26:39 <slagle> if not, i'll do it
19:26:48 <jdob> i'll do it
19:26:52 <slagle> jdob: thanks!
19:27:00 <slagle> #action jdob to do releases
19:27:01 <jdob> np, will release all the things
19:27:22 <slagle> #topic CI
19:27:42 <slagle> any other CI topic besides unblocking the puppet job?
19:28:46 * slagle assumes not
19:28:59 <greghaynes> I need to make another dib job
19:29:12 <slagle> i think it might make sense to replace the current ha job with a puppet based one once the ha is ready there
19:29:19 <slagle> something to consider anyway
19:29:27 <greghaynes> for the image format func test I mae
19:29:42 <bnemec> We should probably just nix the ha job until someone actually commits to making it work.
19:30:14 <slagle> bnemec: yea, we could do that too
19:30:18 <gfidente> bnemec, indeed I agree with slagle it'd better to switch it to puppet, when puppet implementation is ready
19:30:30 <greghaynes> bnemec: ++
19:30:33 <greghaynes> its useless ATM :(
19:30:39 <greghaynes> (even though thats my baby)
19:30:46 <slagle> greghaynes: that doesnt need to run as part of tripleo ci though does it?
19:31:15 <greghaynes> slagle: no, just dib actually
19:31:22 <dprince> ++ for switching the HA job to puppet
19:31:51 <dprince> One thing I would like to highly recommend is that we first optimize our image building for CI a bit
19:32:23 <slagle> what types of things do you have in mind?
19:32:34 <dprince> Like... either we build one image with everything (saves us time), or we build one very basic image with almost nothing and install packages at deployment time
19:32:42 <dprince> Either would save us significant CI time...
19:32:52 <bnemec> single image++
19:33:08 <dprince> I started working on this a bit but I'd like it to be in devtest_overcloud.sh so devs can use it as well
19:33:12 <greghaynes> a thought - the distro-minimal elments weve made in dib have very good caching potential
19:33:38 <dprince> greghaynes: ack
19:33:44 <slagle> so, fwiw, we're using a single image in the rdo/instack workflow and it's working quite well
19:35:23 <dprince> sure, for me it is about speeding up the CI runtime
19:35:40 <slagle> dprince: yea i think adding the option to devtest makes sense
19:35:41 <gfidente> I think in CI the roles of the various nodes are not going to change a lot or frequently so single image wouldn't cause troubles
19:36:23 <jistr> +1 for single image as well, sounds reasonable to me
19:36:28 <dprince> So an HA job isn't really hard from a tripleo-ci standpoint. It is just a bit of configuration work.
19:36:55 <dprince> The real work here is re-structuring some things in devtest_overcloud.sh so we are less prescriptive about imaage builds
19:37:30 * gfidente will jump on injecting failure in the HA job as soon as it works decently
19:37:39 <dprince> And also supporting swap in default_parameters for things like Ceph, etc.
19:37:59 <slagle> #idea add option to use single image to devtest_overcloud
19:38:02 <dprince> gfidente: but that is the fun part!
19:38:13 <slagle> #info plan is to replace current HA job with puppet based one
19:38:36 <slagle> gfidente: keep in midn we can put an ha job up and make it non-voting at first
19:39:21 <slagle> any other CI topics?
19:39:36 <slagle> #topic Specs
19:40:30 <slagle> moving on in 5...
19:40:37 <slagle> #topic Meeting time
19:40:56 <slagle> the main thing i wanted to cover is if the alternate meeting time is still useful to folks?
19:41:38 <slagle> it's been skipped the last few times
19:41:41 <gfidente> slagle, glad you raised this, the alternate time still works for me, but we skipped a few instances there I think
19:42:01 <slagle> ok, well, this is probably something we need to raise on the list for increased visibility
19:42:16 <slagle> but if no one is attending...we probably don't need to say we have one
19:42:22 <bnemec> Yeah, by definition the people who need the alternate time aren't going to be here. :-)
19:42:29 <slagle> or maybe we can find a better time
19:42:30 <jdob> haha
19:42:37 <jdob> touche bnemec
19:42:58 <slagle> bnemec: well they aren't at the alternate time either :)
19:43:01 <gfidente> my problem is, I skipped both
19:43:09 <slagle> maybe they fled earth
19:43:21 <slagle> #action slagle email list about alternate meeting time
19:43:31 <gfidente> if we had a single timeframe, I might have tried to join that at least
19:43:53 <slagle> well, let's see what feedback we get, then re-evaluate
19:44:11 <slagle> #topic open discussion
19:44:33 <slagle> there is a liberty summit ideas etherpad
19:44:45 <slagle> #link https://etherpad.openstack.org/p/tripleo-liberty-proposed-sessions
19:44:54 <jdob> crap, that's next month already
19:46:07 <slagle> let's get some ideas flowing on the etherpad
19:46:48 <gfidente> one question: shall we switch USE_MERGEPY to 0 by default?
19:47:11 <bnemec> +1
19:47:25 <slagle> gfidente: i'm in favor
19:47:27 <bnemec> I believe the mergepy templates were already moved to a deprecated folder.
19:47:41 <bnemec> So we should stop using them by default.
19:47:45 <gfidente> yeah
19:47:52 <slagle> sound logic :)
19:47:53 <bnemec> Although we should keep a CI job running them until we can remove them completely.
19:47:54 <jdob> +1
19:48:38 <dprince> I'm for switching, we'll have to do the migration carefully so as not to break CI on various projects though
19:48:51 <tchaypo> RE the alternate time
19:49:11 <tchaypo> fwiw I believe that was originally pushed by me because I was one of a few people who’d started in .au
19:49:47 <tchaypo> as far as i know none of us are following tripleo now (much), and in any case it stopped being useful to .au when it moved to be more .eu friendly
19:51:36 <slagle> ok. well, hopefully folks will speak up on the list
19:51:53 <slagle> so we can accomdate more people if they'd like to be involved in the meetings
19:52:28 <slagle> if we need to pick a totally new time for the alternate meeting, we could do that
19:52:44 <gfidente> slagle, I remember we had a doodle with some votes which maybe is worth pointing at for people to update their vote or remove theirselves
19:53:01 <slagle> gfidente: yea, i remember, i'll look it up
19:53:30 <slagle> anything else to discuss?
19:53:31 <jistr> (maybe a new vote, because the people who are not interested in tripleo anymore might not see the message that they should remove themselves)
19:54:43 <slagle> thx everyone!
19:54:46 <slagle> #endmeeting