19:01:37 <slagle> #startmeeting tripleo
19:01:38 <openstack> Meeting started Tue Apr 21 19:01:37 2015 UTC and is due to finish in 60 minutes.  The chair is slagle. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:41 <openstack> The meeting name has been set to 'tripleo'
19:02:03 <slagle> hello everyone
19:02:47 <EmilienM> hello
19:03:42 <slagle> we'll get started, maybe more folks will trickle in
19:03:44 <slagle> #topic agenda
19:03:45 <slagle> * bugs
19:03:45 <slagle> * reviews
19:03:45 <slagle> * Projects needing releases
19:03:45 <slagle> * CI
19:03:47 <slagle> * Specs
19:03:49 <slagle> * open discussion
19:04:02 <slagle> oh, we have an additional agenda item as well
19:04:11 <slagle> * Ceph blueprint, elements implementation lacking way behind puppet
19:05:03 <slagle> # topic bugs
19:05:10 <slagle> #topic bugs
19:05:23 <slagle> #link https://bugs.launchpad.net/tripleo/
19:05:23 <slagle> #link https://bugs.launchpad.net/diskimage-builder/
19:05:23 <slagle> #link https://bugs.launchpad.net/os-refresh-config
19:05:23 <slagle> #link https://bugs.launchpad.net/os-apply-config
19:05:23 <slagle> #link https://bugs.launchpad.net/os-collect-config
19:05:25 <slagle> #link https://bugs.launchpad.net/os-cloud-config
19:05:28 <slagle> #link https://bugs.launchpad.net/os-net-config
19:05:30 <slagle> #link https://bugs.launchpad.net/tuskar
19:05:33 <slagle> #link https://bugs.launchpad.net/python-tuskarclient
19:05:44 <slagle> i believe all bugs have been triaged last i checked
19:07:51 <dasm> beginner's question: tuskar-ui is not the part of tripleo?
19:08:11 <slagle> dasm: it's actually part of horizon
19:08:27 <dasm> slagle: ok, makes sense. thanks
19:08:30 <slagle> i see only 2 crits in tripleo that seem well handled
19:09:22 <slagle> https://bugs.launchpad.net/os-collect-config/+bug/1444999 can be closed
19:09:22 <openstack> Launchpad bug 1444999 in os-collect-config "oslo.config requirement is not following global requirements" [Critical,Triaged]
19:09:24 * slagle does so
19:10:01 <slagle> i think that's it for bugs
19:10:12 <slagle> #topic reviews
19:10:47 <slagle> are there any reviews people would like to ask for attention on?
19:12:13 <dprince> slagle: as always mine :)
19:12:34 <slagle> if no one is going to ask...
19:12:47 <slagle> then i shall prioritize dan's
19:12:51 <slagle> :)
19:13:16 <slagle> #topic releases
19:13:26 <slagle> i'll do releases this week
19:13:31 <slagle> #action slagle to do releases
19:13:37 <slagle> #topic CI
19:14:25 <slagle> our CI has been crusing
19:15:04 <slagle> dprince: hey, speaking of that puppet-concat regression that hit us last week, do you think we can try moving the puppet CI job to use openstack-puppet-modules?
19:15:16 <slagle> i know we can try...do you think we should?
19:15:20 <dprince> slagle: yes, been meaning to get to it
19:15:44 <slagle> k
19:15:55 <slagle> #info puppet CI job should be moved to use openstack-puppet-modules
19:15:58 <dprince> slagle: oh, wait you mean use a package instead of git?
19:16:02 <slagle> dprince: yes
19:16:23 <dprince> slagle: so the package in Delorean will actually just use the latest stuff anyways
19:16:35 <slagle> i see, so that wouldn't have helped
19:16:37 <dprince> slagle: what I want is master (trunk) for all the stackforge modules
19:16:56 <dprince> but stable branches for all the rest (puppet-concat, mysql, rabbit, etc.)
19:17:23 <slagle> should the delorean packaging just be updated to do that?
19:17:34 <dprince> slagle: it could as well, yes.
19:17:45 <slagle> i think that makes sense
19:18:15 <dprince> slagle: but we need to stick with Git for puppet modules in the CI at this point because we are starting to use the same job for actually CI'ing the puppet modules too
19:18:26 <dprince> just this week puppet-keystone is getting some coverage for example (as a test)
19:18:45 <slagle> oh nice
19:18:56 <dprince> I'm actually really excited about this because it means TripleO is helping CI things outside of tripleo
19:19:10 <slagle> well it would be pretty easy to just swith the puppet-modules element to use the stable branches of the stuff from puppetlabs
19:19:21 <dprince> we just need to be mindful of that our CI jobs are used this way...
19:19:56 <slagle> #info TripleoCI being used to CI puppet modules. puppet-keystone initially as a test
19:20:03 <dprince> sure, we could for example create another CI job that set a DIB_INSTALLTYPE_puppet_modules=package variable
19:20:10 <slagle> yep
19:20:39 <dprince> I'm not sure it really is worth it given limited resources and the confusion it might cause if people used it in the wrong place
19:20:48 <dprince> but we could debate that
19:22:26 <slagle> #topic Specs
19:23:29 <slagle> #topic Ceph blueprint, elements implementation lacking way behind puppet
19:23:53 <slagle> hmm, we arent in gfidente's timezone
19:24:10 <slagle> there was a thread about this topic as well on openstack-dev
19:24:45 <slagle> we need to come up with a plan going forward around the non-puppet heat templates
19:26:11 <slagle> and the non-puppet elements
19:26:46 <slagle> keeping in mind the seed and undercloud are still using the non-puppet elements
19:26:55 <slagle> anyway, moving on
19:26:58 <slagle> #open discussion
19:26:59 <dasm> what does it mean: plan? migrating non-puppet to puppet? or creating workaround?
19:27:28 <slagle> dasm: just that no one is maintaining the non-puppet overcloud templates at the moment
19:28:02 <slagle> and that they're starting to lag as new features get added to the puppet versions
19:28:37 <dprince> slagle: I think it is fine, if someone is interested in keeping tripleo-image-element features upgraded they can take this on
19:28:57 <dprince> if not, then what is there keeps working as is
19:29:42 <dasm> so, if there is no one responsible for non-puppet templates, maybe it should be marked as deprecated?
19:30:07 <slagle> dasm: yep, that's on the table
19:30:07 <dasm> can we check somehow, who is using it? maybe no one?
19:30:10 <dprince> dasm: we may be headed in that direction
19:30:33 * bnemec arrives late
19:30:35 <dprince> we still rely on many of the elements for features though so I think it is too early to go there
19:32:54 <slagle> i think that's about a wrap, if there's nothing else
19:33:10 <bnemec> Excellent timing then. :-)
19:33:10 <slagle> thanks folks!
19:33:22 <slagle> bnemec: complete all the things
19:33:25 <slagle> thanks!
19:33:28 <slagle> #endmeeting