19:01:51 <slagle> #startmeeting tripleo
19:01:52 <openstack> Meeting started Tue May  5 19:01:51 2015 UTC and is due to finish in 60 minutes.  The chair is slagle. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:56 <openstack> The meeting name has been set to 'tripleo'
19:02:14 <slagle> hi everyone
19:02:22 <slagle> #topic agenda
19:02:35 <slagle> * bugs
19:02:36 <slagle> * reviews
19:02:36 <slagle> * Projects needing releases
19:02:36 <slagle> * CI
19:02:36 <slagle> * Specs
19:02:38 <slagle> * open discussion
19:02:57 <slagle> we have some one-off agenda items as well from last time:
19:03:04 <slagle> * Ceph blueprint, do we consider it completed based on puppet status?
19:03:10 <slagle> * Meetings time, shall we switch back to single meeting time?
19:03:20 <bnemec> o/
19:03:25 <slagle> i just noticed those, let's talk about those prior to open discussion
19:03:27 <gfidente^2nd> o/
19:03:34 <slagle> #topic bugs
19:03:41 <slagle> #link https://bugs.launchpad.net/tripleo/
19:03:41 <slagle> #link https://bugs.launchpad.net/diskimage-builder/
19:03:41 <slagle> #link https://bugs.launchpad.net/os-refresh-config
19:03:41 <slagle> #link https://bugs.launchpad.net/os-apply-config
19:03:41 <slagle> #link https://bugs.launchpad.net/os-collect-config
19:03:44 <slagle> #link https://bugs.launchpad.net/os-cloud-config
19:03:46 <slagle> #link https://bugs.launchpad.net/os-net-config
19:03:49 <slagle> #link https://bugs.launchpad.net/tuskar
19:03:51 <slagle> #link https://bugs.launchpad.net/python-tuskarclient
19:04:48 <slagle> i downgraded https://bugs.launchpad.net/tripleo/+bug/1444585
19:04:48 <openstack> Launchpad bug 1444585 in tripleo "Error: Invalid parameter warn on Concat failing puppet jobs" [High,Confirmed] - Assigned to James Slagle (james-slagle)
19:04:50 <slagle> we have a workaround in place
19:05:48 <slagle> believe we can downgrade https://bugs.launchpad.net/tripleo/+bug/1441170 as well
19:05:48 <openstack> Launchpad bug 1441170 in python-ironicclient "ironicclient "Not Acceptable" error" [High,In progress] - Assigned to John L. Villalovos (happycamp)
19:05:53 <slagle> if not close it out
19:06:21 <slagle> i guess we can leave it open until the ironicclient fix is released
19:07:38 <slagle> diskimage-builder needs some triage
19:10:10 <slagle> hmm, i thought we had already fixed https://bugs.launchpad.net/diskimage-builder/+bug/1451767
19:10:10 <openstack> Launchpad bug 1451767 in diskimage-builder "IOError: [Errno 13] Permission denied: '/tmp/svc-map-services'" [High,Confirmed]
19:10:20 <gfidente^2nd> I think I've seen this https://bugs.launchpad.net/diskimage-builder/+bug/1451767 happening when devtest is launched as root as the svc-map-services is not deleted after the run
19:10:29 <slagle> maybe there's just a review up for it
19:10:33 <gfidente^2nd> so a new attempt with non-root user gets that
19:10:38 <slagle> ah
19:10:43 <bnemec> slagle: I was thinking the same thing.
19:11:08 <slagle> oh well, we can take a look at post-meeting. it's triaged now
19:11:16 <slagle> i dont see anything else untriaged
19:12:03 <bnemec> https://review.openstack.org/#/c/139064 should have fixed the svc-map thing, I believe.
19:12:25 <slagle> yea
19:12:31 <slagle> maybe the reported as an old dib
19:12:38 <slagle> *reporter
19:12:42 <bnemec> Yeah
19:12:55 <slagle> any other bug business?
19:13:26 <slagle> #topic reviews
19:13:45 <slagle> #link http://russellbryant.net/openstack-stats/tripleo-openreviews.html
19:14:38 <slagle> i'd just like to continue to remind everyone that a good way to get your own code reviewed is to do reviews yourself
19:15:00 <slagle> the more you do, the more it frees up others to review your own code :)
19:15:16 <slagle> i also sent a core reviewer update to openstack-dev
19:15:41 <slagle> #link http://lists.openstack.org/pipermail/openstack-dev/2015-May/063275.html
19:15:55 <jdob> glad to see us adding new cores
19:16:07 <slagle> existing cores, please review that and respond as you see fit
19:16:18 <slagle> jdob: indeed, it's good to see some folks stepping up
19:17:06 <gfidente> so an old rule I remember from tempest is that cores are not supposed to leave +1
19:17:27 <gfidente> what is the sentiment in regard to this for us?
19:17:33 <jdob> no, we leave +1s
19:17:47 <jdob> under the rationale of "I'm with this, but not a complete expert that I'm comfortable leaving a +2"
19:17:54 <slagle> i still do +1's
19:18:01 <jdob> IMO, that's because of how diverse our repos are
19:18:07 <shardy> I think it's fine, it's generally "ok but could be better", or as jdob says, some subsystem you're not super expert in
19:18:08 <bnemec> +1
19:18:13 <gfidente> yeah I would myself prefer +1 unless sure of a +2
19:18:15 <jdob> personally, I'm way more familiar with tht than I am DIB
19:18:22 <shardy> at least that's how I've always treated +1 w/heat reviews
19:18:43 <gfidente> ack :)
19:19:19 <slagle> #topic Projects needing releases
19:19:39 <slagle> any volunteers?
19:19:44 <slagle> if not, i can do it
19:19:50 <slagle> i think i forgot to last time actually
19:19:51 <jdob> i'll do it
19:19:56 <slagle> jdob: thanks!
19:20:01 <slagle> #action jdob to release the world
19:20:19 <slagle> #topic CI
19:20:53 <dprince> leaving +1 as a core is totally valid
19:20:53 <slagle> we had a regression last week, but it was reverted
19:20:59 <slagle> #link http://goodsquishy.com/downloads/tripleo-jobs.html
19:21:10 <jdob> WE'VE MOVED ON DPRINCE, KEEP UP
19:21:10 <slagle> hmm, i do see a string of red there
19:22:14 <slagle> guess zuul/jenkins is still having problems
19:22:16 <bnemec> Oh yeah, there was a weird error in one of the puppet jobs I looked at.
19:24:05 <gfidente> well I have a couple of changes which never got the CI results
19:24:13 <slagle> looks like a variety of problems
19:24:44 <bnemec> gfidente: That's probably the infra problem.  Just recheck.
19:24:48 <gfidente> one of the change is against a puppet-module though so it seems a problem with streams again
19:25:04 <slagle> i see a overcloud create failed, an overcloud instnace ping timeout, but they both end with a jenkins traceback
19:25:20 <slagle> oh yea, and here's one that look like it passed but with the same tb
19:26:27 <slagle> something to keep an eye on anyway to see if we start to get some passing jobs
19:26:35 <bnemec> Okay, so no need to panic until zuul/jenkins get this stuff together.
19:26:42 <bnemec> s/this/their/
19:26:50 * bnemec typey typey too much
19:27:36 <slagle> yea
19:27:38 <slagle> ok, moving on
19:27:42 <slagle> #topic Specs
19:28:14 <slagle> anything new to report?
19:28:31 <bnemec> Did we ever merge the selinux spec?
19:28:41 <slagle> no
19:29:24 <gfidente> one of the topics I had was about the cinder/ceph spec
19:29:27 <bnemec> A bunch of the work is done, and I don't think anyone had more than nit picks with the spec itself.
19:30:30 <slagle> i'm curious how much is still relevant given the move away from openstack elements
19:30:48 <slagle> maybe all of it still is?
19:31:25 <bnemec> Some of it, at least.  Maybe it does need to be re-reviewed in light of that though.
19:32:10 <slagle> gfidente: would you like to talk about the ceph spec now?
19:32:17 <gfidente> yeah we still get denials in the puppet jobs
19:32:51 <gfidente> so some of it still applies, +1 on a re-review
19:33:04 <gfidente> the ceph spec yes, problem is along same lines
19:33:25 <gfidente> we have it implemented but only with puppet, what shall we do with the spec? close?
19:34:09 * bnemec wonders if he ever actually got around to reviewing that spec
19:34:35 <slagle> well that spec is merged
19:34:41 <slagle> i think we could close the blueprint
19:35:06 <slagle> so i think the question is, when we end up implementing something differently (or not at all) from how we said we would in the spec, what do we do
19:36:08 <gfidente> yeah in this case the implementation is pretty much what was described in the spec, only it is not via elements but via puppet
19:36:47 <gfidente> for bugs, I am using the 'puppet' tag
19:36:59 <gfidente> for blueprints it looks like there can't be a tag
19:37:43 <slagle> gfidente: i would consider the spec complete
19:37:56 <slagle> i dont think we need to retroactively update them to reflect what happened
19:38:26 <bnemec> I'm fine with that, fwiw.
19:38:32 <slagle> i'm seeing a lot less specs. and not a lot of complaints
19:39:14 <slagle> gfidente: we can close the blueprint as well if you feel the work is complete
19:39:17 <slagle> just let me know
19:39:53 <gfidente> I think support for pre-existing ceph can be considered a different task
19:40:30 <slagle> ok
19:40:33 <gfidente> if people agree with that, I'm inclined to close it
19:40:37 <slagle> wfm
19:40:57 <bnemec> +1
19:41:04 <slagle> #topic Meetings time, shall we switch back to single meeting time?
19:41:29 <slagle> i think it's evident we dont need the alternate meeting time any longer
19:41:39 <slagle> no one spoke up in support of it
19:41:43 <bnemec> I think it's somewhat academic, given that the people who ran the alternate time no longer are.
19:41:49 <slagle> indeed
19:42:03 <bnemec> No one to run the meeting == no meeting :-)
19:42:14 <slagle> the next question is if we feel the need to meet every week, at the same time
19:42:26 <slagle> and, i'm actually thinking no
19:42:40 <slagle> given our every other week meeting is usually sparsely attended
19:42:56 <jdob> so keeping this schedule and outright cancelling the alt week?
19:43:03 <slagle> jdob: pretty much
19:43:07 <jdob> +1
19:43:13 <gfidente> +1 as well
19:43:16 <jistr> +1
19:43:20 <bnemec> +1's all around!
19:43:27 <slagle> let it be so!
19:43:38 <slagle> #topic open discussion
19:44:00 <slagle> i've set the topic for the 2 tripleo fishbowl sessions at the summit
19:44:04 <slagle> on sched.org
19:44:41 <slagle> #link http://libertydesignsummit.sched.org/overview/type/design+summit/TripleO
19:44:51 <bnemec> Yeah, I guess that makes this the last scheduled meeting before summit.
19:45:15 <slagle> for the work sessions, i plan to just push up a summary of what folks are likely to be working on
19:45:25 <slagle> and let everyone self-organize at the individual sessions
19:45:49 <slagle> the contributors meetup is also open ended for self-organizing to work on what we want to work on
19:46:33 <slagle> any other business?
19:47:36 <slagle> thanks folks!
19:47:39 <slagle> #endmeeting