19:01:38 <slagle> #startmeeting tripleo
19:01:38 <openstack> Meeting started Tue Jun  2 19:01:38 2015 UTC and is due to finish in 60 minutes.  The chair is slagle. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:43 <openstack> The meeting name has been set to 'tripleo'
19:02:22 <slagle> #topic agenda
19:02:22 <slagle> * bugs
19:02:23 <slagle> * reviews
19:02:23 <slagle> * Projects needing releases
19:02:23 <slagle> * CI
19:02:25 <slagle> * Specs
19:02:27 <slagle> * open discussion
19:02:39 <slagle> there were no new one off agenda items
19:02:44 <slagle> #topic bugs
19:02:53 <slagle> #link https://bugs.launchpad.net/tripleo/
19:02:54 <slagle> #link https://bugs.launchpad.net/diskimage-builder/
19:02:54 <slagle> #link https://bugs.launchpad.net/os-refresh-config
19:02:54 <slagle> #link https://bugs.launchpad.net/os-apply-config
19:02:54 <slagle> #link https://bugs.launchpad.net/os-collect-config
19:02:56 <slagle> #link https://bugs.launchpad.net/os-cloud-config
19:02:59 <slagle> #link https://bugs.launchpad.net/os-net-config
19:03:01 <slagle> #link https://bugs.launchpad.net/tuskar
19:03:04 <slagle> #link https://bugs.launchpad.net/python-tuskarclient
19:04:13 <slagle> closed out https://bugs.launchpad.net/tripleo/+bug/1453076
19:04:13 <openstack> Launchpad bug 1453076 in tripleo "Error: Cannot validate PXE bootloader. Some parameters were missing in node's driver_info. Missing are: ['deploy_ramdisk', 'deploy_kernel']" [Critical,Fix committed] - Assigned to Derek Higgins (derekh)
19:04:23 <slagle> we released os-cloud-config the week of summit to address that
19:06:27 <slagle> i dont see any other bugs to discuss or anything untriaged
19:06:33 <slagle> any other bug business?
19:07:01 <slagle> #topic reviews
19:08:15 <slagle> was just perusing the review stats
19:08:33 <slagle> #action slagle submit update to review-stats to reflect new cores
19:08:55 <jdob> is the russelbryant link still the one we're looking at?
19:08:56 <slagle> are there any reviews people would like to ask for attention on?
19:09:01 <slagle> jdob: it is!
19:09:08 <jdob> kk
19:09:11 <slagle> #link http://russellbryant.net/openstack-stats/tripleo-openreviews.html
19:09:14 <slagle> #link http://russellbryant.net/openstack-stats/tripleo-reviewers-30.txt
19:09:17 <slagle> #link http://russellbryant.net/openstack-stats/tripleo-reviewers-90.txt
19:10:10 <slagle> #topic CI
19:12:25 <slagle> hmm, i'm seeing a lot of red
19:12:48 <bnemec> I broke one of the big patch series with a typo. :-/
19:13:20 <bnemec> Oh, that was not all me though. :-)
19:14:04 <bnemec> Connecting to 192.168.1.100:3128... failed: Connection refused.
19:14:04 <jdob> this page hurts my eyes :)
19:14:06 <bnemec> Squid is down?
19:14:08 <jistr> there's probably some genuine problem in non-puppet jobs
19:14:45 <slagle> yea we probably need someone to look into what is up
19:14:58 <slagle> i see a lot of various failures
19:15:06 <bnemec> Oh, I managed to click on the one change that failed that early.
19:15:32 <bnemec> Ah, I might know what's causing it.
19:15:35 <slagle> 2015-06-02 17:00:25.918 | InternalServerError: Timed out waiting for a reply to message ID e03f7fc0b97e4b53a96422fd4e2611c5 (HTTP 500)
19:15:40 <slagle> when registering nodes
19:15:46 <bnemec> Someone reported that the new oslo.messaging broke Ironic.
19:15:48 <jdob> ya, I see that in a bunch of differen ones
19:15:49 <slagle> i see that in a few
19:15:57 <slagle> bnemec: yea, that sounds like the culprit
19:16:06 <slagle> is there a bug?
19:17:04 <slagle> https://bugs.launchpad.net/ironic/+bug/1461182
19:17:04 <openstack> Launchpad bug 1461182 in oslo.messaging "After oslo.messaging release Ironic gate is broken" [Undecided,In progress] - Assigned to Doug Hellmann (doug-hellmann)
19:17:27 <bnemec> Heh, was just going to link that.
19:17:59 <slagle> we should link to that in #tripleo
19:18:30 <bnemec> I added it as a crit too.
19:18:45 <slagle> thanks
19:19:27 <bnemec> Also added to topic in #tripleo
19:19:44 <slagle> thanks again
19:20:12 <slagle> any other CI business?
19:20:38 <slagle> #topic Specs
19:21:18 <slagle> i have nothing to say about specs other than we stopped doing them, and I'm not sure that was such a good idea
19:21:30 <jdob> not sure it was a good idea to stop or have started in the first place?
19:21:35 <slagle> to have stopped
19:21:42 <bnemec> +1
19:21:47 <jdob> agreed, i'd prefer them to etherpads and what not
19:22:00 <slagle> given a large chunk of folks have no idea what others are working on, or have much context about their work
19:22:15 <slagle> and general feedback at the summit was that no one really knew what tripleo was working on
19:22:24 <jdob> would anyone be opposed to me proposing a simpler format?
19:22:34 <jdob> the current template always felt a bit cumbersome to me
19:22:50 <shardy> +1 on specs but we should keep it fairly lightweight IMO
19:22:51 <jdob> or is there some sort of larger openstack thing we're trying to adhere to?
19:23:17 <slagle> there may be some basic format expected
19:23:30 <bnemec> Not sure about simplifying it.  "Not applicable" is a valid answer to any of the sections, but it's nice to know someone had to at least think about it.
19:23:37 <jdob> fair enough
19:23:53 <bnemec> But if we can streamline the process without losing that then I'm +1.
19:24:12 <slagle> as long as they're rst, we're probably OK
19:24:22 <slagle> but they do end up doc'd here: http://specs.openstack.org/openstack/tripleo-specs/
19:24:28 <jdob> i'm not hell bent on changing them
19:24:42 <jdob> i think the bigger issue in the past has been on what constitutes a -1, but I dont want to dredge that up again
19:24:46 <jdob> we have discussed it in the past
19:25:54 <slagle> i'd be game to either see something simpler/lightweight or just be less nitpicky in specs
19:26:18 <slagle> anyway, something to think about
19:26:30 <slagle> i think it could help bring some awareness to tripleo related work
19:26:50 <slagle> not everyone clicks around etherpads randomly
19:27:02 <bnemec> Wut!?
19:27:08 <slagle> ok, bnemec does
19:27:24 <bnemec> :-)
19:27:30 <slagle> #topic open discussion
19:28:32 <slagle> oh, i forgot releases
19:28:35 <slagle> #topic releases
19:28:53 <bnemec> os-collect-config was released yesterday.
19:29:18 <slagle> i saw that
19:29:19 <bnemec> We need to work with dhellmann to get our projects configured so the standard release management tools can do their thing.
19:29:54 <slagle> configured how? in launchpad?
19:30:03 <bnemec> That should simplify the release process too.  They've essentially scripted the steps we have on the wiki.
19:30:37 <bnemec> Yeah, I think we just need to give some permissions to the relman group or something.
19:30:55 <bnemec> I meant to follow up on it after the Oslo meeting yesterday, but I forgot.
19:30:58 <slagle> ok
19:31:14 <bnemec> #action bnemec to figure out release management setup for our launchpad projects
19:31:37 <slagle> cool
19:31:47 <slagle> #topic open discussion
19:31:56 <slagle> ok, anything else to discuss before wrapping up?
19:33:06 <slagle> alright, that times it out
19:33:10 <slagle> thanks everyone!
19:33:11 <slagle> #endmeeting