19:01:36 <slagle> #startmeeting tripleo
19:01:36 <openstack> Meeting started Tue Jun 16 19:01:36 2015 UTC and is due to finish in 60 minutes.  The chair is slagle. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:41 <openstack> The meeting name has been set to 'tripleo'
19:01:55 <slagle> #topic agenda
19:01:55 <slagle> * bugs
19:01:55 <slagle> * reviews
19:01:55 <slagle> * Projects needing releases
19:01:55 <slagle> * CI
19:01:57 <slagle> * Specs
19:02:00 <slagle> * open discussion
19:02:18 <slagle> first off i should edit the wiki page to remove the alternate meeting time
19:02:46 <slagle> done
19:02:56 <slagle> there is probably an official schedule i need to make that change to as well
19:03:02 <slagle> #action slagle remove alternate meeting time
19:03:03 <jdob> does that mean we're weekly at this time or still biweekly?
19:03:35 <slagle> biweekly still
19:03:46 <jdob> kk
19:04:03 <slagle> i need to figure out how to update the official ics feed
19:04:06 <slagle> i'll do that this week
19:04:13 <slagle> #topic bugs
19:04:21 <slagle> #link https://bugs.launchpad.net/tripleo/
19:04:21 <slagle> #link https://bugs.launchpad.net/diskimage-builder/
19:04:21 <slagle> #link https://bugs.launchpad.net/os-refresh-config
19:04:21 <slagle> #link https://bugs.launchpad.net/os-apply-config
19:04:21 <slagle> #link https://bugs.launchpad.net/os-collect-config
19:04:23 <slagle> #link https://bugs.launchpad.net/os-cloud-config
19:04:26 <slagle> #link https://bugs.launchpad.net/os-net-config
19:04:28 <slagle> #link https://bugs.launchpad.net/tuskar
19:04:31 <slagle> #link https://bugs.launchpad.net/python-tuskarclient
19:05:34 <slagle> i'm just reviewing the crits in tripleo
19:11:57 <bnemec> o/
19:12:42 <dasm> o/
19:13:04 <slagle> ok i believe i've triaged everything that needed it
19:14:06 <slagle> #topic reviews
19:14:45 <slagle> #link http://russellbryant.net/openstack-stats/tripleo-openreviews.html
19:14:48 <slagle> #link http://russellbryant.net/openstack-stats/tripleo-reviewers-30.txt
19:14:51 <slagle> #link http://russellbryant.net/openstack-stats/tripleo-reviewers-90.txt
19:15:12 <slagle> are there any reviews people would like to raise up for attention?
19:15:24 <jdob> more pressing is that CI is hosed and we can't +A stuff
19:15:48 <slagle> wait, still?
19:16:05 <slagle> i just looked at the crit bugs, it looked like everything was handled
19:16:15 <bnemec> CI looks mostly green
19:16:24 <slagle> yea i'm looking at it now
19:16:25 <bnemec> http://goodsquishy.com/downloads/tripleo-jobs.html
19:16:41 <slagle> i mean don't scroll down too far
19:16:43 <jdob> ah, my bad, I was looking at an old review
19:16:45 <slagle> but it's green at the top :)
19:17:07 <slagle> the nova folks don't agree on the proposed revert
19:17:13 <slagle> but that's reverted in tripleo-ci for now
19:17:21 <slagle> so we should be around that issue
19:17:54 <slagle> #topic CI
19:18:00 <slagle> since we were already talking about it :)
19:18:12 <bnemec> Yeah, they're kind of ugly problems.
19:18:20 <bnemec> One is upstream keepalived package.
19:18:28 <bnemec> One is a bug fix for a serious bug in Nova.
19:18:42 <dasm> guys, i was thinking about this ci problems. and afaik, everything is connected to external services.
19:19:04 <dasm> so, maybe the solution for this would be to add extra gate to those services, involved in tripleo?
19:19:36 <dasm> it's not so simple, and takes some time, but could be really helpful to prevent problems like in prev week.
19:19:53 <slagle> that has been more or less our mission for a while
19:20:14 <bnemec> We would like to, but Nova alone is kind of a fire hose.
19:20:17 <dasm> slagle: adding to other services?
19:20:25 <bnemec> And we can't really gate on upstream packages, AFAIK.
19:20:41 <slagle> dasm: yes; the issue is that we lack capacity and an HA cloud that is reliable enough to gate other projects
19:21:05 <bnemec> We should maybe look at getting in as a non-voting third-party CI though.
19:21:15 <bnemec> Been meaning to talk to Derek about that for a while.
19:21:18 <dasm> so, does it mean, we cannot prevent this situation?
19:21:31 <dasm> bnemec: +1
19:21:43 <slagle> we're also in the experimental queue
19:22:03 <dasm> i was thinking about exactly this kind of thing. add as non-voting, maybe even with little changed devtest (or anything what will be after this)
19:22:04 <slagle> but that relies on people being aware enough to check-experimental if they think a patch might affect tripleo
19:22:22 <dasm> so instead of creating 15 vms, it could create 3 cc + 1 cn
19:22:31 <dasm> just for this extra gate.
19:22:57 <slagle> what's cc? cn?
19:23:05 <dasm> cloud controller, compute node
19:23:11 <bnemec> dasm: It doesn't actually create 15 vms in CI.
19:23:21 <slagle> the testenv's deployed with 15vm's don't actually get all used or take up capacity
19:23:37 <bnemec> The testenvs are static, with four(?) nodes, I believe.
19:24:15 <dasm> ok, so i've misinterpreted this. all the time thought about 15 vms called baremetal_
19:24:27 <slagle> #idea add tripleo-ci as 3rd party non-voting ci
19:24:29 <bnemec> dasm: For local devtest, it does.
19:24:38 <bnemec> CI is a little different though.
19:24:56 <dasm> but still, what kind of infrastructure would need to be added/created to add it as next gate?
19:25:06 <dasm> bnemec: ack
19:26:04 <dasm> correct me, if i'm wrong, but should we have one gate per project? so it would be like 5 or 6 gates?
19:26:07 <bnemec> dasm: I'm not sure anyone here knows that for sure.  If you can catch derekh he might know.
19:26:39 <dasm> ok, i'll try to talk to derekh and ask about it.
19:27:23 <dasm> and maybe anyone has different idea? or is it the only one?
19:29:30 <slagle> 3rd party ci is the other idea
19:29:38 <slagle> and envangelizing check-experimental more
19:30:06 <slagle> for instance, in that nova revert dprince posted, the reviewers were saying they had no way to test actual deployments via ironic
19:30:09 <slagle> which is clearly not true
19:30:20 <slagle> tripleo can via check-experimental
19:30:55 <slagle> #topic Specs
19:31:25 <slagle> i dont see any new specs proposed
19:31:28 <slagle> #topic open discussion
19:31:54 <dasm> what is the highest priority right now, for tripleo?
19:32:32 <dasm> i couldn't attend openstack summit, so have a little lack of knowledge.
19:32:59 <slagle> i'm not sure we're organized in a way where we have 1 single list of prioritized items
19:33:20 <slagle> we have many different people working on different things, all with their own priorities
19:33:49 <slagle> if i had to guess i'd say, HA and network isolation are the 2 biggest things people are working on right now
19:34:07 <dasm> ok, so different question: what would be nice to have, but no one is working on this.
19:34:35 <dasm> i'm interested in merging efforts from kolla into tripleo.
19:34:42 <dasm> anyone is doing it already?
19:35:24 <slagle> there are 2 people working on that.
19:35:42 <slagle> slower and rhallisey on irc
19:35:52 <slagle> have you seen the patch they've posted?
19:36:14 <dasm> not yet. but will check it.
19:37:15 <sdake> slagle while on subject of kolla, a new ansible-multi spec is up for review addressing your comments here: https://review.openstack.org/#/c/189157/
19:37:24 <sdake> invite the tripleo community to review and vote :)
19:37:32 <slagle> dasm: https://review.openstack.org/#/c/178840/
19:37:39 <slagle> sdake: thanks, i will
19:37:50 <slagle> #link https://review.openstack.org/#/c/189157/
19:38:15 <sdake> some of your comments are addressed in the review rather then in the spec itself
19:38:34 <sdake> but I feel they accurately represent the state of the community
19:39:47 <slagle> sdake: ok, great, i'll take another look
19:39:50 <dasm> slagle: thanks for link. i'm on it. and will check link from sdake.
19:40:08 <slagle> any other items before we wrap up?
19:41:06 <slagle> thanks folks!
19:41:08 <slagle> #endmeeting