14:04:46 <dprince> #startmeeting tripleo
14:04:46 <openstack> Meeting started Tue Nov 3 14:04:46 2015 UTC and is due to finish in 60 minutes. The chair is dprince. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:04:50 <openstack> The meeting name has been set to 'tripleo'
14:05:22 <dprince> hello everyone
14:05:25 <jdob> o/
14:05:32 <marios> \o
14:05:35 <jaosorior> o/
14:05:53 <trown> o/
14:05:59 <tremble> o/
14:06:07 <dprince> trown: thanks for the meeting ping. I would have waited another hour :)
14:06:30 <tzumainn> hiya!
14:06:47 <dprince> #topic agenda
14:06:54 <dprince> * bugs
14:06:54 <dprince> * Projects releases or stable backports
14:06:54 <dprince> * CI
14:06:54 <dprince> * Specs
14:06:54 <dprince> * Review Priorities: https://etherpad.openstack.org/p/tripleo-review-priorities
14:06:57 <dprince> * one off agenda items
14:06:59 <dprince> * open discussion
14:07:17 <dprince> anything to add to todays agenda anyone?
14:07:23 * gfidente late
14:07:47 <jaosorior> dprince: Could we add the TLS enablement work there?
14:08:01 <marios> in reviews /priorities i guess
14:08:19 <marios> https://review.openstack.org/#/c/231930/
14:08:23 <trown> dprince: I dont think it was discussed in a tripleo context on summit, but it looks like DLM is a thing for mitaka
14:08:29 <trown> dprince: https://trello.com/c/G5kyYZ5e/103-add-dlm-support card for RDO
14:09:00 <dprince> jaosorior: yeah, lets get that in review priorities as marios suggests
14:09:11 <dprince> jaosorior: thanks for mentioning
14:10:02 <dprince> trown: ack on DLM
14:10:35 <dprince> trown: lets perhaps get that in open discussion (hopefully we get there in time)
14:10:46 <trown> dprince: works for me
14:11:26 <dprince> #topic bugs
14:11:47 <dprince> any major bugs come up in the past two weeks?
14:12:51 <dprince> I still see a few bugs coming in that are related to the old tripleo-incubator workflow
14:13:03 <dprince> perhaps we should add a DEPRECATED file to that project now?
14:13:30 <dprince> or at least to the devtest_ scripts...
14:15:05 <trown> the devtest scripts are still used in instack-virt-setup would be the only thing
14:15:32 <dprince> trown: good point, perhaps we skip devtest_testenv.sh maybe?
14:15:36 <marios> dprince: probably a few bugs at https://bugs.launchpad.net/tripleo/ that need closing, example https://bugs.launchpad.net/tripleo/+bug/1239450
14:15:36 <openstack> Launchpad bug 1239450 in tripleo "nova floating-ip extension doesn't work on overcloud" [High,Triaged]
14:16:13 <marios> dprince: wasn't there a thought a while back about pulling the scripts we still use out of incubator? into common possibly
14:16:26 <marios> dprince: but this discussion is getting away from bugs
14:16:56 <dprince> marios: re https://bugs.launchpad.net/tripleo/+bug/1239450 I think that could be closed
14:16:57 <openstack> Launchpad bug 1239450 in tripleo "nova floating-ip extension doesn't work on overcloud" [High,Triaged]
14:18:00 <marios> dprince: we probably still incidentally use quite a few more of those, like wait-for or create-nodes being called
14:18:17 <dprince> marios: any yes, we are starting to gradually pull the things into the incubator. Some of Brad's recent patches look promising
14:18:27 <dprince> https://review.openstack.org/#/c/235569/ for example is the build-images patch
14:19:06 <dprince> any other bugs, probably a slow week because of Summit
14:20:06 <dprince> #topic Projects releases or stable backports
14:20:40 <dprince> shardy: any updates on the stable branches stuff? You've made good progress on this right?
14:21:07 <trown> I think shardy is mostly afk
14:21:08 <trown> [08:51] <shardy> dprince: Hey, apologies but I can't make the meeting today due to a conflict
14:21:09 <marios> dprince: he said he had a conflict, lurking
14:21:12 <slagle> did we bump the tags in the master branches?
14:21:33 <slagle> i'd think we'd need to at least bump the .Y's there, so we can increment .Z's in the stable branches
14:21:40 <trown> yep
14:21:42 <dprince> slagle: not sure, lets action that
14:21:47 <slagle> although since we're backporting features, maybe we should bump the X?
14:22:15 <trown> slagle: but we are not backporting breaking features
14:22:48 <dprince> #action bump the version of the master branches so we can release stable
14:22:48 <slagle> semver says to bump .Y for new features to the "api"
14:23:13 <slagle> so if we wanted to be strict about that, we'd need to bump .Y in the stable branches
14:23:14 <trown> ah, ok... guess we need to bump X
14:23:21 <trown> for master
14:23:41 <dprince> probably safer to use the big hammer for this. No harm in bumping X right?
14:23:51 <slagle> that would mean making some stuff 1.0.0
14:24:02 <slagle> not sure if that actually has any significance or not
14:24:23 <dprince> slagle: yeah, perhaps a mailing list thread would help further discuss
14:25:14 <dprince> either way
14:25:40 <dprince> any other stable branch stuff?
14:26:28 <dprince> #topic CI
14:26:52 <dprince> CI looks to have been fairly stable this past week or so
14:27:29 <dprince> we agreed at the Summit to have add a few more CI jobs
14:27:45 <dprince> derekh: any CI specific updates?
14:27:48 <marios> dprince: fyi will be adding aping test for toci_instack soon
14:27:57 <marios> dprince: https://trello.com/c/OQlIbGoK/19-toci-start-a-user-instance-and-ping-it
14:28:12 <derekh> dprince: no thing I can think of at the moment
14:28:23 <dprince> marios: cool, will be nice to have that again
14:28:32 <marios> discussed a bit with derekh and slagle, first part is like https://review.openstack.org/#/c/241167/
14:28:37 <dprince> marios: on that, you might consider using a Heat stack to drive it?
14:28:43 <dprince> marios: that way we get Heat coverage
14:28:54 <derekh> dprince: sorry you cought me on the hope, calender was out by an hour
14:29:06 <derekh> *hop
14:29:07 <dprince> marios: also, would be good to (like devtest_overcloud.sh) make the instance volume backed... so that we cover Cinder/Ceph too
14:29:15 <marios> dprince: so here's the thing
14:29:26 <marios> dprince: really, we don't want to write any tests. run tempest
14:29:28 <dprince> derekh: me too, trown reminded us
14:29:39 <marios> dprince: like smoketests will do all those things for example
14:30:02 <marios> dprince: so the idea was to just carry a simple ping test locally, but eventually go to running tempest against the overcloud
14:30:32 <dprince> marios: agree with eventually running tempest if we have time
14:31:04 <dprince> marios: and I agree with a simple ping test for now. Rather than drive it w/ Nova I was just suggesting that using Heat would get us a bit more coverage
14:31:23 <trown> does adding it to a heat stack really add that much complication to the implementation?
14:31:36 <trown> I think the value is pretty high coverage wise
14:31:36 <marios> dprince: sure, i hadn't thought about that and can investigate it. just saying, there are a number of things to test (when you said about the volumes etc)
14:32:01 <dprince> marios: the previous devtest_overcloud.sh coverage gave us minimum Cinder/Ceph coverage
14:32:14 <marios> dprince: i'd also be happy to work on more test cases/coverage if that is a worthwhile thing to have
14:32:16 <dprince> marios: glance image -> converted to a volume
14:32:44 <marios> dprince: ack, will revisit. just mentioning it, as you can see my ping test is still wip, today.
14:33:35 <dprince> marios: but I'm really glad to see work on this. Just having the same coverage we had before would be great
14:33:40 <dprince> marios: http://git.openstack.org/cgit/openstack/tripleo-incubator/tree/scripts/devtest_overcloud.sh#n671
14:34:15 <derekh> actually now that I think of it, I've been working on using a mirror for the puppet modules we pull from github, wouldn't mind is somebody could take a look https://review.openstack.org/#/c/238414/
14:34:47 <dprince> derekh: ack
14:35:28 <dprince> derekh: oh, and I had a thought about the idea of using rsync or swift to deploy the modules
14:35:35 <slagle> marios: cool. were you able to copy from instack-test-overcloud at all? if not, no worries, but it's there if you need any pointers
14:35:59 <dprince> derekh: if we do that, it means our CI only needs to pull the modules once. Where as now it pulls them for the instack install, and the overcloud image build
14:36:09 <dprince> derekh: so a slight optimization...
14:36:17 <marios> slagle: so the bulk of the bash is from earlier - can't remember where i lifted it from, when we were in the business of init the overcloud tenant stuff
14:36:30 <marios> slagle: can't remember if i looked at instack-test-overcloud
14:36:31 <derekh> dprince: this patch is supposed to fix the double pull https://review.openstack.org/#/c/237929/3
14:36:47 <derekh> dprince: but you right swift would do it too
14:37:39 <marios> slagle: oh, that looks very useful :)
14:37:52 <dprince> derekh: yeah, a bit less fragile than optimizing it in our CI
14:38:05 <dprince> any other CI things?
14:38:12 <slagle> marios: and most of that came from devtest_overcloud :)
14:38:13 <marios> slagle: so why aren't we using that in ci?
14:38:26 <slagle> i think we meant to
14:38:30 <slagle> just forgot to tack it on
14:38:47 <derekh> dprince: nothing from me
14:38:57 <marios> ok, well do you still think it makes sense for this stuff to live in tripleo.sh? let's discuss offline
14:39:06 <dprince> #topic Review Priorities: https://etherpad.openstack.org/p/tripleo-review-priorities
14:39:25 <jaosorior> could we pick up the TLS stuff? I gotta go in around 10 min :/
14:39:29 <dprince> trown: you meantioned TLS
14:39:37 <dprince> #link https://review.openstack.org/#/c/231930/
14:40:09 <trown> dprince: nope I mentioned a different three letter acronym :)
14:40:11 <dprince> jaosorior: this is blocked on the puppet keystone stuff
14:40:32 <dprince> jaosorior: which I think is getting some love now, so I'd expect more eyes on this soon
14:40:53 <jaosorior> dprince, well,the patch it depends on which is this one https://review.openstack.org/#/c/230375/39 only needs a workflow
14:40:58 <jaosorior> and there was another one that was merged already
14:41:17 <tremble> Also https://review.openstack.org/#/c/238887/ is part of the chain of CRs after it we'd like some eyes on re the general approach
14:41:20 <jaosorior> but I already did the splitting of the TLS patch as suggested by marios
14:42:59 <jaosorior> so the patch that tremble is pointing to, mostly is work directed towards making the TLS patch more testable
14:43:18 <slagle> did anyone test stack-update'ing a cloud that was deployed with os-cloud-config keystone to one that uses puppet managed keystone?
14:43:40 <slagle> i was doing this for the parallel patch for the undercloud, and it was failing pretty badly
14:43:52 <dprince> jaosorior: okay, I've added it to review priorities
14:43:57 <dprince> jaosorior: thanks for highlighting this
14:44:15 <jaosorior> currently the keystone endpoints are IPs, which is not something that's very easily tested if we want to start deploying the certificates; on the other hand, we also make the ports and the protocol (http or https) configurable
14:44:24 <jaosorior> and in one single place
14:44:55 <dprince> slagle: not me
14:45:11 <dprince> slagle: perhaps we should wait until our "upgrades" CI job is in place before landing?
14:45:45 <gfidente> one thing I was thinking about the upgrade job, it seems to be we'll want to use some 'upgrade.yaml' in the upgrade job
14:46:05 <gfidente> and we probably want this to be in the tht repo itself, sounds valid?
14:46:27 <dprince> gfidente: you mean a heat environment that contains settings users who upgrade will need?
14:46:30 <slagle> dprince: that would be ideal, but i dont know that we need to completely block on it. i might try it locally if i get the time
14:46:38 <gfidente> dprince, yes
14:47:07 <dprince> slagle: okay, perhaps we just need to leave clear notes on these reviews so we don't miss this
14:47:13 <jaosorior> one option is for me to cherry-pick the TLS and root CA cert injection and make them depend on the current master
14:47:22 <dprince> slagle: I think I +2'd them already without thinking of this
14:47:35 <gfidente> dprince, I am not sure if and how this should be maintained though, it might be dependent on which version one wants to update from
14:47:51 <jaosorior> but but this patch https://review.openstack.org/#/c/238887/ and the subsequent ones are needed to test the tLS stuff
14:49:35 <dprince> jaosorior: okay, are the CI failures in that series valid
14:50:02 <dprince> just noticing a few of them are failing
14:50:04 <jaosorior> dprince, which CI failures?
14:50:08 <tremble> dprince: The Syntax/lint ones are unrelated
14:50:27 <jistr> yeah those are new and haven't got to pass yet afaik
14:50:29 <dprince> ah right, yeah. Just those
14:50:42 <dprince> looks like the "tripleo" ones are all fine
14:50:55 <jaosorior> dprince, currently CI is running them again since I just split some patches into smaller ones. But functional test were passing
14:51:15 <tremble> dprince: Syntax/lint ones are fixed by https://review.openstack.org/#/c/225664/
14:51:56 <dprince> cool, any other reviews to talk about this week?
14:52:12 <jaosorior> hey guys, I gotta go. But thanks for taking the TLS parts into account. Any reviews would be greatly appreciated :)
14:53:03 <dprince> #topic open discussion
14:53:15 <dprince> trown: you mentioned DLM
14:53:23 <trown> yep that is the acronym :)
14:53:43 <trown> but ya I just wanted to put that on the radar for mitaka
14:53:48 <dprince> trown: yeah, second time I got it
14:54:07 <dprince> trown: cool, do you see this as something we'd need to SPEC out?
14:54:11 <trown> looks like we will need to setup zookeeper on the undercloud
14:54:23 <trown> and probably overcloud too
14:54:40 <marios> trown: any links for background/context
14:55:00 <trown> marios: https://trello.com/c/G5kyYZ5e/103-add-dlm-support is the RDO card for it
14:55:26 <trown> zookeeper is not even packaged yet, so it is not a right now thing as much as a by the end of mitaka thing
14:55:34 <marios> trown: thanks
14:56:30 <trown> it also has upgrade implications as far as the migration from db-backed locks to DLM
14:57:13 <dprince> trown: okay, thanks for the heads up on this
14:58:12 <dprince> any other items, issues to bring up this week
14:58:25 <dprince> next meeting will be in a week
15:00:11 <dprince> thanks everyone
15:00:14 <dprince> #endmeeting