14:00:16 <derekh> #startmeeting tripleo
14:00:17 <openstack> Meeting started Tue Mar 15 14:00:16 2016 UTC and is due to finish in 60 minutes.  The chair is derekh. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:22 <openstack> The meeting name has been set to 'tripleo'
14:00:25 <EmilienM> o/
14:00:27 <jdob> o/
14:00:30 <michchap> o/
14:00:30 <jaosorior> o/
14:00:35 <slagle> Hi
14:01:02 <dprince> hi
14:01:21 <adarazs> \o
14:01:23 <bnemec> o/
14:01:32 <derekh> Hi all, dprince isn't around today so I'm gonna try and not mess this up ;-)
14:02:03 <EmilienM> derekh: you have all our support !
14:02:03 <rwsu> hi
14:02:13 <derekh> #topic agenda
14:02:14 <jrist> o/
14:02:20 <derekh> * bugs
14:02:20 <derekh> * Projects releases or stable backports
14:02:20 <derekh> * CI
14:02:20 <derekh> * Specs
14:02:20 <derekh> * open discussion
14:02:30 <derekh> That is our agenda this week. Anything else to add/subtract?
14:02:35 <derekh> shardy isn't able to make it bug want us to discuss  the timeline re mitaka branching, so we'll discuss that in "Projects releases or stable backports"
14:02:55 <derekh> anything else ? 2 minutes
14:03:12 <saneax> o/
14:03:48 <derekh> #topic bugs
14:03:57 * dprince is in another meeting, but lurks if needed
14:04:09 <derekh> ok, any bugs need to be getting attention ?
14:05:54 <derekh> ok, looks like nothing major to be brought up here
14:06:01 <derekh> * Projects releases or stable backports
14:06:08 <derekh> #topic Projects releases or stable backports
14:06:15 <derekh> Let discuass projects needing releases first
14:06:15 <derekh> then liberty stable branhces
14:06:15 <derekh> and finally Mitaka branches
14:06:33 <derekh> So do any projects need releases ?
14:06:59 <derekh> is this mic on ?
14:07:00 <slagle> i planned on doing liberty releases today
14:07:59 <derekh> slagle: ok, this that of a particular project/s ? or a bunch of them ?
14:08:07 <slagle> we will need to do master releases after we branch mitaka
14:08:11 <slagle> derekh: anything needing it
14:08:31 <slagle> so that we bump the major version on master
14:08:31 <derekh> #action slagle to do liberty releases where needed
14:08:46 <derekh> slagle: make sense
14:09:03 <derekh> #info master releases needed once we branch mitaka
14:09:27 <slagle> i think we can branch mitaka this week, if there are no objections
14:09:47 <slagle> we still need to land aodh/gnocchi on master first though
14:09:59 <derekh> so befor moving onto the timing of the mitaka branch anything else need to be brought up about liberty ?
14:10:17 <EmilienM> branching mitaka this week sounds very early
14:10:52 <derekh> Ok, moving on to mitaka so
14:11:01 <derekh> This was the list of blockers we had for creating the Mitaka branches https://etherpad.openstack.org/p/tripleo-mitaka-rc-blockers
14:11:33 <derekh> hows it looking now, somebody(slagle?) mentioned yesterday aodh was the only outstanding thing, if so is it close to merging so we can branch?
14:11:55 <slagle> aodh is close to merging
14:11:55 <EmilienM> I'm wondering if getting IPV6 testing in CI is a blocker to branch Mitaka
14:12:08 <slagle> the dependent patch has passed CI a few times
14:12:28 <slagle> #link https://review.openstack.org/#/c/289435/
14:12:39 <slagle> the depends-on aren't passing though
14:13:11 <slagle> i think there are some circular deps, so we might need to merge it all at once
14:13:22 <bnemec> We should also merge https://review.openstack.org/290570 before branching.
14:13:29 <adarazs> EmilienM: the IPv6 gate passed the overcloud creation, now it has a weird error in the after deploy test with image upload.
14:13:39 <adarazs> EmilienM: so I'd say it's not too far from working.
14:14:02 <derekh> slagle: ack, if the patches are sane, I'm happy to merge together
14:14:37 <derekh> bnemec: +2
14:14:40 <EmilienM> are we going to manage keystone resource with Puppet in stable/mitaka ? https://review.openstack.org/#/c/244162/
14:14:58 <bnemec> I don't think CI needs to block branching.  We don't branch tripleo-ci so we can keep working on CI jobs after the branch happens.
14:15:00 <EmilienM> it's to me, a big change and we need to whether decide if we wait for it or not
14:15:08 <EmilienM> bnemec: right.
14:15:11 <bnemec> Unless lack of a CI job is blocking a functional change merging.
14:15:37 <marios> o/
14:15:55 <slagle> EmilienM: that is a good question. someone would need to drive it forward getting it landed
14:16:06 <EmilienM> AFIK the blocker to land it was upgrade
14:16:11 <bnemec> Yeah, the patch is broken right now.
14:16:20 <EmilienM> I can work on it (again) if you want
14:16:22 <derekh> EmilienM: RE "branching mitaka this week sounds very early" , I disagree here now that RDO has a mitaka repository we should us it, if we don't we'll be developing mitaka tripleo against master openstack
14:16:43 <EmilienM> derekh: I was just comparing with other OpenStack projects
14:17:17 <EmilienM> bnemec: I can try (again) to take over this one
14:17:31 <slagle> personally, i think we could branch without https://review.openstack.org/#/c/244162/, and consider allowing an exception to backport that if we get it working
14:17:41 <slagle> it's not really a feature
14:17:45 <slagle> not really a bugfix either
14:17:55 <EmilienM> it's a "move"
14:18:05 <EmilienM> it will help a lot in composable roles
14:18:18 <slagle> well that won't be in mitaka
14:18:54 <EmilienM> ok, so we don't wait for it
14:19:24 <EmilienM> #action EmilienM to work on Manage keystone initialization directly in t-h-t manifests https://review.openstack.org/#/c/244162/ but don't expect to have it in Mitaka
14:19:27 <EmilienM> slagle: ok ^?
14:19:30 <slagle> wfm
14:19:44 <bnemec> Then we definitely need https://review.openstack.org/#/c/290570/ before we branch
14:19:52 <slagle> trown|ooobootcam: any update on getting an updated consistent repo?
14:20:03 <slagle> fwiw, rdo mitaka was cut from the consistent repo
14:20:08 <slagle> which doesnt work with tripleo right now
14:20:32 <slagle> we do however work with current! b/c i tested it yesterday
14:20:58 <slagle> so we are in a weird state right now, the periodic ha job will never pass right now as is
14:21:18 <derekh> slagle: ooo lemme check why we got no consistent repo
14:21:41 <slagle> yesterday trown|ooobootcam said the delorean builder was down
14:21:51 <slagle> an in fact, even current hasn't been updated since the 13th
14:22:06 <slagle> anyway, we should sync with rdo folks on this, we can move on
14:22:28 <derekh> slagle: yup, its still down, I'll ask on rdo after the meeting
14:23:18 <derekh> so is that an agreement, we can branch once aodh and the deprecated warning are merged ?
14:23:27 <slagle> +1 from me
14:23:45 <derekh> +1
14:23:55 <slagle> we're in agreement! :)
14:24:09 <EmilienM> +1 too
14:24:19 * derekh wonders what quorum is
14:25:13 <d0ugal> o/
14:25:36 <jistr> +1 from me too
14:26:29 <derekh> #info we're free to branch mitaka once aodh and and deprecated message have been merged, then patches merged into mitaka should be fixes only
14:26:49 <derekh> accurate ^ ?
14:27:00 <trown|ooobootcam> nice, sorry a bit distracted
14:27:02 <trown|ooobootcam> +1
14:27:03 <slagle> yes
14:27:44 <derekh> ok, once that happens we'll need to figure out who does the branching but I think we can coordinate that on our usual channel
14:28:24 <derekh> #topic CI
14:28:33 <derekh> We've bumped up the RAM in CI on both the undercloud and overcloud nodes by 1G last week
14:29:09 <derekh> Some of us also spent a bit of time trying to dubug some of the errors we were seeing, looks like the addition of extra nics may have tickled a bug in our test env hosts
14:29:51 <derekh> I believe this will fix it, I'll deploy the fix either tonight or tomorrow night https://review.openstack.org/#/c/292480/
14:30:06 <derekh> Besides that I think overall our pass rate has increased to something more acceptable (although still not perfect)
14:30:38 <derekh> the ceph job has been re purposed to be the new upgrades job and has been renamed, merge this so it appears on the cistatus page https://review.openstack.org/#/c/292359/
14:30:54 <derekh> Also the patch to start using a mirror server is still hanging out there, https://review.openstack.org/#/q/topic:mirror-server
14:31:02 <derekh> would be nice to get some eyeballs on it, it should increase reliability and speed.
14:31:15 <derekh> that all I got on CI anybody got anything else ?
14:31:17 <slagle> merged https://review.openstack.org/#/c/292359
14:31:27 <derekh> slagle: thanks
14:32:14 <derekh> ok, moving on
14:32:16 <derekh> #topic specs
14:32:56 <derekh> Would anybody like to draw attention to any specs ?
14:34:38 <derekh> nope,
14:34:49 <derekh> #topic open discussion
14:35:13 <EmilienM> just an FYI, michchap and I are working on composable roles
14:35:29 <EmilienM> we have a PoC : https://review.openstack.org/#/c/292712
14:35:38 <derekh> EmilienM: cool
14:35:42 <EmilienM> and https://review.openstack.org/289459 /  https://review.openstack.org/289466
14:35:50 <michchap> (just the puppet side for now)
14:35:56 <EmilienM> we are working on a first iteration where we move out Puppet code from THT to profiles in puppet-tripleo
14:36:19 <derekh> #info  PoC for composable roles https://review.openstack.org/#/c/292712 https://review.openstack.org/289459 /  https://review.openstack.org/289466
14:36:35 <akrivoka> another FYI - tripleo ui is about to get included into upstream tripleo, we are very excited about that: https://review.openstack.org/#/c/291246/
14:36:37 <EmilienM> we are doing a "service by service" iteration
14:38:34 <derekh> akrivoka: great job, I wonder if there is anything we need to do to include it in one of our CI jobs, probably worth discussing at some stage,
14:38:54 <derekh> EmilienM: sounds like a good way to do it
14:39:07 <akrivoka> derekh: ultimately yes, but I think we're not there yet
14:39:37 <derekh> akrivoka: yup, fair enough we can visit the idea once its at the point
14:39:47 <derekh> *that point
14:39:49 <akrivoka> derekh: definitely
14:40:11 <jrist> derekh: when we do, it sounds like akrivoka is becoming the expert :)
14:40:21 <derekh> #info FYI - tripleo ui is about to get included into upstream tripleo https://review.openstack.org/#/c/291246/
14:40:28 <derekh> ;-)
14:40:59 <EmilienM> nice work here!
14:41:20 <derekh> ok, if there is nothing else, I'll close this early, 2 minutes to get in
14:43:25 <derekh> ok, thanks all
14:43:27 <derekh> #endmeeting