14:00:07 <EmilienM> #startmeeting tripleo
14:00:08 <openstack> Meeting started Tue Oct  4 14:00:07 2016 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:11 <jistr> o/
14:00:11 <openstack> The meeting name has been set to 'tripleo'
14:00:14 <hrybacki> o/
14:00:18 <shadower> hey
14:00:19 <trown> o/
14:00:21 <EmilienM> hello folks
14:00:21 <[1]cdearborn> \o
14:00:25 <jpich> o/
14:00:26 <ccamacho> /o/
14:00:26 <mwhahaha> hi2u
14:00:26 <coolsvap> o/
14:00:32 <panda> |o|
14:00:37 <beagles> o/
14:00:43 <jistr> panda: r u a tie fighter
14:00:45 <EmilienM> mwhahaha: hi2u2
14:00:51 <trown> jistr: I thought the same
14:00:58 <jtomasek> o/
14:01:14 <adarazs> o/
14:01:16 <mwhahaha> :o
14:01:24 <rhallisey> hi
14:01:48 <EmilienM> if you have some off items please add them here https://etherpad.openstack.org/p/tripleo-meeting-items
14:01:52 <jcoufal> I mean o/
14:01:57 <derekh> o/
14:02:05 <EmilienM> #topic agenda
14:02:07 <EmilienM> * one off agenda items
14:02:09 <EmilienM> * bugs
14:02:11 <EmilienM> * Projects releases or stable backports
14:02:13 <EmilienM> * CI
14:02:15 <EmilienM> * Specs
14:02:16 <d0ugal> o/
14:02:17 <EmilienM> * open discussion
14:02:19 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:02:34 <mandre> o/
14:03:05 <EmilienM> ok sounds like we don't have off items this week
14:03:14 <EmilienM> so we'll go through the regular agenda items
14:03:21 <EmilienM> #topic bugs
14:03:42 <EmilienM> as a reminder, this week is focused on delivering Newton RC3
14:03:44 <EmilienM> #link https://launchpad.net/tripleo/+milestone/newton-rc3
14:03:55 <EmilienM> we still have 10 bugs open
14:04:32 <EmilienM> everything that is not critical to Newton, should be moved to ocata-1. Please do it yourself if it's the case for your assigned bugs
14:04:43 <weshay> 0/
14:04:44 <bandini> o/
14:04:54 <saneax> o/
14:05:09 <rbrady> o/
14:05:28 <EmilienM> we have 3 bugs triaged but not in progress
14:05:40 <EmilienM> d0ugal, rbrady: any progress on https://bugs.launchpad.net/tripleo/+bug/1626736 ?
14:05:42 <openstack> Launchpad bug 1626736 in tripleo " Unable to delete overcloud node" [Critical,Triaged] - Assigned to Ryan Brady (rbrady)
14:06:14 <marios> o/
14:06:24 <rbrady> EmilienM: Not yet.  I'm looking into it now
14:06:36 <EmilienM> mhh ok
14:06:41 <EmilienM> apetrich: same question for https://bugs.launchpad.net/tripleo/+bug/1623673
14:06:42 <openstack> Launchpad bug 1623673 in tripleo "mixed deployment fails resources.ControllerServicesBaseDeployment_Step2 with status code: 6 " [High,Triaged] - Assigned to Adriano Petrich (apetrich)
14:07:05 <shardy> o/ (sorry I'm late)
14:07:25 <EmilienM> perfect timing
14:07:36 <EmilienM> shardy: https://bugs.launchpad.net/tripleo/+bug/1625783 - any patch coming for this one?
14:07:37 <openstack> Launchpad bug 1625783 in tripleo "unable to leverage swap-partition extraconfig" [High,Triaged] - Assigned to Steven Hardy (shardy)
14:08:08 <shardy> EmilienM: Yes, I actually think it's either already fixed or will be fixed by https://review.openstack.org/#/c/379547/
14:08:11 <apetrich> EmilienM, it is working with workaround there
14:08:13 <EmilienM> I would like to set a limit of Wednesday EOD to have bugfixes merged in master and eventually backported
14:08:17 <shardy> EmilienM: I'll test it this afternoon and confirm on the bug
14:08:21 <EmilienM> we plan to release on Thursday or Friday
14:08:37 <EmilienM> shardy: ack, in that case, please update the bug report
14:09:05 <EmilienM> apetrich: it's not clear to me if we need to fix something or not
14:09:41 <EmilienM> do we have any other bugs to discuss?
14:09:50 <EmilienM> is there an outstanding bug we missed this week?
14:10:11 <shardy> https://bugs.launchpad.net/tripleo/+bugs?field.tag=composable-roles
14:10:21 <shardy> ccamacho and I are trying to solve as many of those as we can before release
14:10:23 <marios> EmilienM: just filed this fyi https://bugs.launchpad.net/tripleo/+bug/1630247 to track the sahara mitaka..newton
14:10:24 <openstack> Launchpad bug 1630247 in tripleo "sahara services during mitaka to newton upgrade" [Undecided,Triaged] - Assigned to Marios Andreou (marios-b)
14:10:29 <shardy> but some may have to be backported after GA
14:10:51 <EmilienM> marios: excellent. Upgrade bugs are High or Critical and targeted for RC3 of course
14:10:53 <ccamacho> all submissions tagged as tripleo/rc3
14:11:04 <EmilienM> shardy: ack, i'll try to make the RC3 release as late as I can this week
14:11:12 <EmilienM> shardy: I'll sync with Doug on that topic
14:11:28 <shardy> EmilienM: sounds good, thanks!
14:11:33 <EmilienM> shardy: anyway, I think those are candidates to be backported
14:11:36 <apetrich> EmilienM, I'm not completely sure myself, I will comment my thoughts in the bug and we can go from there if that's ok
14:11:43 <EmilienM> apetrich: ok thx.
14:11:49 <EmilienM> anything else about bugs?
14:12:13 <EmilienM> marios: don't forget to set "importance" of bugs when you report
14:12:16 <rhallisey> https://review.openstack.org/#/c/375540/
14:12:17 <EmilienM> and milestone
14:12:20 <rhallisey> ^ easy review
14:12:23 <EmilienM> marios: otherwise it's not in our radar
14:12:26 <rhallisey> related to upgrades/updates
14:12:42 <EmilienM> ... same for rhallisey https://bugs.launchpad.net/tripleo/+bug/1623978
14:12:44 <openstack> Launchpad bug 1623978 in tripleo "overcloud update fails because of missing template in swift" [Undecided,In progress] - Assigned to Ryan Hallisey (rthall14)
14:12:44 <marios> EmilienM: ack thanks
14:12:47 <EmilienM> no milestone, no importance
14:12:54 <EmilienM> I already sent reminders about that
14:13:05 <EmilienM> please do auto triage, we don't have enough resources to triage all incoming bugs
14:13:45 <EmilienM> #action EmilienM to configure launchpad with a message to make auto triage when creating new bugs
14:14:15 <EmilienM> anything else about bugs?
14:14:46 <EmilienM> #topic Projects releases or stable backports
14:14:54 <EmilienM> so a couple of reminders :
14:15:14 <EmilienM> 1) please backport your patches that have been merged in master, into stable/newton, if they fix a bug that was targeted for RC3.
14:15:42 <EmilienM> 2) we'll tag RC3 (Final Newton) by end of week
14:16:09 <EmilienM> after RC3, I encourage people to continue backports for critical/high bugs, specially about upgrades
14:16:32 <EmilienM> there is nothing blocking us to propose a new Newton release after final release
14:16:51 <EmilienM> do we have any question/feedback about release management?
14:17:31 <EmilienM> #topic CI
14:17:54 <EmilienM> matbu, weshay: do where are we with third party jobs to test tripleo upgrades?
14:18:01 <EmilienM> s/do/so/
14:18:23 <matbu> EmilienM: for third party idk
14:18:47 <EmilienM> I remember an action from you to start looking at it
14:18:48 <matbu> EmilienM: for upstream CI, it should be fix by the https://review.openstack.org/379547
14:19:19 <weshay> the jobs are in ci.centos and available, not passing obviously for mitaka -> master
14:19:27 <EmilienM> matbu: ok
14:19:35 <matbu> EmilienM: yes i started to look at, but tripleo-quickstart wasn't ready, the topic is in the hand of apetrich i guess
14:19:43 <EmilienM> matbu: ok good
14:20:07 <EmilienM> matbu: oh I remember now "matbu to move upgrade jobs to ovb and use experimental pipeline until it's stabilized then periodic + experimental"
14:20:14 <EmilienM> is it done? ^
14:20:14 <matbu> EmilienM: the review ^ should also fix the update jobs
14:20:22 <matbu> EmilienM: yep
14:20:25 <EmilienM> good.
14:20:47 <matbu> EmilienM: we loose time to fight with multinode with those jobs :/
14:21:03 <EmilienM> bnemec, derekh, dprince, slagle: anything special to mention about CI this week?
14:21:10 <EmilienM> sshnaidm: also ^
14:21:23 <dprince> nothing from me
14:21:30 <derekh> ditto
14:21:37 <slagle> matbu: what do you mean "fight with multinode"?
14:22:50 <slagle> EmilienM: nothing major other than I'm trying to get the uc upgrade job passing, and have moved the job to run on both instack-undercloud and tripleoclient
14:22:58 <slagle> as previously it was only running on tripleo-ci patches
14:23:00 <EmilienM> cool ^
14:23:04 <matbu> slagle: i mean we got (i and sshnaidm ) some failure, the job wasn't consistent
14:23:14 <EmilienM> matbu: failures on what?
14:23:37 <matbu> EmilienM: on upgrade job, when trying to install the undercloud
14:23:42 <slagle> matbu: i've not seen the failures. is there a bug?
14:23:52 <matbu> slagle: yep i fill a LP
14:24:25 <slagle> please link it here and I will look
14:24:28 * matbu trying to find the number
14:25:57 <bnemec> Hmm,  I see the ipv6 job finally passed.  I wonder why the updates job still won't.
14:25:58 <matbu> slagle: https://bugs.launchpad.net/tripleo/+bug/1624448
14:25:59 <openstack> Launchpad bug 1624448 in tripleo "CI Upgrade job hang or failed on undercloud install" [Undecided,New]
14:26:41 <EmilienM> bnemec: me too, i'm wondering if we should move the job to the gate or just set ipv6 by default in ha job?
14:27:01 <slagle> matbu: thanks. i will push a patch for that today. it doesnt happen very frequently, but it should be relatively easy to address.
14:27:23 <EmilienM> slagle, matbu : thanks
14:27:24 <matbu> slagle: ack, with the upgrade job it was arround 80% of the time
14:27:28 <panda> EmilienM: I think making it a gate was the main point for newton
14:27:30 <bnemec> EmilienM: I can try to reproduce the updates job failure locally.  It's a single node pacemaker setup, so it is a little different from full ha.
14:28:09 <matbu> slagle: but the workflow is a bit different than a classic job (i mean, start with a stable/mitaka, deploy, then build repo and upgrade)
14:28:10 <EmilienM> bnemec: wdyt about switching current ovb job (HA) to ipv6 by default?
14:28:35 <panda> EmilienM: don't we have to test ha ipv4 jobs too ?
14:28:36 <bnemec> EmilienM: Then we lose coverage of the ipv4 net-iso case.
14:28:52 <EmilienM> bnemec: non-ha is testing net-iso?
14:28:58 <bnemec> EmilienM: No
14:29:13 <bnemec> At least IIRC
14:29:22 <slagle> matbu: ack, it just has to do with different cloud instances have different interface(s) and names. but we can account for that in tripleo-ci
14:29:34 <panda> bnemec: I too remember it's not
14:29:53 <EmilienM> bnemec: ok. Well, we might want to 1) enable net-iso on nonha and 2) enable ipv6 on ha
14:29:54 <matbu> slagle: k
14:29:56 <EmilienM> wdyt?
14:30:06 <bnemec> slagle: Could you just pass nic2 and let os-net-config map it?
14:30:32 <slagle> bnemec: i'm not even sure all the instances have 2 nics
14:30:44 <slagle> bnemec: i don't think all the cloud providers used by nodepool use static ip's
14:30:51 <bnemec> Oh, that would be a problem.
14:30:52 <slagle> some only have 1
14:30:59 <slagle> 1 interface
14:33:05 <EmilienM> any thoughts on my proposal?
14:33:31 <EmilienM> slagle: or have we tried to run multinode jobs with ipv6?
14:34:23 <EmilienM> ok sounds like we'll catch-up after the meeting
14:34:43 <EmilienM> anything else about CI this week?
14:35:03 <slagle> EmilienM: someone could try it
14:35:22 <panda> I can try it
14:36:04 <EmilienM> panda: we are interested on having both ipv4 and ipv6 coverage
14:36:08 <EmilienM> so let's see what we can do
14:36:26 <EmilienM> #action panda and EmilienM to investigate how to gate with ipv6 with current jobs
14:36:52 <EmilienM> #topic specs
14:36:55 <EmilienM> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:37:47 <EmilienM> it's more a reminder, if you would like your spec ready to be discussed and approved by end of next Summit, please update it, make sure it pass CI and maybe engage discussion on mailing list about the spec.
14:38:43 <EmilienM> anything else about specs?
14:39:26 <EmilienM> #topic open discussion
14:39:54 <EmilienM> I have (another) reminder for Summit: https://etherpad.openstack.org/p/ocata-tripleo
14:40:19 <EmilienM> feel free to polish and prepare our design sessions, I'll continue to work on the agenda next week after RC3 thing
14:40:38 <EmilienM> sounds like we start to have a bunch of sessions, /me looking forward
14:41:19 <EmilienM> I'll keep the discussion open a little bit, feel free to ask anything or give any feedback now
14:42:22 <EmilienM> sounds like we're good for this week, thanks for your time!
14:42:29 <EmilienM> #endmeeting