14:00:47 <EmilienM> #startmeeting tripleo
14:00:48 <openstack> Meeting started Tue Dec  6 14:00:47 2016 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:51 <openstack> The meeting name has been set to 'tripleo'
14:00:52 <EmilienM> hello folks!
14:00:55 <bandini> o/
14:00:55 <thrash> o/
14:01:00 <d0ugal> o/
14:01:05 <trown> o/
14:01:16 <marios> \o
14:01:35 <hrybacki> o/
14:01:41 <EmilienM> #topic agenda
14:01:43 <EmilienM> * one off agenda items
14:01:45 <EmilienM> * bugs
14:01:47 <EmilienM> * Projects releases or stable backports
14:01:49 <EmilienM> * CI
14:01:51 <EmilienM> * Specs
14:01:53 <EmilienM> * open discussion
14:01:55 <EmilienM> * review past actions items
14:02:19 <EmilienM> feel free to add off items https://etherpad.openstack.org/p/tripleo-meeting-items
14:02:28 <mwhahaha> o/
14:02:49 <EmilienM> let's start!
14:02:56 <EmilienM> #topic review past actions items
14:03:04 <sshnaidm> o/
14:03:05 <beagles> o/
14:03:17 <EmilienM> jpich to propose a policy for TripleO Spec Reviews: DONE with https://review.openstack.org/#/c/406264/
14:03:24 <EmilienM> jpich: thx a lot for ^
14:03:28 <EmilienM> now we need to review it :)
14:03:53 <EmilienM> #action team to review tripleo spec reviews policy https://review.openstack.org/#/c/406264/
14:04:06 <jpich> Looking forward to the feedback (though it's mainly a straight up migration from the wiki)
14:04:32 <EmilienM> ++ excellent. Maybe we can approve this patch if it's a copy/paste from wiki, and eventually make changes through Gerrit?
14:04:42 <EmilienM> (in separated patches)
14:05:01 <bandini> +1
14:05:04 <jpich> EmilienM: Sure, I can break it down into two patches (I indicated the one bit I added to the commit message)
14:05:12 <marios> jpich: /me quickly scanning, ws about to compliment you on how well it was written didn't realise it was from the wiki anyway will look closer
14:05:16 <beagles> agreed
14:05:21 <marios> jpich: but EmilienM +1 land and iterate
14:05:27 <EmilienM> jpich: that would be great, it makes things easier to review
14:05:43 <EmilienM> marios: lol :D you can still compliment her to work on it :D
14:05:51 <jpich> Ok, I'll workflow -1 and break it down during the week
14:05:56 <EmilienM> excellent
14:05:57 <marios> EmilienM: heh :)
14:06:13 <EmilienM> #action jpich to breakdown https://review.openstack.org/#/c/406264/
14:06:20 <EmilienM> matbu to build upgrade jobs for N to O
14:06:24 <EmilienM> matbu lets use oooq in tripleo-ci for periodics M to N jobs
14:06:44 <EmilienM> sshnaidm, matbu: so I saw the upgrade job is making progress. Can you give updates maybe?
14:06:45 <matbu> EmilienM: yep the N to O is here: https://review.openstack.org/404831
14:07:23 <EmilienM> matbu: excellent. What are our current blockers?
14:07:25 <matbu> EmilienM: i have adressed shardy's comments (ie deploy a O undercloud and just get newton OC images)
14:08:00 <matbu> EmilienM: the goal is to not upgrade the undercloud in this job
14:08:38 <EmilienM> sounds good to me
14:08:41 <EmilienM> and a good first iteration
14:08:45 <EmilienM> we'll also save runtime
14:08:57 <marios> matbu: just the templates?
14:09:01 <EmilienM> matbu: let us know if you hit any problem / blocker, as usual :)
14:09:04 <matbu> yep, so i'm trying to make this solution work
14:09:33 <EmilienM> matbu: and some progress on periodic jobs? or not yet?
14:09:35 <matbu> EmilienM: yep sure, i tried something, idk if it's the right way to do it
14:09:55 <matbu> EmilienM: not yet, but i'm afraid we will also hit the timeout
14:10:14 <matbu> EmilienM: since it's executed on the upstream infra , right ?
14:10:14 <EmilienM> matbu: right. I think N to O is currently high prio
14:10:23 <matbu> EmilienM: yep true
14:10:33 <matbu> marios: just the templates ?
14:10:34 <EmilienM> matbu: it's executed on rh1, ovb iirc
14:10:56 <marios> matbu: i mean if we aren't upgrading the undercloud then what templates are you using for the overcloud upgrade
14:11:14 <marios> matbu: are you just updating the tripleo-heat-templates but not upgrading the rest of the undercloud?
14:11:41 <marios> matbu: anyway, i haven't looked at the n..o review you have out yet /me looking now and will look closer will ask you on irc later/scrum etc
14:11:46 <EmilienM> I think that's the idea
14:11:55 <EmilienM> let's move to our topics
14:12:00 <EmilienM> #topic one off agenda items
14:12:01 <matbu> marios: it would be like a mixed deploy
14:12:21 <EmilienM> beagles: you want to start?
14:12:30 <EmilienM> (beagles) any objections to cleaning up (abandoning) old reviews, eg:https://review.openstack.org/#/q/project:openstack/tripleo-heat-templates+status:open+age:6mon
14:12:32 <matbu> marios: start with the Ocata undercloud and Newton overcloud and then upgrade the newton overcloud to ocata
14:12:44 <beagles> EmilienM, sure.. minor thing, lots of very old reviews kicking around
14:12:44 <EmilienM> I think it's a good idea and I also think we should document in TripleO policies
14:12:55 <bandini> agreed
14:12:56 <EmilienM> beagles: we have the same problem in Puppet modules
14:13:00 <EmilienM> and 6 months looks fair
14:13:07 <marios> matbu: i see so you already have the templates thanks it makes sense
14:13:21 <marios> matbu: i mean you start with the newer already upgraded undercloud, so you don't need to upgrade as part of the job
14:13:23 <beagles> EmilienM, ok cool. I'll swing through, starting from oldest
14:13:26 <marios> matbu: nice
14:13:40 <EmilienM> beagles: would you also volunteer to document it in a policy?
14:13:42 <marios> beagles: +1 thanks i have a couple in there
14:13:48 <beagles> EmilienM, sure
14:13:58 <bandini> beagles: +1
14:14:19 <marios> beagles: really no biggie/no brainer if someone really wants to they can just restore it
14:14:22 <marios> !
14:14:25 <beagles> yup
14:14:27 <EmilienM> marios, matbu: thanks for this disussion, it's indeed more clear to me now :)
14:14:42 <EmilienM> beagles: thanks!
14:15:00 <EmilienM> #action beagles to abandon old reviews and propose a policy to document it
14:15:10 <EmilienM> (bandini) Do we have any ETA on when Centos 7.3 will be released and when we will switch to it? I need a specific pcs feature that is 7.3 only in my composable HA work
14:15:26 <EmilienM> bandini: I think that's a question for centos-devel channel
14:15:31 <EmilienM> have we asked there?
14:15:32 <bandini> yep :) Does anyone here know or do I need to poke the centos folks?
14:15:50 <EmilienM> I use to jump on #centos-devel (freenode)
14:15:56 <bandini> no, not yet. if came up last night and I thought maybe folks here know already
14:16:09 <trown> bandini: it is already available via the CR repo, so soon?
14:16:18 <bandini> how much time do we think we need to switch to it for CI, once it is released?
14:16:23 <EmilienM> I was told "this week" last time I checked
14:16:25 <snecklifter> bandini: if it helps, I've been testing with virt-customize and CentOS-CR repo
14:16:28 <EmilienM> but it might have be delayed
14:16:43 <bandini> snecklifter: yeah that is what I am doing, but am wondering about the various deadlines
14:16:52 <bandini> thanks *. I will check in centos-devel
14:17:07 <EmilienM> trown: have we tried tripleo with centos 7.3 already somewhere?
14:17:18 <snecklifter> I think they have a standard response. "When its done".
14:17:23 * EmilienM is prepared to the worst :)
14:17:25 <trown> EmilienM: not in RDO yet
14:17:35 <EmilienM> trown: mhh, ok
14:17:39 <EmilienM> I'm taking an action here
14:17:40 <snecklifter> I am using it with Newton now
14:17:40 <bandini> yeah it would also be nice to have 7.3 because it reduces the gap with downstream
14:17:55 <EmilienM> #action EmilienM to test tripleo with centos7.3 and see how it goes
14:18:02 <EmilienM> snecklifter: and how does it work?
14:18:07 <EmilienM> would we have some blockers/workarounds?
14:18:08 <snecklifter> seems ok except I need later version of qemu-kvm-common-ev
14:18:23 <snecklifter> passing tempest in the same way as Mitaka
14:18:30 <EmilienM> oh I've heard about that. RDO plans to update it, if not already but it would be for Ocata only.
14:18:42 <snecklifter> https://bugzilla.redhat.com/show_bug.cgi?id=1371617
14:18:42 <openstack> bugzilla.redhat.com bug 1371617 in libvirt "Libvirt passes unsupported "arat" flag to QEMU when using host-model" [High,Assigned] - Assigned to jdenemar
14:19:01 <EmilienM> snecklifter: we can still ask on #rdo about this package. I remember folks mentionning it recently
14:19:02 <snecklifter> ^^^ thats the problem so will prob need to be updated for all branches
14:19:12 <snecklifter> EmilienM: ack, was waiting for dmsimard
14:19:16 <EmilienM> cool
14:19:28 <EmilienM> are we good with off items?
14:19:40 <bandini> yep I am good thanks
14:19:47 <EmilienM> ok let's continue
14:19:50 <EmilienM> #topic bugs
14:20:27 <EmilienM> ocata-2 : 2 New, 15 Confirmed, 53 Triaged, 32 In Progress
14:20:37 <EmilienM> I think a lot of bugs will move to ocata-3
14:21:15 <EmilienM> I'm not aware about any critical bug we have right now in CI, but I might have missed something. Please raise any critical bug we should take care of
14:21:51 <EmilienM> sshnaidm: we even got a packaging promotion. What happenned ? :)
14:21:54 <EmilienM> #link https://launchpad.net/tripleo/+milestone/ocata-2
14:23:06 <EmilienM> anything else about bugs?
14:23:18 <EmilienM> #topic Projects releases or stable backports
14:23:26 <EmilienM> so we'll cut ocata-2 next week
14:23:39 <sshnaidm> EmilienM, nothing special :)
14:24:10 <EmilienM> please let me know if you want me to wait for a patch to land before we cut ocata-2
14:24:32 <EmilienM> otherwise we'll proceed to the release by next Thursday
14:25:08 <EmilienM> I also think it will be a good time to release a new Newton version, we backported a bunch of things lately
14:25:15 <EmilienM> same thing, let me know if some patches need to land before
14:25:30 <EmilienM> any question about release management?
14:25:53 <EmilienM> #topic CI
14:25:57 <beagles> is it wortwhile sending a reminder/notice email re: backports to the mailing list
14:26:13 <jpich> They seem easily forgotten so, can't hurt!
14:26:31 <beagles> I guess that might be part of the release protocol anyways ...
14:26:44 <beagles> I forget ;)
14:26:52 <EmilienM> before I forget, dprince added a new link on http://tripleo.org/ for http://status-tripleoci.rhcloud.com/
14:26:59 <EmilienM> bookmark this link ^ :)
14:27:09 <EmilienM> beagles: definitly
14:27:22 <EmilienM> #action EmilienM to send update on ML about releases ocata-2 and newton
14:27:24 <EmilienM> beagles: thx :)
14:27:54 <beagles> that's a cool page
14:28:36 <EmilienM> we still have some patches from slagle about 3-nodes testing
14:28:37 <EmilienM> https://review.openstack.org/#/q/status:open+project:openstack-infra/tripleo-ci+branch:master+topic:3-node
14:28:42 <EmilienM> if folks could review it ^
14:30:02 <EmilienM> i also sent an update on ML about scenarios status
14:30:16 * EmilienM is looking for URL
14:31:25 <EmilienM> ok I can't find it now
14:31:29 <EmilienM> but it's on ML :)
14:31:37 <EmilienM> [openstack-dev] [tripleo] CI scenarios design - how to add more services
14:31:52 <EmilienM> feel free to reach out if you want to contribute to scenarios
14:32:06 <EmilienM> do we have anything else about CI this week?
14:32:08 <jpich> http://lists.openstack.org/pipermail/openstack-dev/2016-December/108459.html
14:32:34 <EmilienM> matbu, weshay_: quick question, any progress on container CI job this week? I saw a patch in OOOQ that was waiting to be reviewed
14:32:45 <EmilienM> jpich: thx :)
14:33:31 <EmilienM> some patches in quickstart need to be reviewed for container CI work
14:33:40 <EmilienM> https://review.openstack.org/#/c/393348/ https://review.openstack.org/#/c/400986/ are some of them
14:33:49 <EmilienM> and https://review.openstack.org/#/c/400983/
14:34:06 <EmilienM> anything else on CI this week?
14:34:12 <hrybacki> EmilienM: weshay_ is pto this week -- last update I heard from him was in the email sent out to openstack-dev (to which you responded)
14:35:14 <EmilienM> hrybacki: I think imain did
14:35:19 <EmilienM> ok let's move forward
14:35:28 <EmilienM> #topic Specs
14:35:43 <EmilienM> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:35:56 <EmilienM> reminder: specs will be frozen by next week
14:36:36 <EmilienM> I've been told the one with Tendrl will be postponed to Pike, can you confirm gfidente ?
14:36:46 <matbu> EmilienM: i have no info about that
14:36:50 <gfidente> EmilienM, yes I think that is fine
14:36:58 <EmilienM> #link https://review.openstack.org/#/c/387631/
14:37:10 <EmilienM> matbu: np
14:37:35 <gfidente> EmilienM, I will leave a comment there
14:37:36 <EmilienM> if there is any spec at risk and you think we should land it, please also let us know
14:37:43 <EmilienM> gfidente: excellent
14:38:20 <EmilienM> once we've reached ocata-2, I'll -2 ocata specs and ask folks to move them to the pike directory (that we need to create first)
14:39:00 <gfidente> yeah I just commented thatr
14:39:01 <gfidente> thanks
14:39:26 <EmilienM> any feedback / question about specs?
14:40:04 <EmilienM> ok, next & last topic:
14:40:09 <EmilienM> #topic open discussion
14:40:27 <EmilienM> feel free to ask any question or give any feedback, it's the right time :)
14:40:39 <jpich> FYI, I just updated the previously mentioned policy on spec reviews: the straight-up migration from the wiki is still at https://review.openstack.org/#/c/406264/ and the new bits are now at https://review.openstack.org/#/c/407533/
14:41:06 <EmilienM> jpich: merged!
14:42:16 <EmilienM> anything else for this week?
14:42:22 <jpich> EmilienM: Cool! I'll drop a note to the list about it once it's done merging
14:42:42 <EmilienM> cool
14:42:56 <EmilienM> I'll let the meeting open for one more minute if you want to add something
14:44:23 <EmilienM> thanks folks
14:44:25 <EmilienM> have a good week
14:44:27 <EmilienM> #endmeeting