14:00:02 <EmilienM> #startmeeting tripleo
14:00:03 <openstack> Meeting started Tue Jan  3 14:00:02 2017 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:07 <openstack> The meeting name has been set to 'tripleo'
14:00:22 <EmilienM> #topic agenda
14:00:29 <EmilienM> * review past actions items
14:00:33 <EmilienM> * one off agenda items
14:00:35 <EmilienM> * bugs
14:00:37 <EmilienM> * Projects releases or stable backports
14:00:39 <EmilienM> * CI
14:00:41 <EmilienM> * Specs
14:00:43 <EmilienM> * open discussion
14:00:45 <EmilienM> who is around today?
14:00:48 <dtantsur> o/
14:00:49 <mwhahaha> o/
14:00:51 <fultonj> o/
14:00:52 <marios> hello
14:00:52 <hrybacki> o/
14:00:52 <jpich> o/
14:00:52 <shadower> hey
14:00:56 <weshay> o/
14:01:01 <gfidente> hello :)
14:01:05 <EmilienM> ok first:
14:01:09 <EmilienM> HAPPY NEW YEAR EVERYONE
14:01:18 <ccamacho|lunch> hey guys!
14:01:19 <dprince> hi
14:01:29 <ccamacho> o/
14:01:30 <EmilienM> I hope you had some rest during the break because we have a lot of things coming up :-D
14:02:30 <EmilienM> #topic review past actions items
14:02:32 <EmilienM> HA & puppet experts to look https://review.openstack.org/#/c/408726/
14:02:56 <EmilienM> looks like the patch is not in good shape (CI is red and need rebasing)
14:03:01 <EmilienM> we'll postpone the review
14:03:09 <EmilienM> EmilienM to organize TripleO Bug Squash Day, that will happen after the break
14:03:20 <EmilienM> I haven't done it yet, and I'll this week
14:03:35 <EmilienM> #action EmilienM to organize TripleO Bug Squash Day, that will happen after the break (postponed)
14:03:45 <EmilienM> matbu, slagle to figure undercloud major upgrade job status
14:04:00 <EmilienM> matbu, slagle: any update on this action? ^
14:04:08 <EmilienM> EmilienM sends an email to start preparing PTG : DONE
14:05:02 <EmilienM> matbu & slagle seem away now, I'll check later
14:05:18 <shardy> o/ sorry I'm late
14:05:30 <shardy> happy new year all :)
14:05:32 <EmilienM> #topic milienM sends an email to start preparing PTG
14:05:33 <EmilienM> damn
14:05:36 <EmilienM> #undo
14:05:36 <openstack> Removing item from minutes: #topic milienM sends an email to start preparing PTG
14:05:52 <EmilienM> that happens when you don't use a keyboard during 10 days
14:05:55 <adarazs> o/
14:06:03 <EmilienM> #topic one off agenda items
14:06:24 <EmilienM> I have one topic
14:06:40 <shardy> EmilienM: I'm looking into the upgrade job problems with matbu - I think there is a problem with the bootstrap script but not yet debugged it
14:06:49 <shardy> we may need some help from slagle when he's around
14:06:51 <EmilienM> OpenStack Marketing team is asking PTLs to propose one question per project for the User Survey
14:06:58 <EmilienM> I started https://etherpad.openstack.org/p/tripleo-user-survey-2017
14:07:04 <EmilienM> shardy: ack, thx
14:07:08 <jtomasek> o/
14:07:37 <EmilienM> if you would like to ask one question to our users, which one would it be?
14:07:44 <EmilienM> feel free to give feedback on this etherpad
14:07:53 <EmilienM> i'll also send it to the mailing-list after the meeting.
14:08:41 <EmilienM> #topic bugs
14:09:12 <EmilienM> we have a bunch of untriaged bugs (because of the break) - I'll look today, any help is welcome
14:09:17 <EmilienM> #link https://launchpad.net/tripleo/+milestone/ocata-3
14:09:32 <EmilienM> we still have 1 Confirmed, 89 Triaged, 50 In Progress
14:09:46 <EmilienM> which is 140 bugs open for Ocata
14:10:16 <EmilienM> if you're assigned to a bug, please make sure you've updated it with latest status
14:10:35 <EmilienM> also, some bugs seem to be RFE. We might want to move them to Pike.
14:10:42 <EmilienM> again, any help here is appreciated :-)
14:10:51 <slagle> shardy: in that job you sent me, you can look in /var/log/deployed-server-os-collect-config.txt.gz for the bootstrap occ log
14:11:10 <shardy> slagle: ack, thanks will do
14:11:12 <slagle> shardy: it's getting that "null" from heat, so must be something wrong in the template
14:11:22 <EmilienM> slagle: any update on the conversation we had about undercloud major upgrade?
14:11:40 <EmilienM> slagle: I remember we weren't sure if we perform actual major upgrades
14:11:42 <slagle> EmilienM: could you refresh my memory on what that conversation was about? :)
14:11:57 <EmilienM> matbu was saying that we weren't upgrading newton to ocata
14:11:59 <slagle> oh, i think there was a patch to fix that
14:12:13 <shardy> slagle: ack, thanks for the pointer, that may help isolate the problem - still trying to reproduce locally
14:12:36 <slagle> EmilienM: https://review.openstack.org/#/c/413106/
14:12:49 <EmilienM> slagle: problem solved!
14:13:10 <EmilienM> any outstanding bug to discuss this week folks?
14:13:47 <marios> EmilienM: i am hitting this one on my downstream setup after today https://bugs.launchpad.net/tripleo/+bug/1649341 - shardy looks like that is still in progres/things landed
14:13:49 <openstack> Launchpad bug 1649341 in tripleo "Undercloud upgrade fails with "Cell mappings are not created, but required for Ocata"" [Critical,In progress] - Assigned to Alex Schultz (alex-schultz)
14:14:14 <EmilienM> marios: afik mwhahaha is working on this one
14:14:27 <EmilienM> and afik we're close to have it fixed (if not done already)
14:14:56 <shardy> EmilienM, marios: yeah I pulled the undercloud patches locally and it got me past the issues
14:14:57 <marios> EmilienM: ok i was happy to see it already reported upstream (the downstream trails by at least a week usually plus break)
14:15:18 <EmilienM> anything else about bugs?
14:15:40 <EmilienM> #topic Projects releases or stable backports
14:15:49 <marios> shardy: thanks may ask you about that later
14:15:53 <EmilienM> #link https://releases.openstack.org/ocata/schedule.html
14:16:14 <EmilienM> 2 infos:
14:16:24 <EmilienM> Jan 16-20 is Final release for non-client libraries
14:16:36 <EmilienM> (I think it's Oslo things)
14:16:40 <EmilienM> and:
14:16:50 <shardy> We ran into problems here last cycle, as there were some folks considering tripleo-common a library
14:17:02 <EmilienM> Jan 23-27 is Ocata-3 milestone / Feature freeze / Final release for client libraries
14:17:09 <shardy> so worth clarifying that with dhellmann prior to the deadline I think
14:17:53 <EmilienM> #action clarify if tripleo-common should be considered as a library or not
14:18:24 <shardy> FWIW I think we shouldn't be considering any tripleo repos externally consumable libraries (perhaps with the exception of tripleoclient?)
14:18:26 <EmilienM> I would like to branch stable/newton as late as possible to avoid backports
14:18:43 <EmilienM> shardy: I agree.
14:19:05 <shardy> EmilienM: cool, it may be we need to change some tags for avoidance of confusion this time
14:19:29 <EmilienM> #action EmilienM to update governance/tripleo tags
14:19:50 <EmilienM> any question / comment about release management?
14:20:09 <EmilienM> #topic CI
14:20:12 <trown> +1 to tripleo-common not being an external library
14:20:39 <EmilienM> it seems like CI was pretty stable during the break
14:20:55 <EmilienM> I'm trying to create a new CI job that would test composable HA scenario: https://review.openstack.org/#/c/414585/ - any feedback is welcome
14:21:50 <slagle> EmilienM: should we propose moving the 3nodes job to non-experimental?
14:22:12 <slagle> might be nice to see how stable that is running on all patches
14:22:12 <EmilienM> slagle: I think it would be a good idea. Maybe in periodic?
14:22:19 <slagle> before trying to go to 4 nodes
14:22:19 <EmilienM> oh, on all patches?
14:22:34 <EmilienM> only for THT then, maybe.
14:23:00 <slagle> sure, that would work
14:23:11 <shardy> +1 sounds good
14:23:40 <EmilienM> #action move 3nodes job to THT check -nv
14:23:52 <EmilienM> any other update on CI?
14:24:08 <sshnaidm> fyi, the promotion-blocking bug has a patch: https://review.openstack.org/#/c/416078/
14:24:26 <sshnaidm> I've tested it yesterday with manual promotion
14:24:53 <EmilienM> sshnaidm: lgtm
14:25:06 <sshnaidm> I'm talking about https://bugs.launchpad.net/tripleo/+bug/1651811 seems like alert tag doesn't work..
14:25:07 <openstack> Launchpad bug 1651811 in tripleo "CI: undercloud idempotency step fails because of out of memory" [High,Triaged]
14:25:34 <EmilienM> oops
14:25:50 <EmilienM> do we know where the alert script is running from?
14:25:50 <sshnaidm> containers patches were merged and promoted, so container CI job task is unblocked and I'm working on it
14:26:00 <EmilienM> sshnaidm: excellent news!
14:26:16 <sshnaidm> EmilienM, the script is in infra somewhere..
14:26:40 <EmilienM> ok
14:26:44 <EmilienM> anything else about CI?
14:27:05 <sshnaidm> that's it
14:27:11 <EmilienM> #topic Specs
14:27:30 <EmilienM> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:28:06 <EmilienM> not sure we need to discuss much here
14:28:12 <EmilienM> but all specs from now are targeted for Pike.
14:30:08 <EmilienM> #topic open discussion
14:30:31 <EmilienM> feel free to ask anything or give feedback
14:31:16 <EmilienM> ok sounds like we're done
14:31:22 <EmilienM> thanks folks, see you next week!
14:31:25 <EmilienM> #endmeeting