14:29:14 <EmilienM> #startmeeting tripleo
14:29:15 <openstack> Meeting started Tue Jan 10 14:29:14 2017 UTC and is due to finish in 60 minutes. The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:18 <openstack> The meeting name has been set to 'tripleo'
14:29:47 <EmilienM> I take the opportunity to remind people that right now it's a good time to stop starting things
14:30:01 <EmilienM> and start fixing bugs and bring more stability
14:30:23 <EmilienM> the deadline to push a feature in TripleO is Jan 23 - Jan 27 week
14:30:33 <EmilienM> #info deadline for features in ocata is Jan 23 - Jan 27
14:31:05 <EmilienM> #info queen series has been created in launchpad
14:31:24 <EmilienM> dsneddon asked for it
14:31:32 <EmilienM> any question about release management?
14:31:56 <EmilienM> #link https://releases.openstack.org/ocata/schedule.html
14:32:16 <EmilienM> ok next topic
14:32:18 <EmilienM> #topic CI
14:32:27 <EmilienM> #link http://tripleo.org/cistatus.html
14:32:35 <EmilienM> #link http://status-tripleoci.rhcloud.com/
14:32:59 <EmilienM> lot of green since last week, sounds like we're doing pretty well lately
14:33:17 <EmilienM> we still have the undercloud-upgrade job failing, but it's under control
14:33:27 <EmilienM> it's related to the nova/cellv2 that mwhahaha and owalsh have been working on
14:33:41 <EmilienM> matbu: quick update on upgrade job?
14:34:09 <matbu> EmilienM: we hit timeout on upgrade due to multinode
14:34:23 <matbu> EmilienM: thank you slagle to poke at and help
14:34:30 <EmilienM> what is timeouting?
14:34:36 <EmilienM> the upgrade process?
14:35:03 <matbu> EmilienM: it's related to multinode, i let slagle to be more specific
14:35:07 <slagle> there were several backwards incompatible changes made to the deployed-server template
14:35:07 <EmilienM> #action team to look http://lists.openstack.org/pipermail/openstack-dev/2017-January/109600.html and give feedback
14:35:17 <EmilienM> #action team to look https://review.openstack.org/#/c/359060/ and https://review.openstack.org/#/c/415179/ + give feedback
14:35:19 <slagle> which caused neutron ports to get recreated
14:35:43 <slagle> which is exposing another bug...that haproxy.cfg is not getting the updated port IP
14:35:58 <slagle> so then the upgrade hangs trying to connect to mysql during Step5
14:36:05 <EmilienM> slagle: might be a bug in puppet
14:36:12 <EmilienM> in puppet-tripleo eventually?
14:36:17 <slagle> i'm trying to add a backwards compatible deployed-server here: https://review.openstack.org/#/c/418072/
14:36:35 <EmilienM> I can try to look at is today (haproxy config update), it's probably a puppet thing
14:36:58 <slagle> if that doesn't work, we might just need to revert https://review.openstack.org/#/c/409523/
14:37:01 <EmilienM> #action EmilienM to help debug upgrade job timeout wrt haproxy config update
14:37:18 <EmilienM> slagle: ack, thx for your help here
14:37:38 <matbu> EmilienM: +1
14:37:46 <EmilienM> I have an update to give about CI
14:37:53 <slagle> EmilienM: you can look at my comment on PS 67 here: https://review.openstack.org/#/c/404831/ to see the details of the IP change
14:37:58 <matbu> the good news from last week, is that the workflow is working on tripleo-quickstart
14:38:02 <EmilienM> I've been working on a new experimental job, that aims to test composable HA architecture: https://review.openstack.org/#/c/418099/
14:38:12 <EmilienM> slagle: ack, I'll start from there
14:39:00 <matbu> so it might be good to set push as a periodic job for now, or a silent gate
14:39:00 <EmilienM> do we have any other useful update about CI this week?
14:39:15 <EmilienM> matbu: for upgrade?
14:39:18 <matbu> s/push/it/
14:39:21 <matbu> EmilienM: yes
14:39:31 <EmilienM> matbu: well, we need to solve this timeout issue first
14:39:42 <EmilienM> jobs stay as experimental until they actually work
14:39:54 <EmilienM> I don't see any value to move it into periodic pipeline if it timeouts now
14:40:05 <EmilienM> but indeed, when it will work, +1 for periodic job.
14:40:06 <matbu> EmilienM: i mean the tripleo-quickstart upgrade job is working and doesn't timeout
14:40:12 <EmilienM> ahhhh
14:40:18 <EmilienM> #needmoretea
14:40:38 <EmilienM> matbu: yes, go ahead.
14:40:52 <EmilienM> #action matbu to move the tripleo-quickstart upgrade job into periodic pipeline
14:41:08 <matbu> EmilienM: maybe it a good candidate for the transition
14:41:16 <matbu> i let the CI squad decide about that
14:41:21 <hrybacki> weshay ^^
14:41:40 <sshnaidm> matbu, you can talk to me if you need any help with it
14:41:59 <matbu> and i'll say 's/matbu/ci-squad/' to move the tripleo-quickstart ... :)
14:42:24 <EmilienM> #undo
14:42:25 <openstack> Removing item from minutes: #action matbu to move the tripleo-quickstart upgrade job into periodic pipeline
14:42:31 <weshay> matbu, ya.. getting upgrade in the ovb oooq experimental is a good idea
14:42:34 <EmilienM> #action ci squad to move the tripleo-quickstart upgrade job into periodic pipeline
14:42:34 <weshay> imho
14:42:48 <EmilienM> matbu: we're talking about periodic, not experimental
14:42:56 <weshay> ah.. +1 on either
14:42:57 <trown> ya periodic would be better
14:43:06 <EmilienM> sounds like there is no pushbash
14:43:10 <EmilienM> pushback even
14:43:13 <EmilienM> go4it!
14:43:18 <matbu> hehe
14:43:26 <EmilienM> anything else about CI this week?
14:43:50 <EmilienM> #topic Specs
14:44:04 <EmilienM> not sure we have specs to discuss this week but feel free to go ahead
14:44:16 <EmilienM> please note that from now specs are for Pike cycle only.
14:44:35 <EmilienM> if you've had a spec for Ocata, please update it to be in Pike folder
14:45:30 <EmilienM> I'll open the disucssion
14:45:37 <EmilienM> #topic open discussion
14:45:58 <EmilienM> if we have any other topic to discuss or if there is any question, it's the right time
14:46:19 <mwhahaha> just an FYI, i've got reviews out for https://blueprints.launchpad.net/tripleo/+spec/capture-environment-status-and-logs. see https://review.openstack.org/#/c/405001/ and https://review.openstack.org/#/c/405002/
14:46:22 <mwhahaha> feedback is welcome
14:46:25 <EmilienM> I would gently remind people we have an etherpad for Atlanta: https://etherpad.openstack.org/p/tripleo-ptg-pike
14:46:27 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-ptg-pike
14:46:43 <EmilienM> feel free to create some sessions ^
14:47:31 <EmilienM> #action team to review capture-environment-status-and-logs blueprint: 405001 and 405002
14:47:37 <EmilienM> mwhahaha: nice work!
14:48:24 <EmilienM> anything else for this week?
14:48:55 <EmilienM> ok thanks folks
14:49:01 <EmilienM> see you online
14:49:03 <EmilienM> #endmeeting