14:00:23 <EmilienM> #startmeeting tripleo
14:00:24 <openstack> Meeting started Tue Jan 17 14:00:23 2017 UTC and is due to finish in 60 minutes. The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:27 <jrist> o/
14:00:27 <openstack> The meeting name has been set to 'tripleo'
14:00:29 <EmilienM> #topic agenda
14:00:31 <EmilienM> * review past action items
14:00:33 <EmilienM> * one off agenda items
14:00:35 <EmilienM> * bugs
14:00:37 <EmilienM> * Projects releases or stable backports
14:00:39 <EmilienM> * CI
14:00:41 <EmilienM> * Specs
14:00:43 <EmilienM> * open discussion
14:00:45 <EmilienM> hello, who is around today?
14:00:49 <trown> o/
14:00:50 <jpich> o/
14:00:52 <beagles> o/
14:00:53 <matbu> o/
14:00:55 <panda> o/
14:00:58 <arxcruz> o/
14:01:00 <Ng> o/
14:01:05 <mwhahaha> o/
14:01:10 <ccamacho> hi!
14:01:32 <EmilienM> I'll let people take a seat and review past action it in meantime
14:01:36 <sshnaidm> o/
14:01:39 <marios> o/
14:01:39 <EmilienM> #topic review past action items
14:01:44 <owalsh> o/
14:01:44 <thrash> o/
14:01:47 <gfidente> o/
14:01:59 <shardy> o/
14:02:04 <EmilienM> EmilienM to help debug upgrade job timeout wrt haproxy config update: done (job has been promoted to check-nv)
14:02:11 <EmilienM> team to look http://lists.openstack.org/pipermail/openstack-dev/2017-January/109600.html and give feedback: done
14:02:21 <hrybacki> o/
14:02:21 <EmilienM> team to look https://review.openstack.org/#/c/359060/ and https://review.openstack.org/#/c/415179/ + give feedback: done by gfidente
14:02:31 <EmilienM> ci squad to move the tripleo-quickstart upgrade job into periodic pipeline: in progress
14:02:40 <fultonj> o/
14:02:50 <EmilienM> trown: or is it done ^ ?
14:03:01 <EmilienM> team to review capture-environment-status-and-logs blueprint: 405001 and 405002: done by d0ugal
14:03:34 <bandini> o/
14:03:40 <EmilienM> anything else?
14:04:00 <EmilienM> #topic one off agenda items
14:04:02 <trown> EmilienM: I dont think so... I have not payed attention to that one though... sshnaidm panda?
14:04:05 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:04:17 <sshnaidm> trown, no, it's still on review afaik, matbu ?
14:04:25 <EmilienM> arxcruz, panda: o/
14:04:42 <panda> trown: nope
14:04:44 <weshay> 0/
14:04:45 <d0ugal> o/
14:04:48 <panda> EmilienM: hey
14:04:48 <rbrady> o/
14:04:52 <EmilienM> panda: go ahead
14:05:16 <weshay> matbu, ^
14:05:30 <panda> so we have two patches https://review.openstack.org/420647 https://review.openstack.org/420620 in place to replace the current periodic tempest job
14:05:31 <matbu> sshnaidm: review are still waiting for vote :(
14:05:41 <weshay> EmilienM, at the moment it's running internally.. looking to see if oooq upgrade job in upstream is a requirement
14:05:54 <panda> the infra patch already got the approval from infra, but then we needed to add something more
14:06:20 <EmilienM> panda: ok, something needs to be discussed or some actions taken?
14:06:23 <matbu> EmilienM: sshnaidm i'll probably need to update the quickstart one, some services has been added last week
14:06:25 <EmilienM> or it's just announcement
14:06:27 <EmilienM> ?
14:06:29 <panda> we are currently running a test upstream using thiss change https://review.openstack.org/421272 to see the end results from this replacement
14:07:08 <panda> EmilienM: I proposed a discussion on the mailing list, just to see if there are any objections
14:07:21 <sshnaidm> matbu, EmilienM maybe it's worth to mark upgrade reviews as action items?
14:07:31 <matbu> sshnaidm: +1
14:07:45 <panda> arxcruz: can confirm as he's looking at the tempest part, the full list of tempest test passes, with a few exceptions
14:07:55 <matbu> i think tripleo cores should be involved in the quickstart reviews
14:08:02 <weshay> 3 failures last I checked in full tempest on master
14:08:03 <matbu> the delay is really huge
14:08:07 <arxcruz> EmilienM: confirmed
14:08:08 <weshay> 2 are known issues
14:08:23 <EmilienM> #action team to review oooq periodic job https://review.openstack.org/420647 https://review.openstack.org/420620
14:08:36 <arxcruz> which https://review.openstack.org/#/c/421018/ will add to skip file
14:08:41 <panda> so, if no one has anything to object, seems like tempest is back on the menu
14:08:51 <panda> arxcruz: do you want to add something for the tempestmail spec ?
14:09:01 <EmilienM> matbu: have you documented how to review quickstart patches?
14:09:08 <arxcruz> panda: I wrote the spec, but didn't finish the code yet on tripleo-ci/scripts
14:09:09 <EmilienM> matbu: have you thought at a deep dive sessions?
14:09:20 <weshay> +1 on deep dive
14:09:25 <arxcruz> panda: EmilienM spec at https://review.openstack.org/#/c/420878/
14:09:27 <EmilienM> and it's out of topic now, sorry
14:09:35 <matbu> EmilienM: the commit message is explicit i guess
14:09:53 <sshnaidm> panda, is it nonha intentionally?
14:10:03 <arxcruz> sshnaidm: yes
14:10:04 <EmilienM> folks, we're having 4 topics in same time
14:10:12 <trown> ya, I am really lost
14:10:33 <weshay> ha
14:10:40 <panda> :/
14:10:40 <arxcruz> there are some tests that fail in ha, because the sync between the controllers
14:10:52 <adarazs> o/
14:11:03 <panda> EmilienM: mark the active topic then, sorry I thought you gave the green light.
14:11:06 <sshnaidm> I think we started from upgrade job
14:11:28 <EmilienM> ok, so nothing else for moving periodic job to use oooq?
14:11:51 <EmilienM> ok, seems like we can move to the next topic
14:12:01 <EmilienM> weshay, matbu: it's you now
14:12:30 <panda> EmilienM: changes, jobs, and spec to send email to proper group in case of failure, nothing else on my part
14:12:34 <weshay> EmilienM, I'm looking for input whether or not we think the upgrade oooq job should be running in a check gate
14:13:00 <EmilienM> weshay: is it a multinode or an ovb?
14:13:07 <weshay> or experimental
14:13:13 <EmilienM> panda: feel free to use #action to track the list of things todo
14:13:13 <weshay> ovb
14:13:31 <EmilienM> weshay: right now, we already have a multinode (non oooq) job in THT check -nv
14:13:34 <matbu> EmilienM: weshay fyi the tripleo-ci experimental has been merged
14:13:42 <matbu> and it's working properly now
14:13:56 <EmilienM> matbu: please be precise and give the jobname
14:14:05 <EmilienM> the "the tripleo-ci experimental" is not enough to understand which one
14:14:35 <shardy> weshay: we just moved the brand new non-ooq upgrade job to the t-h-t check queue yesterday
14:14:40 <matbu> EmilienM: gate-tripleo-ci-centos-7-multinode-upgrades-nv
14:14:51 <shardy> weshay: can you clarify, this is the exact same steps done via quickstart, or something else?
14:15:07 <EmilienM> matbu: gate-tripleo-ci-centos-7-multinode-upgrades-nv has moved to check pipeline for THT and experimental for tripleo-ci
14:15:12 <matbu> shardy: yes, but with less services than we added recently
14:15:15 <weshay> shardy, ok.. having coverage is the most important thing
14:15:42 <shardy> weshay: I'm kinda thinking we should leave that one alone for now, as it blocked landing upgrades patches for nearly two months
14:15:59 <weshay> shardy, ok.. this is the input I was looking for
14:15:59 <trown> +1 to just using the multinode upgrade we have
14:16:05 <EmilienM> +1 too
14:16:11 <EmilienM> and we can revisit in Pike
14:16:11 <shardy> I'd be fine with us proving the oooq one via the experimental queue tho and proving we can switch them later
14:16:20 <EmilienM> shardy: yes exactly
14:16:24 <gfidente> +1 on oooq experimental
14:16:37 <weshay> ok.. we can do that.. by replacing one of the current oooq jobs in experimental w/ upgrade
14:17:01 <weshay> seems like a good idea to me to ensure we're covered in the short term and further out
14:17:02 <shardy> weshay: sounds good - I'd be keen to see it running, but wary of any further blockages re the upgrades patches
14:17:07 <trown> I think we should make the oooq upgrade job based on top of the recent oooq-multinode job
14:17:18 <trown> the ovb queue is too crowded to add more jobs
14:17:28 <weshay> oh.. that would be awesome
14:17:32 <EmilienM> trown: yes
14:17:33 <weshay> matbu, you following this?
14:17:35 <EmilienM> sounds like we have a plan
14:17:37 <shardy> trown: +1 - the current upgrades job uses multinode, so that would be consistent
14:17:56 <shardy> when we prove they're working exactly the same, we can switch them in the t-h-t check queue, but probably not before early pike
14:18:10 <weshay> +1
14:18:10 <matbu> +1
14:18:13 <EmilienM> maybe we can create a blueprint for that
14:18:17 <EmilienM> so we track the work
14:18:31 <EmilienM> weshay: can you take some #action please?
14:18:38 <EmilienM> so it's somewhere in logs :-)
14:19:40 <weshay> #action weshay, matbu, sofer to create a tripleo blueprint for multinode nodepool oooq based upgrade job
14:19:49 <EmilienM> excellent
14:19:53 <EmilienM> weshay: anything else for this topic?
14:20:00 <weshay> nada
14:20:03 <EmilienM> thanks!
14:20:13 <EmilienM> bandini, ccamacho : o/
14:20:18 <bandini> yo ;)
14:20:21 <EmilienM> yoooo
14:20:22 <ccamacho> hey!
14:20:24 <bandini> So with https://review.openstack.org/#/c/359060/ we add an explicit nonha-arch environment file *and* default to the HA deployment. The corresponding CI patch https://review.openstack.org/#/c/415179/ makes sure the nonha jobs use -e nonha-arch.yaml. The CI patch is failing on the current unrelated mitaka nonha. I'd love to merge both patches at the same time. Are there any concerns? (Note that
14:20:26 <bandini> I added release notes for THT here https://review.openstack.org/421226 and plan to send a mail on openstack-dev once this stuff merges)
14:21:05 <EmilienM> is it safe to do it now? (end of ocata)
14:21:08 <dtantsur> bandini, does it mean that we won't have a job testing the "default" deployment (i.e. one without any -e)?
14:21:56 <bandini> dtantsur: well for ocata -e environment/puppet-pacemaker and default will mean the same thing. so yes we are and it is the ha job
14:22:07 <ccamacho> dtantsur, yes but it will be deployed using the resources that previously were in the puppet-pacemaker template
14:22:17 <bandini> EmilienM: I think it is, but wanted to get the input of the larger group
14:22:42 <bandini> it is basically one of the only differences between downstream and upstream and has confused endless folks
14:22:42 <trown> ya... looks like the same coverage CI wise to me
14:22:54 <dtantsur> bandini, the HA job deploys with ControllerCount=3, right?
14:22:55 <trown> just changes which job needs to be explicit about changing default
14:23:16 <gfidente> bandini if we keep the puppet-pacemaker.yaml release, as planned, I think it's safe to do
14:23:21 <bandini> dtantsur: I believe so
14:23:25 <gfidente> anything pointing to the old file should continue to work as intended
14:23:34 <ccamacho> yeahp gfidente until pike the template will be there
14:23:36 <marios> bandini: fwiw reviewed that today, imo can land... besides CI most people will be using puppet-pacemaker already anyway
14:23:38 <bandini> gfidente: yeah I plan to kill that file for pike, not anytime sooner
14:23:42 <gfidente> we just need to maintain registry/nonha/puppet-pacemaker in good shape for a release right?
14:24:01 <trown> bandini: I think we can't kill the file until queens
14:24:01 <EmilienM> why do we need nonha job then?
14:24:06 <EmilienM> for introspection?
14:24:10 <trown> deprecate in O remove in Q
14:24:14 <EmilienM> why not moving introspection to ha job then?
14:24:18 <ccamacho> trown++
14:24:32 <EmilienM> trown: sounds good to me too
14:24:37 <bandini> EmilienM: so my take on nonha is that we can kill that too eventually, but it seemed too much of a big change
14:24:41 <bandini> trown: +1
14:24:48 <gfidente> two releases better than one
14:24:48 <ccamacho> EmilienM I think we should do this step by step
14:24:51 <EmilienM> bnemec: thoughts ^ ?
14:25:11 <EmilienM> I don't see any blocker
14:25:16 <EmilienM> any actions to take folks?
14:25:20 <gfidente> on dropping entirely nonha I am not convinced
14:25:42 <bandini> I'd just let the reviews merge after appropriate +2, if folks agree
14:25:46 <gfidente> I think it's good to keep it in working state
14:25:48 <bandini> gfidente: yeah that requires a longer discussion
14:25:56 <sshnaidm> EmilienM, ceph and undercloud-ssl are checked in nonha only
14:26:06 <EmilienM> right
14:26:13 <gfidente> so for ceph I am adding HCI to the HA job
14:26:21 <EmilienM> ceph is highly tested in scenario001 and scenario004
14:26:24 <gfidente> https://review.openstack.org/338088
14:26:28 <shardy> gfidente: Yeah I agree, if nothing else it's useful for minimal testing by developers
14:26:30 <gfidente> so we don't need extra nodes
14:26:41 <shardy> however I guess the question is can we justify bandwidth if that's the only reason
14:26:49 <shardy> e.g CI bandwidth
14:26:55 <sshnaidm> EmilienM, and "no network isolation" there
14:26:57 <gfidente> ceph HCI that depends on https://review.openstack.org/#/c/419049/ though
14:27:03 <EmilienM> sshnaidm: right
14:27:14 <gfidente> sshnaidm right if we land that we will test it with network isolation
14:27:20 <EmilienM> bandini, ccamacho: any #action to take before we go to next topic?
14:27:39 <gfidente> shardy ack on bandwidth
14:27:42 <ccamacho> EmilienM we are good
14:27:43 <bandini> EmilienM: I think we're good. We'll let the reviews do the rest and merge once we're okay
14:27:47 <EmilienM> we can revisit the topic of keeping nonha for later
14:27:51 <bandini> yeah
14:27:55 <ccamacho> thanks!
14:28:00 <bandini> thanks everyone
14:28:03 <EmilienM> #action team to review https://review.openstack.org/#/c/359060/ and https://review.openstack.org/#/c/415179/
14:28:04 <gfidente> can I add one more question for CI topic?
14:28:13 <EmilienM> gfidente: of course, go ahead now
14:28:26 <gfidente> if with jprovazn we wanted to have a scenario to test the manila/cephmds
14:28:37 <gfidente> shall we prefer hacking on an existing scenario or add a new one?
14:28:57 <gfidente> (cephmds is a new service we don't deploy by default, needed for cephfs, needed in turn by manila)
14:29:00 <EmilienM> gfidente: that's a good question
14:29:20 <EmilienM> so scenario001 is really about testing rbd with nova/cinder/glance/telemetry
14:29:29 <gfidente> cool, so we could add it there?
14:29:31 <EmilienM> and scenario004 is about ceph rgw with glance
14:29:41 <EmilienM> could it be in scenario004?
14:29:47 <gfidente> yes fine for me
14:29:53 <gfidente> thanks
14:30:05 <EmilienM> #action gfidente to investigate cephmds + manila on scenario004
14:30:18 <EmilienM> gfidente: thanks for adding more CI coverage, very nice :)
14:30:44 * dtantsur reminds himself that he should get to an ironic scenario eventually
14:30:47 <gfidente> you mean better than driving bling in the night
14:30:52 <gfidente> yes I learned that
14:31:05 <EmilienM> :)
14:31:16 <EmilienM> ok next topic
14:31:21 <EmilienM> PTG
14:31:27 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-ptg-pike
14:31:35 <EmilienM> we already have a few sessions, which is great!
14:31:50 <EmilienM> I've set a deadline for submitting sessions, so we have enough time to organize ourselves
14:31:58 <EmilienM> deadline: February 6th
14:32:06 <EmilienM> any feedback on ^ is welcome
14:32:21 <EmilienM> I haven't seen much sessions about CI
14:32:37 <EmilienM> weshay, trown, adarazs : are you interested to add some?
14:33:05 <adarazs> EmilienM: I won't be there, so as you wish. :)
14:33:15 <adarazs> EmilienM: it might be useful though for people present.
14:33:21 <weshay> I believe trown will have to lead some sessions, I am moving to colorado at that time
14:33:24 <trown> EmilienM: ya maybe we can discuss more in CI squad meeting on thursday and put something up based on that
14:33:42 <EmilienM> sounds like a plan
14:33:52 <EmilienM> #action trown & EmilienM to prepare CI sessions for PTG
14:33:55 <trown> #action trown bring up PTG CI sessions in thursday CI squad meeting
14:34:00 <trown> jinz
14:34:06 <trown> jinx even
14:34:08 <EmilienM> other folks, please propose topics by the deadline
14:34:21 <EmilienM> reminder: we have a room for 3 days, so don't be shy :)
14:34:33 <EmilienM> #undo
14:34:34 <openstack> Removing item from minutes: #action trown bring up PTG CI sessions in thursday CI squad meeting
14:34:42 <EmilienM> #undo
14:34:43 <openstack> Removing item from minutes: #action trown & EmilienM to prepare CI sessions for PTG
14:34:50 <EmilienM> #action trown bring up PTG CI sessions in thursday CI squad meeting
14:34:52 <EmilienM> voilĂ
14:34:55 <EmilienM> :)
14:35:09 <EmilienM> any question about PTG or feedback?
14:35:22 <EmilienM> ok let's move
14:35:26 <EmilienM> #topic bugs
14:35:36 <EmilienM> #link https://launchpad.net/tripleo/+milestone/ocata-3
14:35:57 <EmilienM> I sent an email about remaining bugs for tripleoclient before we release it next week
14:35:59 <EmilienM> #link https://goo.gl/R2hO4Z
14:36:10 <EmilienM> we still have 6 bugs open
14:36:37 <EmilienM> tripleoclient reviewers, please look at them and make sure they need to be in ocata-3 or defer it to pike-1
14:36:58 <EmilienM> other than tripleoclient, do we have outstanding bugs to discuss this week?
14:37:16 <EmilienM> 74 Triaged, 67 In Progress for ocata-3
14:37:40 <EmilienM> it's huge :)
14:37:46 <beagles> just a heads up on https://bugs.launchpad.net/tripleo/+bug/1656939...
14:37:46 <openstack> Launchpad bug 1656939 in tripleo "Empty THT strings now being interpreted as actual values by puppet" [High,In progress] - Assigned to Brent Eagles (beagles)
14:37:51 <EmilienM> I think I already asked last time, but any help on triage would be welcome
14:38:11 <marios> EmilienM: i just added one more (the tag was wiped earlier when i added puppet-nova) https://bugs.launchpad.net/tripleo/+bug/1656791
14:38:11 <openstack> Launchpad bug 1656791 in tripleo "Mitaka to Newton undercloud upgrade needs "nova db online_data_migrations" after the undercloud upgrade" [High,In progress] - Assigned to Marios Andreou (marios-b)
14:38:13 <shardy> I suggest we defer all low/medium unassigned bugs to pike-1, and move all high unassigned bugs to rc1
14:38:25 <marios> EmilienM: its the one you already reviewed the code for (its an upgrade related one)
14:38:29 <EmilienM> #link https://review.openstack.org/#/c/420947/
14:38:30 <shardy> then we can focus on fixing the most serious issues prior to the release
14:38:35 <EmilienM> beagles: ack, thanks for this one
14:38:37 <beagles> this came to my attention yesterday. I expect that neutron might've been the only one affected but if in case you've done the "bad thing" mentioned in the bug in the past you might want to check on
14:38:54 <EmilienM> shardy: sounds like a plan
14:39:33 <EmilienM> #action EmilienM to move ocata-3 low/medium unassigned bugs to pike-1
14:39:35 <beagles> +1 shardy
14:39:46 <EmilienM> #action EmilienM to move ocata-3 high/critical unassigned bugs to ocata-rc1
14:40:09 <EmilienM> marios: sounds good, it's in our radar for this week
14:40:16 <EmilienM> marios: i'll help you to get this puppet-nova patch merged asap
14:40:50 <EmilienM> mwhahaha: FYI https://review.openstack.org/#/c/421249/
14:40:53 <marios> EmilienM: thanks will reach out to someone from nova to sanity check too
14:41:07 <marios> EmilienM: appreciate the reviews
14:41:15 <EmilienM> marios: please
14:41:30 <EmilienM> do we have other bugs to discuss this week?
14:42:29 <EmilienM> #topic Projects releases or stable backports
14:42:44 <EmilienM> reminder: tripleoclient will be release next week, on Thursday
14:42:58 <EmilienM> #link https://releases.openstack.org/ocata/schedule.html
14:43:33 <EmilienM> we'll also release ocata-3
14:43:51 <EmilienM> Jan 27 is the target but it will likely happen on Jan 26 I think
14:44:26 <EmilienM> No featureful patch should be landed after this point. Exceptions may be granted by the project PTL, on openstack-dev ML
14:44:57 <EmilienM> I'm working on release notes with d0ugal
14:45:07 <EmilienM> any help on adding release notes for Ocata is very welcome
14:45:18 <EmilienM> ping me or d0ugal to sync
14:46:11 <EmilienM> any question or feedback on releases?
14:46:44 <EmilienM> #topic CI
14:46:51 <EmilienM> #link http://tripleo.org/cistatus.html
14:46:59 <EmilienM> #link http://status-tripleoci.rhcloud.com/
14:47:13 <EmilienM> #link https://dashboards.rdoproject.org/rdo-dev
14:47:22 <EmilienM> panda, sshnaidm: any idea why we haven't promoted last night?
14:48:17 <EmilienM> (if there is anything to discuss about CI, please raise it here)
14:48:32 <EmilienM> bnemec managed to make Mitaka jobs passing again, see https://review.openstack.org/#/c/420156/ - bnemec: can you remove -W when you can?
14:48:37 <sshnaidm> EmilienM, " Ironic deployment timeout" in nonha job
14:48:45 <EmilienM> sshnaidm: have we filed a bug?
14:48:51 <sshnaidm> EmilienM, I don't think so
14:49:10 <EmilienM> sshnaidm: let's do it after meeting and see why we have that now.
14:49:14 <sshnaidm> EmilienM, I'll handle it, suspecting it's timeout issue we had in past
14:49:15 <trown> just want to bring up that we have a CI squad meeting on Thursdays to discuss ongoing improvements to CI... adarazs is the liason and did a great write up of last weeks meeting http://lists.openstack.org/pipermail/openstack-dev/2017-January/110034.html
14:49:22 <EmilienM> sshnaidm: we can maybe ask dtantsur to look if it's ironic related
14:49:55 <trown> #link http://lists.openstack.org/pipermail/openstack-dev/2017-January/110034.html
14:49:59 <adarazs> trown: thanks. :) I think that status is still correct.
14:50:05 <EmilienM> adarazs: yes, I also found it excellent
14:50:27 <adarazs> all right, looking forward to the next. :)
14:50:31 <EmilienM> marios: do you keep doing weekly standups? I'm not sure I've seen notes posted on ML
14:50:39 <EmilienM> chem: ^
14:51:04 <marios> EmilienM: no we have been having more ad-hoc calls really
14:51:13 <marios> EmilienM: we always announce on the tripleo chan
14:51:37 <marios> EmilienM: i guess we should organise a weekly if that would be useful/if there is someone who is interested and is unable to follow the work
14:51:38 <EmilienM> like I said, it's good to let squads do how they like, though having public notes on the ML would be helpful
14:52:07 <chem> EmilienM: marios hum, yes that's kind of a good idea
14:52:09 <EmilienM> weekly or not, I think having public notes make to do things "in the open"
14:52:32 <shardy> Just having an etherpad with the current status of upgrades would probably help - I think matbu started one
14:52:40 <marios> EmilienM: fwiw we have notes https://etherpad.openstack.org/p/tripleo-upgrades-squad
14:52:44 <matbu> shardy: yep
14:52:46 <EmilienM> excellent
14:52:47 <marios> EmilienM: last time we had a call was last friday for example
14:53:07 <matbu> https://etherpad.openstack.org/p/composable-upgrade
14:53:07 <EmilienM> I guess this etherpad is enough :-) thanks folks
14:53:17 <EmilienM> #link https://etherpad.openstack.org/p/composable-upgrade
14:53:24 <jpich> It might have been more appropriate for the bugs section rather than CI, but I noticed unit tests don't pass on stable/mitaka anymore so patches can't merge (the branch is still security supported). I put some debugging notes up at https://bugs.launchpad.net/tripleo/+bug/1656871 but am a bit stuck. I'd appreciate pointers on how to help resolve it, if anyone has any
14:53:24 <openstack> Launchpad bug 1656871 in tripleo "Mitaka unit tests broken (CLI/OSC test dependencies)" [High,Triaged]
14:53:24 <matbu> it needs more love :D
14:54:07 <EmilienM> #action team to help jpich to debug https://bugs.launchpad.net/tripleo/+bug/1656871 and unblock stable/mitaka unit tests
14:54:23 <EmilienM> jpich: thank you
14:54:41 <EmilienM> do we have anything else about this CI week?
14:54:46 <jpich> Thanks!
14:55:03 <EmilienM> #topic specs
14:55:14 <EmilienM> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:55:23 <shardy> jpich: have you seen https://review.openstack.org/#/c/413792/ ?
14:55:37 <shardy> that's a patch from bnemec which aims to fix several mitaka related issues
14:55:40 <shardy> not yet landed
14:56:06 <EmilienM> yeah it's a backport
14:56:29 <EmilienM> we probably need to Depends-On https://review.openstack.org/#/c/420156/
14:56:40 <EmilienM> to check that it doesn't break OVB jobs
14:57:11 <EmilienM> jpich: can you check with bnemec when he's around?
14:57:20 <jpich> shardy: I suspect this is related to larger issues with the long-running jobs, that bug seems to be related to unit tests and dependencies at the pip level
14:57:28 <jpich> EmilienM: Will do
14:58:06 <EmilienM> a quick note on specs, more a reminder
14:58:25 <EmilienM> if you submit a spec, please target it for Pike and not Ocata :-)
14:58:42 <EmilienM> I know it makes sense but I've seen specs for Ocata coming up yesterday ;-)
14:58:54 <dtantsur|mtg> lol, that's the spirit!
14:59:03 <EmilienM> :)
14:59:10 <EmilienM> i'll open the discussion
14:59:13 <EmilienM> #topic open discussion
14:59:23 <EmilienM> if you have any question or feedback, you have 45 seconds
14:59:35 <EmilienM> or you can use #tripleo at any time
14:59:39 <panda> EmilienM: there as spec for adding tempest mail to tripleo-ci, bt arxcruz
14:59:48 <EmilienM> panda: I've seen it
14:59:50 <panda> EmilienM: not sure it should be targeted to OPike also
14:59:56 <EmilienM> panda: yes, Pike.
15:00:07 <EmilienM> spec freeze was December 16th iirc
15:00:08 <panda> EmilienM: ok, thanks
15:00:22 <EmilienM> thanks everyone!
15:00:24 <EmilienM> #endmeeting