14:00:05 <EmilienM> #startmeeting tripleo
14:00:11 <EmilienM> #topic agenda
14:00:11 <bkero> o/
14:00:11 <openstack> Meeting started Tue Jan 24 14:00:05 2017 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:13 <EmilienM> * review past action items
14:00:14 <bandini> o/
14:00:15 <openstack> The meeting name has been set to 'tripleo'
14:00:15 <hrybacki> o/
14:00:16 <EmilienM> * one off agenda items
14:00:17 <EmilienM> * bugs
14:00:19 <EmilienM> * Projects releases or stable backports
14:00:21 <EmilienM> * CI
14:00:23 <EmilienM> * Specs
14:00:26 <EmilienM> * open discussion
14:00:27 <EmilienM> hello, who is around today?
14:00:29 <mwhahaha> o/
14:00:30 <sshnaidm> o/
14:00:32 <ccamacho> o/
14:00:32 <cdearborn> \o
14:00:33 <shardy> o/
14:00:38 <marios> o/
14:00:43 <adarazs> \o
14:00:47 <chem> o/
14:00:55 <beagles> o/
14:01:05 <radez> o/
14:01:08 <EmilienM> nice crowd here
14:01:08 <owalsh> o/
14:01:21 <EmilienM> #topic review past action items
14:01:27 <EmilienM> team to review oooq periodic job https://review.openstack.org/420647 https://review.openstack.org/420620
14:01:38 <EmilienM> both are merged
14:01:42 <EmilienM> weshay, matbu, sofer to create a tripleo blueprint for multinode nodepool oooq based upgrade job
14:01:54 <EmilienM> weshay, matbu, chem: where is it?
14:02:09 <jrist> o/
14:02:30 <EmilienM> (going to next action in the meantime)=
14:02:35 <EmilienM> team to review https://review.openstack.org/#/c/359060/ and https://review.openstack.org/#/c/415179/
14:02:57 <EmilienM> bandini: sounds like patches are still under review ^
14:03:04 <EmilienM> gfidente to investigate cephmds + manila on scenario004
14:03:16 <bandini> EmilienM: yes. there is still work to do there. at this point I don't think we'll manage for ocata
14:03:17 <EmilienM> gfidente is not around (yet?) I'll ask him again
14:03:26 <EmilienM> bandini: ok
14:03:35 <EmilienM> trown bring up PTG CI sessions in thursday CI squad meeting
14:03:40 <EmilienM> ^ done (I was there)
14:03:41 <florianf> o/
14:03:47 <EmilienM> EmilienM to move ocata-3 low/medium unassigned bugs to pike-1
14:03:50 <EmilienM> EmilienM to move ocata-3 high/critical unassigned bugs to ocata-rc1
14:03:57 <EmilienM> done, I had so much fun believe me
14:04:03 <EmilienM> team to help jpich to debug https://bugs.launchpad.net/tripleo/+bug/1656871 and unblock stable/mitaka unit tests
14:04:03 <openstack> Launchpad bug 1656871 in tripleo mitaka "Mitaka unit tests broken (CLI/OSC test dependencies)" [High,In progress] - Assigned to Ben Nemec (bnemec)
14:04:03 <bandini> :)
14:04:04 <EmilienM> and.... DONE !
14:04:14 <jpich> Many thanks to bnemec :)
14:04:16 <EmilienM> any feedback or question about last meeting?
14:04:39 <EmilienM> #action (postponed) weshay, matbu, sofer to create a tripleo blueprint for multinode nodepool oooq based upgrade job
14:05:03 <EmilienM> ok let's move on folks
14:05:07 <EmilienM> #topic one off agenda items
14:05:19 * EmilienM waves on bandini
14:05:23 <bandini> :)
14:05:47 <bandini> ok so the remaining composable ha patches are here https://review.openstack.org/#/q/topic:bp/composable-ha+status:open, I think they are in pretty good shape at this point
14:05:48 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:06:00 <EmilienM> bandini: yes I think so, I've made a review this morning and it looks good
14:06:02 <bandini> I will also try and help bring forward scenario-005
14:06:05 <EmilienM> there is one thing that worries me
14:06:09 <bandini> yes?
14:06:12 <EmilienM> yes that thing :D
14:06:13 <EmilienM> CI
14:06:23 <EmilienM> scenario005 is still failing, I would like to make progress on this thing
14:06:47 <bandini> :) yeah I need some help there, I think I know why it is breaking but I think I am missing a few details on how it works
14:06:48 <EmilienM> bandini: let's merge your patches asap this week and then work together on making this job passing ok?
14:06:56 <bandini> EmilienM: ack.
14:07:09 <bandini> all from me
14:07:10 <EmilienM> #actio bandini and EmilienM to work on scenario005 when composable-ha patches are landed
14:07:14 <EmilienM> #action bandini and EmilienM to work on scenario005 when composable-ha patches are landed
14:07:29 <EmilienM> no more items? let's go to regular topics
14:07:30 <chem> got disconnected will look at the log
14:07:37 <EmilienM> #topic bugs
14:07:48 <EmilienM> chem: you had an action from last week, could you do it?
14:07:57 <EmilienM> chem: "weshay, matbu, sofer to create a tripleo blueprint for multinode nodepool oooq based upgrade job"
14:08:44 <EmilienM> #link https://launchpad.net/tripleo/+milestone/ocata-3
14:08:50 <marios> 16:06 < EmilienM> bandini: let's merge your patches asap this week and then work together on making this job passing ok?
14:09:08 <marios> oops sry accidental ^
14:09:09 <EmilienM> #link tripleoclient bugs: https://goo.gl/R2hO4Z
14:09:27 <EmilienM> for tripleoclient devs, highest priority is ^
14:09:38 <EmilienM> we are releasing tripleoclient ocata this week
14:10:05 <EmilienM> we need to make sure we don't have critical bug in progress
14:10:34 <EmilienM> d0ugal, jpich, thrash ^ anything to say?
14:10:52 <jpich> Nope, let's do more reviews :)
14:11:01 <jrist> +1\
14:11:01 <EmilienM> ok
14:11:04 <thrash> EmilienM: validations work is ongoing
14:11:13 <thrash> EmilienM: couple of reviews up there now
14:11:33 <EmilienM> thrash: can we have links please?
14:11:39 <thrash> EmilienM: sure.
14:11:49 <EmilienM> we also have High/critical bugs for rc1
14:11:51 <EmilienM> #link https://launchpad.net/tripleo/+milestone/ocata-rc1
14:12:06 <thrash> https://review.openstack.org/#/c/416284/
14:12:08 <EmilienM> everything that is not High or Critical should go in Pike
14:12:15 <thrash> https://review.openstack.org/#/c/418507/
14:12:21 <thrash> https://review.openstack.org/#/c/419506/
14:12:56 <EmilienM> #action team to review validation work https://review.openstack.org/#/c/416284/ / https://review.openstack.org/#/c/418507/ / https://review.openstack.org/#/c/419506/
14:13:00 <EmilienM> thrash: thank you
14:13:22 <jtomasek> o/
14:13:32 <shardy> https://bugs.launchpad.net/tripleo/+bug/1632289 may need to move to pike, because fixing it will require changes to tripleoclient
14:13:32 <openstack> Launchpad bug 1632289 in tripleo "Composable roles require all services in Services list" [High,Triaged] - Assigned to Steven Hardy (shardy)
14:13:46 <shardy> I guess we can defer it and decide if a backport is viable
14:13:51 <EmilienM> shardy: is it something we can backport?
14:14:06 <shardy> EmilienM: probably, but last time I tried to fix it the patch got quite invasive
14:14:16 <shardy> perhaps I can find a simpler way when I revisit the problem
14:14:17 <dtantsur> could you please get RAID command in before tripleoclient release? https://review.openstack.org/#/c/421242/ would be a bit sad to get workflow landed, but not the command
14:14:42 <EmilienM> I just created ocata-backport-potential tag in Launchpad
14:14:49 <EmilienM> shardy: can you move it to pike-1 with ocata-backport-potential tag please?
14:14:59 <trown> o/
14:15:12 <EmilienM> #action team to review https://review.openstack.org/#/c/421242/
14:15:27 <EmilienM> shardy: we'll evaluate later if whether or not we do backport it
14:15:53 <shardy> EmilienM: ack, done
14:16:01 <EmilienM> another bug:
14:16:05 <EmilienM> https://bugs.launchpad.net/tripleo/+bug/1658755
14:16:05 <openstack> Launchpad bug 1658755 in tripleo "scenario002 ResourceInError: resources.volume1: Went to status error due to "Unknown"" [Critical,In progress] - Assigned to Lee Yarwood (lyarwood)
14:16:22 <EmilienM> this one is ongoing: https://review.openstack.org/#/c/424307/
14:16:35 <EmilienM> it's breaking scenario002 jobs
14:16:41 <EmilienM> it should be fixed by today
14:16:42 <mwhahaha> can we get a +A on https://review.openstack.org/#/c/400364/
14:17:02 <EmilienM> mwhahaha: done
14:17:10 <EmilienM> ok folks, any other outstanding bug this week?
14:17:22 <marios> EmilienM: this one is ocata-3 https://bugs.launchpad.net/tripleo/+bug/1656791 should i move to -rc1
14:17:22 <openstack> Launchpad bug 1656791 in tripleo "Mitaka to Newton undercloud upgrade needs "nova db online_data_migrations" after the undercloud upgrade" [High,In progress] - Assigned to Marios Andreou (marios-b)
14:17:38 <marios> EmilienM: really we need this backported to newton too but it needs to land first
14:17:41 <shardy> https://bugs.launchpad.net/tripleo/+bug/1658645 is still in progress, newton CI is broken until we land the fixes
14:17:41 <openstack> Launchpad bug 1658645 in tripleo "dbsync fails in newton " [Critical,In progress] - Assigned to Steven Hardy (shardy)
14:17:43 <EmilienM> marios: please move ocata-3 bugs into rc1, I did it last week already but I guess I missed some
14:18:01 <EmilienM> shardy: this one has been a mess :(
14:18:05 <marios> EmilienM: ack
14:18:11 <panda> wasn't the commit reverted ?
14:18:18 <shardy> or we can work around it in CI by removing the bigswitch packages as in https://review.openstack.org/#/c/424199/
14:18:43 <shardy> EmilienM: yes it has, IMO we should really stop carrying any vendor packages in the default upstream overcloud-full
14:18:51 <EmilienM> shardy: I would like your workaround in our CI for now, until we sort things out with Gabriele in tripleoclient & tripleo-common
14:19:05 <EmilienM> shardy: +2
14:19:29 <EmilienM> panda: it was
14:19:43 <shardy> EmilienM: if we have to we can do a similar workaround for the ovb jobs
14:19:47 <EmilienM> shardy: oh wait
14:19:49 <shardy> my patch only aims to fix the upgrade job
14:19:49 <EmilienM> https://review.openstack.org/#/c/424172/ is passing
14:19:51 <EmilienM> panda: ^
14:20:26 <panda> O_o
14:20:38 <EmilienM> shardy: i'll hold on your tripleo-ci patch and work with panda to fix it in tripleo projects
14:20:55 <EmilienM> panda: yes, i think RDO had an outage this morning and your patch was hiting it
14:21:13 <panda> yep , the pillow
14:21:13 <EmilienM> panda: but my revert got merged so it should fix it when deploying the elements
14:21:21 <EmilienM> panda: let's continue to work together on removing the elements and documenting it
14:21:35 <EmilienM> panda, shardy: sounds good folks?
14:21:44 <panda> ok, so the bug was "fixed" but we are trying to put in a long term solution by removing vendor plugins anyway
14:21:58 <EmilienM> yes
14:22:02 <shardy> +1
14:22:03 <panda> ok
14:22:19 <EmilienM> cool
14:22:26 <EmilienM> do we have other bugs to discuss this week?
14:22:47 <EmilienM> moving to next topic
14:22:52 <EmilienM> #topic Projects releases or stable backports
14:22:59 <EmilienM> #link https://releases.openstack.org/ocata/schedule.html
14:23:04 <EmilienM> some reminders :
14:23:10 <EmilienM> python-tripleoclient is released this week
14:23:22 <EmilienM> other projects have RC1 next week
14:23:35 <EmilienM> which means, by end of next week, we'll enter in feature freeze
14:24:00 <EmilienM> people should now focus on bug fixing or upgrades, instead of pushing for new features
14:24:28 <shardy> There are still 21 open features targetted at the ocata-3 milestone
14:24:48 <shardy> we'll have to decide how many are reasonable for FFEs vs deferring to pike
14:24:53 <EmilienM> yes, next week I'll take care of moving the features not finished for Ocata
14:25:06 <EmilienM> FFEs can be submitted on the mailing list
14:25:11 <EmilienM> (do not ping me directly please)
14:25:43 <EmilienM> to be honest, I would prefer focusing on bug fixing & stabilization versus FFEs
14:25:54 <dtantsur> after this RAID patch merges, I'll bump the remaining bits to Pike
14:26:19 <EmilienM> I would like to talk about release notes
14:26:40 <EmilienM> I haven't seen a huge interest in release notes until now, I would like to remind folks that we'll enforce release notes in Pike
14:27:11 <bandini> +1 I think it's just that we all need to get used to do it
14:27:11 <EmilienM> I'm currently working on adding release notes for THT right now (see openstack-dev) and I need some help for some features (I dressed the list on the thread)
14:27:19 <EmilienM> I'll do puppet-tripleo this week
14:27:23 <trown> I plan to submit releasenotes patch for quickstart for ocata
14:27:26 <EmilienM> any help from the team would be appreciated
14:27:39 <bandini> I plan to add stuff for some of my work as well
14:27:40 <EmilienM> we need someone from tripleo-ui doing notes for UI
14:27:50 <EmilienM> and some help on tripleo-common
14:28:03 <EmilienM> oh and instack-undercloud
14:28:28 <EmilienM> jtomasek, honza, florianf: any help on UI?
14:28:54 <jrist> I don't think they're here
14:28:58 <jrist> I'll poke them
14:29:00 <EmilienM> mhh ok
14:29:06 <honza> EmilienM: I can :)
14:29:06 <EmilienM> nobody else can help for the other projects?
14:29:09 <florianf> EmilienM: I can add a patch with the release notes
14:29:10 <jpich> I think our initial set of notes merged in tripleo-common, though more is always welcome for the bits we missed :) https://review.openstack.org/#/c/421166/
14:29:23 <EmilienM> jpich: you're awesome, thanks
14:29:35 <jpich> d0ugal did most of the work :)
14:29:46 <jpich> I don't know if the UI is set up with reno yet
14:29:51 <EmilienM> I'll do puppet-tripleo. So we need someone to help in instack-undercloud
14:30:08 <EmilienM> if no volunteer, I'll do it..
14:30:28 <EmilienM> any question about release management & backports?
14:31:06 <EmilienM> #topic CI
14:31:26 <EmilienM> I prepared some work to support stable/ocata CI: https://review.openstack.org/#/c/424622/ and https://review.openstack.org/#/c/424637/ - any feedback is welcome
14:31:59 <EmilienM> do we have any update on CI this week?
14:32:18 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:32:23 <shardy> until the bigswitch thing upgrades CI was working well, should we consider making it voting soon?
14:32:24 <EmilienM> for folks who want to follow what CI squad is doing
14:32:37 <EmilienM> shardy: that would be nice.
14:32:58 <EmilienM> shardy: but
14:33:11 <EmilienM> shardy: if we make it voting, it means we have to include it in the promotion pipeline somehow
14:33:11 <shardy> Ok, I'll monitor the stability after the bigswitch fix lands and we can consider making it voting after we cut ocata-3
14:33:23 <EmilienM> because breakage can happen in other projects
14:33:44 <shardy> EmilienM: yes, that would be an excellent idea, any help (from anyone) doing that would be great
14:34:11 <EmilienM> sshnaidm: ^ can you help?
14:34:22 <sshnaidm> shardy, EmilienM sure
14:34:26 <EmilienM> thank you
14:34:33 <shardy> sshnaidm: thanks! :)
14:35:10 <EmilienM> nothing else about CI?
14:35:43 <sshnaidm> EmilienM, we had full tempest (of panda and arxcruz) runs if somebody is interested
14:35:49 <EmilienM> nice
14:35:53 <EmilienM> how much time does it take?
14:36:39 <EmilienM> sshnaidm: ^
14:36:49 <sshnaidm> EmilienM, about 3 hrs
14:36:56 <EmilienM> ouch, it's long
14:37:08 <EmilienM> what is the benefit of running full tempest?
14:37:13 <shardy> wow, I was about to suggest we run that before/after upgrades but maybe not ;)
14:37:30 <EmilienM> I see a benefit for projects like nova, etc
14:37:43 <sshnaidm> http://logs.openstack.org/periodic/periodic-tripleo-ci-centos-7-ovb-nonha-tempest-oooq/946e654/logs/oooq/collected_logs/undercloud/home/jenkins/tempest/tempest.html.gz
14:37:47 <EmilienM> but for tripleo, we just want to test basic API calls, and scenarios no?
14:38:25 <panda> EmilienM: the basic Idea is to email results periodically to DFGs, containing only the parts of interest
14:38:32 <EmilienM> ok
14:38:37 <EmilienM> looks cool though
14:38:41 <EmilienM> depending on the use case
14:38:51 <EmilienM> for shardy, I think he wants to check basic things
14:38:58 <EmilienM> and smoke tests would be enough for now imho
14:39:16 <sshnaidm> shardy, "smoke" tests take about 20 mins
14:39:26 <shardy> yeah, but it'd be good in the periodic jobs to do a better validation than the basic sanity tests I'm doing atm
14:39:38 <shardy> sshnaidm: Ok, that could work then, great
14:40:01 <EmilienM> sshnaidm, shardy: are you done?
14:40:08 <shardy> yup, thanks
14:40:21 <EmilienM> #topic specs
14:40:29 <EmilienM> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:40:44 <EmilienM> I would encourage folks to prepare their specs before the PTG
14:40:55 <EmilienM> that would help to prepare discussion in Atlanta
14:41:39 <EmilienM> someone wants to talk about a spec?
14:42:07 <EmilienM> I'll move to open discussion
14:42:11 <EmilienM> #topic open discussion
14:42:20 <EmilienM> I would like to talk about PTG
14:42:24 <EmilienM> some sessions are proposed: https://etherpad.openstack.org/p/tripleo-ptg-pike
14:42:35 <EmilienM> if you haven't looked yet, please do it asap
14:42:48 <EmilienM> feel free to propose a topic you would like to talk to, like a blueprint or a policy
14:42:56 <EmilienM> we'll have a room for 3 days, so, plenty of time
14:43:16 <EmilienM> also, if you already proposed something in the etherpad, please look at it now, I see some comments, that might need to be addressed
14:43:25 <bkero> Related to that, it is looking like I will not be sent to the PTG, so if someone wants to chair the session that I put up, please do so. :)
14:43:56 <EmilienM> trown: maybe you? ^
14:44:45 <trown> sure
14:44:45 <EmilienM> it's open discussion now, feel free to ask any question or give feedback on something
14:44:56 <EmilienM> trown: thx. I put your name :P
14:45:04 <EmilienM> I can also do it
14:46:02 <EmilienM> I'll close the meeting in 30s if nothing comes up
14:46:37 <EmilienM> thanks everyone
14:46:43 <EmilienM> #endmeeting