14:00:09 <EmilienM> #startmeeting tripleo
14:00:09 <openstack> Meeting started Tue Feb 14 14:00:09 2017 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:13 <EmilienM> #topic agenda
14:00:13 <openstack> The meeting name has been set to 'tripleo'
14:00:15 <bandini> o/
14:00:17 <adarazs> o/o/
14:00:20 <EmilienM> * review past action items
14:00:20 <chem> /o~
14:00:22 <shardy> o/
14:00:22 <EmilienM> * one off agenda items
14:00:24 <EmilienM> * bugs
14:00:26 <EmilienM> * Projects releases or stable backports
14:00:28 <EmilienM> * CI
14:00:30 <EmilienM> * Specs
14:00:32 <beagles> o/
14:00:32 <EmilienM> * Week roadmap
14:00:34 <EmilienM> * open discussion
14:00:36 <EmilienM> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:00:38 <EmilienM> Hi everyone! who is around today?
14:00:45 <marios> o/
14:00:49 <shardy> hey all
14:01:14 * EmilienM proposes a quick meeting so folks can get back to work
14:01:19 <ccamacho> o/ hey guys
14:01:23 <hrybacki> o/
14:01:34 <EmilienM> #topic review past action items
14:01:45 <EmilienM> EmilienM to create etherpad with list of granted FFE for ocata: done - all FFE are merged.
14:01:51 <EmilienM> team to review https://review.openstack.org/#/q/topic:bp/overcloud-upgrades-per-service and https://review.openstack.org/#/q/topic:bp/overcloud-updates-per-service_fixup: still WIP
14:01:58 <mwhahaha> o/
14:02:01 <dtantsur> o/
14:02:04 <EmilienM> owalsh / EmilienM to work together on short term solutions for nova blockers: done.
14:02:15 <rbrady> o/
14:02:16 <karthiks> o/
14:02:18 <michapma_alt> o/
14:02:43 <EmilienM> quick info on nova, we need https://review.openstack.org/#/c/432954 to be backported so stable/ocata Ci will work in tripleo
14:02:50 <jrist> o/
14:02:55 <EmilienM> owalsh: ^ we can catchup on that topic later
14:03:07 <EmilienM> owalsh: I created a list of actions for this week: https://trello.com/c/zyzKZ9MX/65-ocata-tripleo-nova-placement-backport
14:03:14 <EmilienM> gfidente / EmilienM to help Dell to get Scale-IO on time for ocata https://review.openstack.org/#/c/422238/: done & thanks gfidente!
14:03:19 <EmilienM> team to review https://review.openstack.org/#/q/topic:bp/octavia-service-integration: done
14:03:23 <EmilienM> EmilienM to propose RC1 by end of this week if possible or next week: postponed to this week (hopefully)
14:03:26 <EmilienM> EmilienM to double check about novajoin blueprint & ffe status: done, postponed to pike
14:03:29 <EmilienM> team to look at ovs-2.6 blueprints and give feedback: done, approved for pike-2
14:03:32 <EmilienM> karthiks post on ML about ovs-2.6 blueprints and ask for feedback: done
14:03:35 <EmilienM> High - team to work on Critical / High bugs for ocata-rc1: WIP
14:03:38 <EmilienM> Medium - team to finish features with granted FFE and help in review: done
14:03:41 <EmilienM> Low - Pike planning - prepare specs, prepare PTG: done: schedule is ready: https://etherpad.openstack.org/p/tripleo-ptg-pike
14:03:45 <EmilienM> #info PTG schedule is ready, please review
14:03:47 <EmilienM> #link PTG schedule https://etherpad.openstack.org/p/tripleo-ptg-pike
14:04:11 <pradk> o/
14:04:12 <marios> =
14:04:17 <EmilienM> any question / feedback before we jump to next topic?
14:04:18 <matbu> o/
14:04:25 <fultonj> o/
14:04:37 <EmilienM> #topic one off agenda items
14:04:41 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:04:45 <cdearborn> o/
14:04:57 <EmilienM> no topic this week? let's move forward then
14:04:59 <jrist> EmilienM: none
14:04:59 <jrist> yup
14:05:09 <EmilienM> #topic bugs
14:05:12 <EmilienM> #link https://launchpad.net/tripleo/+milestone/ocata-rc1
14:05:59 <EmilienM> there are a bunch of High / Critical bugs in progress
14:06:21 <shardy> And we're still working on landing a few remaining patches for composable upgrades
14:06:25 <shardy> https://review.openstack.org/#/q/status:open+project:openstack/tripleo-heat-templates+branch:master+topic:bp/overcloud-upgrades-per-service
14:06:25 <EmilienM> I would ask folks to update their bugs if not done already
14:06:40 <marios> EmilienM: this one was filed today by mcornea...  https://bugs.launchpad.net/tripleo/+bug/1664304 the way we are planning on applying puppet wont work  but there is a fixup in progres https://review.openstack.org/#/c/433641/ and there are a number of folks testing
14:06:40 <openstack> Launchpad bug 1664304 in tripleo "Upgrading compute nodes fails with: Error: Evaluation Error: Error while evaluating a Function Call, Could not find data item step in any Hiera data file and no default supplied at /etc/puppet/modules/tripleo/manifests/profile/base/ceph/client.pp:27:11 on node overcloud-novacompute-0.localdomain" [Critical,In progress] - Assigned to Sofer Athlan-Guyot (sofer-athlan-guyot)
14:06:49 <shardy> I'd suggest we declare the BP complete as soon as we land nova support, then handle any remaining upgrade issues as bugfixes?
14:06:56 <EmilienM> and if you feel like the bug you're working on or you reported has a fix that needs to be backported, please tag is 'ocata-backport-potential'
14:06:57 <jrist> +1
14:07:12 <EmilienM> shardy: works for me
14:07:19 <marios> shardy: yeah i think that one is pretty important though (as important as the nova one) and we'l have to land it for the 'basic' workflow
14:07:30 <marios> shardy: i mean the one ^^^ bug/1664304
14:08:18 <shardy> marios: ack, thanks - yeah I just meant we can track things more closely via bugs vs the umbrealla blueprint
14:08:34 <EmilienM> #action upgrade squad to move remaining work in bugs instead of blueprint
14:08:39 <shardy> sounds like we're already doing that, so it'd be good to close off the BP given the end-of-cycle deadline looming
14:08:49 <marios> yes makes sense to me thanks shardy
14:09:02 <EmilienM> shardy: do you want to do it now?
14:09:17 <EmilienM> or wait for the tht/nova patch
14:09:42 <EmilienM> fwiw, i'm ok to wait until Thursday
14:09:42 <shardy> EmilienM: I was hoping we'd land the nova patch, but I'll sync with folks after the meeting so we can decide if that's going to happen very soon or not
14:09:48 <EmilienM> ok
14:10:20 <marios> shardy: EmilienM i think we are really close matbu has been updating it regularly
14:10:32 <EmilienM> I would like to highlight a bug reported by bnemec yesterday: https://bugs.launchpad.net/tripleo/+bug/1664418
14:10:32 <openstack> Launchpad bug 1664418 in tripleo "HA deployments taking close to the CI timeout" [High,Triaged]
14:10:35 <EmilienM> it's a bit concerning tbh
14:10:39 <marios> lots of folks owalsh and others helping to review
14:10:44 <matbu> shardy: for my side, im just testing a little fix, but then if owalsh and ansiwen is ok to land (on the latest revision) then it's cool
14:10:55 <shardy> matbu: ack, Ok great, thanks for the update
14:11:01 <EmilienM> we might need some eyes on this bug report, if anyone has time to investigate ^
14:11:04 <shardy> would be nice if we can land that before we branch rc1
14:11:20 <matbu> yep
14:11:49 <EmilienM> can you use links please?
14:12:02 <EmilienM> I need to know which patch(es) exactly we're waiting for
14:12:08 <matbu> yep
14:12:10 <matbu> secs
14:12:19 <matbu> https://review.openstack.org/405241
14:12:58 <EmilienM> matbu: that's all?
14:13:12 <EmilienM> #info https://review.openstack.org/#/c/405241/ is the last blocker before merging stable/ocata
14:13:27 <marios> EmilienM: https://review.openstack.org/#/c/433641/ too i think ? shardy ?
14:14:06 <matbu> EmilienM: for the nova patch yes
14:14:12 <marios> shardy: i mean it is the one for the puppet apply bug https://bugs.launchpad.net/tripleo/+bug/1664304
14:14:12 <openstack> Launchpad bug 1664304 in tripleo "Upgrading compute nodes fails with: Error: Evaluation Error: Error while evaluating a Function Call, Could not find data item step in any Hiera data file and no default supplied at /etc/puppet/modules/tripleo/manifests/profile/base/ceph/client.pp:27:11 on node overcloud-novacompute-0.localdomain" [Critical,In progress] - Assigned to Sofer Athlan-Guyot (sofer-athlan-guyot)
14:14:12 <shardy> marios: yes would be good to land that too, but anything with a bug reference we can backport
14:14:39 <EmilienM> ok, let's move forward
14:14:48 <EmilienM> anything else about bugs this week?
14:14:49 <marios> no pressure chem :D
14:15:11 <EmilienM> #topic projects releases or stable backports
14:15:14 <chem> marios: it's working 100% :)
14:15:17 <EmilienM> #info Essential release blocker: composable upgrades
14:15:22 <EmilienM> no major update to announce
14:15:34 <EmilienM> I already sent a status on Sunday - feel free to ask questions
14:15:50 <EmilienM> the tl;dr is we expect to release tripleo ocata rc1 by Friday and we'll have stable/ocata by then
14:16:17 <EmilienM> #action EmilienM to propose RC1 by end of this week (postponed)
14:16:21 <EmilienM> #link Ocata release patch https://review.openstack.org/#/c/428416/
14:16:36 <EmilienM> any question about release management?
14:16:49 <jrist> reminder to add release notes to patches now
14:16:55 <jrist> including ui!
14:17:00 <trown> o/ apologies for the tardiness
14:17:20 <EmilienM> jrist: right, release notes for all projects that are released
14:17:27 <EmilienM> #topic CI
14:17:31 <EmilienM> #info tripleo multinode upgrades job is currently broken: attempt to fix it with https://review.openstack.org/#/c/433646/
14:18:06 <EmilienM> except bnemec's bug report with timeout, OVB jobs & multinode (except upgrades) are working & pretty stable AFIK
14:18:24 <shardy> when that's fixed we should probably move it into the check queue for tripleo-ci and make it voting on tripleo-ci & tripleo-heat-templates
14:18:46 <trown> #info CI Squad meeting notes http://lists.openstack.org/pipermail/openstack-dev/2017-February/112036.html
14:18:47 <EmilienM> my main concern now is stable/ocata jobs: https://review.openstack.org/#/c/426231/ to have the ipv6 job we need the backport in nova
14:18:55 <jtomasek> o/
14:18:55 <jrist> https://en.wikipedia.org/wiki/House_of_Cards_(UK_TV_series)
14:18:57 <jrist> oops
14:18:59 <jrist> lol
14:19:09 <EmilienM> shardy: making it voting means moving to gate, not only check queue
14:19:22 <sshnaidm> EmilienM, containers job is broken, testing now patch of jistr
14:19:27 <slagle> multinode jobs seem to have slown down a bit too
14:19:34 <shardy> EmilienM: sure, I'm saying we should consider doing that, since it's been stable until this regression
14:19:45 <EmilienM> slagle: :( it might be related to the steps changes
14:19:51 <slagle> i wonder if it's just b/c we have moved so much puppet stuff to run at earlier steps
14:20:01 <slagle> so now we're running things an additional 2 or 3 times
14:20:03 <EmilienM> to be honest, I would have avoided this change, but the thing with nova placement & cells was really required
14:20:29 <EmilienM> slagle: well, resources are not supposed to be recreated at every puppet run, since puppet is idempotent
14:20:40 <EmilienM> slagle: but the time to "check" the resources takes time, yes
14:20:54 <slagle> and compiling catalogs, etc etc
14:20:59 <slagle> idempotent really has nothing to do with it
14:21:15 <EmilienM> right, I'm just saying it should not take that long but I'm probably under estimating
14:22:18 <EmilienM> slagle: we might want to take it offline after the meeting or this week, I would like to run some investigations
14:22:50 <EmilienM> sshnaidm: ok thx for the info, any bug report?
14:23:04 <EmilienM> anything else about CI this week?
14:23:15 <sshnaidm> EmilienM, yes, https://bugs.launchpad.net/tripleo/+bug/1664569
14:23:15 <openstack> Launchpad bug 1664569 in tripleo "Containerized overcloud fails due to missing EndpointMap parameter" [High,In progress] - Assigned to Jiří Stránský (jistr)
14:23:26 <weshay> yup
14:23:31 <EmilienM> sshnaidm: thanks
14:23:52 <panda> all periodic jobs green today
14:24:06 <EmilienM> some good news :-)
14:24:20 <panda> yeah, I feel like I'm on vacation.
14:24:25 <weshay> lol
14:24:38 <panda> .. and then I look at the review backlog
14:24:40 <EmilienM> if you're bored, let me know we have a ton of bugs :-)
14:24:41 <beagles> jinx!
14:24:54 <EmilienM> ok next topic
14:24:57 <EmilienM> #topic specs
14:24:58 <EmilienM> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:25:07 <EmilienM> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:25:38 <EmilienM> I proposed a squad for Python 3. I would like to talk about it at PTG
14:25:43 <EmilienM> #link Python 3 squad https://review.openstack.org/#/c/425294/
14:26:06 <EmilienM> #action EmilienM to propose a Python3 session & invite RDO folks
14:26:54 <EmilienM> anyone wants to talk about a spec in particular?
14:27:19 <EmilienM> #topic week roadmap
14:27:27 <EmilienM> #action High - team to work on last Critical / High bugs for ocata-rc1
14:27:29 <EmilienM> #link High - ocata-rc1 https://launchpad.net/tripleo/+milestone/ocata-rc1
14:27:31 <EmilienM> #action Medium - Pike planning - prepare specs, prepare PTG
14:27:33 <EmilienM> #link Pike PTG https://etherpad.openstack.org/p/tripleo-ptg-pike
14:27:35 <EmilienM> #info Next week is PTG in Atlanta, no TripleO weekly meeting
14:27:49 <EmilienM> #action jrist to finish House of Cards before PTG
14:28:02 <EmilienM> anything else we need to achieve this week?
14:28:02 <beagles> lol
14:28:04 <jrist> lol
14:28:07 <jrist> thanks EmilienM
14:28:34 <EmilienM> is it ok if we don't run a meeting next week?
14:28:43 <EmilienM> I think most of us will be in Atlanta
14:29:13 <EmilienM> #topic open discussion
14:29:27 <EmilienM> do we want to talk about the logo now?
14:29:34 <jrist> yes
14:29:35 <jrist> :)
14:29:36 <EmilienM> I forwared an email I got from marketing
14:29:41 <EmilienM> forwarded*
14:30:07 <EmilienM> first question: do we have strong opinions on keeping our current logo?
14:30:44 <EmilienM> I remember dprince was a bit worried about that, though he's not here so I'll ask him offline
14:30:50 <shardy> AFAICT keeping our current logo isn't actually an option?
14:31:01 <EmilienM> shardy: why that?
14:31:33 <shardy> the mail from Heidi says "But for official channels like the website, we need a logo to represent TripleO that’s cohesive with the rest of the set. "
14:31:41 <trown> ya, that was my understanding as well
14:31:47 <slagle> right, there isn't really any option
14:31:49 <jrist> sadface
14:31:59 <EmilienM> I find that weird tbh
14:32:00 <shardy> which to me implies, we can't keep our current logo for official/foundation use, we have to use one validated by the foundation
14:32:02 <rbrady> it doesn't seem that much of the feedback was incorporated about the logo that we provided
14:32:04 <slagle> we have to accept their logo if we want to be included in "official" branding
14:32:06 <jrist> so Carlos asked if we can have them adapt the current one
14:32:09 <trown> IF keeping current logo was an option, I would be +1 on that... but I dont think it is
14:32:25 <EmilienM> wdyt about the proposed logo?
14:32:37 * EmilienM will miss the real owl
14:32:39 <jrist> I think it looks like a falcon more than an owl
14:32:44 <shardy> Yeah, I prefer the current logo, and my feedback was basically "make it look more like the current logo"
14:32:45 <adarazs> I think there were some good feedback about 'what was wrong with the new logo' besides "not liking it"
14:32:47 <jrist> and it has no personality
14:33:14 <shardy> but I'm not sure what choice we have, other than perhaps asking to do more iterations on what has been proposed
14:33:18 <trown> there was also a request to have someone dedicated to working with the illustrator to iterate quickly on something more to our liking
14:33:26 <trown> ccamacho: would you want to do that ^
14:33:36 <EmilienM> ccamacho, jrist: would you be interested to propose a new logo that meets requirements? Or do we want to ask them to re-iterate on a new one?
14:33:58 <jrist> I currently don't have access to illustrator but I could stab at it with inkscape
14:34:21 <rbrady> if they are not willing to incorporate feedback from the project, the logo doesn't represent us anyway
14:34:22 <shardy> I'm not clear if the requirements are defined, other than the illustrators have a common theme they're going for?
14:34:23 <ccamacho> hey trown EmilienM jrist sure
14:34:35 <trown> jrist: I was not talking about the adobe program, but a real human :P
14:34:36 <EmilienM> jrist: I think trown meant the person in charge of illustration
14:34:42 <shardy> rbrady: I think the comment was the feedback recieved wasn't specific/actionable enough
14:34:50 <jrist> EmilienM: oh
14:34:59 <shardy> so we probably can try to give more specific feedback to iterate towards something which everyone is OK with
14:35:08 <jrist> I was talking about adobe illustrator
14:35:11 <jrist> my mac died
14:35:12 <ccamacho> the thing is that I believe they didn't iterate from the first logo "the current logo" they did something from scratch
14:35:19 <shardy> seems like a pretty poor use of developer time at this point in the cycle but <sigh>
14:35:28 <EmilienM> shardy: I agree
14:35:34 <jrist> did they happen to do any updates based on feedback?
14:35:36 <jrist> it doesn't seem like it
14:35:38 <trown> fwiw ironic is having a similar issue
14:35:42 <EmilienM> and I would continue offline if you don't mind, to let people doing their work
14:35:50 <ccamacho> sure
14:36:02 <shardy> jrist: I think the concentric circles were added to attempt to encapsulate the OoO theme
14:36:02 <jtomasek> yeah, too bad the illustrators did not take any of the feedback and reiterate on the logo
14:36:21 <rbrady> shardy: I guess I disagree on the actionable part.
14:36:22 <jrist> shardy: perhaps
14:36:39 <EmilienM> jtomasek, ccamacho, jrist: do you want to take action and reply with graphical details on what you expect?
14:37:07 <jrist> sure but it might be violent
14:37:14 <shardy> lol
14:37:16 <ccamacho> sure, Ill start a draft this afternoon/night
14:37:17 <jrist> oh no did I type that?
14:37:18 <jtomasek> EmilienM, jrist we can try to propose illustrators to turn our logo into one that is compliant with general style
14:37:26 <shardy> lets keep it constructive ;)
14:37:31 <jrist> shardy: :)
14:37:34 <jrist> just joking
14:37:38 <EmilienM> I agree, let's be constructive and open :D
14:37:42 <EmilienM> jtomasek: sounds like a good idea
14:37:47 <ccamacho> I think the idea is con convert what we have to be compliant with the styles
14:38:00 <ccamacho> yeahp
14:38:03 <ccamacho> agreed
14:38:18 <shardy> yeah - it'd be cool if we could propose a variation on the current logo that moves closer to the foundation themes
14:38:34 <shardy> kudos to anyone with the skills to do that /me doesn't :)
14:38:50 <EmilienM> ok I'll reply to Heidi using the thread on openstack-dev
14:38:51 <jrist> haha but I dont' have your skills, that's why we're a team
14:39:14 <EmilienM> do we have any other topic for this week?
14:39:46 <EmilienM> #action EmilienM to reply to Heidi and ask Design team to re-propose a new logo that would be a variation on the current logo that moves closer to the foundation themes
14:40:03 <EmilienM> thanks folks for your time!
14:40:07 <EmilienM> jrist: enjoy TV shows
14:40:13 <EmilienM> oh and see you next week
14:40:13 <trown> lol
14:40:14 <EmilienM> #endmeeting