14:00:09 <shardy> #startmeeting tripleo
14:00:10 <openstack> Meeting started Tue Apr 11 14:00:09 2017 UTC and is due to finish in 60 minutes.  The chair is shardy. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:12 <adarazs> o/
14:00:15 <openstack> The meeting name has been set to 'tripleo'
14:00:17 <shardy> Hey all, who's around?
14:00:25 <mwhahaha> o/
14:00:25 <marios> hello tripleo o/
14:00:30 <jrist> o/ o/
14:00:34 <owalsh> o/
14:00:48 <bogdando> o/
14:00:50 <dtantsur> o/
14:01:06 <mandre> \o/
14:01:20 <d0ugal> o/
14:01:21 <beagles> o/
14:01:27 <akrivoka> \o
14:01:34 <[1]cdearborn> o/
14:01:55 <shardy> Ok then - EmilienM is out today so I'll run the meeting, feel free to shout if I forget anything ;)
14:01:56 <dprince> hi
14:01:57 <florianf> o/
14:02:02 <shardy> #topic agenda
14:02:02 <shardy> * review past action items
14:02:02 <shardy> * one off agenda items
14:02:02 <shardy> * bugs
14:02:02 <shardy> * Projects releases or stable backports
14:02:04 <shardy> * CI
14:02:07 <weshay> o/
14:02:07 <shardy> * Specs
14:02:09 <shardy> * Week roadmap
14:02:12 <shardy> * open discussion
14:02:14 <shardy> #topic review past action items
14:02:23 <shardy> #link http://eavesdrop.openstack.org/meetings/tripleo/2017/tripleo.2017-04-04-14.00.html
14:02:35 <shardy> EmilienM to postpone pike-1 Triaged bugs to pike-2 milestone this week
14:03:00 <shardy> Thats done https://launchpad.net/tripleo/+milestone/pike-1
14:03:20 <shardy> pike 1 released, nice work folks, thats the first milestone done :)
14:03:36 <shardy> 8 blueprints & 149 bugs
14:03:54 <shardy> dprince moves introspection from non-ha to ovb-containers and remove nonha job starting from pike (and keep it for stable/ocata and stable/newton)
14:04:03 <shardy> dprince: Hey that's in progress right?
14:04:08 * jrist claps
14:04:35 <dprince> shardy: yes. I gave priority to getting the mirrors in place to stablize our job times (hopefully)
14:04:54 <dprince> shardy: once that plays out I'll push the infra/project-config patch to make the switch
14:04:58 <shardy> dprince: Ok cool, shall we add an action to discuss again next week?
14:05:27 <dprince> shardy: sure, I really do hope it gets done in the next day or two as its been almost 2 weeks now without a containers overcloud job
14:05:32 <shardy> #action dprince follow up re switch of OVB jobs to provide container coverage after mirrors are in place
14:05:47 <shardy> dprince: yeah agreed, it'd be great to see that running again
14:05:54 <shardy> jistr / shardy / weshay / EmilienM to synchronize about the work prioritization on container / multinode CI work
14:06:13 <shardy> So I think jistr panda|pto and matbu have been working on this
14:06:30 <shardy> mattbu and jistr have upgrade quickstart patches which look pretty close
14:06:43 * jistr nods
14:06:51 <shardy> panda|pto isn't around I assume, anyone else have an update of the status of multinode non-upgrade container patches?
14:07:28 <shardy> If not I'll defer the action and we can keep tracking it outside of the meeting
14:08:03 <shardy> #action jistr/matbu/panda/weshay/shardy/Emilien work together to move multinode w/containers CI forward
14:08:25 <shardy> Ok, anyone have anything else from last week to discuss?
14:08:45 <shardy> #topic one off agenda items
14:08:57 <shardy> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:09:01 <shardy> bogdando: hi!
14:09:24 <bogdando> shardy: hi
14:09:32 <shardy> bogdando: is there specific discussion required re your items, or was it just to raise visibility of those topics?
14:09:56 <bogdando> to raise visibility and ask for discussion
14:10:20 <shardy> #action all to review http://lists.openstack.org/pipermail/openstack-dev/2017-April/115182.html and respond
14:10:27 <trown> o/
14:10:49 <shardy> dprince, jistr do you have anything specific to add now re the hostpath thread?
14:11:21 <bogdando> the main point is to come up with a consolidated approach for code review
14:11:31 <jistr> i replied to the list, don't have anything more to add than what's there ATM
14:12:00 <bogdando> and agree on best practices whenever to use kolla_config command/extend start/bootstrap/permissions or not to do so
14:12:11 <shardy> Ok sounds like we can take it to the ML, thanks for raising it bogdando
14:12:15 <bogdando> and set in stone or the like
14:12:17 <dprince> bogdando: I think we want to use kolla_start for now
14:12:25 <dprince> bogdando: for the most part, but not kolla_config
14:12:39 <bogdando> dprince: command is a part of the kolla_config
14:12:42 <dprince> bogdando: well we still use kolla_config
14:12:42 <bogdando> permissions as well
14:12:47 <dprince> bogdando: and permissions
14:13:06 <bogdando> so it looks complicated for ppl writing patches AND doing reviews
14:13:11 <dprince> bogdando: lets put it this way. We just want to avoid using kolla_config to map in our service config files.
14:13:12 <bogdando> let's help each other ;)
14:13:27 <dprince> bogdando: we'd rather just do the bind mounts
14:13:44 <bogdando> yeah, that is the most clear part of the thing
14:13:52 <dprince> bogdando: and moutn in our config files like that. Fwiw we are taking a simpler approach in doing this
14:13:53 <bogdando> but there are more...
14:14:19 <bogdando> I've rised all that came to my mind in the mail thread, feel free to add and suggest alts
14:14:19 <dprince> bogdando: using kolla_config to map in config files was actually causing extra maintenance (and bugs even)
14:14:46 <jistr> yea, like what entrypoints to use for what actions ("normal" container start, one-time init actions, etc.) and where do those entrypoints live
14:15:18 <dprince> jistr: the entrypoints we use today live in t-h-t for us
14:15:35 <bogdando> next step after a review policy, could be to unify that we already have
14:15:36 <jistr> well not if we use kolla_start
14:15:59 <jistr> as those live in Kolla repos
14:16:06 * jistr made some points on the ML about that
14:16:07 <dprince> jistr: we specify our own commands though
14:16:12 <bogdando> and basically I'm blocked with https://review.openstack.org/#/c/442603/ because of that
14:16:16 <dprince> jistr: it is a mix, yes
14:16:21 <bogdando> no approach to apply for all cases
14:16:25 <dprince> jistr: but there are some features there we rely on for now too
14:16:48 <jistr> right, we mix the approaches in many places. our entrypoints vs. kolla ones
14:17:07 <jistr> that's what bogdando is raising i belive, as he was -1'd for not using kolla entrypoint
14:17:26 <dprince> bogdando: so the logs patch is what you are after?
14:17:28 <jistr> and it seems opinions about this somewhat differ among reviewers
14:17:42 <jistr> etcd patch i think...
14:17:46 <bogdando> what is not a big deal, the more issues bring doing code review of new process
14:17:50 <bogdando> patches*
14:17:58 <bogdando> that is*
14:18:25 <jistr> i'd suggest that we read the ML and either discuss on #tripleo or on the ML
14:18:30 <bogdando> that's all from my side wrt that topic, thank you for a hot discussion
14:18:46 <shardy> Ok, thanks bogdando, lets see if we can reach consensus on the ML
14:19:07 <shardy> #topic bugs
14:19:34 <shardy> #link https://bugs.launchpad.net/tripleo/?orderby=-id&start=0
14:19:53 <shardy> https://launchpad.net/tripleo/+milestone/pike-2
14:20:11 <shardy> 325 bugs targetted wow
14:20:21 <shardy> Does anyone have specific bugs to raise this week?
14:21:16 <marios> shardy: nothing urgent but since is quiet may as well mention 1680006
14:21:23 <shardy> I wanted to remind everyone, please when you raise a bug, self-triage it and set the milestont to pike-2 or pike-3
14:21:38 <marios> shardy: https://bugs.launchpad.net/tripleo/+bug/1680006 came up last week end of week but just moved it to fix released
14:21:39 <openstack> Launchpad bug 1680006 in tripleo "Check for legacy hiera data fails preventing the upgrade from proceeding" [Critical,Fix released] - Assigned to Marios Andreou (marios-b)
14:21:40 <shardy> also, if you set a bug wontfix or invalid, please remove the milestone
14:21:49 <shardy> the milestone is for tracking work we expect to do
14:22:24 <shardy> marios: Yeah, there is something weird happening there, as we still trip the legacy hieradata check even with the element removed
14:22:29 <shardy> but only on update or upgrade
14:22:44 <shardy> I've not had time to reproduce it locally, but any help figuring that out would be good
14:22:55 <marios> shardy: ack yes for https://bugs.launchpad.net/tripleo/+bug/1680996
14:22:56 <openstack> Launchpad bug 1680996 in tripleo "ocata ovb jobs fail with CREATE_FAILED Error: resources.NovaComputeDeployment" [Critical,Fix released] - Assigned to Steven Hardy (shardy)
14:24:19 <shardy> I have been doing a bunch of stack updates locally which work, so we need to find out why the updates job triggered the issue
14:24:27 <shardy> marios: Ok lets follow up with anyone interested after the meeting
14:24:40 <shardy> Any more bugs to mention before we continue?
14:24:58 <marios> ack thanks shardy
14:25:05 <shardy> #topic Projects releases or stable backports
14:25:14 <shardy> Ok so pike-1 was released
14:25:32 <shardy> I assume we'll want at least an ocata release as we've been backporting things, I'll sync with EmilienM about that
14:26:12 <shardy> Does anyone have anything else to raise re releases, high priority backports which need review, or any questions?
14:27:04 <shardy> #topic CI
14:27:36 <shardy> http://tripleo.org/cistatus.html
14:28:21 <shardy> marios: I'm a little confused re why patches to tripleo-ci pass the upgrades job
14:28:38 <shardy> I guess we can dig into that after the meeting
14:29:14 <marios> shardy: ack
14:29:22 <shardy> So one thing, I posted https://review.openstack.org/#/c/455379/ because it seems Depends-On to heat-agents didn't work
14:29:41 <shardy> I'm not certain if that's all we need for the delorean build to pick up the depends-on version
14:29:53 <shardy> but getting that working would be useful I think
14:29:56 <marios> shardy: i thought it was ocata only for the 'hiera check' (but we did see it on master too so..)
14:30:17 <shardy> marios: yeah I've seen the same error in ocata upgrades and master updates jobs
14:30:45 <shardy> Seems we have a plan re the container CI, is there anything else to raise?
14:31:06 <shardy> Do we need any update from pabelanger re the mirroring, or is that all ready to use now?
14:31:33 <pabelanger> should be ready to use
14:31:50 <pabelanger> please CC' me on patches, so I can monitor apache logs to confirm
14:31:54 <shardy> pabelanger: great, thanks for getting that working :)
14:32:02 <pabelanger> np, happy to do it
14:32:30 <weshay> woot
14:32:55 <shardy> Ok, anything else re CI?
14:33:32 <shardy> #topic Specs
14:33:39 <shardy> https://review.openstack.org/#/q/status:open+project:openstack/tripleo-specs
14:34:04 <shardy> There's a number of specs needing review, any help appreciated
14:34:21 <shardy> seems many have +2 so I'll see what we can land later today
14:35:05 <shardy> Anyone have comments/questions re specs?
14:35:36 <shardy> There was some ML discussion and I think we agreed to try to keep specs fairly lightweight
14:36:05 <shardy> I feel like in some cases things get bogged down in a lot of detail, we can often do that detail better during code-review
14:36:18 <shardy> e.g implementation detail vs interfaces and general direction
14:36:46 <shardy> Does anyone know what "Week Roadmap" is on the agenda?
14:36:47 <jrist> +1 to details in code review
14:37:00 <jrist> shardy: I think that's plans for the week for the team
14:37:35 <shardy> #topic Week Roadmap
14:37:54 <shardy> So, maybe everyone can give a one-liner of what they'll be working on primarily this week?
14:38:19 * shardy containerized deployment support of minor updates, probably via heat+ansible
14:39:24 * marios any outstanding n..o bugs (like bug/1680006 or bug/1680006) then catching up on the containers upgrade/update efforts with jistr & shardy (rest of upgrades team will be joining along)
14:40:02 * trown reviewing quickstart containers and OVB transition patches and helping OPNFV folks with quickstart
14:40:20 <shardy> Ok, I'm not sure how EmilienM normally does this so we can move on if folks aren't keen to share :)
14:40:29 <shardy> #topic Open Discussion
14:40:30 <trown> I think that is new
14:40:38 <trown> I have never done that in this meeting
14:40:39 * matbu almost the same as marios + review and checkout the work on upgrade containers CI from jistr
14:40:44 * jistr container upgrades CI, plus tangential optimization in OOOQ
14:40:47 <marios> shardy: +1 effort to try something new /at least makes people think about it
14:40:53 <trown> tricky EmilienM putting something new in the mix when he is on PTO
14:40:54 <shardy> trown: hehe, yeah I didn't remember it so made a guess how the topic should be handled :)
14:41:21 <beagles> beagles: clewing up octavia post-deploy steps and switching focus to containerization (fwiw)
14:42:36 * slagle trying to wrap up a few minor split-stack bugs
14:43:01 <slagle> oh, and if anyone wants to review https://review.openstack.org/#/c/452223/ :)
14:43:15 <slagle> i'd like to land that soon'ish if there are no major objections
14:43:25 <slagle> it's a highly requested feature/bugfix by operators
14:43:35 <matbu> shardy: yep +1 maybe something to keep for the next mtg
14:43:36 * adarazs will try to make a "landing page" for the quickstart logs to make it easier to find your way around them and debug when the job is run with OOOQ.
14:43:38 <shardy> slagle: It'd be good to chat about split stack in the context of https://review.openstack.org/#/c/454816/ at some point
14:43:58 <shardy> slagle: one option here is to build an ansible playbook and make it a stack output or write to swift
14:44:11 <shardy> vs running it via heat (which could still be a default mode)
14:44:39 <slagle> shardy: ok; so in that case, heat would be used to effectively generate an ansible playbook?
14:44:53 <shardy> slagle: Yeah it's one option I've been thinking about
14:44:54 <slagle> which is then executed via other means
14:45:04 <shardy> but we could stop before running it, and e.g run it via mistral or whatever
14:45:20 <slagle> ok, i'll have a closer look
14:45:25 <shardy> that would solve another operator concern, e.g lack of control/visibility when running traditional config management via heat
14:45:42 <matbu> shardy: slagle maybe im out of context but i have already made a WIP patch for that (dump ansible playbook from heat)
14:45:54 <shardy> slagle: ack, thanks - I'm just at the polling for ideas stage and some prototyping, any thoughts appreciated
14:46:09 <slagle> matbu: link us?
14:46:37 <matbu> slagle: yep secs
14:46:54 <matbu> slagle: shardy https://review.openstack.org/444224
14:46:55 <shardy> matbu: Yeah it's something we could already do for upgrade tasks, but we need to fix https://bugzilla.redhat.com/show_bug.cgi?id=1421440 first (sorry I've not yet raised a LP bug)
14:46:55 <openstack> bugzilla.redhat.com bug 1421440 in openstack-tripleo-validations "tripleo-ansible-inventory does not report ceph" [High,New] - Assigned to flfuchs
14:47:07 <matbu> its in a wip state
14:47:10 <shardy> otherwise we can't run against anything except controller/compute
14:47:21 <shardy> I think flaper87 might take a look at that
14:47:29 <shardy> unless florianf is already on it
14:48:34 <florianf> shadower, matbu So this is basically something that will solve itself once the inventory is ready for composable roles.
14:48:45 <shardy> matbu: cool - yeah IMO we shouldn't special case this in tripleoclient, but in general it's something we can look at
14:48:49 <florianf> And I have a WIP patch for that
14:49:05 <shardy> florianf: cool, can you link please as I'd like to test/review?
14:49:21 <matbu> shardy: ack any feedback would be nice, i wanted to rework on that in the next days
14:49:23 <shardy> I think we basically just need to iterate over the role names from roles_data in the plan?
14:49:46 <florianf> shardy: it's not really ready to test, but it's here: https://review.openstack.org/#/c/450233/
14:49:47 <shardy> matbu: there's a heat swift resource, it might be cleaner to just write to swift from heat
14:49:56 <shardy> matbu: or expose some config outputs
14:50:00 <shardy> matbu: I'll comment on the review
14:50:22 <matbu> shardy: yep thank you
14:50:31 <florianf> shardy: So the idea is to let the inventory expose hosts both by role and by service
14:51:16 <shardy> florianf: ack, nice - perhaps you can rebase that & we can iterate on some reviews?
14:51:25 <florianf> shardy: sure, will do
14:51:29 <shardy> florianf: related to my ansible ideas above we kinda need this fixed
14:51:34 <shardy> florianf: thanks!
14:52:17 <shardy> Ok, anyone have anything else to raise
14:52:28 <florianf> shardy: right, I can continue with it tomorrow. Shouldn't take long to finish
14:54:06 <shardy> Ok then if there's nothing else lets endmeeting, thanks everyone!
14:54:11 <shardy> #endmeeting