13:59:56 <EmilienM> #startmeeting tripleo
13:59:57 <openstack> Meeting started Tue Jun 13 13:59:56 2017 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:00 <adarazs> \o/
14:00:02 <openstack> The meeting name has been set to 'tripleo'
14:00:04 <EmilienM> #topic agenda
14:00:10 <EmilienM> * review past action items
14:00:12 <EmilienM> * one off agenda items
14:00:14 <EmilienM> * bugs
14:00:16 <EmilienM> * Projects releases or stable backports
14:00:18 <EmilienM> * CI
14:00:20 <EmilienM> * Specs
14:00:22 <EmilienM> * open discussion
14:00:24 <EmilienM> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:00:26 <EmilienM> Hi everyone! who is around today?
14:00:28 <trown> o/
14:00:30 <d0ugal> o/
14:00:31 <ccamacho> o/
14:00:32 <shardy> o/
14:00:32 <jpich> o/
14:00:36 <jaosorior> o/
14:00:36 <panda> o/
14:00:38 <beagles> ./
14:00:45 <rasca> o/
14:00:47 <jtomasek> o/
14:00:49 <mwhahaha> o/
14:00:50 <atoth> o/
14:00:57 <akrivoka> o/
14:01:09 <EmilienM> what a nice crowd :D
14:01:14 <EmilienM> let's start
14:01:18 <matbu> o/
14:01:18 <EmilienM> #topic review past action items
14:01:39 <EmilienM> oh I think we didn't have any action last meeting
14:01:44 <EmilienM> #topic one off agenda items
14:01:49 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:01:58 <EmilienM> akrivoka, jpich : floor is yours :-)
14:02:06 <jpich> Ok! :)
14:02:11 <jpich> I was going to ask for reviews but I guess most patches merged in the meantime :) I'd still like to bring them up for attention since they change an important piece of plan management (this is part of the deployment plan changes spec)
14:02:18 <jpich> The Mistral environment no longer exists, parameters and passwords are now stored in Swift with the rest of the plan files
14:02:39 <weshay> o/
14:02:39 <jpich> There's a couple of clean-up patches to remove the last references to the Mistral environment (for instack-undercloud and the CLI) so other patches that are up for review may not fail obviously yet, even if they still use the Mistral env - something to be careful about
14:02:45 <myoung> o/
14:02:53 <jpich> akrivoka will also look through the code again to see if there might have been new commits using the Mistral env while the tripleo-common patch was up for review, and update them to use the Swift plan instead if that's the case
14:03:04 <jpich> https://review.openstack.org/#/q/topic:bp/stop-using-mistral-env for the remaining patches
14:03:05 <EmilienM> do we have a Gerrit topic to watch ?
14:03:07 <EmilienM> ah :D
14:03:08 <jpich> ...Thanks :-)
14:03:33 <EmilienM> #action workflow team to review https://review.openstack.org/#/q/topic:bp/stop-using-mistral-env
14:03:52 <EmilienM> jpich, akrivoka: thanks for the update. Is there anything else?
14:04:09 <jpich> That was it, thank you
14:04:14 <jrist> o/
14:04:16 <EmilienM> thank you
14:04:23 <akrivoka> thanks jpich @
14:04:25 <EmilienM> rlandy, weshay: o/
14:04:44 <EmilienM> sounds like you have 2 topics
14:05:11 <EmilienM> not sure if weshay and rlandy are around
14:05:11 <weshay> yes.. two distinct topics that we wanted to make sure everyone was aware of
14:05:16 <EmilienM> ah
14:05:20 <rlandy> we just want to raise awareness of two postings about RDO cloud and tripleo CI jobs
14:05:33 <EmilienM> #link http://lists.openstack.org/pipermail/openstack-dev/2017-June/118262.html
14:05:39 <EmilienM> #link http://lists.openstack.org/pipermail/openstack-dev/2017-June/118254.html
14:05:45 <rlandy> we would appreciate feedback on those postings as there is potential for impact
14:06:09 <EmilienM> rlandy: great, thanks for the updates. I haven't replied yet because it's still on my list todo
14:06:19 <weshay> we can follow up next meeting after people have a chance to read through them :)
14:06:26 <EmilienM> sounds great
14:06:30 <rlandy> thanks
14:06:44 <EmilienM> #action follow-up next meeting about OVB check gates moving to third party
14:06:56 <EmilienM> #action follow-up next meeting about tripleo periodic jobs will be moving to rdo infra
14:07:02 <EmilienM> rlandy, weshay: anything else?
14:07:03 <weshay> perfect
14:07:05 <weshay> nope
14:07:08 <rlandy> that's it
14:07:11 <EmilienM> cool
14:07:33 <EmilienM> before we jump to regular topics, do we have other off items for this week?
14:07:46 <EmilienM> let's move on
14:07:48 <EmilienM> #topic bugs
14:07:51 <EmilienM> #link https://launchpad.net/tripleo/+milestone/pike-3
14:08:20 <EmilienM> do we have outstanding bugs this week that we need to discuss here?
14:09:11 <EmilienM> sounds like no
14:09:17 <EmilienM> great let's move on
14:09:19 <EmilienM> #topic projects releases or stable backports
14:09:26 <EmilienM> so we released pike m2 last week, congrats team
14:09:35 <EmilienM> we also moved all bugs / blueprints from pike-2 to pike-3
14:09:50 <shardy> https://launchpad.net/tripleo/+milestone/pike-2
14:09:56 <EmilienM> this week, I'm doing some triage on blueprints, it seems some of them are implemented and some others are more for queens
14:10:02 <shardy> 7 blueprints and over 200 bugs fixed, nice :)
14:10:03 <EmilienM> don't be surprised if I ping you on IRC to ask for status
14:10:38 <EmilienM> shardy: indeed. Though the number of blueprint scheduled and done are still hugely different
14:10:40 <shardy> Yeah the pike-3 backlog doesn't look realistic at this point
14:10:41 <EmilienM> but that's the usual
14:10:44 <EmilienM> exactly
14:11:02 <EmilienM> I'll try to make it more realistic this week, so we know what we'll deliver and what is really at risk.
14:11:16 <EmilienM> if you're working on a blueprint, please help us and update the blueprint status
14:11:35 <EmilienM> next milestone is m3: Jul 24 - Jul 28
14:11:48 <EmilienM> #link https://releases.openstack.org/pike/schedule.html
14:12:03 <EmilienM> any question on release management & backports ?
14:12:18 <EmilienM> #topic CI
14:12:28 <EmilienM> I have a few positive news:
14:12:48 <EmilienM> - We got TripleO CI repo promotion this week-end (thanks Alfredo and Ihar for their hard work here)
14:12:53 <weshay> +1
14:12:54 <EmilienM> #link dashboards.rdoproject.org/rdo-dev
14:13:05 <shardy> nice work :)
14:13:10 <jpich> Nice!
14:13:10 <EmilienM> - Upgrade jobs are green on master AFIK
14:13:49 <ccamacho> yeahp there
14:13:50 <EmilienM> ccamacho and abishop were involved, but thanks to all who helped here
14:14:08 <ccamacho> thanks abishop for the hints
14:14:08 <EmilienM> do we have any other announcement on CI?
14:14:11 <panda> periodic jobs today has been hit by: https://bugs.launchpad.net/tripleo/+bug/1697626, should be solved now, kicked manual promotion.
14:14:13 <openstack> Launchpad bug 1697626 in tripleo "CI promotion fails to create image for conflicting python-cffi package" [High,In progress] - Assigned to Haïkel Guémar (hguemar)
14:14:23 <EmilienM> panda: ack, thanks for the heads-up
14:15:08 <EmilienM> ok if we don't have anything else, let's move
14:15:10 <EmilienM> #topic specs
14:15:13 <EmilienM> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:15:40 <EmilienM> bogdando: could you check with Lars about https://review.openstack.org/#/c/465633/ ? I've dropped some comments / questions
14:16:16 <EmilienM> paramite, larks and mrunge are offline from this channel
14:16:24 <EmilienM> bogdando: I thought you could follow-up with them eventually
14:16:44 <bogdando> EmilienM: ack
14:16:46 <EmilienM> bogdando: thx
14:16:53 <EmilienM> do we need to discuss about a spec in specific?
14:17:17 <EmilienM> sounds like no
14:17:18 <EmilienM> #topic open discussion
14:17:38 <EmilienM> FYI PTG is now open for registration
14:17:38 <jtomasek> Hi, I'd like to bring attention to the Roles management discussion started by Alex http://lists.openstack.org/pipermail/openstack-dev/2017-June/118157.html
14:17:40 <EmilienM> #link https://queensptg.eventbrite.com/
14:17:48 <jtomasek> It touches the topic of CLI and GUI interoperability and maintaining business logic in 2 places. I'd love to hear peoples opinions on the topic
14:17:54 <EmilienM> TripleO project will have sessions between Wednesday and Friday morning
14:18:19 <EmilienM> #action team to give feedback on http://lists.openstack.org/pipermail/openstack-dev/2017-June/118157.html
14:18:28 <jtomasek> EmilienM: thanks
14:18:45 <weshay> FYI.. for those interested in tempest results from tripleo upstream, we have some results here and you can watch this job for daily results http://logs.openstack.org/periodic/periodic-tripleo-ci-centos-7-ovb-nonha-tempest-oooq-master/6817d3a/logs/oooq/stackviz/#/stdin
14:19:04 <EmilienM> weshay: I'm about to send an email to explain how folks can subscribe to RSS and follow results
14:19:11 <weshay> great
14:19:23 <EmilienM> #action EmilienM to send email about how to use RSS to monitor Tempest results in TripleO CI
14:19:45 <EmilienM> anything else for this week?
14:20:22 <EmilienM> thanks everyone
14:20:24 <EmilienM> #endmeeting