14:00:31 <EmilienM> #startmeeting tripleo
14:00:31 <openstack> Meeting started Tue Jun 20 14:00:31 2017 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:35 <openstack> The meeting name has been set to 'tripleo'
14:00:41 <EmilienM> #topic agenda
14:00:46 <EmilienM> * review past action items
14:00:48 <EmilienM> * one off agenda items
14:00:50 <EmilienM> * bugs
14:00:52 <EmilienM> * Projects releases or stable backports
14:00:54 <EmilienM> * CI
14:00:54 <mwhahaha> o/
14:00:56 <EmilienM> * Specs
14:00:58 <EmilienM> * open discussion
14:01:00 <EmilienM> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:01:02 <EmilienM> hey folks, who is around today?
14:01:07 <jrist> o/
14:01:11 <jpich> o/
14:01:13 <panda> /o
14:01:17 <owalsh> o/
14:01:29 <sshnaidm> o\
14:01:40 <dprince> hi
14:01:45 <hjensas> \o (first timer)
14:02:21 <panda> hjensas: if it's your first time, you have to fight.
14:02:22 <EmilienM> let's start
14:02:28 <EmilienM> #topic review past action items
14:02:36 <EmilienM> workflow team to review https://review.openstack.org/#/q/topic:bp/stop-using-mistral-env
14:02:38 <marios> o/
14:02:42 <beagles> o/
14:02:49 <EmilienM> sounds like everything merged, so DONE
14:02:57 <EmilienM> follow-up next meeting about OVB check gates moving to third party
14:03:16 <cdearborn_> o/
14:03:19 <EmilienM> we'll probably talk about that during CI topic
14:03:27 <EmilienM> follow-up next meeting about tripleo periodic jobs will be moving to rdo infra
14:03:28 <EmilienM> ditto
14:03:32 <EmilienM> team to give feedback on http://lists.openstack.org/pipermail/openstack-dev/2017-June/118157.html
14:03:51 <matbu_> o/
14:03:54 <florianf> o/
14:03:54 <EmilienM> mwhahaha: ^ did you have enough feedback on this thread?
14:04:10 <weshay> 0/
14:04:12 <EmilienM> EmilienM to send email about how to use RSS to monitor Tempest results in TripleO CI: POSTPONED
14:04:16 <mwhahaha> i haven't seen any comments on my last patches
14:04:17 <adarazs> o/
14:04:17 <EmilienM> #action EmilienM to send email about how to use RSS to monitor Tempest results in TripleO CI
14:04:21 <mwhahaha> about moving the bits to tripleo-common
14:04:35 <mwhahaha> other than that i think i'm good
14:04:41 <trown> o/
14:04:46 <shardy> o/
14:05:11 <EmilienM> mwhahaha: ok, moving forward then
14:05:13 <EmilienM> #topic one off agenda items
14:05:25 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:05:38 <EmilienM> weshay: sir, floor is now yours
14:06:22 <weshay> EmilienM, ah.. well good news. I believe the issue is resolved by an update to lon's email tool :)
14:06:27 * weshay crosses it out
14:06:42 <EmilienM> mhh ok
14:06:51 <EmilienM> hjensas: please go ahead!
14:07:35 <EmilienM> sounds like you want to add coverage to avoid having https://bugs.launchpad.net/tripleo/+bug/1699026 next time
14:07:36 <openstack> Launchpad bug 1699026 in tripleo "Composable roles in tht master - 'dict object' has no attribute 'lower' error" [High,In progress] - Assigned to Harald Jensås (harald-jensas)
14:07:36 <hjensas> EmilienM: thanks, well not much to discuss. But looks like the roles jinja is'nt tested in CI.
14:08:14 <EmilienM> hjensas: do you mean custom roles?
14:08:17 <hjensas> yes
14:08:26 <EmilienM> it is tested, by 3-nodes jobs
14:08:34 <EmilienM> which has been broken for some days, maybe it's the reason
14:09:00 <EmilienM> but gate-tripleo-ci-centos-7-3nodes-multinode-nv is already covering custom roles
14:09:08 <EmilienM> it deploys 2 controllers
14:09:16 <EmilienM> and one of them is a custom controller with some services
14:09:38 <hjensas> hm, the commit I belive cause the issue was from april.
14:09:55 <EmilienM> one role is Controller and another, custom is ControllerApi
14:10:10 <EmilienM> hjensas: FYI gate-tripleo-ci-centos-7-3nodes-multinode-nv isn't voting
14:10:21 <EmilienM> so it's highly possible that this patch in April broke the job
14:10:57 <EmilienM> hjensas: it's weird, it passed CI: https://review.openstack.org/#/c/456739/
14:11:18 <EmilienM> hjensas: /me doing recheck on https://review.openstack.org/#/c/475750/ - we had git failures this morning
14:11:30 <EmilienM> hjensas: anything we need to discuss in this meeting?
14:11:59 <hjensas> no, feel free to move on.
14:12:17 <EmilienM> ok
14:12:21 <EmilienM> #topic bugs
14:12:25 <EmilienM> #link https://launchpad.net/tripleo/+milestone/pike-3
14:12:40 <EmilienM> do we have any bug to discuss this week?
14:13:23 <EmilienM> i've proposed on the mailing-list to make some triage for https://bugs.launchpad.net/tripleo/+bugs?field.tag=deployment-time
14:13:35 <EmilienM> we have a Performance sprint, starting tomorrow and we need some inputs
14:13:50 <EmilienM> if you're aware about bugs in tripleo that affects the time of deployment, please tag the bug as deployment-time
14:14:19 <EmilienM> if there is no outstanding bug to discuss, let's move on
14:14:30 <EmilienM> #topic projects releases or stable backports
14:14:49 <EmilienM> no updates on release management on my side - do we have any question or feedback?
14:15:27 <EmilienM> #topic CI
14:15:37 <EmilienM> ok so we have 2 topics at least, regarding CI
14:16:02 <EmilienM> OVB check gates moving to third party
14:16:15 <EmilienM> pabelanger, sshnaidm, adarazs, weshay ^: what is the progress here?
14:16:48 <EmilienM> maybe just a quick status or summary for the team, it doesn't need to be long (we already have the tripleo ci squad meeting)
14:16:55 <weshay> EmilienM, so the infrastructure is not ready yet for a move, dmsimard is point for details afaik
14:17:20 <dmsimard> for moving tripleo periodic jobs to rdo-infra ?
14:17:25 * dmsimard missing context
14:17:25 <EmilienM> yes
14:17:38 <EmilienM> periodic and also gate OVB
14:17:48 * adarazs is not directly involved in setting stuff up at this point.
14:18:00 <dmsimard> Hoping to be able to build upstream images with nodepool elements out of project-config from review.rdo sometime today or tomorrow
14:18:10 <weshay> dmsimard, apevec said it's not ready until you say its ready :)
14:18:31 <dmsimard> I meant to ask and was redirected to weshay about quota -- we don't currently carry enough quota in our current tenants to accomodate for tripleo based jobs
14:18:33 <EmilienM> ok, sounds like we'll have more updates for our CI meeting on Thursday, where anyone is welcome to join btw
14:18:45 <weshay> dmsimard, similiar but diff topic
14:19:06 <dmsimard> weshay: ok let's sync off-meeting if you want but I need to know where those jobs will end up running
14:19:19 <weshay> dmsimard, sure thing.. and thanks
14:19:45 <EmilienM> anything else about CI?
14:19:51 <weshay> just BAH
14:19:54 <EmilienM> lol
14:20:01 <EmilienM> sshnaidm: I saw multinode jobs are back
14:20:06 <weshay> woot
14:20:06 <EmilienM> the git sync issue is fixed I guess
14:20:11 <shardy> I wanted to ask if anyone has bandwidth to help convert the 3nodes job to oooq
14:20:11 <EmilienM> see http://tripleo.org/cistatus.html
14:20:31 <shardy> I started looking at it, but I'm not clear how we're supposed to populate the inventory so the bootstrap happens
14:20:49 <shardy> if any quickstart experts have time to help, I'd appreciate it
14:20:50 <EmilienM> panda: was it something in the transition backlog? If yes, what was the priority? ^
14:21:01 <shardy> context is, we want a containers 3node HA/updates job
14:21:24 <panda> EmilienM: it was in the backlogs, but the priority is not high AFAIK
14:21:24 <shardy> so first step is make quickstart do undercloud + 3nodes vs undercloud +1
14:21:41 <panda> but lending a hand is possible I think
14:21:49 <weshay> EmilienM, we also should be running the undercloud containers oooq job at this point, /me getting on the to-do list
14:21:53 <dmsimard> Master promotion is lagging 4 days behind right now, is that under control ?
14:22:15 <weshay> dmsimard, it promoted on saturday I think
14:22:28 <dmsimard> Yeah, 4 days ago :) https://dashboards.rdoproject.org/rdo-dev
14:22:32 <weshay> I would say it's under control
14:23:02 <EmilienM> yeah i think we had some tripleo-ci patches recently, from sshnaidm to fix some issues
14:23:06 <adarazs> hopefully it's okay. yesterday ovb-ha-oooq failed, today it passed, today ovb-updates failed and ovb-ha-oooq passed... so probably we're not in too bad shape.
14:23:09 <EmilienM> that were blocking promotion I guess
14:23:22 <EmilienM> dmsimard: https://review.openstack.org/#/c/475715/
14:23:27 <EmilienM> https://review.openstack.org/#/c/475805/
14:24:07 <sshnaidm> EmilienM, yeah, the last were submitted today for stable branches, we used there "current" instead of "consistent"
14:24:33 <EmilienM> ok
14:25:27 <EmilienM> shardy, panda: maybe we could try to work in pair to make this 3-nodes thing, to transfer a bit of knowledge
14:25:40 <panda> shardy: how's the priority for the 3-nodes job to be transitioned for you ? The person that developed the multinode parts left, so it will take some time for anyone to help
14:25:56 <EmilienM> oops :(
14:26:22 <shardy> panda: well we're about to land the final patches for containers+HA, so we really need CI coverage ASAP
14:26:30 <EmilienM> panda: I can try to have a look this week
14:26:40 <EmilienM> I'll probably ask for some review / help
14:26:44 <shardy> hence I started looking at it, but I'm struggling due to lack of quickstart knowledge
14:26:46 <EmilienM> but I volunteer to start the investigation
14:26:59 <shardy> the alternative is I just write the test in the old scripts, because I know them pretty well
14:27:09 <weshay> EmilienM, panda is pretty slamed atm w/ getting the containers check gate to work
14:27:09 <EmilienM> shardy: let's sync on this thing later and maybe share progress / ask questions on the ML if support is needed
14:27:15 <shardy> then we switch both 3nodes jobs to quickstart later
14:27:24 <EmilienM> weshay: yeah no worries. I'll start looking
14:27:48 <EmilienM> #action EmilienM to start looking how to convert 3-nodes jobs in oooq
14:28:07 * EmilienM has no idea in what he's jumping in
14:28:07 <weshay> shardy, EmilienM I can try to help there as well
14:28:19 <EmilienM> cool thanks
14:28:25 <shardy> weshay, EmilienM: ack thanks, lets figure out how to work together on it, thanks!
14:28:28 <EmilienM> do we have anything else CI related?
14:28:35 <weshay> just BAH!
14:28:36 <panda> EmilienM: piece of cake!
14:28:40 <shardy> I understand how to get the containers pieces running, and can propose a new featureset for that
14:28:54 <shardy> it's the bootstrap multiple nodes for deployed-server I'm unsure about atm
14:28:56 <EmilienM> shardy: yeah, i'll look the multinode part
14:29:15 <EmilienM> shardy: let's ketchup later on topic
14:29:24 <shardy> +1
14:29:32 <EmilienM> #topic specs
14:29:35 <EmilienM> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:30:05 <EmilienM> do we have any spec to discuss this week?
14:30:32 <EmilienM> I still some some specs for Pike
14:30:38 <EmilienM> it's great to see that people are confident :D
14:30:56 <EmilienM> we should probably postpone the specs to Queens at this stage.
14:31:29 <EmilienM> #action EmilienM to postpone open specs to Queens, unless code has already been started during Pike and made good progress
14:31:32 <EmilienM> any feedback on this?
14:32:01 <EmilienM> #topic open discussion
14:32:18 <EmilienM> reminder: tomorrow we have a 2-days sprint to improve TripleO deployment time
14:32:41 <EmilienM> https://etherpad.openstack.org/p/tripleo-deploy-time-hack
14:32:57 <EmilienM> I haven't seen much interest to be very honest
14:33:47 <EmilienM> if you're interested to participate, please write your name in the etherpad
14:33:48 <panda> maybe we're too close to release ?
14:34:06 <EmilienM> panda: pike-3 is in 1 month
14:34:16 <EmilienM> we're in the middle of the cycle (a bit after)
14:34:18 <jpich> People might not be sure they have enough skills/knowledge to contribute maybe... (<- me). Will be following along though :)
14:34:31 <panda> people finish starting and start finishing ...
14:34:37 <EmilienM> jpich: I was expecting the people familiar with it, trying to help a little
14:34:48 <EmilienM> anyway
14:34:51 <jpich> Fair enough!
14:34:54 <sshnaidm> fyi, the etherpad: https://etherpad.openstack.org/p/tripleo-deploy-time-hack
14:35:02 <EmilienM> is there anything else for this week?
14:35:21 <EmilienM> thanks everyone
14:35:26 <EmilienM> have a great week and have fun
14:35:28 <EmilienM> #endmeeting