14:01:47 <EmilienM> #startmeeting tripleo
14:01:48 <openstack> Meeting started Tue Jul 4 14:01:47 2017 UTC and is due to finish in 60 minutes. The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:51 <openstack> The meeting name has been set to 'tripleo'
14:01:55 <EmilienM> #topic agenda
14:02:01 <EmilienM> * review past action items
14:02:03 <EmilienM> * one off agenda items
14:02:05 <EmilienM> * bugs
14:02:07 <EmilienM> * Projects releases or stable backports
14:02:10 <EmilienM> * CI
14:02:11 <EmilienM> * Specs
14:02:13 <EmilienM> * open discussion
14:02:15 <EmilienM> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:02:17 <EmilienM> hey, who is around this week?
14:02:22 <ccamacho> hi folks o/
14:02:25 <jpich> o/
14:02:26 <owalsh> o/
14:02:27 <marios> hello o/
14:02:34 <panda> o/
14:03:00 <florianf> o/
14:03:19 <EmilienM> let's get started
14:03:23 <shardy> o/
14:03:24 <EmilienM> #topic review past action items
14:03:33 <jfrancoa> hello o/
14:03:38 <EmilienM> review contrail patches https://review.openstack.org/#/c/475045/ https://review.openstack.org/#/c/475048
14:03:46 <EmilienM> I think patches have been reviewed, and progress has been made
14:03:54 <EmilienM> EmilienM to make gate-tripleo-ci-centos-7-undercloud-containers job voting in tripleo gate and make sure we run it where useful: DONE
14:04:01 <EmilienM> EmilienM to continue the postponing to Queens: DONE
14:04:11 <EmilienM> #topic one off agenda items
14:04:16 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:04:23 <EmilienM> ccamacho: please go ahead
14:04:28 <ccamacho> Hey guys, just wanted to introduce Jose Luis, he is starting to work with us in TripleO with Upgrades/Updates so welcome jfrancoa
14:04:43 <jpich> Welcome!
14:04:45 <EmilienM> woot more humans
14:05:18 <jfrancoa> Hi! thanks for the welcome
14:05:18 <EmilienM> jfrancoa: welcome here :) let us know on #tripleo if there is anything we can do to help
14:05:21 <atoth> o/
14:05:28 <marios> o/ welcome jfrancoa !
14:05:31 <panda> braaaainz
14:05:38 <numans> Hi, welcome jfrancoa
14:05:52 <ccamacho> #tripleo and #oooq are cool places to be and bugging out people, dont be afraid to ask! jfrancoa
14:06:13 <EmilienM> ccamacho: I thought #oooq was killed
14:06:26 <ccamacho> really :(
14:06:32 <ccamacho> oki then
14:06:33 <panda> yeah, we're trying to
14:06:36 <jfrancoa> ccamacho is helping me to get familiar with the workflow, tools and hopefully I can contribute some time soon
14:06:52 <EmilienM> cool, we're looking forward to it
14:06:55 <ccamacho> jfrancoa dont use #oooq xD thants all guys
14:07:00 <EmilienM> #topic bugs
14:07:04 <EmilienM> #link https://launchpad.net/tripleo/+milestone/pike-3
14:07:15 <EmilienM> is there any specific bug we need to discuss this week?
14:07:49 <EmilienM> (i'm still catching up lauchpad emails, I was away 5 days)
14:08:22 <EmilienM> sounds like we can move on
14:08:29 <EmilienM> #topic projects releases or stable backports
14:08:52 <EmilienM> I have no update on release mgt this week, neither on stable backports
14:09:21 <EmilienM> we still target Jul 24 - Jul 28 week for the pike-3 milestone
14:09:41 <EmilienM> moving on
14:09:47 <EmilienM> #topic CI
14:10:13 <EmilienM> do we have any update or topic to discuss / announce this week about CI? (same here, I haven't seen CI status for 5 days)
14:10:47 <numans> EmilienM, about enabling OVN scenario..
14:11:10 <numans> https://review.openstack.org/#/c/412831/
14:11:36 <EmilienM> numans: it's on my list to review, thanks for the link
14:11:41 <numans> EmilienM, thanks
14:11:49 <EmilienM> numans: I think we'll need another scenario
14:12:06 <EmilienM> because I'm not sure upgrades from ML2 OVS to OVN would work
14:12:09 <numans> right, since the scenario 3 has upgrade as well.
14:12:27 <EmilienM> scenario005 is a 4nodes scenario, and is not passing yet
14:12:41 <numans> ok.
14:12:43 <EmilienM> not sure we'll finish this work, I need to catchup with bandini
14:13:00 <EmilienM> scenario006 is very new and flaper87 / me are working on it, it's a k8s specific scenario
14:13:14 <EmilienM> which won't deploy OpenStack on the overcloud for now, so bad scenario for OVN
14:13:33 <numans> ok. i was thinking of trying these scenarios. thanks for the update
14:13:45 <EmilienM> otherwise there is an option
14:13:56 <EmilienM> scenario004 was added during ocata cycle
14:14:23 <numans> ok. I will try it out and see how upgrade behaves with this one ?
14:14:25 <EmilienM> so if we switch tripleo-heat-templates/ci/environments/scenario004.yaml to use OVN backend (if we consider OVN working fine on ocata)
14:14:41 <EmilienM> numans: can we deploy OVN on tripleo/ocata?
14:14:54 <EmilienM> I think the version of OVS was problematic but might have been fixed in stable/ocata repos as well
14:14:55 <numans> EmilienM, I think yes
14:15:03 <EmilienM> ok so let's try that
14:15:23 <numans> EmilienM, it might fail if ovs 2.6 is used for ocata. letr try and see
14:15:30 <numans> s/letr/lets
14:15:38 <EmilienM> step 1. Patch https://github.com/openstack/tripleo-heat-templates/blob/stable/ocata/ci/environments/scenario004-multinode.yaml and deploy OVN
14:16:09 <EmilienM> if it works: step 2. Patch https://github.com/openstack/tripleo-heat-templates/blob/master/ci/environments/scenario004-multinode.yaml
14:16:19 <EmilienM> and upgrade job should work (since we used OVN before and now)
14:16:35 <numans> ack. I will try step 1 first.
14:16:37 <EmilienM> cool
14:16:41 <numans> thanks
14:16:44 <EmilienM> let me know the results, and I can help if needed
14:16:49 <numans> sure.
14:16:51 <EmilienM> anything else CI related this week?
14:17:05 <panda> I'd like to ask reviews on https://review.openstack.org/478516
14:17:38 <panda> a way to manually trigger jobs that is not a hack that renames job types on the fly
14:17:57 <panda> it's actually needed to test the container images promotion job
14:17:59 <EmilienM> oh nice
14:18:08 <EmilienM> #action team to review https://review.openstack.org/#/c/478516/
14:18:15 <panda> that needs a long timeout
14:18:38 <sshnaidm> EmilienM, ovb-updates is ready to be moved to oooq
14:18:46 <sshnaidm> EmilienM, just wait for your vote in project-config
14:19:20 <EmilienM> panda, sshnaidm: ok I'll catchup with project-config patches, thanks
14:19:33 <panda> EmilienM: thank you
14:19:40 <ccamacho> the undercloud upgrades gate works on master and ocata FYI the patch is on its way to be merged https://review.openstack.org/#/c/477606/
14:20:28 <EmilienM> ccamacho: wow, great and thanks for taking over
14:20:49 <ccamacho> EmilienM quick question, we really want to make it vote
14:21:05 <ccamacho> its painful to fix it each time
14:21:20 <EmilienM> I'll check with bnemec to revert the revert
14:21:34 <ccamacho> do we have any requirements to make it vote?
14:21:46 <EmilienM> ccamacho: we don't make upgrade jobs voting on master now, because they aren't stable
14:21:55 <EmilienM> to make job voting, we need them in promotion pipeline imho
14:22:02 <EmilienM> otherwise our gate will break every morning
14:22:21 <ccamacho> mmmm ack Ill sync with you later then to discuss it
14:22:22 <EmilienM> I'm aware undercloud-upgrade job has been non voting even on stable branches
14:22:35 <EmilienM> (while overcloud upgrade jobs are voting on stable branches)
14:22:56 <ccamacho> thanks :)
14:23:12 <EmilienM> I would +1 a project-config patch that would make undercloud-upgrade voting on stable branches
14:23:17 <EmilienM> ccamacho: can you propose it maybe?
14:23:43 <ccamacho> yeah np jfrancoa will do it
14:23:51 <EmilienM> add me as reviewer
14:23:53 <ccamacho> ILl check it
14:23:57 <ccamacho> awesome :)
14:24:05 <jfrancoa> sure, no problem I will add you
14:24:58 <EmilienM> cool
14:25:01 <EmilienM> anything else for CI?
14:25:09 <EmilienM> moving on:
14:25:11 <EmilienM> #topic specs
14:25:14 <EmilienM> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:25:24 <EmilienM> do we need to discuss about any specs this week?
14:26:03 <EmilienM> probably not, moving on
14:26:05 <EmilienM> #topic open discussion
14:26:12 <EmilienM> feel free to bring any last minute topic or question
14:26:18 <jpich> Stealth reminder about the deep dive on i18n in the UI on Thursday -> http://lists.openstack.org/pipermail/openstack-dev/2017-June/119137.html :)
14:26:21 <numans> request to review OVN patches for container support - https://review.openstack.org/#/c/468860/ and https://review.openstack.org/#/c/474944/
14:26:35 <ccamacho> thanks jpich!
14:26:49 <EmilienM> jpich: woot, nice reminder, thx
14:27:00 <EmilienM> numans: ack
14:27:17 <EmilienM> numans: I think there is an etherpad somewhere, let me find it
14:27:37 <numans> this one - https://etherpad.openstack.org/p/tripleo-meeting-items ?
14:27:41 <EmilienM> I can't find it
14:27:52 <EmilienM> no no, an etherpad with a list of things to review that are container specific
14:28:00 <EmilienM> but I've lost the link now
14:28:07 <EmilienM> anyway, is there anything else for this week?
14:28:15 <numans> ok. i will try to find
14:28:19 <shardy> https://etherpad.openstack.org/p/tripleo-containers-todo
14:28:25 <EmilienM> numans: ping jistr or mandre
14:28:31 <EmilienM> ahah! thanks shardy :)
14:28:44 * EmilienM clicks and bookmarks :)
14:28:55 <numans> thanks shardy. i will update the etherpad.
14:29:18 <EmilienM> have a great week everyone, ttyl online
14:29:23 <EmilienM> #endmeeting