14:00:58 <mwhahaha> #startmeeting tripleo
14:00:58 <openstack> Meeting started Tue Aug  8 14:00:58 2017 UTC and is due to finish in 60 minutes.  The chair is mwhahaha. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:03 <openstack> The meeting name has been set to 'tripleo'
14:01:06 <mwhahaha> #topic agenda
14:01:19 <mwhahaha> * review past action items
14:01:19 <mwhahaha> * one off agenda items
14:01:19 <mwhahaha> * bugs
14:01:19 <mwhahaha> * Projects releases or stable backports
14:01:19 <mwhahaha> * CI
14:01:19 <mwhahaha> * Specs
14:01:19 <mwhahaha> * open discussion
14:01:42 <mwhahaha> So who's here today?
14:01:53 <beagles> o/
14:01:58 <marios> o/
14:02:02 <jaosorior> o/
14:02:04 <sshnaidm> o/
14:02:21 <ccamacho> o/
14:02:58 <owalsh> o/
14:03:03 <oidgar> o/
14:03:22 <mwhahaha> i like how everyone disappeared :D
14:03:50 <janki> o/
14:03:58 <mwhahaha> well then let's get going
14:04:01 <bogdando> o/
14:04:04 <mwhahaha> #topic review past action items
14:04:11 <mwhahaha> EmilienM to switch master to run new upgrade jobs and not old ones anymore
14:04:33 <mwhahaha> not sure if that's been done yet given the CI issues as of late so we'll pospone that
14:04:39 <mwhahaha> jaosorior and abishop to talk together about plans for queens relating to barbican backends (prepare ptg session if needed + discuss about migration tool)
14:04:47 <mwhahaha> jaosorior, abishop -^ any update?
14:06:16 <abishop> mwhahaha: sorry, none from my end (I've been away), but will make it a priority now that I'm back
14:06:21 <mwhahaha> k
14:06:35 <mwhahaha> jkilpatr brings up perf testing discussion again when tripleo promotion workflow moved to RDO
14:06:53 <mwhahaha> jkilpatr: -^ any update?
14:07:16 <mwhahaha> #action EmilienM to switch master to run new upgrade jobs and not old ones anymore (postponed)
14:07:29 <mwhahaha> #action jaosorior and abishop to talk together about plans for queens relating to barbican backends (prepare ptg session if needed + discuss about migration tool) (postponed)
14:07:33 <jkilpatr> mwhahaha, I'm not really sure about the status of the RDO/tripleo promotion stuff
14:07:51 <jkilpatr> I keep hearing about a dlrn api I can use to vote, but I've never seen any docs for it, where should I be looking?
14:08:12 <mwhahaha> jkilpatr: not sure we'll follow up off line about that, probably want to check in #rdo around some of that
14:08:25 <jkilpatr> mwhahaha, sounds good.
14:08:48 <mwhahaha> team to review PTP support spec https://review.openstack.org/#/c/483227/
14:09:05 <mwhahaha> i've noticed some patches around PTP support so please make sure to checkout the spec
14:09:17 <mwhahaha> moving on
14:09:18 <mwhahaha> #topic one off agenda items
14:09:24 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:09:41 <mwhahaha> the items list is empty for today, does anyone have anything pressing they would like to talk about?
14:09:44 <gfidente> can I add a topic on the fly?
14:09:58 <mwhahaha> sure
14:10:02 <gfidente> was thinking to move rgw testing from scenario4 to scenario1
14:10:08 <gfidente> https://review.openstack.org/#/c/491566/
14:10:13 <ooolpbot> URGENT TRIPLEO TASKS NEED ATTENTION
14:10:15 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1708793
14:10:15 <openstack> Launchpad bug 1708793 in tripleo "tempest is no longer failing appropriately in oooq" [Critical,In progress] - Assigned to Arx Cruz (arxcruz)
14:10:16 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1709066
14:10:16 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1709152
14:10:16 <openstack> Launchpad bug 1709066 in tripleo "[CI] Upgrade job down: AnsibleUndefinedVariable: 'docker_registry_namespace' is undefined" [Critical,In progress] - Assigned to Jiří Stránský (jistr)
14:10:17 <openstack> Launchpad bug 1709152 in tripleo ocata "tripleo-common docs job broken on stable/ocata" [Critical,In progress] - Assigned to James Slagle (james-slagle)
14:10:19 <gfidente> this to facilitate testing of fixes for rgw and mds independently
14:10:35 <gfidente> because currently scenario4 uses both mds and rgw, while scenario1 uses ceph but doesn't enable any of the two
14:10:56 <mwhahaha> sounds reasonable to me
14:10:56 <gfidente> anything against the reshuffle?
14:11:24 <gfidente> can you guys point me to the code which matches scenario jobs with file changes?
14:11:28 <gfidente> I can't find that anymore
14:11:50 <slagle> gfidente: that's in project-config
14:11:56 <gfidente> slagle++ ah thanks! :D
14:11:59 <mwhahaha> gfidente: i think it's in layout.yaml
14:12:09 <gfidente> thanks guys
14:12:16 <mwhahaha> gfidente: might be a good idea to send a note to the ML about the switch
14:12:25 <gfidente> mwhahaha will do
14:12:44 <mwhahaha> #action gfidente to send an ML note about moving ceph rgw from scenario004 to 001
14:12:54 <mwhahaha> any other topics?
14:13:37 <mwhahaha> sounds like no
14:13:38 <mwhahaha> moving on
14:13:39 <mwhahaha> #topic bugs
14:13:45 <mwhahaha> #link https://launchpad.net/tripleo/+milestone/pike-rc1
14:13:52 <mwhahaha> we've got a bunch of high/critical bugs
14:14:11 <mwhahaha> please take a look at the list as we need to start addressing some of these for RC1
14:14:39 <mwhahaha> also see EmilienM's note about the RC schedule on the ml
14:14:41 <mwhahaha> #link http://lists.openstack.org/pipermail/openstack-dev/2017-August/120806.html
14:15:00 <mwhahaha> any one have any specific bugs they want to point out? or have issues with?
14:15:55 <beagles> can we remove the milestone from ones marked invalid/incomplete?
14:16:37 <mwhahaha> is there a better way to track when the bug was reported?
14:16:55 <mwhahaha> or are we moving the invalid bugs incorrectly
14:17:10 <openstackgerrit> Damien Ciabrini proposed openstack/puppet-tripleo master: Enable TLS configuration for containerized HAProxy  https://review.openstack.org/491599
14:18:34 <mwhahaha> we don't really have too many of them but maybe we can think of a different thing to do with those so they don't show up on the list
14:18:36 <mwhahaha> anyway
14:18:39 <mwhahaha> #topic projects releases or stable backports
14:18:44 <beagles> ack
14:18:55 <mwhahaha> any one have any stable backports they need reviews on?
14:19:59 <mwhahaha> also note that there is a bug around the docs job for tripleo-common being broken on stable/ocata. https://bugs.launchpad.net/bugs/1709152
14:19:59 <openstack> Launchpad bug 1709152 in tripleo ocata "tripleo-common docs job broken on stable/ocata" [Critical,In progress] - Assigned to James Slagle (james-slagle)
14:20:10 <mwhahaha> i need to see if we have a solution for that today
14:20:31 <slagle> i have a patch that removes the svg's, which makes the job pass
14:20:47 <slagle> i don't really know why it's suddenly broken though
14:20:52 <mwhahaha> that's probably not right since everyone else has those
14:21:18 <mwhahaha> but if no one has another solution we might just pull them
14:21:44 <mwhahaha> moving on
14:21:45 <mwhahaha> #topic CI
14:22:03 <mwhahaha> I think the buildlogs ddos is over, ci seemed to be doing better today.
14:22:17 <mwhahaha> pabelanger do you have any update you want to share with the elastic stuff?
14:23:23 <sshnaidm> fyi https://bugs.launchpad.net/tripleo/+bug/1709327
14:23:23 <openstack> Launchpad bug 1709327 in tripleo "CI: extremely long times of overcloud deploy in multinode jobs" [Critical,Triaged]
14:23:54 <openstackgerrit> Damien Ciabrini proposed openstack/tripleo-heat-templates master: Enable TLS configuration for containerized HAProxy  https://review.openstack.org/491602
14:24:37 <mwhahaha> k sounds like we have some perf issues without osic
14:24:42 <openstackgerrit> Michele Baldessari proposed openstack/instack-undercloud master: Remove docker --iptables=false on the undercloud  https://review.openstack.org/491824
14:24:53 <mwhahaha> If we find perf fixes we may also want to look into backporting some of those for the scenario upgrade jobs in ocata as they are timing out still
14:25:03 <mwhahaha> any other CI issues?
14:25:27 <sshnaidm> it ran on centos-7-2-node-infracloud-vanilla-10319460, not sure it's osic.. but seems like infra issue anyway
14:25:42 <sshnaidm> we promoted today
14:25:53 <mwhahaha> yay promotion
14:25:55 <sshnaidm> and that's all good news about CI
14:26:08 <mwhahaha> k moving on
14:26:19 <mwhahaha> #topic specs
14:26:19 <mwhahaha> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:26:59 <mwhahaha> the usual, take some time to review specs. the ptp was mentioned eariler and we have some patches for it. So it would be a good idea to make sure it's in a good spot before we merge the code
14:27:07 <mwhahaha> anyone have any specific specs they want to talk about?
14:27:33 <openstackgerrit> Marios Andreou proposed openstack/tripleo-common master: Download and run upgrade/deploy_steps_playbooks for upgrade  https://review.openstack.org/490847
14:27:46 <mwhahaha> moving on
14:27:47 <mwhahaha> #topic open discussion
14:27:55 <mwhahaha> last call for things to talk about
14:28:06 <mwhahaha> if nothing, i'll close the meeting in 2 minutes and we can get back to work
14:29:11 <openstackgerrit> Jose Luis Franco proposed openstack/tripleo-heat-templates master: Correct gnocchi-upgrade command quotes  https://review.openstack.org/491826
14:29:38 <openstackgerrit> Steven Hardy proposed openstack/tripleo-heat-templates master: WIP show how to create per node service IPs map  https://review.openstack.org/491828
14:29:53 <shardy> gfidente: ^^ incomplete but that shows the approach we discussed
14:30:17 <shardy> http://paste.openstack.org/show/617793/
14:30:19 <mwhahaha> ok thanks everyone
14:30:21 <mwhahaha> #endmeeting