14:00:57 <EmilienM> #startmeeting tripleo
14:00:58 <openstack> Meeting started Tue Aug 29 14:00:57 2017 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:01 <openstack> The meeting name has been set to 'tripleo'
14:01:08 <EmilienM> #topic agenda
14:01:19 <EmilienM> * review past action items
14:01:21 <EmilienM> * CI status
14:01:23 <EmilienM> * bugs
14:01:25 <EmilienM> * Projects releases or stable backports
14:01:27 <EmilienM> * Specs / blueprints
14:01:28 <openstackgerrit> Martin André proposed openstack/tripleo-common master: Make curl healthchecks work with internal TLS  https://review.openstack.org/498805
14:01:29 <EmilienM> * one off agenda items
14:01:31 <EmilienM> * open discussion
14:01:33 <EmilienM> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:01:37 <EmilienM> Hi everyone! who is around today?
14:01:50 <mwhahaha> hi
14:01:53 <adarazs>14:02:09 <jkilpatr> \o
14:02:14 <sshnaidm> 8/
14:02:15 <mandre> hello
14:02:17 <pradk> o/
14:02:21 <jrist> o/
14:02:37 <cdearborn> \o
14:02:40 <jaosorior> o/
14:02:41 <EmilienM> there is no action taken recorded in last week meeting
14:02:42 <marios> o/
14:02:55 <EmilienM> so I'll skip "review past action items" item in the agenda
14:03:04 <EmilienM> #topic CI status
14:03:25 <openstackgerrit> Giulio Fidente proposed openstack/tripleo-heat-templates master: Add support for deploying RGW with ceph-ansible  https://review.openstack.org/480804
14:03:27 <EmilienM> allright, we have a bunch of alerts which affect CI status, let's review it
14:03:36 <EmilienM> https://bugs.launchpad.net/tripleo/+bug/1689556
14:03:37 <openstack> Launchpad bug 1689556 in tripleo "CI: containers overcloud can't start vm when deployed with multinic network isolation" [Critical,In progress] - Assigned to Steve Baker (steve-stevebaker)
14:03:54 <EmilienM> #link https://review.openstack.org/#/c/493695/ is the fix
14:03:59 <EmilienM> so this one is covered
14:04:06 <EmilienM> https://bugs.launchpad.net/tripleo/+bug/1691403
14:04:07 <openstack> Launchpad bug 1691403 in tripleo "containerized overcloud - neutron-openvswitchagent fails to start" [Critical,In progress] - Assigned to Steve Baker (steve-stevebaker)
14:04:11 <saneax> o/
14:04:12 <trown> o/
14:04:36 <EmilienM> this one needs review
14:04:37 <openstackgerrit> Jaganathan Palanisamy proposed openstack/tripleo-common master: Derive Params OvsPmdCoreList compute issue  https://review.openstack.org/498816
14:04:43 <beagles> o/
14:04:51 <EmilienM> #action team to help with reviewing https://review.openstack.org/#/q/topic:bug/1691403 (CI alert fix)
14:05:09 <EmilienM> if you're familiar with docker & networking, please have a look ^
14:05:44 <EmilienM> there are some patches on quickstart as well, sshnaidm, trown, adarazs ^
14:06:01 <EmilienM> next one: https://bugs.launchpad.net/tripleo/+bug/1702955
14:06:02 <openstack> Launchpad bug 1702955 in tripleo "tripleo upgrade jobs timeout on stable/ocata" [Critical,Triaged] - Assigned to mathieu bultel (mat-bultel)
14:06:11 <EmilienM> matbu: any update on this one?
14:06:19 * adarazs is looking
14:06:40 <EmilienM> the last one will be https://bugs.launchpad.net/tripleo/+bug/1712910
14:06:41 <openstack> Launchpad bug 1712910 in tripleo "oooq virt-customize repo setup logs are not saved " [Critical,Triaged] - Assigned to wes hayutin (weshayutin)
14:06:52 <EmilienM> which is I think wip by weshay and ssh
14:06:55 <EmilienM> sshnaidm: ^
14:07:07 <sshnaidm> EmilienM, yeah, patch is on the gate I think
14:07:14 <EmilienM> sshnaidm: https://review.openstack.org/#/c/498772 ?
14:07:31 <sshnaidm> EmilienM, oh, yeah
14:07:51 <abishop> o/
14:07:55 <EmilienM> sshnaidm: when merged and fixed, please update the launchpad
14:08:04 <sshnaidm> EmilienM, sure
14:08:18 <EmilienM> do we have any other CI issues at this time?
14:09:03 <EmilienM> alright - is there anything else to discuss about CI this week?
14:09:20 <openstackgerrit> Jiri Tomasek proposed openstack/tripleo-ui master: Remove semicolons  https://review.openstack.org/498822
14:09:39 <EmilienM> reminder: we have a 1h meeting, focused on tripleo ci work, on thursday. ping adarazs or me to get details
14:10:07 <EmilienM> moving on
14:10:09 <EmilienM> #topic bugs
14:10:12 <EmilienM> #link https://launchpad.net/tripleo/+milestone/pike-rc2
14:10:16 <ooolpbot> URGENT TRIPLEO TASKS NEED ATTENTION
14:10:16 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1689556
14:10:17 <openstack> Launchpad bug 1689556 in tripleo "CI: containers overcloud can't start vm when deployed with multinic network isolation" [Critical,In progress] - Assigned to Steve Baker (steve-stevebaker)
14:10:17 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1691403
14:10:18 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1702955
14:10:18 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1712910
14:10:19 <openstack> Launchpad bug 1691403 in tripleo "containerized overcloud - neutron-openvswitchagent fails to start" [Critical,In progress] - Assigned to Steve Baker (steve-stevebaker)
14:10:20 <openstack> Launchpad bug 1702955 in tripleo "tripleo upgrade jobs timeout on stable/ocata" [Critical,Triaged] - Assigned to mathieu bultel (mat-bultel)
14:10:21 <openstack> Launchpad bug 1712910 in tripleo "oooq virt-customize repo setup logs are not saved " [Critical,In progress] - Assigned to wes hayutin (weshayutin)
14:10:25 <adarazs> CI Squad meeting details: https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:10:41 <EmilienM> adarazs: thanks
14:10:50 <EmilienM> 76 Triaged, 62 In Progress, currently for RC2 - it's a lot
14:11:29 <EmilienM> I would use some help to triage them otherwise the script will move them to queens-1 automatically when we release final pike
14:11:46 <EmilienM> but we want critical / high bugs fixed and backported to stable/pike, as a goal
14:12:08 <EmilienM> any bug to discuss this week in particular?
14:12:46 <EmilienM> no bug? perfect. Let's move on ;-)
14:12:55 <EmilienM> #topic projects releases or stable backports
14:13:19 <EmilienM> pike: we released RC1 last week (thanks mwhahaha for the huge help) - which means we have stable/pike branch everywhere in tripleo now
14:13:28 <openstackgerrit> Honza Pokorny proposed openstack/tripleo-ui master: Add 'discover and enroll nodes' workflow  https://review.openstack.org/488526
14:13:48 <EmilienM> which means: please take care of backporting patches you want in stable/pike (need FFE for blueprints or a launchpad bug for bugs)
14:14:21 <EmilienM> we aim to release RC2 by next week, we still have a bunch of things to land
14:14:30 <EmilienM> any question about Pike release?
14:14:53 <EmilienM> if any, ping me or mwhahaha anytime
14:15:22 <EmilienM> I also plan to release new tags for Newton and Ocata - probably this week
14:15:40 <EmilienM> jschlueter|znc: ^ fyi
14:15:58 <EmilienM> any question / feedback about release management and backports?
14:15:59 <jschlueter> EmilienM: ack
14:16:20 <EmilienM> #topic specs / blueprints
14:16:23 <EmilienM> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:16:30 <EmilienM> #link https://launchpad.net/tripleo/+milestone/pike-rc2
14:16:41 <EmilienM> so we still have 5 open blueprints
14:17:23 <EmilienM> Dell blueprints are going to be implemented in Pike, some patches are missing, but all in gate now.
14:17:45 <EmilienM> https://blueprints.launchpad.net/tripleo/+spec/websocket-logging will be closed in Pike iiuc
14:18:01 <EmilienM> https://blueprints.launchpad.net/tripleo/+spec/node-discovery-by-range as well (closed in Pike) though the UI part will be postponed to queens
14:18:06 <EmilienM> honza, jrist ^ correct?
14:18:13 <jrist> yes
14:18:21 <EmilienM> good
14:18:34 <jrist> literally only 1 patch for websocket-logging
14:18:38 <EmilienM> please update the launchpad when done, otherwise I'll look myself next week
14:18:41 <EmilienM> jrist: good!
14:18:44 <jrist> ok not true. a backport :(
14:18:50 <honza> #link https://blueprints.launchpad.net/tripleo/+spec/gui-node-discovery-by-range
14:19:01 <EmilienM> honza: excellent
14:19:02 <honza> new node discovery gui part blueprint
14:19:26 <EmilienM> honza: approved
14:19:36 <EmilienM> for queens-1, to start
14:20:04 <jrist> :)
14:20:32 <EmilienM> and https://blueprints.launchpad.net/tripleo/+spec/node-discovery-by-range closed
14:21:32 <EmilienM> sorry I've lost internet 1min
14:21:41 <EmilienM> can you see my msg?
14:21:51 <mwhahaha> yea
14:21:56 <EmilienM> ok thx
14:22:14 <EmilienM> a last note about blueprints (I'll send a note to ML as well)
14:22:24 <EmilienM> #action EmilienM sends a note about Queens blueprints / specs on ML
14:22:34 <EmilienM> please prepare your blueprints / specs prior to the PTG
14:22:53 <EmilienM> it really help our team when things are written and prepared before, so we can get into the right topics during face to face meetings
14:23:30 <EmilienM> so if you have something you want to do in Queens, please create a blueprint (or a spec if you like) - before the PTG, and share it on the ML if you want
14:24:07 <EmilienM> any question?
14:24:14 <EmilienM> moving on
14:24:16 <EmilienM> #topic one off agenda items
14:24:20 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:24:28 <EmilienM> mwhahaha: go ahead
14:24:33 <mwhahaha> As previously mentioned, the PTG is soon. Please see the ML post by EmilienM about the agenda.
14:24:33 <mwhahaha> #link http://lists.openstack.org/pipermail/openstack-dev/2017-August/121574.html
14:24:33 <mwhahaha> Also please take some time to review the proposed topics.
14:24:33 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ptg-queens
14:24:42 <mwhahaha> that is all
14:24:44 <EmilienM> thanks for the reminder
14:24:52 <EmilienM> can i use uppercase?
14:25:08 <EmilienM> PLEASE READ THIS ETHERPAD AND CHECK THE SCHEDULE
14:25:16 <mwhahaha> :o
14:25:24 <EmilienM> that would be super helpful
14:25:50 <EmilienM> I try to bring sessions together and create some slots that make sense
14:25:57 <EmilienM> like CI topics or Heat / mistral things etc
14:26:13 <EmilienM> ANY feedback on the agenda / schedule is very welcome, you can ping me on IRC or email or on the ML in the thread
14:26:21 <EmilienM> that is all
14:26:23 <EmilienM> sshnaidm: go ahead please
14:26:56 <sshnaidm> just a few reminders of merging policy in tripleo-quickstart/-extras and tripleo-ci repos
14:27:03 <sshnaidm> if you gonna merge patches into oooq, oooq-extras or tripleo-ci repos, please attend our tripleo-ci-squad meetings every Thursday 14.30 UTC, so that you'll get the overview of what is going in CI, please take into account: http://lists.openstack.org/pipermail/openstack-dev/2017-July/119766.html
14:27:03 <sshnaidm> if it's possible, please avoid from merging patches without review of one of oooq-cores, please remember that this framework is used both for a *few* CI systems and for running locally by tripleo developers, you may affect all of them.
14:27:04 <sshnaidm> and general point of course - please be cautious with merging stuff that you don't have full understanding of it, even if it's something urgent
14:27:32 <EmilienM> sshnaidm: it reminds me a patch ;-) let's discuss about this meeting
14:27:57 <sshnaidm> ok
14:28:19 <EmilienM> #topic open discussion
14:28:47 <EmilienM> any question or general feedback?
14:29:28 <EmilienM> ok
14:29:31 <EmilienM> #endmeeting