14:00:35 <mwhahaha> #startmeeting tripleo
14:00:35 <mwhahaha> #topic agenda
14:00:35 <openstack> Meeting started Tue Oct 17 14:00:35 2017 UTC and is due to finish in 60 minutes.  The chair is mwhahaha. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:35 <mwhahaha> * Review past action items
14:00:35 <mwhahaha> * One off agenda items
14:00:35 <mwhahaha> * Squad status
14:00:35 <mwhahaha> * Bugs & Blueprints
14:00:35 <mwhahaha> * Projects releases or stable backports
14:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:36 <mwhahaha> * Specs
14:00:36 <mwhahaha> * open discussion
14:00:37 <mwhahaha> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:00:37 <mwhahaha> Hi everyone! who is around today?
14:00:39 <openstack> The meeting name has been set to 'tripleo'
14:00:43 <jpich> o/
14:00:45 <EmilienM> o/
14:00:48 <beagles> o/
14:00:53 <akrivoka> o/
14:00:56 <jfrancoa> o/
14:00:58 <mandre> o/
14:00:59 <marios> o/
14:01:05 <florianf> o/
14:01:05 <fultonj> o/
14:01:07 <ccamacho> o/
14:01:10 <chem> o/
14:01:16 <jistr> \o/
14:01:24 <shardy> o/
14:01:28 <d0ugal> o/
14:01:47 <cdearborn> o/
14:01:58 <dpeacock> o/
14:02:44 <mwhahaha> #topic review past action items
14:02:49 <mwhahaha> d0ugal investigate ansible logging options around execution to hopefully improve debugging/UX
14:02:58 <mwhahaha> d0ugal: were you able to take a look last week?
14:03:10 <trown> o/
14:03:27 <d0ugal> No, I've not had time to do that unfortunately
14:03:27 <yprokule> o/
14:03:29 <d0ugal> mwhahaha: ^
14:03:32 <mwhahaha> ok
14:03:37 <mwhahaha> EmilienM to sync with tonyb about stable/newton retirement CI
14:03:47 <jrist> o/
14:03:49 <EmilienM> yeah we've discussed about that
14:04:02 <EmilienM> for now it's still under discussion and we don't EOL this month
14:04:06 <openstackgerrit> Merged openstack/tripleo-heat-templates stable/pike: Fix ConfigDebug for puppet host runs  https://review.openstack.org/512373
14:04:14 <mwhahaha> EmilienM: sounds good. i figure you'll keep us updated
14:04:20 <EmilienM> for sure
14:04:31 <mwhahaha> marios and matbu to provide an upgrade workflow status in 2 weeks (reminder)
14:04:38 <mwhahaha> that's for next week, here's your reminder
14:04:47 <openstack> liverpooler: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
14:04:48 <mwhahaha> #action marios and matbu to provide an upgrade workflow status in next week
14:05:05 <mwhahaha> mwhahaha to remove python3 squad from the list - DONE
14:05:06 <mwhahaha> #link https://review.openstack.org/#/c/511321/
14:05:08 <marios> mwhahaha: thanks :)
14:05:15 <mwhahaha> mwhahaha to send a note about spec reviews and spec freeze at queens-2 - DONE
14:05:15 <mwhahaha> #link http://lists.openstack.org/pipermail/openstack-dev/2017-October/123474.html
14:05:25 <matbu> o/ (late sorry)
14:05:28 <mwhahaha> team to review logging to stdout spec https://review.openstack.org/#/c/510001
14:06:10 <mwhahaha> looks like there's a -1 that needs to be reviewed. i'll poke juan about it
14:06:15 <mwhahaha> i think he might be on pto or something
14:06:26 <mwhahaha> so that's it on the action items from last week
14:06:35 <mwhahaha> #topic one off agenda items
14:06:35 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:06:42 <mwhahaha> (fultonj) environments/storage-environment.yaml
14:06:48 <fultonj> thanks
14:06:50 <fultonj> Do we 1. update storage-environment.yaml to use new containerized-ceph default OR 2. deprecate it in favor of the user picking one or the other (as per the upstream doc)?
14:07:08 <fultonj> feedback requested
14:07:23 <EmilienM> I would say, switch to ceph-ansible (container) when we force containerized deployments everywhere
14:07:39 <EmilienM> so 2. until we switch our CI to deploy container only
14:08:15 <fultonj> EmilienM: sounds ok to me
14:08:23 <mcornea> from an upgrades perspective it'd be better to keep storage-environment.yaml and point it to ceph-ansible so the switch is transparent to the user. this way we have less manual steps during upgrade and it's less error prone
14:08:24 <fultonj> mcornea: ?
14:08:50 <fultonj> mcornea: i.e. you mean #1
14:08:59 <mcornea> yes
14:09:02 <EmilienM> mcornea: good point
14:09:21 <EmilienM> the question is, do we really support upgrades for non-containerized tripleo pike?
14:09:27 <EmilienM> (ocata to pike)
14:09:41 <fultonj> mcornea has been testing this
14:09:43 <marios> EmilienM: no, i don't think we can say we do it isn't tested as we discussed in denver
14:09:46 <fultonj> for ceph
14:09:51 <EmilienM> marios: right
14:09:57 <matbu> yep
14:09:59 <mcornea> we only test upgrading to containerized architecture
14:10:17 <ooolpbot> URGENT TRIPLEO TASKS NEED ATTENTION
14:10:17 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1722864
14:10:18 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1724093
14:10:19 <openstack> Launchpad bug 1722864 in tripleo "OVB frequent timeouts on rh1 cloud" [Critical,Triaged]
14:10:20 <openstack> Launchpad bug 1724093 in tripleo "tripleo releases are promoted prior to the image upload" [Critical,Triaged] - Assigned to Gabriele Cerami (gcerami)
14:10:23 <EmilienM> right, that's why imho we should to container-only CI jobs and switch tripleot to use ceph-ansible asap
14:10:29 <fultonj> EmilienM: oh, you mean ocata -> pike without moving to containers
14:10:36 <EmilienM> fultonj: right
14:10:59 <shardy> well, upstream we shouldn't just remove support for baremetal without deprecation, and we did have CI coverage of upgrades it's just not been well maintained
14:11:19 <shardy> but I guess we can mark baremetal upgrade support deprecated and document it as not well tested at this point
14:11:20 <EmilienM> if we agree pike is for containers only, then yes option #1. seems better for users
14:11:40 <EmilienM> shardy: deprecated in queens and removed in rocky?
14:12:21 <shardy> EmilienM: well at this point yes that sounds reasonable, but I agree we need to prioritize CI coverage ref what most users will be using
14:12:37 <fultonj> follow up question then
14:12:45 <fultonj> sounds like +1 for https://review.openstack.org/#/c/512569
14:12:46 <shardy> Tengu: you were planning to deploy pike baremetal then upgrade to containers for queens weren't you, using upstream builds?
14:12:55 <fultonj> so do we backport it to stable/pike?
14:13:34 <fultonj> 512569 is basically option #1
14:13:40 <EmilienM> fultonj: I think https://review.openstack.org/#/c/512569/ is ok for Queens but not for Pike
14:13:53 <fultonj> too late to change default behavior, right?
14:14:00 <EmilienM> of course
14:14:09 <EmilienM> we released upstream Pike more than a month ago
14:14:19 <Tengu> shardy: hmm yep
14:14:29 <EmilienM> at some point we need to do a better job at keeping stable interface
14:14:37 <Tengu> shardy: does it cause any troubles?
14:14:49 <shardy> Tengu: ack thanks for confirming
14:15:06 <EmilienM> mwhahaha: can I add something?
14:15:07 <fultonj> mcornea: so in pike user needs to pick one xor the other
14:15:08 <Tengu> I think I won't be the only one
14:15:11 <mwhahaha> EmilienM: yes
14:15:11 <marios> shardy: wrt documenting the deprecation... we have a note here https://docs.openstack.org/tripleo-docs/latest/install/post_deployment/package_update.html ("note the minor update workflow..>") but we should probably add something more substantial (and not just in the upgrades section... i mean it is more about the default P deployment)
14:15:23 <fultonj> in summary: pike: #1 | queens: #2
14:15:50 <shardy> Tengu: no, it's just that many folks are testing upgrades to containers for pike, so we're figuring out how/when we can deprecate baremetal support and reduce our test matrix
14:15:50 <shardy> particularly around upgrades
14:15:58 <mcornea> fultonj: ack thanks!
14:16:05 <fultonj> thanks all
14:16:23 <EmilienM> wait
14:16:36 <EmilienM> you said, we do https://review.openstack.org/#/c/512569 in Pike?
14:16:55 <fultonj> EmilienM: no, as you said too late to push that default change back
14:17:07 <EmilienM> ok, you said "pike: #1 | queens: #2"
14:17:10 <EmilienM> so it confused me :)
14:17:15 <fultonj> sorryk, you'
14:17:21 <fultonj> sorry, you're right
14:17:29 <openstackgerrit> Marios Andreou proposed openstack/tripleo-common master: Adds --overcloud-user option to upgrade-non-controller.sh  https://review.openstack.org/512638
14:17:41 <fultonj> pike: 2, queens 1
14:17:48 <EmilienM> ok, lgtm
14:18:12 <EmilienM> can we take some actions to document what we said?
14:18:33 <fultonj> EmilienM: yes, i will do that. what is the appropriate format?
14:18:37 <fultonj> lauchpad bug?
14:18:41 <fultonj> blueprint?
14:18:53 <openstackgerrit> Giulio Fidente proposed openstack/tripleo-heat-templates master: Migrates storage-environment.yaml to ceph-ansible  https://review.openstack.org/512569
14:19:31 <EmilienM> we said: 1. We deprecate baremetal in Queens and remove in Rocky 2. We merge https://review.openstack.org/#/c/512569 in Queens 3. We document that upgrades on baremetal are not testing in Pike and Queens anymore
14:20:22 <EmilienM> fultonj: doc, imho
14:21:19 <EmilienM> #action document deprecate baremetal in queens and remove full support in rocky
14:21:25 <mwhahaha> ok so we done with this topic?
14:21:40 <EmilienM> #action merge https://review.openstack.org/#/c/512569 in Queens
14:21:52 <fultonj> EmilienM: lgtm
14:21:58 <EmilienM> #action document that upgrades on baremetal aren't tested in Pike and Queens
14:22:11 <EmilienM> any volunteers to help on the 2 doc tasks?
14:22:20 <fultonj> o/
14:22:30 <marios> o/
14:22:31 <EmilienM> fultonj: thanks. We can pair on it if you like
14:22:41 <EmilienM> mwhahaha: done. I have one item after.
14:22:50 <mwhahaha> ok
14:22:51 <fultonj> EmilienM: ok, thanks. i'll start a WIP
14:22:55 <EmilienM> fultonj: thx
14:22:55 <mwhahaha> EmilienM: what's your topic?
14:23:03 <EmilienM> about the stable policy
14:23:16 <EmilienM> I proposed something on the ML, and sent https://review.openstack.org/511968
14:23:46 <EmilienM> I don't think we've reached a clear consensus yet on whether or not we want this tag for TripleO (and other installers)
14:24:04 <EmilienM> shardy, and mwhahaha already took a look (although some new comments make me think if we really need to continue)
14:24:31 <EmilienM> I just wanted more feedback from tripleo team, so if you have time, please take a look a this topic, it affects all of us and the way we do backports.
14:24:38 <EmilienM> I guess i'm done
14:24:41 <mwhahaha> thanks
14:25:04 <mwhahaha> #action team to review stable policy proposal https://review.openstack.org/511968
14:25:12 <dmsimard> I have something for open floor if there's one, but I'm on different threads right now, please ping me if I'm not there in time
14:25:22 <mwhahaha> dmsimard: k will do
14:25:40 <mwhahaha> moving on
14:25:43 <mwhahaha> #topic Squad status
14:25:52 <mwhahaha> ci
14:25:52 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ci-squad-scrum
14:26:03 <mwhahaha> upgrade
14:26:03 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:26:10 <florianf> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:26:16 <mwhahaha> containers
14:26:16 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-containers-squad-status
14:26:23 <mwhahaha> florianf: thanks i'll get that for next week
14:26:24 <fultonj> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:26:46 <mwhahaha> ui/cli
14:26:46 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ui-cli-squad-status
14:26:54 <florianf> mwhahaha: sounds good
14:27:00 <mwhahaha> workflows: thrash any updates?
14:27:13 <thrash> mwhahaha: nothing new from our side.
14:27:16 <mwhahaha> networking: beagles i see you sent a note to the ML, so i guess progress is being made to form it
14:27:18 <mwhahaha> thrash: thanks
14:27:37 <mwhahaha> everyone thanks for updating your status ether pads
14:27:41 <beagles> mwhahaha, yes
14:27:51 <mwhahaha> good information all around. folks please take some time to review to see what's going on
14:28:02 <mwhahaha> moving on
14:28:07 <mwhahaha> #topic bugs & blueprints
14:28:08 <mwhahaha> #link https://launchpad.net/tripleo/+milestone/queens-1
14:28:08 <mwhahaha> For Queens we currently have 70 (+1 blueprints and about 480 (+36 open bugs. 205 queens-1, 270 queens-2 and 5 queens-3. Please take some time to review your blueprint status and make sure it is properly up to date.  queens-1 is this week. I will be moving all queens-1 bugs to queens-2 at the end of the week. I will also push the <= Medium bugs to queens-3.
14:28:34 <EmilienM> sounds good
14:28:36 <mwhahaha> any bugs or blueprints folks want to talk about?
14:28:58 <EmilienM> did we actually implement a blueprint this milestone?
14:29:08 <mwhahaha> i'm going to spend some time and review
14:29:14 <mwhahaha> i think some of the ui ones might have been addressed
14:29:22 <mwhahaha> but given all the CI issues, not sure how much got landed
14:30:00 <jpich> Two bp showing as implemented. First milestone is always rough
14:30:08 <mwhahaha> indeed
14:30:10 <jrist> +1
14:30:36 <mwhahaha> so take some time to review the status of the stuff you're working on
14:30:37 <mwhahaha> thanks
14:30:38 <mwhahaha> moving on
14:30:39 <mwhahaha> #topic projects releases or stable backports
14:30:44 <mwhahaha> This week is queens-1
14:30:51 <EmilienM> I'll push queens-1 on Thursday
14:30:56 <mwhahaha> EmilienM: sounds good
14:31:06 <EmilienM> (prepare on Wednesday and adjust last commits on Thu)
14:31:13 <EmilienM> also
14:31:53 <EmilienM> last week we had a newton/ocata/pike release - I plan to do again this Friday, so merge it on Monday and hopefully get downstream builds by Tuesday
14:31:58 <EmilienM> (and do that every 2 weeks)
14:32:46 <mwhahaha> sounds good
14:32:48 <mwhahaha> anything else?
14:32:59 * EmilienM clear
14:33:04 <mwhahaha> moving on
14:33:08 <mwhahaha> #topic specs
14:33:08 <mwhahaha> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:33:15 <mwhahaha> we've merged some specs and i've seen some reviews
14:33:19 <mwhahaha> thanks everyone for taking a look
14:33:50 <mwhahaha> please continue to review the specs as they change and let's get them merged so we can implement
14:34:02 <mwhahaha> Any specs that folks would like to bring up?
14:34:36 <mwhahaha> sounds like no
14:34:46 <mwhahaha> moving on to the last item
14:34:51 <mwhahaha> #topic open discussion
14:34:51 <mwhahaha> dmsimard?
14:35:06 <EmilienM> quick question for jistr and mandre, where are we with https://bugs.launchpad.net/tripleo/+bug/1714105 ?
14:35:07 <openstack> Launchpad bug 1714105 in tripleo "Upgrade jobs don't work on stable/pike" [Critical,In progress] - Assigned to Emilien Macchi (emilienm)
14:35:17 <EmilienM> we merged all the patches in https://etherpad.openstack.org/p/tripleo-containers-ha-ci
14:35:19 <dmsimard> yes, thanks
14:35:24 <EmilienM> but I think scenarios are still down
14:35:45 <Tengu> shardy: ah, ok (sorry, I'm on another thing). hmm. well, sorry for the matrix ;). But we'd rather ensure all os stable before moving to containers. When we started pike investigations, it didn't seem to be that stable :/. mayber we were wrong, but…
14:36:01 <dmsimard> I wanted to encourage everyone to sign up to the 'TripleO zuul v3 ask me anything' session we'd like to schedule early next week: http://lists.openstack.org/pipermail/openstack-dev/2017-October/123668.html
14:36:09 <jistr> EmilienM: i haven't had bandwidth to investigate Pike yet
14:36:19 <Tengu> shardy: anyway, we will get some lab infra in order to test each update we want to make. For now I'm re-deploying the whole thing and will freeze our configuration until we have the lab.
14:36:32 <EmilienM> dmsimard++
14:36:34 <mandre> EmilienM: same goes for me :-/
14:36:43 <jrist> dmsimard++
14:36:47 <EmilienM> mandre, jistr: ok, I'll take a look
14:37:03 <openstackgerrit> Dan Prince proposed openstack/python-tripleoclient master: Remove fake_keystone  https://review.openstack.org/510288
14:37:34 <EmilienM> dmsimard: I can't wait to ask questions :P
14:37:50 <EmilienM> can I ask before? or is it like secret :P
14:38:11 <dmsimard> let's try to get as much content as we can in the recording so we can share it after
14:39:42 <EmilienM> I guess we are done?
14:41:07 <EmilienM> mwhahaha: I guess we can #endmeeting at this point
14:41:15 <mwhahaha> k
14:41:19 <mwhahaha> thanks everyone
14:41:24 <mwhahaha> #endmeeting