14:02:08 <EmilienM> #startmeeting tripleo
14:02:09 <openstack> Meeting started Tue Oct 24 14:02:08 2017 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:12 <openstack> The meeting name has been set to 'tripleo'
14:02:16 <EmilienM> * Review past action items
14:02:19 <EmilienM> * One off agenda items
14:02:20 <EmilienM> * Squad status
14:02:23 <EmilienM> * Bugs & Blueprints
14:02:25 <EmilienM> * Projects releases or stable backports
14:02:26 <EmilienM> * Specs
14:02:29 <EmilienM> * open discussion
14:02:30 <EmilienM> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:02:32 <EmilienM> Hi everyone! who is around today?
14:02:35 <gchamoul> florianf: done
14:02:36 <jtomasek> o/
14:02:44 <beagles> o/
14:02:49 <fultonj> o/
14:02:50 <cdearborn> o/
14:02:52 <dprince> hi
14:02:52 <dpeacock> o/
14:02:52 <owalsh> o/
14:02:58 <gchamoul> o/
14:03:13 <jpich> o/
14:03:16 <jkilpatr> o/
14:03:32 <pradk> o/
14:03:41 <EmilienM> #topic review past action items
14:03:43 <slagle> hi
14:03:54 <EmilienM> marios and matbu to provide an upgrade workflow status in next week
14:04:00 <EmilienM> document deprecate baremetal in queens and remove full support in rocky
14:04:03 <florianf> o/
14:04:03 <EmilienM> merge https://review.openstack.org/#/c/512569 in Queens
14:04:13 <Pranav_> mandre: http://paste.openstack.org/show/624482/
14:04:17 <mandre> o/
14:04:21 <EmilienM> https://review.openstack.org/#/c/512569 isn't merged, I just checked
14:04:28 <Pranav_> for now I am trying to deploy with pushing to local registry
14:04:29 <EmilienM> document that upgrades on baremetal aren't tested in Pike and Queens
14:04:34 <fultonj> w.r.t document deprecate baremetal in queens,  https://review.openstack.org/#/c/512782/
14:04:38 <EmilienM> and team to review stable policy proposal https://review.openstack.org/511968 : still in progress
14:04:42 <Pranav_> without* pushing to local registry
14:04:50 <EmilienM> fultonj: oh cool, thanks for the update
14:05:27 <EmilienM> any other updates regarding the actions?
14:05:48 <EmilienM> i'll postpone otherwise
14:05:55 <jrist> /o
14:06:16 <EmilienM> #action (postponed) marios and matbu to provide an upgrade workflow status
14:06:30 <openstackgerrit> Dan Prince proposed openstack/python-tripleoclient master: Support to drive undercloud deploy via undercloud.conf  https://review.openstack.org/511350
14:06:33 <EmilienM> #action (postponed) merge https://review.openstack.org/#/c/512569 (gfidente)
14:06:54 <EmilienM> #action (postponed) document that upgrades on baremetal aren't tested in Pike and Queens
14:07:15 <fultonj> postponed ?
14:07:19 <EmilienM> postpone?
14:07:24 <fultonj> patch merged
14:07:32 <fultonj> i.e. doc change merged
14:07:33 <EmilienM> fultonj: the upgrade?
14:07:44 <fultonj> not the upgrade
14:07:44 <EmilienM> ah ok good
14:07:45 <fultonj> sorry my bad
14:07:55 <EmilienM> anything else?
14:08:04 <EmilienM> fultonj: you made me google translate postponed
14:08:12 <EmilienM> #topic one off agenda items
14:08:20 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:08:24 <fultonj> :)
14:08:35 <EmilienM> someone wrote something about mistral, without name
14:08:42 <EmilienM> who is blue?
14:08:43 <fultonj> o/
14:08:57 <fultonj> we used to have mistral logs
14:09:07 <fultonj> http://logs.openstack.org/69/512569/3/check/legacy-tripleo-ci-centos-7-scenario001-multinode-oooq-container-upgrades/f270dd1/logs/subnode-2/var/log/
14:09:17 <gfidente> for the undercloud
14:09:34 <EmilienM> it's the overcloud ^
14:09:42 <fultonj> never mind
14:09:48 <fultonj> sorry
14:09:56 <EmilienM> http://logs.openstack.org/69/512569/3/check/legacy-tripleo-ci-centos-7-scenario001-multinode-oooq-container-upgrades/f270dd1/logs/undercloud/
14:09:59 <EmilienM> that's the right link
14:10:06 <EmilienM> ok anything else?
14:10:13 <ooolpbot> URGENT TRIPLEO TASKS NEED ATTENTION
14:10:13 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1722864
14:10:14 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1724093
14:10:15 <openstack> Launchpad bug 1722864 in tripleo "OVB frequent timeouts on rh1 cloud" [Critical,Triaged]
14:10:16 <openstack> Launchpad bug 1724093 in tripleo "tripleo releases are promoted prior to the image upload" [Critical,In progress] - Assigned to Gabriele Cerami (gcerami)
14:10:38 <EmilienM> #topic Squad status
14:10:52 <EmilienM> ci
14:10:55 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-ci-squad-scrum
14:11:00 <EmilienM> upgrade
14:11:03 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:11:07 <EmilienM> containers
14:11:09 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-containers-squad-status
14:11:12 <EmilienM> integration
14:11:15 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:11:19 <EmilienM> ui/cli
14:11:22 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-ui-cli-squad-status
14:11:39 <EmilienM> validations
14:11:41 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:11:44 <EmilienM> networking
14:11:45 <Tengu> -.- coool. so now gate is happy, but I get a nice "cannot merge" -.-
14:11:46 <EmilienM> workflows
14:11:50 <gfidente> EmilienM problem with logs is that zuul jobs don't seem to be collecting the entire /var/log anymore
14:12:02 <gfidente> from the undercloud
14:12:04 <gfidente> so we don't have mistral logs
14:12:06 <EmilienM> gfidente: it's not zuul
14:12:17 <EmilienM> it's the oooq config
14:12:23 <EmilienM> we select which logs we want to collect
14:12:32 <gfidente> oh but the legacy jobs seem to have those thoug?
14:12:34 <EmilienM> sshnaidm / weshay|ruck was working on a patch
14:12:41 <gfidente> ah
14:12:44 <EmilienM> gfidente: everything runs legacy now
14:12:48 <EmilienM> all tripleo jobs are "legacy"
14:13:05 <EmilienM> gfidente: show us a link without logs?
14:13:20 <sshnaidm> gfidente, I think we still collect all from /var/log
14:13:41 <sshnaidm> gfidente, but we don't collect from /tmp anymore, there were some mistral related files
14:14:33 <EmilienM> anything special to mention about the squad reports?
14:14:35 <EmilienM> I forgot some links
14:14:44 <gfidente> like this guy http://logs.openstack.org/75/508975/13/check/legacy-tripleo-ci-centos-7-scenario001-multinode-oooq-container/728f094/logs/undercloud/var/log/
14:14:49 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-networking-squad-status
14:15:14 <EmilienM> the workflows squad doesn't have an etherpad afik
14:15:18 <gfidente> anyway maybe I can ping sshnaidm later in the chan, thanks for helping
14:15:31 <openstackgerrit> Ronelle Landy proposed openstack/tripleo-heat-templates stable/pike: DNM, TESTING ONLY  https://review.openstack.org/514465
14:15:38 <EmilienM> gfidente: see https://review.openstack.org/#/c/508975/
14:15:43 <EmilienM> gfidente: undercloud wasn't deployed.
14:15:51 <EmilienM> it's the iptables error from this weekend maybe
14:16:10 <EmilienM> so yeah, no mistral logs, since mistral isn't even deployed
14:16:51 <EmilienM> ok moving on
14:16:59 <EmilienM> #topic bugs & blueprints
14:17:04 <EmilienM> #link https://launchpad.net/tripleo/+milestone/queens-2
14:17:21 <EmilienM> queens-1 tag isn't pushed yet because of zuul v3
14:17:24 <EmilienM> it should be done by today
14:17:33 <EmilienM> but I moved all bugs / blueprints to queens-2
14:17:41 <EmilienM> we closed only one blueprint in queens-1
14:17:50 <EmilienM> and 233 Fix Released
14:18:11 <EmilienM> eternal reminder but please update your blueprints
14:18:27 <EmilienM> it's a lot of work and it would be great to have some help from assignees
14:18:39 <EmilienM> any critical bug to discuss this week?
14:19:07 <openstackgerrit> Ronelle Landy proposed openstack/tripleo-quickstart-extras master: Add the option to run the container-check script  https://review.openstack.org/501028
14:19:18 <bandini> EmilienM: I'd like to rais a bit of attention on https://review.openstack.org/#/c/511509/
14:19:25 <openstackgerrit> Cédric Jeanneret proposed openstack/puppet-tripleo master: Create dedicated "apache" base profile  https://review.openstack.org/513274
14:19:43 <bandini> just as a heads up, we are currently ignoring puppet errors due to the above
14:19:48 <EmilienM> ouch
14:19:52 <openstackgerrit> Andreas Florath proposed openstack/diskimage-builder master: [WIP] Introduce DIB_USE_CACHE and use it in zypper-minimal  https://review.openstack.org/514689
14:20:13 <bandini> mandre and I are trying to fix all the fallouts from this before merging it
14:20:15 <EmilienM> bandini: ok good to know
14:20:20 <EmilienM> #action team to review https://review.openstack.org/#/c/511509/ asap
14:20:30 <EmilienM> bandini: thanks
14:20:34 <EmilienM> it sounds critical
14:20:39 <bandini> yeah
14:20:50 <EmilienM> bandini: please backport all the fallouts fix and this one of course
14:20:50 <openstackgerrit> Ronelle Landy proposed openstack/tripleo-quickstart-extras master: Add the option to run the container-check script  https://review.openstack.org/501028
14:21:26 <bandini> yeah
14:21:36 <EmilienM> bandini: https://review.openstack.org/#/c/513082/ isn't in gate
14:21:39 <EmilienM> while dep is merged
14:21:55 <EmilienM> bandini: maybe you can -A +A
14:21:58 <bandini> EmilienM: I think the last issue is around fluentd and scenario001
14:22:09 <mandre> so bandini's patch highlighted an error in scenario001-containers with fluentd
14:22:16 <Ng> speaking of the gate, is there a known issue with it? the job at the front seems to be about 15 hours old
14:22:24 <EmilienM> paramite, larsks ^ if you can help with the fluentd issue
14:22:47 <paramite> EmilienM, probably, but after mtg
14:22:56 <EmilienM> yup
14:22:57 <bandini> EmilienM: let me try -A +A that one
14:23:41 <EmilienM> ok in gate now
14:23:46 <EmilienM> perfect
14:24:21 <EmilienM> bandini: and https://review.openstack.org/#/c/511509/ as well
14:24:25 <EmilienM> all good
14:24:31 <bandini> so the last known issue around fluentd and scenario001 is due to missing fluentd image (aka due to lack of master promotion)
14:24:34 <mandre> EmilienM: I'd be careful about merging https://review.openstack.org/#/c/511509/ right now
14:24:45 <EmilienM> oh, we want to wait?
14:24:49 <bandini> yeah it would break scenario001
14:24:52 <EmilienM> ok
14:24:57 <mandre> because it highlighted  an issue with fluentd in scenario001
14:25:08 <EmilienM> I blocked it
14:25:22 <EmilienM> ping me when you want to unbluck
14:25:25 <EmilienM> unblock even
14:25:26 <mandre> would it be an option to disable the fluentd service in scenario001?
14:25:35 <bandini> +1 from me ^
14:25:53 <EmilienM> mandre: if we can't fix it, yes
14:26:02 <EmilienM> but let's try to fix it first
14:26:10 <EmilienM> workarounds tend to be forgotten
14:26:12 <bandini> the fix requires a mast promotion (aka flutend container image)
14:26:17 <bandini> *master even
14:26:17 <EmilienM> and increasing tech debt
14:26:22 <EmilienM> ah...
14:26:24 <EmilienM> so yeah
14:26:31 <EmilienM> disable and comment in the file please
14:26:38 <EmilienM> with a bug report or something
14:26:40 <mandre> i believe the issue we're seeing is caused by us using a mix of BM and containers services, and we're waiting for a promoted fluentd image we can use in scenario001 to re-enable the containerized fluentd service
14:26:41 <EmilienM> so it's not lost
14:27:26 <EmilienM> bandini, mandre: sounds good?
14:27:27 <mandre> ack, will do
14:27:33 <EmilienM> thx
14:27:39 <EmilienM> and thanks for this work
14:27:52 <EmilienM> #topic projects releases or stable backports
14:28:00 <openstackgerrit> James Slagle proposed openstack/tripleo-common master: Add workflow for deployment via config-download  https://review.openstack.org/512876
14:28:14 <openstackgerrit> James Slagle proposed openstack/python-tripleoclient master: Add --config-download  https://review.openstack.org/514701
14:28:14 <EmilienM> not much update on project release & stable backport for now - queens-1 tag should be pushed today
14:28:23 <EmilienM> any question?
14:28:25 <bandini> ack
14:28:55 <EmilienM> #topic specs
14:28:59 <EmilienM> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:29:17 <EmilienM> we could see a good progress in the spec review, great
14:29:58 <EmilienM> do we need to discuss about specs today?
14:30:28 <EmilienM> moving on to the end
14:30:29 <EmilienM> #topic open discussion
14:30:46 <EmilienM> if you have any question / request / feedback please go ahead
14:31:13 <EmilienM> just a heads-up, we're working to prepare the OpenStack Summit
14:31:18 <EmilienM> we have 2 sessions :
14:31:26 <EmilienM> 1) Project updates that me and stevebaker will do together
14:31:36 <EmilienM> we're working on the slides and will share with the team very soon for feedback
14:31:58 <dprince> EmilienM: might be nice to etherpad it first, but sharing slides is cool
14:32:02 <EmilienM> 2) Project onboarding - I wasn't there in Boston, but I would like some feedback from these who went there (shardy, dprince, slagle maybe?)
14:32:14 <EmilienM> dprince: yeah i'll just google share the slides
14:32:18 <EmilienM> dprince: so anyone can contribute
14:32:23 <EmilienM> dprince: slides are empty now
14:32:37 * dprince can help with onboarding too
14:32:42 <EmilienM> awesome
14:32:57 <EmilienM> #action EmilienM to prepare an etherpad for tripleo onboarding session in Sydney
14:33:11 <slagle> EmilienM: i found the onboarding was most useful by just allowing participants to drive the agenda
14:33:30 <EmilienM> slagle: like a "ask me anything" session?
14:33:46 <dprince> slagle: agree. I don't think there is a lot of prep other than having a few of us show up and interactively help answer questions, etc.
14:33:47 <EmilienM> and then drive the session depending on what is being asked
14:33:50 <slagle> EmilienM: i'd keep it related to TripleO :)
14:33:53 <dprince> but we could anticipate some questions
14:33:59 <EmilienM> sounds excellent
14:34:20 <EmilienM> anything for this week?
14:34:25 <slagle> EmilienM: otherwise, you may get something like "How many pullups can you do?"
14:34:34 <openstackgerrit> Dan Prince proposed openstack/python-tripleoclient master: Don't install packages as part of undercloud deploy.  https://review.openstack.org/510239
14:34:42 <EmilienM> slagle:  I did 8 this weekend
14:34:46 <EmilienM> slagle: target is 10 by Sydney
14:35:00 <EmilienM> thanks everyone
14:35:04 <EmilienM> have a great week
14:35:06 <EmilienM> #endmeeting