14:00:12 <mwhahaha> #startmeeting tripleo
14:00:13 <mwhahaha> #topic agenda
14:00:13 <mwhahaha> * Review past action items
14:00:13 <mwhahaha> * One off agenda items
14:00:13 <mwhahaha> * Squad status
14:00:13 <openstack> Meeting started Tue Jan  9 14:00:12 2018 UTC and is due to finish in 60 minutes.  The chair is mwhahaha. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:13 <mwhahaha> * Bugs & Blueprints
14:00:13 <mwhahaha> * Projects releases or stable backports
14:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:14 <mwhahaha> * Specs
14:00:14 <mwhahaha> * open discussion
14:00:15 <mwhahaha> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:00:15 <mwhahaha> Hi everyone! who is around today?
14:00:16 <openstack> The meeting name has been set to 'tripleo'
14:00:21 <beagles> o/
14:00:26 <dpeacock> o/
14:00:44 <oidgar> o/
14:00:52 <marios> o/
14:00:53 <EmilienM> o/
14:01:05 <matbu> o/
14:01:08 <ykarel> o/
14:02:03 <jfrancoa> o/
14:02:13 <ykarel> ohh wrong channel
14:02:21 <dprince> hi
14:02:32 <sshnaidm> o/
14:02:34 <slagle> hi
14:02:51 <tbarron> hi
14:03:10 <mwhahaha> #topic review past action items
14:03:16 <mwhahaha> jistr, gfidente and shardy look at ceph-ansible and config-download
14:03:23 <mwhahaha> this was a carry over from last year
14:03:38 <mwhahaha> not sure if we had any specific items, it was a reminder for a while. We can postpone it if necessary
14:04:05 <fultonj> o/
14:04:24 <jistr> we'll have a call about it soon
14:04:29 <jistr> hopefully this week
14:04:32 <mwhahaha> ok we'll post pone it
14:04:43 <mwhahaha> #action jistr, gfidente and shardy look at ceph-ansible and config-download
14:04:54 <mwhahaha> EmilienM to start a policy doc around bug priority
14:05:13 <EmilienM> I did nothing about that
14:05:34 <EmilienM> I guess it was a one-off discussion
14:05:49 <mwhahaha> we needed to document it somewhere
14:06:00 <mwhahaha> since I don't think we have anything
14:06:12 <EmilienM> yeah I'll take start something this week
14:06:15 <mwhahaha> k
14:06:21 <mwhahaha> #action EmilienM to start a policy doc around bug priority
14:06:31 <mwhahaha> mwhahaha/EmilienM to schedule a Newton day in January before EOL
14:06:41 <ccamacho> sorry for the delay o/
14:06:58 <mwhahaha> so we need to figure out what when we want to do something, i know downstream is looking to do a final import but they said they can import the tripleo bits again if necessary
14:07:11 <mwhahaha> not sure if we want to combine the newton bug day and the end of queens
14:07:12 <arxcruz|ruck> o/
14:07:19 <EmilienM> the amount of backport in newton becomes rare
14:07:30 <EmilienM> which is a good sign probably?
14:07:36 <mwhahaha> hopefully :D
14:07:46 <EmilienM> the CI job are still green on newton
14:07:56 <mwhahaha> so maybe we just pick a day and send out a list of existing items for review/merge?
14:08:23 <EmilienM> yeah
14:08:32 <EmilienM> a bunch of patches in stable/newton need love
14:08:40 <EmilienM> otherwise we'll just abandon them
14:08:53 <EmilienM> I guess if they're here for months they're not so important after all
14:08:53 <mwhahaha> k let's send a note this week and pick a day
14:09:13 <mwhahaha> #action mwhahaha/EmilienM to schedule a Newton day in January before EOL
14:09:41 <mwhahaha> #topic one off agenda items
14:09:42 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:09:51 <mwhahaha> looks like we've got nothing
14:10:05 <mwhahaha> any one got anything specific?
14:10:17 <ooolpbot> URGENT TRIPLEO TASKS NEED ATTENTION
14:10:17 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1729569
14:10:18 <openstack> Launchpad bug 1729569 in tripleo "Periodic jobs using swift as glance backend failing" [Critical,In progress] - Assigned to Christian Schwede (cschwede)
14:10:20 <dprince> do we want to talk about this revert
14:10:29 <dprince> https://review.openstack.org/#/c/531366/
14:10:32 <dprince> reverting that ^^
14:10:39 <mwhahaha> we can
14:10:40 <dprince> shardy_afk, mandre
14:10:56 <mwhahaha> so revert it because it's only 3 of the services or soemthing?
14:11:00 <dprince> mhenkel_: ^^
14:11:31 <dprince> mwhahaha: yes, it makes the interfaces inconsistent. Also it poses some concerns about orchestrating service restarts
14:11:54 <mwhahaha> what would be the correct/alternative way to handle the issue?
14:12:04 <dprince> it was a pattern we specifically avoided for those reasons
14:12:19 <dprince> alternate pattern... is install the freakin package *in* the container :)
14:12:32 <mwhahaha> a novel concept
14:12:59 <dprince> which causes you to have to update the container if it changes... but that can be automated
14:13:15 <jrist> o/
14:13:50 <mandre> hello
14:14:07 <mandre> I'm fine with the revert of https://review.openstack.org/#/c/531366/, for the reasons dprince explained
14:14:34 <dprince> mandre: yeah. I think we just need to sync w/ micheal now
14:14:46 <mandre> last time we wanted to confirm with mhenkel_ that it was ok with him, have we done that?
14:15:11 <openstackgerrit> Honza Pokorny proposed openstack/tripleo-ui master: Upgrade to npm 5  https://review.openstack.org/532192
14:15:16 <dprince> mandre: not yet, was trying to do it here
14:15:23 <dprince> mwhahaha: I think that is all from me
14:15:31 <mwhahaha> ok sounds good
14:15:55 <mwhahaha> #action dprince to sync with mhenkel_ about the revert of https://review.openstack.org/#/c/531366/
14:16:10 <mwhahaha> time for the wall o' status
14:16:14 <mwhahaha> #topic Squad status
14:16:14 <mwhahaha> ci
14:16:14 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:16:14 <mwhahaha> upgrade
14:16:14 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:16:15 <mwhahaha> containers
14:16:15 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-containers-squad-status
14:16:16 <mwhahaha> integration
14:16:16 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:16:17 <mwhahaha> ui/cli
14:16:17 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ui-cli-squad-status
14:16:18 <mwhahaha> validations
14:16:18 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:16:19 <mwhahaha> networking
14:16:19 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-networking-squad-status
14:16:20 <mwhahaha> workflows
14:16:20 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-workflows-squad-status
14:16:53 <mwhahaha> everyone has updates except workflows whose meeting is tomorrow
14:17:16 * EmilienM will prepare the Weekly Owl e-mail ;-)
14:17:31 <mwhahaha> any specific items that people would like to raise?
14:18:23 <dprince> mwhahaha: why are people talking about downstream release numbers on these etherpads!
14:18:39 <EmilienM> oops
14:18:45 <dprince> mwhahaha: I see a lot of 13/14 references... we should avoid this on TripleO upstream etherpads I think
14:18:56 <mwhahaha> would be correct
14:19:27 * dprince makes a few changes
14:20:30 <mwhahaha> moving on
14:20:32 <EmilienM> dprince++
14:20:34 <mwhahaha> #topic bugs & blueprints
14:20:35 <mwhahaha> #link https://launchpad.net/tripleo/+milestone/queens-3
14:20:35 <mwhahaha> For Queens we currently have 34 (+4) blueprints and about 574 (+5) open bugs. 557 queens-3, 3 queens-rc1, 13 rocky-1, 1 rocky-2.
14:20:45 <mwhahaha> as a reminder, please make sure your blueprints/bugs are up to date
14:21:02 <mwhahaha> especially for those who have requested ffe items
14:21:30 <mwhahaha> Queens 3 is in ~2.5 weeks
14:21:40 <mwhahaha> so make sure to get your FFE items in ASAP
14:21:56 <mwhahaha> Any specific bugs that need talking about?
14:22:19 <EmilienM> I think everything is under control in term of CI blockers
14:23:19 <mwhahaha> k
14:23:37 <mwhahaha> #topic projects releases or stable backports
14:23:51 <mwhahaha> as reminder again, queens 3 in 2.5 weeks.
14:24:06 <mwhahaha> EmilienM: when's the next stable release stuff?
14:24:24 <EmilienM> we did one yesterday, it was pushed to rdo newton ocata pike
14:24:24 <openstackgerrit> Michele Baldessari proposed openstack/puppet-tripleo master: Let haproxy_defaults be overridable  https://review.openstack.org/532141
14:24:40 <EmilienM> so next one is in 2 weeks
14:24:50 <EmilienM> unless something bad happens and we do it before
14:25:32 <mwhahaha> k
14:25:42 <mwhahaha> #topic specs
14:25:42 <mwhahaha> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:26:04 <mwhahaha> with the rocky ptg coming up, now is the time to prepare your specs
14:27:14 <mwhahaha> #topic open discussion
14:27:26 <mwhahaha> any other business?
14:27:45 <jrist> thanks for everyone's help with tripleo deps issue
14:28:26 <openstackgerrit> Steven Hardy proposed openstack/python-tripleoclient master: Generate undercloud-passwords.conf and fix output dir.  https://review.openstack.org/523511
14:28:44 <mwhahaha> dprince: I've got a question about https://review.openstack.org/#/c/531261/, we were running puppet apply within docker_commands, do those pre-date docker_puppet_tasks and do they just need to be converted?
14:28:58 * mwhahaha thought about this after trying to fix it
14:29:07 <dprince> mwhahaha: looking
14:29:33 <openstackgerrit> Tim Rozet proposed openstack/puppet-tripleo master: Adds TLS support for OpenDaylight  https://review.openstack.org/531003
14:30:41 <mwhahaha> anyway we can continue that conversation after the meeting
14:30:49 <dprince> mwhahaha: no, they don't pre-date it. it was because the pacemaker resources need to executed at those specific steps. During the stepwise 1..5 deployment
14:31:12 <mwhahaha> dprince: ok then i'll fixup the patch with some of the comments today
14:31:14 <mwhahaha> thanks
14:31:19 <dprince> mwhahaha: the pacemaker implementations came later, and did that explicitly
14:31:57 <mwhahaha> alright sounds like nothing else, so thanks everyone
14:31:59 <mwhahaha> #endmeeting