14:01:00 <mwhahaha> #startmeeting tripleo
14:01:01 <mwhahaha> #topic agenda
14:01:01 <mwhahaha> * Review past action items
14:01:01 <mwhahaha> * One off agenda items
14:01:01 <mwhahaha> * Squad status
14:01:01 <mwhahaha> * Bugs & Blueprints
14:01:01 <mwhahaha> * Projects releases or stable backports
14:01:01 <openstack> Meeting started Tue Mar  6 14:01:00 2018 UTC and is due to finish in 60 minutes.  The chair is mwhahaha. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:01 <jaosorior> alee__: oh yeah, and the -x (referencing the patch in master)
14:01:02 <mwhahaha> * Specs
14:01:02 <mwhahaha> * open discussion
14:01:02 <mwhahaha> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:01:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:03 <mwhahaha> Hi everyone! who is around today?
14:01:05 <openstack> The meeting name has been set to 'tripleo'
14:01:07 <EmilienM> o/
14:01:10 <fultonj> o/
14:01:13 <shardy> o/
14:01:14 <trown|rover> o/
14:01:14 <ccamacho> hey guys!
14:01:15 <dprince> hi
14:01:18 <holser__> o/
14:01:18 <marios> \o
14:01:20 <florianf> o/
14:01:23 <jaosorior> o/
14:01:29 <gchamoul> o/
14:01:36 <jfrancoa> o/
14:01:38 <prad> O/
14:01:45 <openstackgerrit> Jiri Tomasek proposed openstack/tripleo-ui master: Make Validation actions use startWorkflow  https://review.openstack.org/550086
14:01:49 <dpeacock> o/
14:02:01 <rasca> o/
14:02:15 <jrist> o/
14:03:08 <mwhahaha> looks like we've got a decent turnout today, let's do this
14:03:09 <mwhahaha> #topic review past action items
14:03:19 <gunix> can anybody explain the difference between cloudforms and tripleo?
14:03:21 <mwhahaha> #action sshnaidm to raise ML post about reducing risk with quickstart and quickstart-extras patches
14:03:23 <gunix> what does cloudforms cover ?
14:03:37 <mwhahaha> not sure if that was covered at the PTG
14:03:38 <cdearborn> o/
14:04:21 <mwhahaha> since those folks are in Brno this week, i guess we can post pone that again one more time
14:04:49 <jrist> gunix "the day after you deploy openstack"
14:04:59 <mwhahaha> shardy, jpich, EmilienM to change the default deploy to include docker
14:05:07 <mwhahaha> #link https://review.openstack.org/#/c/548554/
14:05:14 <mwhahaha> jaosorior has a patch to do this
14:05:37 <mwhahaha> please review and make comments as necessary
14:05:46 <mwhahaha> EmilienM, mwhahaha to cut a rc1 in the next 2 weeks - DONE
14:06:02 <mwhahaha> done as of Saturday. Thanks everyone who helped get the Queens promotion we needed
14:06:03 <EmilienM> bogdando: have you seen replies from Juan & Dan?
14:06:17 <mwhahaha> don't forget you'll need to backport things to stable/queens now
14:06:25 <mwhahaha> but that also means we can start landing features
14:06:25 <d0ugal> o/
14:06:39 <EmilienM> correct, Rocky cycle is now open
14:07:16 <bogdando> o/
14:07:39 <ccamacho> mwhahaha the cut was on last of Jan so anything merged afterwards needs to be backported, right?
14:07:45 <marios> mwhahaha: ack it was painful getting the tripleoclient in order for the latest upgrade cli i'd advise folks to check stable/queens for the things they are interested in asap before it gets too painful
14:07:58 <marios> mwhahaha: (more on upgrade squad status for reviews)
14:07:58 <EmilienM> the cut was on Friday evening
14:08:16 <ccamacho> last Friday?
14:08:21 <mwhahaha> yea
14:08:21 <EmilienM> 4 days ago
14:08:30 <EmilienM> I made it with a GUiness in my hands
14:08:35 <EmilienM> hopefully all went right :D
14:08:39 <marios> EmilienM: was perfect :)
14:08:42 <ccamacho> EmilienM we have patches merged before and they are not in queens
14:08:53 <EmilienM> o_O
14:08:55 <mwhahaha> ccamacho: depends on the repo, please provide links after
14:08:57 <bogdando> EmilienM: yes, will keep an eye on it
14:09:00 <ccamacho> oki
14:09:08 <ccamacho> thanks mwhahaha
14:09:23 <marios> EmilienM: by staring at https://github.com/openstack/python-tripleoclient/commits/stable/queens vs https://github.com/openstack/python-tripleoclient/commits/master I ended up at https://review.openstack.org/#/q/topic:update/workflow-stable/queens+(status:open+OR+status:merged)
14:09:23 <mwhahaha> #action EmilienM & mwhahaha to sync with ccamacho about patch missing from queens?
14:09:34 <marios> EmilienM: at least for the python-tripleoclient i am currently working on
14:09:35 <EmilienM> tripleoclient was branched weeks ago
14:09:48 <marios> EmilienM: right seems we forgot to start picking things over there
14:09:50 <EmilienM> because it's the client, and client is always branched before other projects
14:09:54 <mwhahaha> right we cut tripleoclient long ago
14:09:57 <EmilienM> yeah, just propose backports and problem solve
14:10:01 <marios> EmilienM: ack makes more sense now
14:10:17 <gunix> jrist: what do you mean ?
14:10:50 <mwhahaha> so yea tripleoclient may needed to have things cherry-picked and they weren't so please review any changes you had over there
14:10:57 <ccamacho> thanks for the clarification mwhahaha EmilienM marios
14:11:08 <mwhahaha> that got branched weeks ago where as THT, etc was branched on Friday
14:11:15 <mwhahaha> moving on
14:11:15 <jrist> gunix: let's chat after the meeting. I'll try to explain more
14:11:18 <mwhahaha> mwhahaha move any non-blocking bugs to Rocky-1 - DONE
14:11:29 <EmilienM> mwhahaha: I closed RC1 in LP
14:11:30 <mwhahaha> since we released rc1, i moved everything
14:11:47 <EmilienM> do we want to create RC2 in LP? imho we don't need I think
14:11:53 <mwhahaha> EmilienM: no i don't think so
14:11:55 <EmilienM> k
14:12:07 <mwhahaha> I didn't see any major blocking issues that would warrant an rc2
14:12:17 <bogdando> ccamacho: is it related to the github desync from cgit?
14:12:18 <marios> jaosorior: might want to check that https://github.com/openstack/python-tripleoclient/commits/stable/queens i think my eye caught a few ssl related things missing compared to master fyi you might want to check
14:12:40 <bogdando> marios: ^^
14:13:10 <mwhahaha> EmilienM to release stable tripleo early march
14:13:14 <EmilienM> bogdando: no it's not
14:13:16 <myoung|ruck> o/
14:13:17 <jaosorior> marios: like what?
14:13:19 <EmilienM> bogdando: it's the fact they missed to cherry-pick
14:13:27 <EmilienM> mwhahaha: I'm working on it today
14:13:41 <mwhahaha> EmilienM: k we might want to land my iptables fixes first
14:13:45 <mwhahaha> EmilienM: if we haven't already
14:13:52 <ccamacho> bogdando yeah the cut date was previous the merge
14:13:52 <EmilienM> they landed, most of them
14:13:52 * mwhahaha hasn't gotten that far in his email
14:13:55 <EmilienM> but I'll check
14:14:04 <mwhahaha> k
14:14:08 <mwhahaha> #topic one off agenda items
14:14:08 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:14:09 <EmilienM> #action EmilienM to release stable tripleo this week
14:14:19 <mwhahaha> the agenda is empty
14:14:23 <mwhahaha> moving on to squads
14:14:26 <openstackgerrit> Martin Mágr proposed openstack/tripleo-common master: Activate new healthchecks  https://review.openstack.org/539190
14:14:31 <mwhahaha> #topic Squad status
14:14:31 <mwhahaha> ci
14:14:31 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:14:31 <mwhahaha> upgrade
14:14:31 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:14:31 <mwhahaha> containers
14:14:32 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-containers-squad-status
14:14:32 <mwhahaha> config-download
14:14:33 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-config-download-squad-status
14:14:33 <mwhahaha> integration
14:14:34 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:14:34 <mwhahaha> ui/cli
14:14:35 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ui-cli-squad-status
14:14:35 <mwhahaha> validations
14:14:36 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:14:36 <mwhahaha> networking
14:14:37 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-networking-squad-status
14:14:37 <mwhahaha> workflows
14:14:38 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-workflows-squad-status
14:14:44 <EmilienM> mwhahaha: we have a new squad :)
14:14:45 <mwhahaha> EmilienM, jaosorior: I noticed a ping about a Security squad
14:14:52 <EmilienM> https://etherpad.openstack.org/p/tripleo-security-squad
14:14:52 <mwhahaha> yea what's the url to the ether pad?
14:15:10 <mwhahaha> cool
14:15:12 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-security-squad
14:15:18 <jaosorior> mwhahaha: yep, here's the relevant mail http://lists.openstack.org/pipermail/openstack-dev/2018-March/127955.html
14:15:25 <bogdando> looks secured now
14:16:04 <EmilienM> :)
14:16:07 <mwhahaha> :D
14:16:10 <jaosorior> lol
14:16:20 <mwhahaha> don't forget to update your statuses
14:16:26 <jaosorior> But yeah, for anyone interested, first meeting for the security squad will be tomorrow  (wednesday) at 1pm UTC
14:16:54 <marios> jaosorior: i thought perhaps this one https://github.com/openstack/python-tripleoclient/commit/1e033c98fae51fee192660e28812ef0ec15dd4e8 but it looks like it is already in queens (I thought i saw more but cant quickly see. it sounds like you don't expect more so sorry for the noise)
14:17:20 <mwhahaha> cool thanks jaosorior
14:17:31 <mwhahaha> #topic bugs & blueprints
14:17:31 <mwhahaha> #link hhttps://launchpad.net/tripleo/+milestone/rocky-1
14:17:31 <mwhahaha> For Rocky we currently have 62 (+0) blueprints and about 586 (+3) open bugs.  583 rocky-1, 1 rocky-2, 2 rocky-3.
14:17:37 <openstackgerrit> Ade Lee proposed openstack/tripleo-heat-templates stable/queens: Add step to run secret_store_sync before instance startup  https://review.openstack.org/549852
14:17:47 <mwhahaha> so we have a whole bunch of blueprints now since it's rocky
14:17:54 <mwhahaha> please make sure they are up to date with owners
14:18:28 <mwhahaha> I'm wondering if we should move any blueprints without an owner out of Rocky by M1?
14:18:45 <EmilienM> yes
14:18:55 <mwhahaha> I'll send a note to the ML as well
14:19:02 <EmilienM> 52 blueprints :-O
14:19:05 <mwhahaha> #action mwhahaha to send a note about blueprints & owners to the ML
14:19:09 <mwhahaha> 62
14:19:39 <openstackgerrit> Pradeep Kilambi proposed openstack/tripleo-heat-templates master: FFU: Introduce fluentd fast-forward-upgrade tasks  https://review.openstack.org/545986
14:19:59 <mwhahaha> Also make sure you've captured any larger work items from the PTG in a blueprint as well
14:20:05 <mwhahaha> while it's still fresh on your mind
14:20:30 <mwhahaha> any major bugs that folks would like to draw attention to?
14:20:32 <openstackgerrit> Martin Mágr proposed openstack/tripleo-common master: Activate new healthchecks  https://review.openstack.org/539190
14:21:19 <marios> jaosorior: (btw i think that one is *not* in queens (I was on wrong branch locally), i mean this https://review.openstack.org/#/c/530737/ fyi)
14:21:30 <mwhahaha> sounds like nope
14:21:33 <mwhahaha> #topic projects releases or stable backports
14:21:45 <mwhahaha> we already talked about this, we'll be cutting stable soonish
14:21:53 <EmilienM> this weke
14:21:56 <EmilienM> week even
14:22:03 <jaosorior> marios: that's ok. We don't really support the containerized undercloud for queens. So that patch doesn't need backporting.
14:22:18 <mwhahaha> #topic specs
14:22:18 <mwhahaha> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:22:30 <marios> jaosorior: ack
14:22:34 <mwhahaha> please make sure your specs are properly targeted to rocky
14:22:38 <mwhahaha> or abandon them
14:22:39 <mwhahaha> thanks
14:22:58 <jrist> ++
14:23:25 <mwhahaha> jaosorior, honza, rasca, shardy, weshay, panda, dsneddon, mcornea -^
14:23:29 <mwhahaha> that means you people
14:23:49 <mwhahaha> #topic open discussion
14:23:53 <mwhahaha> anything else?
14:24:28 <honza> mwhahaha: roger that
14:24:34 <openstackgerrit> Martin Mágr proposed openstack/tripleo-common master: Activate new healthchecks  https://review.openstack.org/539190
14:24:45 <EmilienM> nope
14:24:50 <mwhahaha> cool
14:24:52 <EmilienM> I planned to send an email about PTG
14:24:54 <mwhahaha> thanks everyone
14:24:57 <EmilienM> some recap about some things
14:25:00 <jrist> yeah if you can please summarise PTG
14:25:05 <jrist> not just EmilienM
14:25:05 <EmilienM> people who led some sessions are welcome to do it
14:25:06 <jrist> :)
14:25:22 <EmilienM> I plan to kick off some summaries this week
14:25:23 <mwhahaha> also thanks to the people who ran sessions
14:26:17 <mwhahaha> #action EmilienM & and others to send ML posts about PTG
14:26:24 <EmilienM> thanks who kept the train running while we were away
14:26:31 <jrist> choo choo
14:26:35 <EmilienM> thanks to those who kept the train running I mean
14:26:44 * EmilienM needs to learn english
14:26:55 <openstackgerrit> Merged openstack/tripleo-quickstart-extras master: Set network-feature-enabled.port_security to True  https://review.openstack.org/549769
14:27:24 <mwhahaha> http://2.bp.blogspot.com/-F-hfpcvFQx8/VhK93FOvRbI/AAAAAAAADYY/4K0VZa99Vpw/s400/images%2B%25284%2529.jpg
14:27:27 <mwhahaha> #endmeeting