14:01:15 <mwhahaha> #startmeeting tripleo
14:01:15 <openstack> Meeting started Tue Mar 20 14:01:15 2018 UTC and is due to finish in 60 minutes.  The chair is mwhahaha. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:15 <mwhahaha> #topic agenda
14:01:15 <mwhahaha> * Review past action items
14:01:15 <mwhahaha> * One off agenda items
14:01:15 <mwhahaha> * Squad status
14:01:15 <mwhahaha> * Bugs & Blueprints
14:01:16 <mwhahaha> * Projects releases or stable backports
14:01:16 <mwhahaha> * Specs
14:01:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:17 <mwhahaha> * open discussion
14:01:18 <mwhahaha> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:01:18 <mwhahaha> Hi everyone! who is around today?
14:01:19 <openstack> The meeting name has been set to 'tripleo'
14:01:20 <fultonj> o/
14:01:24 <trown|ruck> o/
14:01:28 <EmilienM> o/
14:01:28 <matbu> o/
14:01:33 <beagles> o/
14:01:34 <cdearborn> o/
14:01:36 <chem> o/
14:01:39 <jfrancoa> o/
14:01:47 <dpeacock> o/
14:01:48 <ccamacho> hola!
14:01:50 <rasca> o/
14:01:58 <shardy> o/
14:01:58 <marios> o/
14:02:02 <d0ugal> o/
14:02:09 <openstackgerrit> Dougal Matthews proposed openstack/tripleo-common master: Use the standard messaging in the fernet-key-rotate workbook  https://review.openstack.org/554552
14:02:15 <jistr> hi
14:02:17 <florianf> o/
14:02:48 <mwhahaha> may be a quick meeting today
14:02:52 <mwhahaha> so let's get started
14:02:55 <mwhahaha> #topic review past action items
14:02:55 <mwhahaha> None!
14:03:04 <mwhahaha> #topic one off agenda items
14:03:04 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:03:12 <radeks_> o/
14:03:16 <mwhahaha> any agenda items? the etherpad is blank
14:03:44 <openstackgerrit> Dougal Matthews proposed openstack/tripleo-common master: Use the standard messaging in the fernet-key-rotate workbook  https://review.openstack.org/554552
14:04:24 <mwhahaha> I'll take that as a noooope
14:04:53 <bandini> o/
14:04:57 <abishop> o/
14:05:16 <openstackgerrit> Dougal Matthews proposed openstack/tripleo-common master: Use the standard messaging in the derive_parameters workbook  https://review.openstack.org/554548
14:05:22 <mwhahaha> #topic Squad status
14:05:22 <mwhahaha> ci
14:05:22 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:05:22 <mwhahaha> upgrade
14:05:22 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:05:22 <mwhahaha> containers
14:05:23 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-containers-squad-status
14:05:23 <mwhahaha> config-download
14:05:24 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-config-download-squad-status
14:05:25 <mwhahaha> integration
14:05:25 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:05:26 <mwhahaha> ui/cli
14:05:26 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ui-cli-squad-status
14:05:27 <mwhahaha> validations
14:05:27 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:05:27 <mwhahaha> networking
14:05:28 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-networking-squad-status
14:05:29 <mwhahaha> workflows
14:05:29 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-workflows-squad-status
14:06:13 <mwhahaha> anything anyone wants to highlight in their status?
14:06:25 <openstackgerrit> Athlan-Guyot sofer proposed openstack/tripleo-upgrade stable/queens: Add floating ip connectivity check to common dir and use it for FFU  https://review.openstack.org/554256
14:07:56 <EmilienM> nope
14:08:09 <mwhahaha> #topic bugs & blueprints
14:08:09 <mwhahaha> #link https://launchpad.net/tripleo/+milestone/rocky-1
14:08:09 <mwhahaha> For Rocky we currently have 65 (+2) blueprints and about 635 (+30) open bugs.  629 rocky-1, 2 rocky-2, 4 rocky-3.
14:08:19 <mwhahaha> so looks like we've had a recent up tick in open bugs
14:08:25 <mwhahaha> was +19 last week and now +30
14:08:47 <mwhahaha> 635 is also quite the unmanageable backlog
14:08:55 <mwhahaha> i'm open for ideas on how to tackle this
14:09:05 <holser___> o/
14:09:32 <EmilienM> the question is, do people work on bug by "Important" or by milestones?
14:09:44 <chem> mwhahaha: on my upgrade side I think a lot of bug are not in the right status
14:09:47 <mwhahaha> or better yet "do people work on bugs"
14:09:53 <EmilienM> because even if we move some of them to rocky-2, people might still work on them *now*
14:10:03 <chem> mwhahaha: maybe a cleanup session by tag for each squad ?
14:10:16 <EmilienM> and like chem said, I think a bunch of bugs needs to be updated (and closed?)
14:10:17 <ooolpbot> URGENT TRIPLEO TASKS NEED ATTENTION
14:10:17 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1757111
14:10:19 <openstack> Launchpad bug 1757111 in tripleo " fs020(both queens/master) tempest tests failing while booting an instance" [Critical,Triaged]
14:10:26 <bandini> chem: +1
14:10:30 <mwhahaha> ok i'll send a note about ensuring the status of bugs
14:10:35 <EmilienM> chem: +1 good idea
14:10:55 <mwhahaha> #action mwhahaha to send an ML note about making sure to review current status of assigned bugs, also review bugs by squad tags
14:11:05 <mwhahaha> Also reminder about the deadline for blueprints for Rocky is April 3, 2018.
14:11:05 <mwhahaha> #link http://lists.openstack.org/pipermail/openstack-dev/2018-March/128217.html
14:11:06 <EmilienM> also, a bunch of bugs don't belong to any squad, just fyi
14:11:10 <holser___> EmilienM, mwhahaha - I think we need to describe a workflow otherwise everyone will update bugs on his own
14:11:46 <mwhahaha> holser___: what do you mean by workflow? you mean when a bug is first triaged or after it's being eorked on
14:12:03 <holser___> after being worked on
14:12:26 <mwhahaha> once it's merged it's fix released, there's not much else on that front
14:12:46 <mwhahaha> so i'm not exactly sure what else to document
14:13:44 <chem> holser___: a example is that one https://bugs.launchpad.net/tripleo/+bug/1724636
14:13:45 <openstack> Launchpad bug 1724636 in tripleo "[ocata to pike] upgrade failing at step3 during dbsync" [Critical,In progress] - Assigned to Sofer Athlan-Guyot (sofer-athlan-guyot)
14:13:46 <holser___> k, For instance I have 5 bugs 3 triaged, 2 in progress... As a human being I cannot work on 2 bugs at the same time, so logically I should have update the status to triaged
14:13:57 <holser___> of one bug
14:14:06 <chem> holser___: 152 days old ... sholud be fixed by now :)
14:14:14 <holser___> :D
14:14:16 <mwhahaha> well you could have multiple in flight patches
14:14:18 <holser___> yeah yeah
14:14:30 <shardy> yeah in progress just means you pushed a fix for review
14:14:33 <mwhahaha> i think it's more likely that the bug bot didn't catch a merge or people just need to review what's assigned to them
14:14:43 <chem> must be others all over the place
14:14:53 <mwhahaha> let's start with folks reviewing the bugs assigned to themselves
14:14:55 <mwhahaha> and see what falls out
14:15:13 <holser___> mwhahaha - like what chem said I would focus on on old - long playing bugs
14:15:23 <shardy> If we enforced all bugs were tagged to a squad, would that be a way to divide the workload?
14:15:35 <mwhahaha> only if the squads were using it as a source of work
14:15:39 <shardy> e.g part of the triage process which we periodically check via a script or something
14:15:51 <mwhahaha> just tagging it doesn't actually get them fixed
14:16:00 <mwhahaha> also there are bugs that fall outside of the squads so who fixes those
14:16:03 <shardy> mwhahaha: yeah but it enables clear ownership of both the backlog and the fixes
14:16:31 * mwhahaha already deals with catch all bugs and doesn't want to continue to add to that list
14:16:58 <shardy> mwhahaha: sure, I'm just throwing some ideas around to reduce the catch-all number
14:17:28 <shardy> what I'm suggesting is pretty close to how the bz-squad mapping is done downstream I think, so it could potentially be an easy pattern to replicate
14:18:17 <mwhahaha> fair enough, maybe some conversation will get spawned out of the ML note
14:18:24 <EmilienM> shardy: I think that makes sense
14:18:28 <holser___> +1 for ML
14:18:31 <mwhahaha> anyway be aware it's a thing and we're probably going to want to deal with it sooner rather than later
14:18:40 <arxcruz> o/
14:19:01 <mwhahaha> i'm also partial to reviewing some of the bugs we've had open for 1+ years and maybe we need to just close those out
14:19:16 <mwhahaha> so there's multiple efforts that probably need to get started
14:19:32 <mwhahaha> anyway. any other bug/blueprint related items?
14:19:40 <chem> we have 4years old open bug :)
14:19:53 <mwhahaha> it's probably still valid too :D
14:19:59 <bandini> lol
14:20:26 <chem> hehe
14:20:35 <mwhahaha> moving on
14:20:36 <mwhahaha> #topic projects releases or stable backports
14:20:48 <mwhahaha> rocky m1 is in ~1 month
14:20:49 <mwhahaha> just fyi
14:21:44 <mwhahaha> I think we just released stable ~2 weeks ago so i'm not sure the next release for that
14:21:54 <EmilienM> this week
14:21:56 <mwhahaha> k
14:22:26 <mwhahaha> any backport related items that folks would like to raise?
14:22:28 <openstackgerrit> Dan Macpherson proposed openstack/tripleo-docs master: WIP: Add FFU docs  https://review.openstack.org/549892
14:23:32 <mwhahaha> sounds like nope
14:23:41 <mwhahaha> #topic specs
14:23:41 <mwhahaha> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:23:56 <mwhahaha> we merged some specs this week, if you have some time please review the open items
14:24:49 <mwhahaha> any spec related items?
14:25:47 <mwhahaha> sounds like no
14:25:48 <mwhahaha> #topic open discussion
14:25:51 <mwhahaha> anything else?
14:27:48 <mwhahaha> alright, sounds like that's it for the week.
14:27:50 <mwhahaha> thanks everyone
14:27:52 <mwhahaha> #endmeeting